FAQ
New install of 2.5.1 on Ubuntu 10.10 server. Multiple (6) new installs on
Ubuntu 12.04 clients running agent 2.7.14-1puppetlabs1 from the puppetlabs
repo generating the following error.

err: Could not retrieve catalog from remote server: Error 400 on SERVER: No
matching value for selector param ‘undef’ at
/opt/puppet/share/puppet/modules/pe_mcollective/manifests/init.pp:89 on
node host.example.com warning: Not using cache on failed catalog err: Could
not retrieve catalog; skipping run

Agent running on Puppet Master is functioning correctly.

$ sudo puppet agent -tv —pluginsync
info: Retrieving plugin info: Loading facts in
/var/lib/puppet/lib/facter/facter_dot_d.rb info: Loading facts in
/var/lib/puppet/lib/facter/root_home.rb info: Loading facts in
/var/lib/puppet/lib/facter/puppet_vardir.rb err: Could not retrieve catalog
from remote server: Error 400 on SERVER: No matching value for selector
param ‘undef’ at
/opt/puppet/share/puppet/modules/pe_mcollective/manifests/init.pp:89 on
node puppet.example.net warning: Not using cache on failed catalog err:
Could not retrieve catalog; skipping run

Any suggestions for troubleshooting and resolving are appreciated.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Nan Liu at May 5, 2012 at 9:19 pm

    On Sat, May 5, 2012 at 2:08 PM, Jester 2.0 wrote:
    New install of 2.5.1 on Ubuntu 10.10 server. Multiple (6) new installs on
    Ubuntu 12.04 clients running agent 2.7.14-1puppetlabs1 from the puppetlabs
    repo generating the following error.

    err: Could not retrieve catalog from remote server: Error 400 on SERVER: No
    matching value for selector param ‘undef’ at
    /opt/puppet/share/puppet/modules/pe_mcollective/manifests/init.pp:89 on node
    host.example.com warning: Not using cache on failed catalog err: Could not
    retrieve catalog; skipping run

    Agent running on Puppet Master is functioning correctly.

    $ sudo puppet agent -tv —pluginsync
    info: Retrieving plugin info: Loading facts in
    /var/lib/puppet/lib/facter/facter_dot_d.rb info: Loading facts in
    /var/lib/puppet/lib/facter/root_home.rb info: Loading facts in
    /var/lib/puppet/lib/facter/puppet_vardir.rb err: Could not retrieve catalog
    from remote server: Error 400 on SERVER: No matching value for selector
    param ‘undef’ at
    /opt/puppet/share/puppet/modules/pe_mcollective/manifests/init.pp:89 on node
    puppet.example.net warning: Not using cache on failed catalog err: Could not
    retrieve catalog; skipping run

    Any suggestions for troubleshooting and resolving are appreciated.
    You should use puppet-enterprise installer on the agents. There's a
    set of facts created during installation during PE that's necessary
    for pe-mcollective module. If you install the opensource version you
    will likely run into issues with pe-* modules. You can still use
    opensource agent, but they can't be part of the default group in
    enterprise console (which includes a set of pe-* modules).

    Thanks,

    Nan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jester 2.0 at May 5, 2012 at 11:50 pm
    Nan,
    Thanks for the explanation. Any ETA on PE supporting 12.04?

    Thanks
    On Sat, May 5, 2012 at 5:18 PM, Nan Liu wrote:
    On Sat, May 5, 2012 at 2:08 PM, Jester 2.0 wrote:
    New install of 2.5.1 on Ubuntu 10.10 server. Multiple (6) new installs on
    Ubuntu 12.04 clients running agent 2.7.14-1puppetlabs1 from the
    puppetlabs
    repo generating the following error.

    err: Could not retrieve catalog from remote server: Error 400 on SERVER: No
    matching value for selector param ‘undef’ at
    /opt/puppet/share/puppet/modules/pe_mcollective/manifests/init.pp:89 on node
    host.example.com warning: Not using cache on failed catalog err: Could not
    retrieve catalog; skipping run

    Agent running on Puppet Master is functioning correctly.

    $ sudo puppet agent -tv —pluginsync
    info: Retrieving plugin info: Loading facts in
    /var/lib/puppet/lib/facter/facter_dot_d.rb info: Loading facts in
    /var/lib/puppet/lib/facter/root_home.rb info: Loading facts in
    /var/lib/puppet/lib/facter/puppet_vardir.rb err: Could not retrieve catalog
    from remote server: Error 400 on SERVER: No matching value for selector
    param ‘undef’ at
    /opt/puppet/share/puppet/modules/pe_mcollective/manifests/init.pp:89 on node
    puppet.example.net warning: Not using cache on failed catalog err: Could not
    retrieve catalog; skipping run

    Any suggestions for troubleshooting and resolving are appreciated.
    You should use puppet-enterprise installer on the agents. There's a
    set of facts created during installation during PE that's necessary
    for pe-mcollective module. If you install the opensource version you
    will likely run into issues with pe-* modules. You can still use
    opensource agent, but they can't be part of the default group in
    enterprise console (which includes a set of pe-* modules).

    Thanks,

    Nan

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Nan Liu at May 6, 2012 at 12:07 am
    Expected in PE 2.5.2. More info here:

    https://groups.google.com/a/puppetlabs.com/group/pe-users/browse_thread/thread/9b45902094332d3d#
    On Sat, May 5, 2012 at 4:50 PM, Jester 2.0 wrote:
    Nan,
    Thanks for the explanation.  Any ETA on PE supporting 12.04?

    Thanks
    On Sat, May 5, 2012 at 5:18 PM, Nan Liu wrote:
    On Sat, May 5, 2012 at 2:08 PM, Jester 2.0 wrote:
    New install of 2.5.1 on Ubuntu 10.10 server. Multiple (6) new installs
    on
    Ubuntu 12.04 clients running agent 2.7.14-1puppetlabs1 from the
    puppetlabs
    repo generating the following error.

    err: Could not retrieve catalog from remote server: Error 400 on SERVER:
    No
    matching value for selector param ‘undef’ at
    /opt/puppet/share/puppet/modules/pe_mcollective/manifests/init.pp:89 on
    node
    host.example.com warning: Not using cache on failed catalog err: Could
    not
    retrieve catalog; skipping run

    Agent running on Puppet Master is functioning correctly.

    $ sudo puppet agent -tv —pluginsync
    info: Retrieving plugin info: Loading facts in
    /var/lib/puppet/lib/facter/facter_dot_d.rb info: Loading facts in
    /var/lib/puppet/lib/facter/root_home.rb info: Loading facts in
    /var/lib/puppet/lib/facter/puppet_vardir.rb err: Could not retrieve
    catalog
    from remote server: Error 400 on SERVER: No matching value for selector
    param ‘undef’ at
    /opt/puppet/share/puppet/modules/pe_mcollective/manifests/init.pp:89 on
    node
    puppet.example.net warning: Not using cache on failed catalog err: Could
    not
    retrieve catalog; skipping run

    Any suggestions for troubleshooting and resolving are appreciated.
    You should use puppet-enterprise installer on the agents. There's a
    set of facts created during installation during PE that's necessary
    for pe-mcollective module. If you install the opensource version you
    will likely run into issues with pe-* modules. You can still use
    opensource agent, but they can't be part of the default group in
    enterprise console (which includes a set of pe-* modules).

    Thanks,

    Nan

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 5, '12 at 9:08p
activeMay 6, '12 at 12:07a
posts4
users2
websitepuppetlabs.com

2 users in discussion

Jester 2.0: 2 posts Nan Liu: 2 posts

People

Translate

site design / logo © 2021 Grokbase