FAQ
Hi,

I am still learning Puppet meaning that I'm still struggling through things.


I have setup Puppet on CentOS 6.x (latest release), installed the
Puppet Labs repos and followed the instructions on the site:

http://docs.puppetlabs.com/guides/setting_up.html

So far I am able to get the server to sign hosts and run: puppet agent
--test on the host successfully (which is more luck then I had with
the Puppet training ISO).


With regards to the dashboard I have gone through this documentation:

http://docs.puppetlabs.com/dashboard/index.html


Which has got me to be able to get the Puppet Dash in my web browser.

My issue is that I have added nodes to the Dash but they are claiming
to be unreported??


I entered the FQDN's of both server and host, the Parameters, Groups,
and Classes sections are blank; but unfortunately the Dash is claiming
that the hosts are not reporting in?


Puppet Client (puppet.conf):

[main]
# The Puppet log directory.
# The default value is '$vardir/log'.
logdir = /var/log/puppet

# Where Puppet PID files are kept.
# The default value is '$vardir/run'.
rundir = /var/run/puppet

# Where SSL certificates are kept.
# The default value is '$confdir/ssl'.
ssldir = $vardir/ssl


[agent]
# The file in which puppetd stores a list of the classes
# associated with the retrieved configuratiion. Can be loaded in
# the separate ``puppet`` executable using the ``--loadclasses``
# option.
# The default value is '$confdir/classes.txt'.
classfile = $vardir/classes.txt

# Where puppetd caches the local configuration. An
# extension indicating the cache format is added automatically.
# The default value is '$confdir/localconfig'.
localconfig = $vardir/localconfig

report = true

server = ps.jabber.com

Puppet Server (puppet.conf):

[main]
# The Puppet log directory.
# The default value is '$vardir/log'.
logdir = /var/log/puppet

# Where Puppet PID files are kept.
# The default value is '$vardir/run'.
rundir = /var/run/puppet

# Where SSL certificates are kept.
# The default value is '$confdir/ssl'.
ssldir = $vardir/ssl

reports = store, http
reporturl = http://ps.jabber.com:3000/reports

[agent]
# The file in which puppetd stores a list of the classes
# associated with the retrieved configuratiion. Can be loaded in
# the separate ``puppet`` executable using the ``--loadclasses``
# option.
# The default value is '$confdir/classes.txt'.
classfile = $vardir/classes.txt

# Where puppetd caches the local configuration. An
# extension indicating the cache format is added automatically.
# The default value is '$confdir/localconfig'.
localconfig = $vardir/localconfig


report = true

server = ps.jabber.com


Here is output of puppet agent --test on client:


# puppet agent --test
info: Caching catalog for pc.jabber.com
info: Applying configuration version '1336044868'
notice: Finished catalog run in 0.01 seconds


...and server:


puppet agent --test
info: Caching catalog for ps.jabber.com
info: Applying configuration version '1336044868'
notice: Finished catalog run in 0.04 seconds



Can anybody help me?


Regards,


Kaya

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Nan Liu at May 4, 2012 at 4:23 pm

    On Fri, May 4, 2012 at 3:59 AM, Kaya Saman wrote:
    Hi,

    I am still learning Puppet meaning that I'm still struggling through things.


    I have setup Puppet on CentOS 6.x (latest release), installed the
    Puppet Labs repos and followed the instructions on the site:

    http://docs.puppetlabs.com/guides/setting_up.html

    So far I am able to get the server to sign hosts and run: puppet agent
    --test on the host successfully (which is more luck then I had with
    the Puppet training ISO).


    With regards to the dashboard I have gone through this documentation:

    http://docs.puppetlabs.com/dashboard/index.html


    Which has got me to be able to get the Puppet Dash in my web browser.

    My issue is that I have added nodes to the Dash but they are claiming
    to be unreported??


    I entered the FQDN's of both server and host, the Parameters, Groups,
    and Classes sections are blank; but unfortunately the Dash is claiming
    that the hosts are not reporting in?


    Puppet Client (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl


    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    report = true

    server = ps.jabber.com

    Puppet Server (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    reports = store, http
    reporturl = http://ps.jabber.com:3000/reports

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig


    report = true

    server = ps.jabber.com


    Here is output of puppet agent --test on client:


    # puppet agent --test
    info: Caching catalog for pc.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.01 seconds


    ...and server:


    puppet agent --test
    info: Caching catalog for ps.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.04 seconds



    Can anybody help me?
    Based on the configuration provided above, it appears you still need
    to configure puppet so dashboard is the external node terminus:

    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#using-dashboard-for-node-classification

    HTH,

    Nan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • MaTi Villagra at May 5, 2012 at 7:03 am
    Hi.

    Scenario: Install puppet/puppet-dashboard successfully, puppet is run by
    passenger. Changes are push from master to client perfectly.

    Issue: Nodes are not reporting on dashboard. When: Never/actually.

    apache2 vhost

    1.name= puppetmasterd

    Listen 8140
    <VirtualHost *.8140>
    Servername xlupupet01
    ........
    ........
    </VirtualHost>

    2. name = dashboard
    <VirtualHost *.80>
    Servername dashboard.example.com
    ........
    ........
    </VirtualHost>



    puppet master --- > puppet.conf

    [master]
    # Where puppet agent stores the last run report in yaml format.
    # The default value is '$statedir/last_run_report.yaml'.
    lastrunreport = /var/lib/puppet/state/last_run_report.yaml
    # The server to send transaction reports to.
    # report_server = puppet
    # report_server = xlupupet01
    # Whether to send reports after every transaction.
    # report = true
    # The port to communicate with the report_server.
    # report_port = 8140
    * report_port = 80*
    # Where puppet agent stores the last run report summary in yaml format.
    # (Deprecated for 'report_server') The server to which to send
    transaction reports.
    # reportserver = puppet
    # reports, allowing you to correlate changes on your hosts to the
    source version on the server.
    # The directory in which to store reports
    # The default value is '$vardir/reports'.
    *reportdir = /var/lib/puppet/reports*
    # reported in its facts)
    # The URL used by the http reports processor to send reports
    # The default value is 'http://localhost:3000/reports/upload'.
    *reporturl = http://dashboard.example.com/reports/upload*
    # The list of reports to generate. All reports are looked for
    # in `puppet/reports/name.rb`, and multiple report names should be
    *reports = store, http*
    # The 'from' email address for the reports.
    # The default value is 'report@xlupupet01.'.
    # reportfrom = report@xlupupet01.
    # The mapping between reporting tags and email addresses.
    # The server through which to send email reports.
    # This should match how often the hosts report back to the server.
    # Directories for each reporting host will be created under


    puppet client --- > puppet.conf

    [main]

    server=xlupupet01
    logdir=/var/log/puppet
    vardir=/var/lib/puppet
    ssldir=/var/lib/puppet/ssl
    rundir=/var/run/puppet
    factpath=$vardir/lib/facter
    templatedir=$confdir/templates
    prerun_command=/etc/puppet/etckeeper-commit-pre
    postrun_command=/etc/puppet/etckeeper-commit-post
    *reports=store, http
    report=true
    reporturl= http://dashboard.example.com/reports/upload*
    runinterval=3600

    Storie: Troubleshoot for a while with not success.

    I will thanks, any idea.
    El viernes, 4 de mayo de 2012 13:23:32 UTC-3, Nan Liu escribió:
    On Fri, May 4, 2012 at 3:59 AM, Kaya Saman wrote:
    Hi,

    I am still learning Puppet meaning that I'm still struggling through things.

    I have setup Puppet on CentOS 6.x (latest release), installed the
    Puppet Labs repos and followed the instructions on the site:

    http://docs.puppetlabs.com/guides/setting_up.html

    So far I am able to get the server to sign hosts and run: puppet agent
    --test on the host successfully (which is more luck then I had with
    the Puppet training ISO).


    With regards to the dashboard I have gone through this documentation:

    http://docs.puppetlabs.com/dashboard/index.html


    Which has got me to be able to get the Puppet Dash in my web browser.

    My issue is that I have added nodes to the Dash but they are claiming
    to be unreported??


    I entered the FQDN's of both server and host, the Parameters, Groups,
    and Classes sections are blank; but unfortunately the Dash is claiming
    that the hosts are not reporting in?


    Puppet Client (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl


    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    report = true

    server = ps.jabber.com

    Puppet Server (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    reports = store, http
    reporturl = http://ps.jabber.com:3000/reports

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion. Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration. An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig


    report = true

    server = ps.jabber.com


    Here is output of puppet agent --test on client:


    # puppet agent --test
    info: Caching catalog for pc.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.01 seconds


    ...and server:


    puppet agent --test
    info: Caching catalog for ps.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.04 seconds



    Can anybody help me?
    Based on the configuration provided above, it appears you still need
    to configure puppet so dashboard is the external node terminus:


    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#using-dashboard-for-node-classification

    HTH,

    Nan
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/v6AdrZkSmZoJ.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Kaya Saman at May 8, 2012 at 8:53 am

    On Fri, May 4, 2012 at 5:23 PM, Nan Liu wrote:
    On Fri, May 4, 2012 at 3:59 AM, Kaya Saman wrote:
    Hi,

    I am still learning Puppet meaning that I'm still struggling through things.


    I have setup Puppet on CentOS 6.x (latest release), installed the
    Puppet Labs repos and followed the instructions on the site:

    http://docs.puppetlabs.com/guides/setting_up.html

    So far I am able to get the server to sign hosts and run: puppet agent
    --test on the host successfully (which is more luck then I had with
    the Puppet training ISO).


    With regards to the dashboard I have gone through this documentation:

    http://docs.puppetlabs.com/dashboard/index.html


    Which has got me to be able to get the Puppet Dash in my web browser.

    My issue is that I have added nodes to the Dash but they are claiming
    to be unreported??


    I entered the FQDN's of both server and host, the Parameters, Groups,
    and Classes sections are blank; but unfortunately the Dash is claiming
    that the hosts are not reporting in?


    Puppet Client (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl


    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    report = true

    server = ps.jabber.com

    Puppet Server (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    reports = store, http
    reporturl = http://ps.jabber.com:3000/reports

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig


    report = true

    server = ps.jabber.com


    Here is output of puppet agent --test on client:


    # puppet agent --test
    info: Caching catalog for pc.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.01 seconds


    ...and server:


    puppet agent --test
    info: Caching catalog for ps.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.04 seconds



    Can anybody help me?
    Based on the configuration provided above, it appears you still need
    to configure puppet so dashboard is the external node terminus:

    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#using-dashboard-for-node-classification

    HTH,

    Nan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    Thanks Nan for the help, however not when the new config is added....
    puppet-dashboard service won't start?

    I have checked the logs to see if there is anything defined but
    nothing comes out as being a guide to what the error maybe :-(


    Regards,

    Kaya

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Kaya Saman at May 8, 2012 at 9:07 am

    On Tue, May 8, 2012 at 9:53 AM, Kaya Saman wrote:
    On Fri, May 4, 2012 at 5:23 PM, Nan Liu wrote:
    On Fri, May 4, 2012 at 3:59 AM, Kaya Saman wrote:
    Hi,

    I am still learning Puppet meaning that I'm still struggling through things.


    I have setup Puppet on CentOS 6.x (latest release), installed the
    Puppet Labs repos and followed the instructions on the site:

    http://docs.puppetlabs.com/guides/setting_up.html

    So far I am able to get the server to sign hosts and run: puppet agent
    --test on the host successfully (which is more luck then I had with
    the Puppet training ISO).


    With regards to the dashboard I have gone through this documentation:

    http://docs.puppetlabs.com/dashboard/index.html


    Which has got me to be able to get the Puppet Dash in my web browser.

    My issue is that I have added nodes to the Dash but they are claiming
    to be unreported??


    I entered the FQDN's of both server and host, the Parameters, Groups,
    and Classes sections are blank; but unfortunately the Dash is claiming
    that the hosts are not reporting in?


    Puppet Client (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl


    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    report = true

    server = ps.jabber.com

    Puppet Server (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    reports = store, http
    reporturl = http://ps.jabber.com:3000/reports

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig


    report = true

    server = ps.jabber.com


    Here is output of puppet agent --test on client:


    # puppet agent --test
    info: Caching catalog for pc.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.01 seconds


    ...and server:


    puppet agent --test
    info: Caching catalog for ps.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.04 seconds



    Can anybody help me?
    Based on the configuration provided above, it appears you still need
    to configure puppet so dashboard is the external node terminus:

    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#using-dashboard-for-node-classification

    HTH,

    Nan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    Thanks Nan for the help, however not when the new config is added....
    puppet-dashboard service won't start?

    I have checked the logs to see if there is anything defined but
    nothing comes out as being a guide to what the error maybe :-(


    Regards,

    Kaya

    Additionally something weird that has happened this morning is that my
    Puppet agents won't sync up??


    I've tested the time, ran ntpdate <server> and then enabled ntpd; this
    unfortunately doesn't help.


    What is strange is that it was working fine last week, even with reboots.???


    The logs don't really give any information other then: "Could not
    retrieve catalog from remote server, not using cache on failed
    catalog, could not retrieve catalog, could not send report"


    I will continue debugging but I don't understand what's going on!


    --K

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Kaya Saman at May 8, 2012 at 12:52 pm

    On Tue, May 8, 2012 at 10:07 AM, Kaya Saman wrote:
    On Tue, May 8, 2012 at 9:53 AM, Kaya Saman wrote:
    On Fri, May 4, 2012 at 5:23 PM, Nan Liu wrote:
    On Fri, May 4, 2012 at 3:59 AM, Kaya Saman wrote:
    Hi,

    I am still learning Puppet meaning that I'm still struggling through things.


    I have setup Puppet on CentOS 6.x (latest release), installed the
    Puppet Labs repos and followed the instructions on the site:

    http://docs.puppetlabs.com/guides/setting_up.html

    So far I am able to get the server to sign hosts and run: puppet agent
    --test on the host successfully (which is more luck then I had with
    the Puppet training ISO).


    With regards to the dashboard I have gone through this documentation:

    http://docs.puppetlabs.com/dashboard/index.html


    Which has got me to be able to get the Puppet Dash in my web browser.

    My issue is that I have added nodes to the Dash but they are claiming
    to be unreported??


    I entered the FQDN's of both server and host, the Parameters, Groups,
    and Classes sections are blank; but unfortunately the Dash is claiming
    that the hosts are not reporting in?


    Puppet Client (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl


    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    report = true

    server = ps.jabber.com

    Puppet Server (puppet.conf):

    [main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    reports = store, http
    reporturl = http://ps.jabber.com:3000/reports

    [agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig


    report = true

    server = ps.jabber.com


    Here is output of puppet agent --test on client:


    # puppet agent --test
    info: Caching catalog for pc.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.01 seconds


    ...and server:


    puppet agent --test
    info: Caching catalog for ps.jabber.com
    info: Applying configuration version '1336044868'
    notice: Finished catalog run in 0.04 seconds



    Can anybody help me?
    Based on the configuration provided above, it appears you still need
    to configure puppet so dashboard is the external node terminus:

    http://docs.puppetlabs.com/dashboard/manual/1.2/bootstrapping.html#using-dashboard-for-node-classification

    HTH,

    Nan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    Thanks Nan for the help, however not when the new config is added....
    puppet-dashboard service won't start?

    I have checked the logs to see if there is anything defined but
    nothing comes out as being a guide to what the error maybe :-(


    Regards,

    Kaya

    Additionally something weird that has happened this morning is that my
    Puppet agents won't sync up??


    I've tested the time, ran ntpdate <server> and then enabled ntpd; this
    unfortunately doesn't help.


    What is strange is that it was working fine last week, even with reboots.???


    The logs don't really give any information other then: "Could not
    retrieve catalog from remote server, not using cache on failed
    catalog, could not retrieve catalog, could not send report"


    I will continue debugging but I don't understand what's going on!


    --K

    Ok I finally managed to get things going!

    It turns out that Puppet-Master hadn't been started and the fact that
    for whatever reason I needed to regenerate all my config for the
    dashboard and even the /etc/hosts file got wiped out?? Probably after
    a yum update :-( {damn linux can be annoying at times}

    So here is new issue if I run puppet agent --test on the server:

    err: Could not retrieve catalog from remote server: Error 400 on
    SERVER: Could not find node 'uk-tst-pup-1.area51.co.uk'; cannot
    compile
    warning: Not using cache on failed catalog
    err: Could not retrieve catalog; skipping run



    This is what the log shows:

    [2012-05-08 14:40:30] INFO WEBrick::HTTPServer#start: pid=1326 port=8140
    [2012-05-08 14:40:36] localhost - - [08/May/2012:14:40:36 BST] "POST
    /production/catalog/uk-tst-pup-1.area51.co.uk HTTP/1.1" 400 63
    [2012-05-08 14:40:36] - -> /production/catalog/uk-tst-pup-1.area51.co.uk
    [2012-05-08 14:40:37] localhost - - [08/May/2012:14:40:37 BST] "PUT
    /production/report/uk-tst-pup-1.area51.co.uk HTTP/1.1" 200 23
    [2012-05-08 14:40:37] - -> /production/report/uk-tst-pup-1.area51.co.uk
    [2012-05-08 14:40:44] localhost - - [08/May/2012:14:40:44 BST] "POST
    /production/catalog/uk-tst-pup-1.area51.co.uk HTTP/1.1" 400 63
    [2012-05-08 14:40:44] - -> /production/catalog/uk-tst-pup-1.area51.co.uk
    [2012-05-08 14:40:44] localhost - - [08/May/2012:14:40:44 BST] "PUT
    /production/report/uk-tst-pup-1.area51.co.uk HTTP/1.1" 200 23
    [2012-05-08 14:40:44] - -> /production/report/uk-tst-pup-1.area51.co.uk



    With /var/log/messages showing this:


    May 8 14:40:30 uk-tst-pup-1 puppet-master[1326]: Reopening log files
    May 8 14:40:30 uk-tst-pup-1 puppet-master[1326]: Starting Puppet
    master version 2.7.14
    May 8 14:40:32 uk-tst-pup-1 puppet-agent[1366]: Reopening log files
    May 8 14:40:32 uk-tst-pup-1 puppet-agent[1366]: Starting Puppet
    client version 2.7.14
    May 8 14:40:36 uk-tst-pup-1 puppet-master[1326]: Could not find node
    'uk-tst-pup-1.area51.co.uk'; cannot compile
    May 8 14:40:36 uk-tst-pup-1 puppet-agent[1366]: Could not retrieve
    catalog from remote server: Error 400 on SERVER: Could not find node
    'uk-tst-pup-1.area51.co.uk'; cannot compile
    May 8 14:40:36 uk-tst-pup-1 puppet-agent[1366]: Using cached catalog
    May 8 14:40:36 uk-tst-pup-1 puppet-agent[1366]: Could not retrieve
    catalog; skipping run
    May 8 14:40:37 uk-tst-pup-1 puppet-master[1326]: Report processor
    failed: Permission denied - connect(2)
    May 8 14:40:44 uk-tst-pup-1 puppet-master[1326]: Could not find node
    'uk-tst-pup-1.area51.co.uk'; cannot compile
    May 8 14:40:44 uk-tst-pup-1 puppet-agent[1514]: Could not retrieve
    catalog from remote server: Error 400 on SERVER: Could not find node
    'uk-tst-pup-1.area51.co.uk'; cannot compile
    May 8 14:40:44 uk-tst-pup-1 puppet-agent[1514]: Not using cache on
    failed catalog
    May 8 14:40:44 uk-tst-pup-1 puppet-agent[1514]: Could not retrieve
    catalog; skipping run
    May 8 14:40:44 uk-tst-pup-1 puppet-master[1326]: Report processor
    failed: Permission denied - connect(2)



    The name lookup should be fine:

    # nslookup uk-tst-pup-1.area51.co.uk
    Server: 172.16.8.15
    Address: 172.16.8.15#53

    Name: uk-tst-pup-1.area51.co.uk
    Address: 172.16.8.72


    and the /etc/hosts file:


    # cat /etc/hosts
    127.0.0.1 localhost localhost.localdomain localhost4
    localhost4.localdomain4 uk-tst-pup-1 uk-tst-pup-1.area51.co.uk puppet
    #127.0.0.1 uk-tst-pup-1 uk-tst-pup-1.area51.co.uk
    ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
    172.16.8.72 uk-tst-pup-1 uk-tst-pup-1.area51.co.uk puppet


    What else can I test or do in order to get round the error???


    Regards,


    Kaya

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 4, '12 at 10:59a
activeMay 8, '12 at 12:52p
posts6
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase