FAQ
Hello all,
I am trying to write a script that will check logs for puppet errors to use
in a nagios check. I am checking /var/log/messages (RHEL6) but when puppet
runs on its 30 minute interval, nothing gets written to messages. I have
also looked at /var/log/puppet/puppet.log but that does not seem to be
consistent either:

[root@gm10v nagios]# tail /var/log/puppet/puppet.log
Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in is_cms_system
Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in lampp_ssl_sn2
Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in vips_vip1_ip
Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
gs_batch_itcl_mfb
Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in is_ntp
Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
gs_batch_getrates_lbma
Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
is_clusterworker
Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in cl_lvs_ssl1
Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
is_feedlistener
Wed May 02 14:27:47 [root@gm10v nagios]#

It does not seem to finish logging.

/var/lib/puppet/state/state.yaml is not much better.

Where can I search for errors?

Thanks,
John

John Kennedy

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Michael Baydoun at May 2, 2012 at 5:14 pm
    Do you have reports=log in your puppet.conf?
    On Wed, May 2, 2012 at 12:49 PM, John Kennedy wrote:

    Hello all,
    I am trying to write a script that will check logs for puppet errors to
    use in a nagios check. I am checking /var/log/messages (RHEL6) but when
    puppet runs on its 30 minute interval, nothing gets written to messages. I
    have also looked at /var/log/puppet/puppet.log but that does not seem to be
    consistent either:

    [root@gm10v nagios]# tail /var/log/puppet/puppet.log
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
    is_cms_system
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
    lampp_ssl_sn2
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in vips_vip1_ip
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
    gs_batch_itcl_mfb
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in is_ntp
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
    gs_batch_getrates_lbma
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
    is_clusterworker
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in cl_lvs_ssl1
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in
    is_feedlistener
    Wed May 02 14:27:47 [root@gm10v nagios]#

    It does not seem to finish logging.

    /var/lib/puppet/state/state.yaml is not much better.

    Where can I search for errors?

    Thanks,
    John

    John Kennedy

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Bernd Adamowicz at May 3, 2012 at 12:07 pm
    You should try

    debug = true
    verbose = true

    in your agent and/or master configurations. Some more hints on monitoring and on Nagios/Icinga checks are found here: http://www.bernd-adamowicz.de/180/monitoring-puppet-part-3/

    Bernd

    Von: puppet-users@googlegroups.com Im Auftrag von John Kennedy
    Gesendet: Mittwoch, 2. Mai 2012 18:49
    An: puppet-users@googlegroups.com
    Betreff: [Puppet Users] Puppet logging

    Hello all,
    I am trying to write a script that will check logs for puppet errors to use in a nagios check. I am checking /var/log/messages (RHEL6) but when puppet runs on its 30 minute interval, nothing gets written to messages. I have also looked at /var/log/puppet/puppet.log but that does not seem to be consistent either:

    [root@gm10v nagios]# tail /var/log/puppet/puppet.log
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in is_cms_system
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in lampp_ssl_sn2
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in vips_vip1_ip
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in gs_batch_itcl_mfb
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in is_ntp
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in gs_batch_getrates_lbma
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in is_clusterworker
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in cl_lvs_ssl1
    Wed May 02 14:27:47 +0000 2012 Puppet (info): Loading facts in is_feedlistener
    Wed May 02 14:27:47 [root@gm10v nagios]#

    It does not seem to finish logging.

    /var/lib/puppet/state/state.yaml is not much better.

    Where can I search for errors?

    Thanks,
    John

    John Kennedy
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com .
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com .
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • John Kennedy at May 4, 2012 at 11:46 am

    On Thu, May 3, 2012 at 8:07 AM, Bernd Adamowicz wrote:

    You should try****

    ** **

    debug = true****

    verbose = true****

    ** **

    in your agent and/or master configurations. Some more hints on monitoring
    and on Nagios/Icinga checks are found here:
    http://www.bernd-adamowicz.de/180/monitoring-puppet-part-3/****

    ** **

    Bernd****

    ** **
    reports=log
    debug=true and
    verbose=true
    all added to puppet.conf on node. No change to output.

    # puppet --version
    2.6.7
    Running on RHEL 6 (puppet installed/updated from EPEL repo)

    Any other thoughts or suggestions?

    Thanks,
    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Michael Baydoun at May 5, 2012 at 12:08 am
    Is your daemon started with a different --logdest=/path/file specified?
    On Fri, May 4, 2012 at 7:45 AM, John Kennedy wrote:


    On Thu, May 3, 2012 at 8:07 AM, Bernd Adamowicz <
    Bernd.Adamowicz@esailors.de> wrote:
    You should try****

    ** **

    debug = true****

    verbose = true****

    ** **

    in your agent and/or master configurations. Some more hints on monitoring
    and on Nagios/Icinga checks are found here:
    http://www.bernd-adamowicz.de/180/monitoring-puppet-part-3/****

    ** **

    Bernd****

    ** **
    reports=log
    debug=true and
    verbose=true
    all added to puppet.conf on node. No change to output.

    # puppet --version
    2.6.7
    Running on RHEL 6 (puppet installed/updated from EPEL repo)

    Any other thoughts or suggestions?

    Thanks,
    John

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • John Kennedy at May 5, 2012 at 1:28 am
    Nope...
    Thanks,
    John

    John Kennedy


    On Fri, May 4, 2012 at 8:08 PM, Michael Baydoun wrote:

    Is your daemon started with a different --logdest=/path/file specified?
    On Fri, May 4, 2012 at 7:45 AM, John Kennedy wrote:


    On Thu, May 3, 2012 at 8:07 AM, Bernd Adamowicz <
    Bernd.Adamowicz@esailors.de> wrote:
    You should try****

    ** **

    debug = true****

    verbose = true****

    ** **

    in your agent and/or master configurations. Some more hints on
    monitoring and on Nagios/Icinga checks are found here:
    http://www.bernd-adamowicz.de/180/monitoring-puppet-part-3/****

    ** **

    Bernd****

    ** **
    reports=log
    debug=true and
    verbose=true
    all added to puppet.conf on node. No change to output.

    # puppet --version
    2.6.7
    Running on RHEL 6 (puppet installed/updated from EPEL repo)

    Any other thoughts or suggestions?

    Thanks,
    John

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Michael Baydoun at May 5, 2012 at 3:00 am
    Can you post your full puppet.conf? Redact anything sensitive.
    On Fri, May 4, 2012 at 9:27 PM, John Kennedy wrote:

    Nope...
    Thanks,
    John

    John Kennedy



    On Fri, May 4, 2012 at 8:08 PM, Michael Baydoun wrote:

    Is your daemon started with a different --logdest=/path/file specified?
    On Fri, May 4, 2012 at 7:45 AM, John Kennedy wrote:


    On Thu, May 3, 2012 at 8:07 AM, Bernd Adamowicz <
    Bernd.Adamowicz@esailors.de> wrote:
    You should try****

    ** **

    debug = true****

    verbose = true****

    ** **

    in your agent and/or master configurations. Some more hints on
    monitoring and on Nagios/Icinga checks are found here:
    http://www.bernd-adamowicz.de/180/monitoring-puppet-part-3/****

    ** **

    Bernd****

    ** **
    reports=log
    debug=true and
    verbose=true
    all added to puppet.conf on node. No change to output.

    # puppet --version
    2.6.7
    Running on RHEL 6 (puppet installed/updated from EPEL repo)

    Any other thoughts or suggestions?

    Thanks,
    John

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • John Kennedy at May 5, 2012 at 12:04 pm
    Here it is in almost all it's glory (comments removed and server domain
    changed...):

    [main]
    logdir = /var/log/puppet

    rundir = /var/run/puppet

    ssldir = /etc/puppet/ssl

    runinetrval = 600
    pluginsync=true

    [agent]
    classfile = /classes.txt

    localconfig = /localconfig

    report = true
    reports = log
    server = puppet.example.com
    debug = true
    verbose = true
    logdest = /var/log/puppet/puppet.log

    Thanks,
    John

    John Kennedy


    On Fri, May 4, 2012 at 11:00 PM, Michael Baydoun wrote:

    Can you post your full puppet.conf? Redact anything sensitive.

    On Fri, May 4, 2012 at 9:27 PM, John Kennedy wrote:

    Nope...
    Thanks,
    John

    John Kennedy



    On Fri, May 4, 2012 at 8:08 PM, Michael Baydoun wrote:

    Is your daemon started with a different --logdest=/path/file specified?
    On Fri, May 4, 2012 at 7:45 AM, John Kennedy wrote:


    On Thu, May 3, 2012 at 8:07 AM, Bernd Adamowicz <
    Bernd.Adamowicz@esailors.de> wrote:
    You should try****

    ** **

    debug = true****

    verbose = true****

    ** **

    in your agent and/or master configurations. Some more hints on
    monitoring and on Nagios/Icinga checks are found here:
    http://www.bernd-adamowicz.de/180/monitoring-puppet-part-3/****

    ** **

    Bernd****

    ** **
    reports=log
    debug=true and
    verbose=true
    all added to puppet.conf on node. No change to output.

    # puppet --version
    2.6.7
    Running on RHEL 6 (puppet installed/updated from EPEL repo)

    Any other thoughts or suggestions?

    Thanks,
    John

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Michael Baydoun at May 5, 2012 at 3:59 pm
    I think this line
    logdest = /var/log/puppet/puppet.log
    is the same as starting the daemon with --logdest

    I believe you are logging to /var/log/puppet/puppet.log
    Remove that line and I think it will log to syslog

    On Sat, May 5, 2012 at 8:04 AM, John Kennedy wrote:

    Here it is in almost all it's glory (comments removed and server domain
    changed...):

    [main]
    logdir = /var/log/puppet

    rundir = /var/run/puppet

    ssldir = /etc/puppet/ssl

    runinetrval = 600
    pluginsync=true

    [agent]
    classfile = /classes.txt

    localconfig = /localconfig

    report = true
    reports = log
    server = puppet.example.com

    debug = true
    verbose = true
    logdest = /var/log/puppet/puppet.log

    Thanks,
    John

    John Kennedy



    On Fri, May 4, 2012 at 11:00 PM, Michael Baydoun wrote:

    Can you post your full puppet.conf? Redact anything sensitive.

    On Fri, May 4, 2012 at 9:27 PM, John Kennedy wrote:

    Nope...
    Thanks,
    John

    John Kennedy



    On Fri, May 4, 2012 at 8:08 PM, Michael Baydoun wrote:

    Is your daemon started with a different --logdest=/path/file specified?
    On Fri, May 4, 2012 at 7:45 AM, John Kennedy wrote:


    On Thu, May 3, 2012 at 8:07 AM, Bernd Adamowicz <
    Bernd.Adamowicz@esailors.de> wrote:
    You should try****

    ** **

    debug = true****

    verbose = true****

    ** **

    in your agent and/or master configurations. Some more hints on
    monitoring and on Nagios/Icinga checks are found here:
    http://www.bernd-adamowicz.de/180/monitoring-puppet-part-3/****

    ** **

    Bernd****

    ** **
    reports=log
    debug=true and
    verbose=true
    all added to puppet.conf on node. No change to output.

    # puppet --version
    2.6.7
    Running on RHEL 6 (puppet installed/updated from EPEL repo)

    Any other thoughts or suggestions?

    Thanks,
    John

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 2, '12 at 4:49p
activeMay 5, '12 at 3:59p
posts9
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2019 Grokbase