FAQ
Hi All,

My puppet dashboard has been working fine. I was just refreshing the
page and suddenly I got "problem loading page" and "The connection was
reset error".

I restarted everything, mysqld, httpd, dashboard and dashboard-workers
and confirmed all the services including passenger was running. I
don't see any errors anywhere. No changes made, no iptables , I can
ping my desktop from the server and vice versa. I can also telnet to
the port from another server.
This is how I have been accessing it:

http:<ip>:3000

The config in my puppet master puppet.conf

reports = store, http
reporturl = http://<ip>:3000/reports/upload

[agent]
pluginsync = false
report = true

My passenger.conf settings:

LoadModule passenger_module modules/mod_passenger.so
<IfModule mod_passenger.c>
PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-3.0.11
PassengerRuby /usr/bin/ruby
PassengerTempDir /var/run/passenger
</IfModule>
<VirtualHost *:3000>
ServerName <ip>
DocumentRoot /usr/share/puppet-dashboard/public
<Directory /usr/share/puppet-dashboard/public>
AllowOverride all
Options -MultiViews
Order allow,deny
allow from all
</Directory>
</VirtualHost>

Any leads or hints is much appreaciated.

Thank you in advance.

kc.



--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Kc at Apr 30, 2012 at 1:10 am
    I've checked the logs in /usr/share/puppet-dashboard/log

    delayed_job.log
    2012-04-27T21:02:35+0000: [Worker(delayed_job.0 host: <servername of
    dashboard> pid:25507)] Report.create_from_yaml_file completed after
    0.3300
    2012-04-27T21:02:35+0000: [Worker(delayed_job.0 host: <servername of
    dashboard> pid:25507)] 1 jobs processed at 2.9742 j/s, 0 failed ...

    production.log
    Processing ReportsController#upload (for <puppet master> at 2012-04-27
    21:16:26) [POST]
    Parameters: {"action"=>"upload", "controller"=>"reports"}
    Completed in 10ms (View: 1, DB: 4) | 200 OK [http://<ip of dashbaord>/
    reports/upload]
    Processing ReportsController#upload (for <puppet master> at 2012-04-27
    21:16:48) [POST]
    Parameters: {"action"=>"upload", "controller"=>"reports"}
    Completed in 11ms (View: 1, DB: 4) | 200 OK [http://<ip of dashboard>/
    reports/upload]

    Seems ok. Could this be a routing issue ?
    On Apr 27, 3:21 pm, kc wrote:
    Hi All,

    My puppet dashboard has been working fine. I was just refreshing the
    page and suddenly I got "problem loading page" and "The connection was
    reset error".

    I restarted everything, mysqld, httpd, dashboard and dashboard-workers
    and confirmed all the services including passenger was running. I
    don't see any errors anywhere. No changes made, no iptables , I can
    ping my desktop from the server and vice versa. I can also telnet to
    the port from another server.
    This is how I have been accessing it:

    http:<ip>:3000

    The config in my puppet master puppet.conf

    reports = store, http
    reporturl = http://<ip>:3000/reports/upload

    [agent]
    pluginsync = false
    report = true

    My passenger.conf settings:

    LoadModule passenger_module modules/mod_passenger.so
    <IfModule mod_passenger.c>
    PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-3.0.11
    PassengerRuby /usr/bin/ruby
    PassengerTempDir /var/run/passenger
    </IfModule>
    <VirtualHost *:3000>
    ServerName <ip>
    DocumentRoot /usr/share/puppet-dashboard/public
    <Directory /usr/share/puppet-dashboard/public>
    AllowOverride all
    Options -MultiViews
    Order allow,deny
    allow from all
    </Directory>
    </VirtualHost>

    Any leads or hints is much appreaciated.

    Thank you in advance.

    kc.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedApr 27, '12 at 7:25p
activeApr 30, '12 at 1:10a
posts2
users1
websitepuppetlabs.com

1 user in discussion

Kc: 2 posts

People

Translate

site design / logo © 2022 Grokbase