FAQ
Hi Everyone;

I want puppet to be installed in /app/puppet instead of the default /etc.
I cannot figure out how to get the puppetmasterd to look for the
config file (puppet.conf) in /app/puppet instead of /etc/puppet.

If anyone can help, I would really appreciate it!

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Craig White at Apr 19, 2012 at 8:14 pm

    On Apr 19, 2012, at 12:56 PM, JA wrote:

    Hi Everyone;

    I want puppet to be installed in /app/puppet instead of the default /etc.
    I cannot figure out how to get the puppetmasterd to look for the
    config file (puppet.conf) in /app/puppet instead of /etc/puppet.

    If anyone can help, I would really appreciate it!
    ----
    not exactly responsive to your question as I suspect that the path is hard coded but...

    If you're hard pressed for disk space why not make a symlink from /app/puppet to /etc/puppet so that puppetmasterd would never know the difference?

    Craig

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Stefan Schulte at Apr 19, 2012 at 10:13 pm

    On Thu, Apr 19, 2012 at 03:56:37PM -0400, JA wrote:
    Hi Everyone;

    I want puppet to be installed in /app/puppet instead of the default /etc.
    I cannot figure out how to get the puppetmasterd to look for the
    config file (puppet.conf) in /app/puppet instead of /etc/puppet.

    If anyone can help, I would really appreciate it!
    It should work if you start your master with --confdir /app/puppet

    -Stefan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • JA at Apr 24, 2012 at 6:18 pm
    Stefan;

    Thanks for the suggestion. However, we are running puppet via
    Passenger. So, I assume I need to update the config.ru file. Do you
    have any suggestions about that? Greatly appreciate your help and
    advice!


    On Thu, Apr 19, 2012 at 6:17 PM, Stefan Schulte
    wrote:
    On Thu, Apr 19, 2012 at 03:56:37PM -0400, JA wrote:
    Hi Everyone;

    I want puppet to be installed in /app/puppet instead of the default /etc.
    I cannot figure out how to get the puppetmasterd to look for the
    config file (puppet.conf) in /app/puppet instead of /etc/puppet.

    If anyone can help, I would really appreciate it!
    It should work if you start your master with --confdir /app/puppet

    -Stefan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Nigel Kersten at Apr 24, 2012 at 6:30 pm

    On Tue, Apr 24, 2012 at 11:18 AM, JA wrote:

    Stefan;

    Thanks for the suggestion. However, we are running puppet via
    Passenger. So, I assume I need to update the config.ru file. Do you
    have any suggestions about that? Greatly appreciate your help and
    advice!
    Look for the ARGV line like:

    ARGV << "--rack"

    and modify it to:

    ARGV << "--config" << "path/to/your/config" << "--rack"



    On Thu, Apr 19, 2012 at 6:17 PM, Stefan Schulte
    wrote:
    On Thu, Apr 19, 2012 at 03:56:37PM -0400, JA wrote:
    Hi Everyone;

    I want puppet to be installed in /app/puppet instead of the default
    /etc.
    I cannot figure out how to get the puppetmasterd to look for the
    config file (puppet.conf) in /app/puppet instead of /etc/puppet.

    If anyone can help, I would really appreciate it!
    It should work if you start your master with --confdir /app/puppet

    -Stefan

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • JA at Apr 24, 2012 at 7:14 pm
    Thanks!

    I am (obviously) very new to ruby/rack!!

    Thanks!
    On Tue, Apr 24, 2012 at 2:30 PM, Nigel Kersten wrote:

    On Tue, Apr 24, 2012 at 11:18 AM, JA wrote:

    Stefan;

    Thanks for the suggestion.  However, we are running puppet via
    Passenger.  So, I assume I need to update the config.ru file.  Do you
    have any suggestions about that?  Greatly appreciate your help and
    advice!

    Look for the ARGV line like:

    ARGV << "--rack"

    and modify it to:

    ARGV << "--config" << "path/to/your/config" << "--rack"



    On Thu, Apr 19, 2012 at 6:17 PM, Stefan Schulte
    wrote:
    On Thu, Apr 19, 2012 at 03:56:37PM -0400, JA wrote:
    Hi Everyone;

    I want puppet to be installed in /app/puppet instead of the default
    /etc.
    I cannot figure out how to get the puppetmasterd to look for the
    config file (puppet.conf) in /app/puppet instead of /etc/puppet.

    If anyone can help, I would really appreciate it!
    It should work if you start your master with --confdir /app/puppet

    -Stefan

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Ramin K at Apr 25, 2012 at 8:56 am

    On 4/24/2012 11:18 AM, JA wrote:
    Stefan;

    Thanks for the suggestion. However, we are running puppet via
    Passenger. So, I assume I need to update the config.ru file. Do you
    have any suggestions about that? Greatly appreciate your help and
    advice!
    in your config.ru add an additional ARGV line
    ARGV << "--config=/my/path/to/puppet.conf"

    Ramin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedApr 19, '12 at 7:56p
activeApr 25, '12 at 8:56a
posts7
users5
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase