FAQ

On Mon, Apr 16, 2012 at 4:14 AM, Afroz Hussain wrote:
Hi,

I updated the Puppet Enterprise 2.0 to 2.5.1 and tried to restart the httpd
and getting following error in /var/log/pe-httpd/puppetdashboard.error.log

[warn] RSA server certificate CommonName (CN) `pe-internal-dashboard' does
NOT match server name!?
This question might be better suited for the pe-users list. [1]

This is just a warning and not an actual error. It means the
certificate's Common Name field doesn't match the server name Apache
is using for the virtual host.

Unfortunately this is by design for the time being. We're having
difficult coming up with a reliable way to issue the certificate used
by the Console's HTTPS vhost. Ideally, the certificate name will
match the hostname, but this is very difficult to make work reliably
given the state of name resolution in most networks PE is installed
into. To make installation and upgrades reliable, we simply issue a
certificate named pe-internal-dashboard rather than try to figure out
the hostname.

[1] https://groups.google.com/a/puppetlabs.com/group/pe-users/topics

Hope this helps,
-Jeff

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

  • Afroz Hussain at Apr 17, 2012 at 10:52 am
    Thanks a lot Jeff,

    yes, It is an warning but still I am not able to access the dashboard,
    Pasted the error:


    I am unable to access the
    https://groups.google.com/a/puppetlabs.com/group/pe-users/topics because of
    permission issues.
    I can see there some certificates for " pe-internal-dashboard" in
    /opt/puppet/share/puppet-dashboard/certs and tried to sign cert as follows:
    puppet cert --sign pe-internal-dashboard
    err: Could not call sign: Could not find certificate request for
    pe-internal-dashboard

    Is it possible to change cn_name: 'pe-internal-dashboard' to cn_name:
    'puppet1' (local hostname) in settings.yml file?

    Thanks,
    On Tue, Apr 17, 2012 at 2:21 AM, Jeff McCune wrote:
    On Mon, Apr 16, 2012 at 4:14 AM, Afroz Hussain wrote:
    Hi,

    I updated the Puppet Enterprise 2.0 to 2.5.1 and tried to restart the httpd
    and getting following error in
    /var/log/pe-httpd/puppetdashboard.error.log
    [warn] RSA server certificate CommonName (CN) `pe-internal-dashboard' does
    NOT match server name!?
    This question might be better suited for the pe-users list. [1]

    This is just a warning and not an actual error. It means the
    certificate's Common Name field doesn't match the server name Apache
    is using for the virtual host.

    Unfortunately this is by design for the time being. We're having
    difficult coming up with a reliable way to issue the certificate used
    by the Console's HTTPS vhost. Ideally, the certificate name will
    match the hostname, but this is very difficult to make work reliably
    given the state of name resolution in most networks PE is installed
    into. To make installation and upgrades reliable, we simply issue a
    certificate named pe-internal-dashboard rather than try to figure out
    the hostname.

    [1] https://groups.google.com/a/puppetlabs.com/group/pe-users/topics

    Hope this helps,
    -Jeff

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.

    --
    Thanks,
    Aphroj Hussain

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Jeff McCune at Apr 17, 2012 at 3:59 pm

    On Tue, Apr 17, 2012 at 3:52 AM, Afroz Hussain wrote:
    Thanks a lot Jeff,

    yes, It is an warning but still I am not able to access the dashboard,
    Pasted the error:
    I'm unable to decode this message in a timely manner. =)

    Could you please paste the details of the error, perhaps with
    screenshots, to http://gist.github.com and send a link to the gist?

    I'm not really able to troubleshoot without this information.

    Thanks,
    -Jeff

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
  • Afroz Hussain at Apr 18, 2012 at 12:30 pm
    yes, It is an warning but still I am not able to access the dashboard,
    attached a screenshot.

    I can see there some certificates for " pe-internal-dashboard" in
    /opt/puppet/share/puppet-dashboard/certs and tried to sign cert as follows:
    puppet cert --sign pe-internal-dashboard
    err: Could not call sign: Could not find certificate request for
    pe-internal-dashboard
    On Tue, Apr 17, 2012 at 9:28 PM, Jeff McCune wrote:
    On Tue, Apr 17, 2012 at 3:52 AM, Afroz Hussain wrote:
    Thanks a lot Jeff,

    yes, It is an warning but still I am not able to access the dashboard,
    Pasted the error:
    I'm unable to decode this message in a timely manner. =)

    Could you please paste the details of the error, perhaps with
    screenshots, to http://gist.github.com and send a link to the gist?

    I'm not really able to troubleshoot without this information.

    Thanks,
    -Jeff

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to
    puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/puppet-users?hl=en.

    --
    Thanks,
    Aphroj Hussain

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To post to this group, send email to puppet-users@googlegroups.com.
    To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedApr 16, '12 at 8:52p
activeApr 18, '12 at 12:30p
posts4
users2
websitepuppetlabs.com

2 users in discussion

Jeff McCune: 2 posts Afroz Hussain: 2 posts

People

Translate

site design / logo © 2022 Grokbase