FAQ
Hi,

kiwiirc: ../deps/uv/src/unix/stream.c:1329: uv_read_stop: Assertion
`!uv__io_active(&stream->io_watcher, 4) || !(&stream->write_completed_queue
== (&stream->write_completed_queue)->prev) || !(&stream->write_queue ==
(&stream->write_queue)->prev) || stream->shutdown_req != ((void *)0) ||
stream->connect_req != ((void *)0)' failed.
Aborted

I have a nodejs process running for a few days until it eventually crashes
with the error output above - completely killing any stability for my
application.
I was previously using 0.9.* which also had the same issue but was told
that 0.10.* had it fixed. I am now running node 0.10.10 on Ubuntu and
Debian boxes - both replicate this issue within a few days of running.

I can't seem to find anything on this topic when searching around so I'm
currently at a loss. Any ideas what could be causing it? Or how I can get
around it?

Thanks,
Darren

--
--
Job Board: http://jobs.nodejs.org/
Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
You received this message because you are subscribed to the Google
Groups "nodejs" group.
To post to this group, send email to nodejs@googlegroups.com
To unsubscribe from this group, send email to
nodejs+unsubscribe@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/nodejs?hl=en?hl=en

---
You received this message because you are subscribed to the Google Groups "nodejs" group.
To unsubscribe from this group and stop receiving emails from it, send an email to nodejs+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Ben Noordhuis at Jul 4, 2013 at 11:29 am

    On Thu, Jul 4, 2013 at 10:15 AM, wrote:
    Hi,

    kiwiirc: ../deps/uv/src/unix/stream.c:1329: uv_read_stop: Assertion
    `!uv__io_active(&stream->io_watcher, 4) || !(&stream->write_completed_queue
    == (&stream->write_completed_queue)->prev) || !(&stream->write_queue ==
    (&stream->write_queue)->prev) || stream->shutdown_req != ((void *)0) ||
    stream->connect_req != ((void *)0)' failed.
    Aborted

    I have a nodejs process running for a few days until it eventually crashes
    with the error output above - completely killing any stability for my
    application.
    I was previously using 0.9.* which also had the same issue but was told that
    0.10.* had it fixed. I am now running node 0.10.10 on Ubuntu and Debian
    boxes - both replicate this issue within a few days of running.

    I can't seem to find anything on this topic when searching around so I'm
    currently at a loss. Any ideas what could be causing it? Or how I can get
    around it?

    Thanks,
    Darren
    Upgrade to the latest v0.10, it's already fixed.

    --
    --
    Job Board: http://jobs.nodejs.org/
    Posting guidelines: https://github.com/joyent/node/wiki/Mailing-List-Posting-Guidelines
    You received this message because you are subscribed to the Google
    Groups "nodejs" group.
    To post to this group, send email to nodejs@googlegroups.com
    To unsubscribe from this group, send email to
    nodejs+unsubscribe@googlegroups.com
    For more options, visit this group at
    http://groups.google.com/group/nodejs?hl=en?hl=en

    ---
    You received this message because you are subscribed to the Google Groups "nodejs" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to nodejs+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupnodejs @
categoriesnodejs
postedJul 4, '13 at 8:15a
activeJul 4, '13 at 11:29a
posts2
users2
websitenodejs.org
irc#node.js

2 users in discussion

Ben Noordhuis: 1 post Darren: 1 post

People

Translate

site design / logo © 2022 Grokbase