FAQ
I tested and reproduced same problem in mongodb 2.2.3. /2.0.8
If you have wrong configured firewall for mongodump then mongodump only
exports 101 documents. Try shutdown firewall or reconfigure it.

On Thursday, March 10, 2011 2:49:26 PM UTC+1, thetuxracer wrote:

I tried to get:

1. mongodump of the entire database.
2. mongoexport of a specific collection.
3. mongodump of a specific collection.

In all the three cases, only 101 records were dumped, even when the amount
exceeds 10000 records. I tried different collections, all with the same
result. For collections that have records less than 100, they export fine.
Even collections with 126 records, in one case exported only 101 records.
This is very frustrating, because I need to fix a bug on a production db,
which is not possible unless I get the complete dump. The logs show the
following:

http://paste.ubuntu.com/578339/

I run mongodb 1.6.5, on a 64 bit machine.

Thanks.
--
--
You received this message because you are subscribed to the Google
Groups "mongodb-user" group.
To post to this group, send email to mongodb-user@googlegroups.com
To unsubscribe from this group, send email to
mongodb-user+unsubscribe@googlegroups.com
See also the IRC channel -- freenode.net#mongodb

---
You received this message because you are subscribed to the Google Groups "mongodb-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mongodb-user+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmongodb-user @
categoriesmongodb
postedFeb 22, '13 at 6:40a
activeFeb 22, '13 at 6:40a
posts1
users1
websitemongodb.org
irc#mongodb

1 user in discussion

Stanislav Prusac: 1 post

People

Translate

site design / logo © 2022 Grokbase