FAQ
Hi All,

I have one new error, that I need help.

I configure Mojo in apache and in test server "./script/doksafe daemon"

If I access app be test server I get OK! eg:

http://www.doksafe.com:3000/welcome

Welcome to the Mojolicious real-time web framework!This page was generated
from the template "templates/example/welcome.html.ep" and the layout
"templates/layouts/default.html.ep", click here<http://www.doksafe.com:3000/welcome> to
reload the page or here <http://www.doksafe.com:3000/index.html> to move
forward to a static page.

If I access using apache (port 80) I get this error: (Any one can helpme!)

http://www.doksafe.com/welcome

Global symbol "$message" requires explicit package name at template "example/welcome.html.ep" line 3, near "This page was generated from the template".

1.

% layout 'default';

2.

% title 'Welcome';

3.

<h2><%= $message %></h2>

4.

This page was generated from the template

5.

"templates/example/welcome.html.ep" and the layout

6.

"templates/layouts/default.html.ep",

7.

<a href="<%== url_for %>">click here</a>

8.

to reload the page or

tap for more
tap for more
Method:

GET

Path:

/welcome

Base:

http://www.doksafe.com

Parameters:

{}

Stash:

{
'controller' => 'example',
'action' => 'welcome'
}

Session:

{}

Version:

1.1

User-Agent:

Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4

Connection:

keep-alive

Cache-Control:

max-age=0

Accept:

text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

X-FORWARDED-PORT:

80

Accept-Language:

pt-BR,pt;q=0.8,en-US;q=0.6,en;q=0.4

COOKIE:

expected_tab=facebook; welcome_info_name=Renato%20Tegon%20Forti; plack_session=283e3f595178cd9a7c853cc5f2abc229b3606bbd; dancer.session=905566260226039767915943019202516; AWSELB=39E34FA914BB5B20DF7F77C4AB78820218CCDA2CC69DCAB1711362FBA9573B91237844E7A1F6735F6FE67277EF494D433B7B68D195A5C7EE6427BB90C4D16C6089D9D6E3FD

Accept-Encoding:

gzip,deflate,sdch

Host:

www.doksafe.com

Accept-Charset:

ISO-8859-1,utf-8;q=0.7,*;q=0.3

X-FORWARDED-PROTO:

http

X-FORWARDED-FOR:

187.107.181.73

tap for more


--
You received this message because you are subscribed to the Google Groups "Mojolicious" group.
To view this discussion on the web visit https://groups.google.com/d/msg/mojolicious/-/lFwMd6KcnFkJ.
To post to this group, send email to mojolicious@googlegroups.com.
To unsubscribe from this group, send email to mojolicious+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/mojolicious?hl=en.

Search Discussions

  • Alister West at Oct 4, 2012 at 11:41 pm
    This is probably a bad apache conf settting.
    If you are running your app as a daemon make sure your using the ProxyPass,
    ProxyPassReverse settings.

    http://mojolicio.us/perldoc/Mojolicious/Guides/Cookbook#Apachemod_proxy


    ~~
    c|_| alisterwest.com - mmm coffee!


    On 4 October 2012 16:09, Renato Forti wrote:

    Hi All,

    I have one new error, that I need help.

    I configure Mojo in apache and in test server "./script/doksafe daemon"

    If I access app be test server I get OK! eg:

    http://www.doksafe.com:3000/welcome

    Welcome to the Mojolicious real-time web framework!This page was
    generated from the template "templates/example/welcome.html.ep" and the
    layout "templates/layouts/default.html.ep", click here<http://www.doksafe.com:3000/welcome> to
    reload the page or here <http://www.doksafe.com:3000/index.html> to move
    forward to a static page.

    If I access using apache (port 80) I get this error: (Any one can helpme!)

    http://www.doksafe.com/welcome

    Global symbol "$message" requires explicit package name at template "example/welcome.html.ep" line 3, near "This page was generated from the template".

    1.

    % layout 'default';

    2.

    % title 'Welcome';

    3.

    <h2><%= $message %></h2>

    4.

    This page was generated from the template

    5.

    "templates/example/welcome.html.ep" and the layout

    6.

    "templates/layouts/default.html.ep",

    7.

    <a href="<%== url_for %>">click here</a>

    8.

    to reload the page or

    tap for more
    tap for more
    Method:

    GET

    Path:

    /welcome

    Base:

    http://www.doksafe.com

    Parameters:

    {}

    Stash:

    {
    'controller' => 'example',
    'action' => 'welcome'
    }

    Session:

    {}

    Version:

    1.1

    User-Agent:

    Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4

    Connection:

    keep-alive

    Cache-Control:

    max-age=0

    Accept:

    text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

    X-FORWARDED-PORT:

    80

    Accept-Language:

    pt-BR,pt;q=0.8,en-US;q=0.6,en;q=0.4

    COOKIE:

    expected_tab=facebook; welcome_info_name=Renato%20Tegon%20Forti; plack_session=283e3f595178cd9a7c853cc5f2abc229b3606bbd; dancer.session=905566260226039767915943019202516; AWSELB=39E34FA914BB5B20DF7F77C4AB78820218CCDA2CC69DCAB1711362FBA9573B91237844E7A1F6735F6FE67277EF494D433B7B68D195A5C7EE6427BB90C4D16C6089D9D6E3FD

    Accept-Encoding:

    gzip,deflate,sdch

    Host:

    www.doksafe.com

    Accept-Charset:

    ISO-8859-1,utf-8;q=0.7,*;q=0.3

    X-FORWARDED-PROTO:

    http

    X-FORWARDED-FOR:

    187.107.181.73

    tap for more


    --
    You received this message because you are subscribed to the Google Groups
    "Mojolicious" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/mojolicious/-/lFwMd6KcnFkJ.
    To post to this group, send email to mojolicious@googlegroups.com.
    To unsubscribe from this group, send email to
    mojolicious+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/mojolicious?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Mojolicious" group.
    To post to this group, send email to mojolicious@googlegroups.com.
    To unsubscribe from this group, send email to mojolicious+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/mojolicious?hl=en.
  • Gabriel Vieira at Oct 4, 2012 at 11:42 pm
    Hi Renato,

    show us your apache/reverse proxy configuration.

    * Try using stash 'message'.

    ** Are you going to YAPC::Brasil? http://www.yapcbrasil.org.br/

    Regards,
    On Thu, Oct 4, 2012 at 8:34 PM, Alister West wrote:

    This is probably a bad apache conf settting.
    If you are running your app as a daemon make sure your using the
    ProxyPass, ProxyPassReverse settings.

    http://mojolicio.us/perldoc/Mojolicious/Guides/Cookbook#Apachemod_proxy


    ~~
    c|_| alisterwest.com - mmm coffee!


    On 4 October 2012 16:09, Renato Forti wrote:

    Hi All,

    I have one new error, that I need help.

    I configure Mojo in apache and in test server "./script/doksafe daemon"

    If I access app be test server I get OK! eg:

    http://www.doksafe.com:3000/welcome

    Welcome to the Mojolicious real-time web framework!This page was
    generated from the template "templates/example/welcome.html.ep" and the
    layout "templates/layouts/default.html.ep", click here<http://www.doksafe.com:3000/welcome> to
    reload the page or here <http://www.doksafe.com:3000/index.html> to move
    forward to a static page.

    If I access using apache (port 80) I get this error: (Any one can helpme!)

    http://www.doksafe.com/welcome

    Global symbol "$message" requires explicit package name at template "example/welcome.html.ep" line 3, near "This page was generated from the template".

    1.

    % layout 'default';

    2.

    % title 'Welcome';

    3.

    <h2><%= $message %></h2>

    4.

    This page was generated from the template

    5.

    "templates/example/welcome.html.ep" and the layout

    6.

    "templates/layouts/default.html.ep",

    7.

    <a href="<%== url_for %>">click here</a>

    8.

    to reload the page or

    tap for more
    tap for more
    Method:

    GET

    Path:


    /welcome

    Base:

    http://www.doksafe.com

    Parameters:

    {}

    Stash:

    {
    'controller' => 'example',
    'action' => 'welcome'
    }

    Session:

    {}

    Version:

    1.1

    User-Agent:

    Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4

    Connection:

    keep-alive

    Cache-Control:

    max-age=0

    Accept:

    text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

    X-FORWARDED-PORT:

    80

    Accept-Language:

    pt-BR,pt;q=0.8,en-US;q=0.6,en;q=0.4

    COOKIE:

    expected_tab=facebook; welcome_info_name=Renato%20Tegon%20Forti; plack_session=283e3f595178cd9a7c853cc5f2abc229b3606bbd; dancer.session=905566260226039767915943019202516; AWSELB=39E34FA914BB5B20DF7F77C4AB78820218CCDA2CC69DCAB1711362FBA9573B91237844E7A1F6735F6FE67277EF494D433B7B68D195A5C7EE6427BB90C4D16C6089D9D6E3FD

    Accept-Encoding:

    gzip,deflate,sdch

    Host:

    www.doksafe.com

    Accept-Charset:

    ISO-8859-1,utf-8;q=0.7,*;q=0.3

    X-FORWARDED-PROTO:

    http

    X-FORWARDED-FOR:

    187.107.181.73

    tap for more


    --
    You received this message because you are subscribed to the Google Groups
    "Mojolicious" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/mojolicious/-/lFwMd6KcnFkJ.
    To post to this group, send email to mojolicious@googlegroups.com.
    To unsubscribe from this group, send email to
    mojolicious+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/mojolicious?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Mojolicious" group.
    To post to this group, send email to mojolicious@googlegroups.com.
    To unsubscribe from this group, send email to
    mojolicious+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/mojolicious?hl=en.


    --
    Gabriel Vieira

    --
    You received this message because you are subscribed to the Google Groups "Mojolicious" group.
    To post to this group, send email to mojolicious@googlegroups.com.
    To unsubscribe from this group, send email to mojolicious+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/mojolicious?hl=en.
  • Renato Forti at Oct 5, 2012 at 10:36 am
    Hi, Tks for help!
    I am using Plack! no Proxy! I have mod_perl that rus Mojo to me. See my
    configuration below!

    <Location />
    SetHandler perl-script
    PerlHandler Plack::Handler::Apache2
    PerlSetVar psgi_app
    /hades/htdocs/zones/sa/east/1b/doksafe/script/doksafe
    </Location>

    I think! I'm a newbie, I do not know if we're talking about the same thing.

    What is stash 'message'?

    Well I don't know! I newbie in Perl, I am from Americana-SP. I will try to
    go!

    Thanks

    Em quinta-feira, 4 de outubro de 2012 20h42min17s UTC-3, Gabriel Vieira
    escreveu:
    Hi Renato,

    show us your apache/reverse proxy configuration.

    * Try using stash 'message'.

    ** Are you going to YAPC::Brasil? http://www.yapcbrasil.org.br/

    Regards,

    On Thu, Oct 4, 2012 at 8:34 PM, Alister West <ali...@alisterwest.com<javascript:>
    wrote:
    This is probably a bad apache conf settting.
    If you are running your app as a daemon make sure your using the
    ProxyPass, ProxyPassReverse settings.

    http://mojolicio.us/perldoc/Mojolicious/Guides/Cookbook#Apachemod_proxy


    ~~
    c|_| alisterwest.com - mmm coffee!



    On 4 October 2012 16:09, Renato Forti <rtf...@gmail.com <javascript:>>wrote:
    Hi All,

    I have one new error, that I need help.

    I configure Mojo in apache and in test server "./script/doksafe daemon"

    If I access app be test server I get OK! eg:

    http://www.doksafe.com:3000/welcome

    Welcome to the Mojolicious real-time web framework!This page was
    generated from the template "templates/example/welcome.html.ep" and the
    layout "templates/layouts/default.html.ep", click here<http://www.doksafe.com:3000/welcome> to
    reload the page or here <http://www.doksafe.com:3000/index.html> to
    move forward to a static page.

    If I access using apache (port 80) I get this error: (Any one can
    helpme!)

    http://www.doksafe.com/welcome

    Global symbol "$message" requires explicit package name at template "example/welcome.html.ep" line 3, near "This page was generated from the template".

    1.

    % layout 'default';

    2.

    % title 'Welcome';

    3.

    <h2><%= $message %></h2>

    4.

    This page was generated from the template

    5.

    "templates/example/welcome.html.ep" and the layout

    6.

    "templates/layouts/default.html.ep",

    7.

    <a href="<%== url_for %>">click here</a>

    8.

    to reload the page or

    tap for more
    tap for more
    Method:

    GET

    Path:

    /welcome

    Base:

    http://www.doksafe.com

    Parameters:

    {}

    Stash:

    {
    'controller' => 'example',
    'action' => 'welcome'
    }

    Session:

    {}

    Version:

    1.1

    User-Agent:

    Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4

    Connection:

    keep-alive

    Cache-Control:

    max-age=0

    Accept:

    text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

    X-FORWARDED-PORT:

    80

    Accept-Language:

    pt-BR,pt;q=0.8,en-US;q=0.6,en;q=0.4

    COOKIE:

    expected_tab=facebook; welcome_info_name=Renato%20Tegon%20Forti; plack_session=283e3f595178cd9a7c853cc5f2abc229b3606bbd; dancer.session=905566260226039767915943019202516; AWSELB=39E34FA914BB5B20DF7F77C4AB78820218CCDA2CC69DCAB1711362FBA9573B91237844E7A1F6735F6FE67277EF494D433B7B68D195A5C7EE6427BB90C4D16C6089D9D6E3FD

    Accept-Encoding:

    gzip,deflate,sdch

    Host:

    www.doksafe.com

    Accept-Charset:

    ISO-8859-1,utf-8;q=0.7,*;q=0.3

    X-FORWARDED-PROTO:

    http

    X-FORWARDED-FOR:

    187.107.181.73

    tap for more


    --
    You received this message because you are subscribed to the Google
    Groups "Mojolicious" group.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/mojolicious/-/lFwMd6KcnFkJ.
    To post to this group, send email to mojol...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    mojolicious...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/mojolicious?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Mojolicious" group.
    To post to this group, send email to mojol...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    mojolicious...@googlegroups.com <javascript:>.
    For more options, visit this group at
    http://groups.google.com/group/mojolicious?hl=en.


    --
    Gabriel Vieira
    --
    You received this message because you are subscribed to the Google Groups "Mojolicious" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/mojolicious/-/ujdK7BqzPUQJ.
    To post to this group, send email to mojolicious@googlegroups.com.
    To unsubscribe from this group, send email to mojolicious+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/mojolicious?hl=en.
  • Renato Forti at Oct 5, 2012 at 12:48 am
    Hi Thanks for help!

    The only thing that I put in my apche is this:

    sudo vi /etc/apache2/httpd.conf

    <Location />
    SetHandler perl-script
    PerlHandler Plack::Handler::Apache2
    PerlSetVar psgi_app
    /hades/htdocs/zones/sa/east/1b/doksafe/script/doksafe
    </Location>

    Fresh instalation on ubuntu, like this:

    sudo apt-get update
    sudo apt-get install build-essential

    sudo apt-get install apache2
    sudo apt-get install libapache2-mod-perl2

    sudo curl get.mojolicio.us | sh
    sudo cpan -i Plack::Handler::Apache2
    sudo apt-get install libmojolicious-perl


    Any Idea? Thanks for help!



    Em quinta-feira, 4 de outubro de 2012 20h09min06s UTC-3, Renato Forti
    escreveu:
    Hi All,

    I have one new error, that I need help.

    I configure Mojo in apache and in test server "./script/doksafe daemon"

    If I access app be test server I get OK! eg:

    http://www.doksafe.com:3000/welcome

    Welcome to the Mojolicious real-time web framework!This page was
    generated from the template "templates/example/welcome.html.ep" and the
    layout "templates/layouts/default.html.ep", click here<http://www.doksafe.com:3000/welcome> to
    reload the page or here <http://www.doksafe.com:3000/index.html> to move
    forward to a static page.

    If I access using apache (port 80) I get this error: (Any one can helpme!)

    http://www.doksafe.com/welcome

    Global symbol "$message" requires explicit package name at template "example/welcome.html.ep" line 3, near "This page was generated from the template".

    1.

    % layout 'default';

    2.

    % title 'Welcome';

    3.

    <h2><%= $message %></h2>

    4.

    This page was generated from the template

    5.

    "templates/example/welcome.html.ep" and the layout

    6.

    "templates/layouts/default.html.ep",

    7.

    <a href="<%== url_for %>">click here</a>

    8.

    to reload the page or

    tap for more
    tap for more
    Method:

    GET

    Path:

    /welcome

    Base:

    http://www.doksafe.com

    Parameters:

    {}

    Stash:

    {
    'controller' => 'example',
    'action' => 'welcome'
    }

    Session:

    {}

    Version:

    1.1

    User-Agent:

    Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.79 Safari/537.4

    Connection:

    keep-alive

    Cache-Control:

    max-age=0

    Accept:

    text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

    X-FORWARDED-PORT:

    80

    Accept-Language:

    pt-BR,pt;q=0.8,en-US;q=0.6,en;q=0.4

    COOKIE:

    expected_tab=facebook; welcome_info_name=Renato%20Tegon%20Forti; plack_session=283e3f595178cd9a7c853cc5f2abc229b3606bbd; dancer.session=905566260226039767915943019202516; AWSELB=39E34FA914BB5B20DF7F77C4AB78820218CCDA2CC69DCAB1711362FBA9573B91237844E7A1F6735F6FE67277EF494D433B7B68D195A5C7EE6427BB90C4D16C6089D9D6E3FD

    Accept-Encoding:

    gzip,deflate,sdch

    Host:

    www.doksafe.com

    Accept-Charset:

    ISO-8859-1,utf-8;q=0.7,*;q=0.3

    X-FORWARDED-PROTO:

    http

    X-FORWARDED-FOR:

    187.107.181.73

    tap for more

    --
    You received this message because you are subscribed to the Google Groups "Mojolicious" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/mojolicious/-/IuFHo-UJnioJ.
    To post to this group, send email to mojolicious@googlegroups.com.
    To unsubscribe from this group, send email to mojolicious+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/mojolicious?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmojolicious @
categoriesperl
postedOct 4, '12 at 11:09p
activeOct 5, '12 at 10:36a
posts5
users3
websitemojolicio.us
irc#mojolicious

People

Translate

site design / logo © 2021 Grokbase