I am trying out memcaced-session-manager and everything appears to be
working correctly except that I can't reduce the amount of logging for
memcached-session-manager. I've tried setting the following in
$CATALINA_HOME/conf/logging.properties to no avail - I am still
getting INFO messages.

de.javakaffee.web.msm.level=WARN

However, I am still getting INFO messages logged to the output. Since
I am using the uriPattern lockingMode, I am getting an entry for every
single request coming into tomcat. How do I configure the session
manager to only log warning and above?

Search Discussions

  • Martin Grotzke at Nov 15, 2011 at 11:42 pm
    Hi Ben
    On 11/16/2011 12:32 AM, Ben wrote:
    I am trying out memcaced-session-manager and everything appears to be
    working correctly except that I can't reduce the amount of logging for
    memcached-session-manager. I've tried setting the following in
    $CATALINA_HOME/conf/logging.properties to no avail - I am still
    getting INFO messages.

    de.javakaffee.web.msm.level=WARN
    it should be WARNING, not WARN (tomcat logging docs:
    http://tomcat.apache.org/tomcat-7.0-doc/logging.html).

    Cheers,
    Martin
  • Ben at Nov 15, 2011 at 11:51 pm
    I tried using WARNING and that also has no effect on the logging
    output. I am using Tomcat 6.
    On Nov 15, 3:42 pm, Martin Grotzke wrote:
    Hi Ben

    On 11/16/2011 12:32 AM, Ben wrote:> I am trying out memcaced-session-manager and everything appears to be
    working correctly except that I can't reduce the amount of logging for
    memcached-session-manager.  I've tried setting the following in
    $CATALINA_HOME/conf/logging.properties to no avail - I am still
    getting INFO messages.
    de.javakaffee.web.msm.level=WARN
    it should be WARNING, not WARN (tomcat logging docs:http://tomcat.apache.org/tomcat-7.0-doc/logging.html).

    Cheers,
    Martin

    signature.asc
    < 1KViewDownload
  • Martin Grotzke at Nov 15, 2011 at 11:56 pm
    Can you give an example of the log output you're seeing?

    Cheers,
    Martin

    Am 16.11.2011 00:51 schrieb "Ben" <Benjamin_Williams@intuit.com>:
    I tried using WARNING and that also has no effect on the logging
    output. I am using Tomcat 6.
    On Nov 15, 3:42 pm, Martin Grotzke wrote:
    Hi Ben

    On 11/16/2011 12:32 AM, Ben wrote:> I am trying out
    memcaced-session-manager and everything appears to be
    working correctly except that I can't reduce the amount of logging for
    memcached-session-manager. I've tried setting the following in
    $CATALINA_HOME/conf/logging.properties to no avail - I am still
    getting INFO messages.
    de.javakaffee.web.msm.level=WARN
    it should be WARNING, not WARN (tomcat logging docs:
    http://tomcat.apache.org/tomcat-7.0-doc/logging.html).
    Cheers,
    Martin

    signature.asc
    < 1KViewDownload
  • Ben at Nov 16, 2011 at 12:02 am
    2011-11-15 15:54:41,376 INFO LockingStrategyUriPattern:73 - Not lock
    request for request [url-omitted]
    2011-11-15 15:54:41,406 INFO LockingStrategyUriPattern:66 - Lock
    request for request [url-omitted]

    -Ben
    On Nov 15, 3:56 pm, Martin Grotzke wrote:
    Can you give an example of the log output you're seeing?

    Cheers,
    Martin

    Am 16.11.2011 00:51 schrieb "Ben" <Benjamin_Willi...@intuit.com>:






    I tried using WARNING and that also has no effect on the logging
    output. I am using Tomcat 6.
    On Nov 15, 3:42 pm, Martin Grotzke <martin.grot...@googlemail.com>
    wrote:
    Hi Ben
    On 11/16/2011 12:32 AM, Ben wrote:> I am trying out
    memcaced-session-manager and everything appears to be
    working correctly except that I can't reduce the amount of logging for
    memcached-session-manager.  I've tried setting the following in
    $CATALINA_HOME/conf/logging.properties to no avail - I am still
    getting INFO messages.
    de.javakaffee.web.msm.level=WARN
    it should be WARNING, not WARN (tomcat logging docs:
    http://tomcat.apache.org/tomcat-7.0-doc/logging.html).
    Cheers,
    Martin
    signature.asc
    < 1KViewDownload
  • Ben at Nov 18, 2011 at 7:23 pm
    You can remove this thread. I resolved this issue.

    -Ben
    On Nov 15, 3:56 pm, Martin Grotzke wrote:
    Can you give an example of the log output you're seeing?

    Cheers,
    Martin

    Am 16.11.2011 00:51 schrieb "Ben" <Benjamin_Willi...@intuit.com>:






    I tried using WARNING and that also has no effect on the logging
    output. I am using Tomcat 6.
    On Nov 15, 3:42 pm, Martin Grotzke <martin.grot...@googlemail.com>
    wrote:
    Hi Ben
    On 11/16/2011 12:32 AM, Ben wrote:> I am trying out
    memcaced-session-manager and everything appears to be
    working correctly except that I can't reduce the amount of logging for
    memcached-session-manager.  I've tried setting the following in
    $CATALINA_HOME/conf/logging.properties to no avail - I am still
    getting INFO messages.
    de.javakaffee.web.msm.level=WARN
    it should be WARNING, not WARN (tomcat logging docs:
    http://tomcat.apache.org/tomcat-7.0-doc/logging.html).
    Cheers,
    Martin
    signature.asc
    < 1KViewDownload
  • Martin Grotzke at Nov 18, 2011 at 7:41 pm
    Can you share what has been the issue / how you resolved it?

    Cheers,
    Martin

    Am 18.11.2011 20:23 schrieb "Ben" <Benjamin_Williams@intuit.com>:
    You can remove this thread. I resolved this issue.

    -Ben
    On Nov 15, 3:56 pm, Martin Grotzke wrote:
    Can you give an example of the log output you're seeing?

    Cheers,
    Martin

    Am 16.11.2011 00:51 schrieb "Ben" <Benjamin_Willi...@intuit.com>:






    I tried using WARNING and that also has no effect on the logging
    output. I am using Tomcat 6.
    On Nov 15, 3:42 pm, Martin Grotzke <martin.grot...@googlemail.com>
    wrote:
    Hi Ben
    On 11/16/2011 12:32 AM, Ben wrote:> I am trying out
    memcaced-session-manager and everything appears to be
    working correctly except that I can't reduce the amount of logging
    for
    memcached-session-manager. I've tried setting the following in
    $CATALINA_HOME/conf/logging.properties to no avail - I am still
    getting INFO messages.
    de.javakaffee.web.msm.level=WARN
    it should be WARNING, not WARN (tomcat logging docs:
    http://tomcat.apache.org/tomcat-7.0-doc/logging.html).
    Cheers,
    Martin
    signature.asc
    < 1KViewDownload

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmemcached-session-manager @
categoriesmemcached
postedNov 15, '11 at 11:41p
activeNov 18, '11 at 7:41p
posts7
users2
websitememcached.org

2 users in discussion

Ben: 4 posts Martin Grotzke: 3 posts

People

Translate

site design / logo © 2022 Grokbase