FAQ
It's crashing on emulator and x86 devices. I've been tracking github issues
on this front. I'm not sure if Go 1.6 supports it.

--
You received this message because you are subscribed to the Google Groups "golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Hyang-Ah Hana Kim at Mar 11, 2016 at 5:50 pm
    1.6 includes experimental support.
    Feel free to file an issue - I will need a crash log and how to reproduce
    it (since builder is quiet I need it)
    On Fri, Mar 11, 2016 at 9:30 AM, wrote:

    It's crashing on emulator and x86 devices. I've been tracking github
    issues on this front. I'm not sure if Go 1.6 supports it.

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.


    --
    __

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Bharath MG at Mar 11, 2016 at 6:07 pm
    Hi!

    The problem is it couldn't find libgojni.so in x86. Gomobile only generated
    .so file under armeabi-v7a folder. Should I reinstall go 1.6 with any
    specific settings to generate libgojini.so file under x86 folder? I
    couldn't find any doc regarding this. I tried with,

    gomobile bind -target android/386 -o filename.aar

    But that target is not defined. Only android/ios are available. Thanks a
    lot for your help!
    On Fri, Mar 11, 2016 at 11:20 PM, Hyang-Ah Hana Kim wrote:

    1.6 includes experimental support.
    Feel free to file an issue - I will need a crash log and how to reproduce
    it (since builder is quiet I need it)
    On Fri, Mar 11, 2016 at 9:30 AM, wrote:

    It's crashing on emulator and x86 devices. I've been tracking github
    issues on this front. I'm not sure if Go 1.6 supports it.

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.


    --
    __


    --

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Hyang-Ah Hana Kim at Mar 11, 2016 at 6:09 pm
    please update and reinstall gomobile command.
    On Friday, March 11, 2016, Bharath MG wrote:

    Hi!

    The problem is it couldn't find libgojni.so in x86. Gomobile only
    generated .so file under armeabi-v7a folder. Should I reinstall go 1.6
    with any specific settings to generate libgojini.so file under x86 folder?
    I couldn't find any doc regarding this. I tried with,

    gomobile bind -target android/386 -o filename.aar

    But that target is not defined. Only android/ios are available. Thanks a
    lot for your help!

    On Fri, Mar 11, 2016 at 11:20 PM, Hyang-Ah Hana Kim <hyangah@gmail.com
    wrote:
    1.6 includes experimental support.
    Feel free to file an issue - I will need a crash log and how to reproduce
    it (since builder is quiet I need it)

    On Fri, Mar 11, 2016 at 9:30 AM, <bharath@hammerhead.io
    wrote:
    It's crashing on emulator and x86 devices. I've been tracking github
    issues on this front. I'm not sure if Go 1.6 supports it.

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts+unsubscribe@googlegroups.com
    <javascript:_e(%7B%7D,'cvml','golang-nuts%2bunsubscribe@googlegroups.com');>
    .
    For more options, visit https://groups.google.com/d/optout.


    --
    __


    --
    --
    __

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Bharath MG at Mar 11, 2016 at 7:21 pm
    That worked perfectly! Thanks a lot!
    On Fri, Mar 11, 2016 at 11:39 PM, Hyang-Ah Hana Kim wrote:

    please update and reinstall gomobile command.

    On Friday, March 11, 2016, Bharath MG wrote:

    Hi!

    The problem is it couldn't find libgojni.so in x86. Gomobile only
    generated .so file under armeabi-v7a folder. Should I reinstall go 1.6
    with any specific settings to generate libgojini.so file under x86 folder?
    I couldn't find any doc regarding this. I tried with,

    gomobile bind -target android/386 -o filename.aar

    But that target is not defined. Only android/ios are available. Thanks a
    lot for your help!

    On Fri, Mar 11, 2016 at 11:20 PM, Hyang-Ah Hana Kim <hyangah@gmail.com>
    wrote:
    1.6 includes experimental support.
    Feel free to file an issue - I will need a crash log and how to
    reproduce it (since builder is quiet I need it)
    On Fri, Mar 11, 2016 at 9:30 AM, wrote:

    It's crashing on emulator and x86 devices. I've been tracking github
    issues on this front. I'm not sure if Go 1.6 supports it.

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.


    --
    __


    --
    --
    __


    --

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Casey Manus at Mar 29, 2016 at 8:47 pm
    I updated the gomobile command (deleted it, then did a go get followed by
    gomobile init) and I am still having the exact same issue. What was the
    final gobind command that worked for you?
    On Friday, March 11, 2016 at 1:21:45 PM UTC-6, Bharath MG wrote:

    That worked perfectly! Thanks a lot!

    On Fri, Mar 11, 2016 at 11:39 PM, Hyang-Ah Hana Kim <hya...@gmail.com
    <javascript:>> wrote:
    please update and reinstall gomobile command.


    On Friday, March 11, 2016, Bharath MG <bha...@hammerhead.io <javascript:>>
    wrote:
    Hi!

    The problem is it couldn't find libgojni.so in x86. Gomobile only
    generated .so file under armeabi-v7a folder. Should I reinstall go 1.6
    with any specific settings to generate libgojini.so file under x86 folder?
    I couldn't find any doc regarding this. I tried with,

    gomobile bind -target android/386 -o filename.aar

    But that target is not defined. Only android/ios are available. Thanks a
    lot for your help!

    On Fri, Mar 11, 2016 at 11:20 PM, Hyang-Ah Hana Kim <hyangah@gmail.com>
    wrote:
    1.6 includes experimental support.
    Feel free to file an issue - I will need a crash log and how to
    reproduce it (since builder is quiet I need it)
    On Fri, Mar 11, 2016 at 9:30 AM, wrote:

    It's crashing on emulator and x86 devices. I've been tracking github
    issues on this front. I'm not sure if Go 1.6 supports it.

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.


    --
    __


    --
    --
    __


    --
    --
    The information contained in this message and any attachments is intended only
    for the use of the individual or entity to which it is addressed, and may
    contain information that is privileged, confidential and exempt from disclosure
    under applicable law. If you have received this message in error, you are
    prohibited from copying, distributing, or using the information. Please
    contact the sender immediately by return e-mail and delete the original
    message. ID442

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Hyang-Ah Hana Kim at Mar 30, 2016 at 1:13 pm
    no change necessary. -target=android builds multiatch apk.
    -target=android/386 will build x86 apk. check gomobile help for details.

    On Tuesday, March 29, 2016, Casey Manus wrote:

    I updated the gomobile command (deleted it, then did a go get followed by
    gomobile init) and I am still having the exact same issue. What was the
    final gobind command that worked for you?
    On Friday, March 11, 2016 at 1:21:45 PM UTC-6, Bharath MG wrote:

    That worked perfectly! Thanks a lot!

    On Fri, Mar 11, 2016 at 11:39 PM, Hyang-Ah Hana Kim <hya...@gmail.com>
    wrote:
    please update and reinstall gomobile command.

    On Friday, March 11, 2016, Bharath MG wrote:

    Hi!

    The problem is it couldn't find libgojni.so in x86. Gomobile only
    generated .so file under armeabi-v7a folder. Should I reinstall go 1.6
    with any specific settings to generate libgojini.so file under x86 folder?
    I couldn't find any doc regarding this. I tried with,

    gomobile bind -target android/386 -o filename.aar

    But that target is not defined. Only android/ios are available. Thanks
    a lot for your help!

    On Fri, Mar 11, 2016 at 11:20 PM, Hyang-Ah Hana Kim <hyangah@gmail.com>
    wrote:
    1.6 includes experimental support.
    Feel free to file an issue - I will need a crash log and how to
    reproduce it (since builder is quiet I need it)
    On Fri, Mar 11, 2016 at 9:30 AM, wrote:

    It's crashing on emulator and x86 devices. I've been tracking github
    issues on this front. I'm not sure if Go 1.6 supports it.

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.


    --
    __


    --
    --
    __


    --
    The information contained in this message and any attachments is intended only
    for the use of the individual or entity to which it is addressed, and may
    contain information that is privileged, confidential and exempt from disclosure
    under applicable law. If you have received this message in error, you are
    prohibited from copying, distributing, or using the information. Please
    contact the sender immediately by return e-mail and delete the original
    message. ID442


    --
    __

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Casey Manus at Mar 30, 2016 at 4:07 pm
    I deleted my go path and tried to install go mobile again from scratch, but
    now I am getting the error:

    Caseys-MacBook-Pro:hello caseymanus$ gomobile init

    gomobile: sha256 for "gomobile-ndk-r10e-darwin-x86_64.tar.gz":
    e8bff8a56f5688ec849a95a4e85130ce02eff5c2d54e361103777c396db8d308, want
    fa69cb2523e5c35e72c7dd24b2db594b67f79dc237db6b1becd5e24368e973e8
    On Wednesday, March 30, 2016 at 8:13:42 AM UTC-5, Hyang-Ah Hana Kim wrote:

    no change necessary. -target=android builds multiatch apk.
    -target=android/386 will build x86 apk. check gomobile help for details.


    On Tuesday, March 29, 2016, Casey Manus <cma...@trakref.com <javascript:>>
    wrote:
    I updated the gomobile command (deleted it, then did a go get followed by
    gomobile init) and I am still having the exact same issue. What was the
    final gobind command that worked for you?
    On Friday, March 11, 2016 at 1:21:45 PM UTC-6, Bharath MG wrote:

    That worked perfectly! Thanks a lot!

    On Fri, Mar 11, 2016 at 11:39 PM, Hyang-Ah Hana Kim <hya...@gmail.com>
    wrote:
    please update and reinstall gomobile command.

    On Friday, March 11, 2016, Bharath MG wrote:

    Hi!

    The problem is it couldn't find libgojni.so in x86. Gomobile only
    generated .so file under armeabi-v7a folder. Should I reinstall go 1.6
    with any specific settings to generate libgojini.so file under x86 folder?
    I couldn't find any doc regarding this. I tried with,

    gomobile bind -target android/386 -o filename.aar

    But that target is not defined. Only android/ios are available. Thanks
    a lot for your help!

    On Fri, Mar 11, 2016 at 11:20 PM, Hyang-Ah Hana Kim <hyangah@gmail.com
    wrote:
    1.6 includes experimental support.
    Feel free to file an issue - I will need a crash log and how to
    reproduce it (since builder is quiet I need it)
    On Fri, Mar 11, 2016 at 9:30 AM, wrote:

    It's crashing on emulator and x86 devices. I've been tracking github
    issues on this front. I'm not sure if Go 1.6 supports it.

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.


    --
    __


    --
    --
    __


    --
    The information contained in this message and any attachments is intended only
    for the use of the individual or entity to which it is addressed, and may
    contain information that is privileged, confidential and exempt from disclosure
    under applicable law. If you have received this message in error, you
    are prohibited from copying, distributing, or using the information. Please
    contact the sender immediately by return e-mail and delete the original
    message. ID442


    --
    __
    --
    The information contained in this message and any attachments is intended only
    for the use of the individual or entity to which it is addressed, and may
    contain information that is privileged, confidential and exempt from disclosure
    under applicable law. If you have received this message in error, you are
    prohibited from copying, distributing, or using the information. Please
    contact the sender immediately by return e-mail and delete the original
    message. ID442

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Casey Manus at Mar 30, 2016 at 6:18 pm
    I deleted everything again, this time including my $GOPATH/src folder and
    it now works. Thanks to everyone that tried to assist!
    On Friday, March 11, 2016 at 10:31:00 AM UTC-6, bha...@hammerhead.io wrote:

    It's crashing on emulator and x86 devices. I've been tracking github
    issues on this front. I'm not sure if Go 1.6 supports it.
    --
    The information contained in this message and any attachments is intended only
    for the use of the individual or entity to which it is addressed, and may
    contain information that is privileged, confidential and exempt from disclosure
    under applicable law. If you have received this message in error, you are
    prohibited from copying, distributing, or using the information. Please
    contact the sender immediately by return e-mail and delete the original
    message. ID442

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgolang-nuts @
categoriesgo
postedMar 11, '16 at 4:30p
activeMar 30, '16 at 6:18p
posts9
users3
websitegolang.org

People

Translate

site design / logo © 2022 Grokbase