FAQ
Hi,

(I got directed here after posting this issue
https://github.com/jnwhiteh/vim-golang/issues/18)

I don't know if it's only on osx, but the instructions to install are
causing problems.

I started getting these messages after editing the commit message with
git: "error: There was a problem with the editor 'vi'."
Some investigation yielded that starting vim as 'vi' and then quitting
with :q results in exiting with error code 1 (check echo $?).

I then went into a binary debugging mode with the .vimrc file,
commenting out half the file until I pinpointed the line causing the
problem:
filetype plugin indent off

I'm a vim-fugitive user, so I commented out the vim-golang enabling
code, and just put a symbolic link in my bundle folder this way:
ln -s $GOROOT/misc/vim ~/.vim/bundle/vim-golang

Maybe the installation instructions could mention this method, because
it is causing troubles for people invoking vim as vi.

Regards,
Jan.

--
You received this message because you are subscribed to the Google Groups "golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Minux at Apr 25, 2014 at 7:43 am

    On Thu, Apr 24, 2014 at 6:58 AM, Jan Willem wrote:

    I started getting these messages after editing the commit message with
    git: "error: There was a problem with the editor 'vi'."
    Some investigation yielded that starting vim as 'vi' and then quitting
    with :q results in exiting with error code 1 (check echo $?).
    Yeah, I was also troubled by this problem some time ago and I came to the
    same conclusion as yours,
    but then I forgot about it completely.

    Please file an issue, this is definitely worth fixing for Go 1.3.
    I then went into a binary debugging mode with the .vimrc file, commenting
    out half the file until I pinpointed the line causing the problem:
    filetype plugin indent off

    I'm a vim-fugitive user, so I commented out the vim-golang enabling code,
    and just put a symbolic link in my bundle folder this way:
    ln -s $GOROOT/misc/vim ~/.vim/bundle/vim-golang

    Maybe the installation instructions could mention this method, because it
    is causing troubles for people invoking vim as vi.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Jan Willem Ps at Apr 25, 2014 at 8:55 am

    On Friday, 25 April 2014 09:43:03 UTC+2, minux wrote:

    On Thu, Apr 24, 2014 at 6:58 AM, Jan Willem <jan.wi...@gmail.com<javascript:>
    wrote:
    I started getting these messages after editing the commit message with
    git: "error: There was a problem with the editor 'vi'."
    Some investigation yielded that starting vim as 'vi' and then quitting
    with :q results in exiting with error code 1 (check echo $?).
    Yeah, I was also troubled by this problem some time ago and I came to the
    same conclusion as yours,
    but then I forgot about it completely.

    Please file an issue, this is definitely worth fixing for Go 1.3.
    Done. Thanks!!

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgolang-nuts @
categoriesgo
postedApr 24, '14 at 1:08p
activeApr 25, '14 at 8:55a
posts3
users2
websitegolang.org

2 users in discussion

Jan Willem Ps: 2 posts Minux: 1 post

People

Translate

site design / logo © 2022 Grokbase