FAQ
Hi nuts,
I want to write golang code in emacs. And I set up the golang for emacs as
below:
1. install auto-complete for emacs.
2. install gocode.
3. write dot emacs
(require 'auto-complete)

(require 'go-mode-load)
(require 'go-mode)

require 'go-autocomplete)
(require 'auto-complete-config)

(ac-config-default)
4. gocode set lib-path "$GO_NATIVE_PKG_PATH:$GO_THIRD_PARTIY_PKG_PATH"
Now it can do autocompletion when I import the native golang package, but
if I import third party pkg, the autocompletion hungs and just prompts a
"PANIC" every time for every package. However, I tried sublime to wirte
golang with same gocode setting, its prompts works well for both native and
third party pkgs.

I don't know what I should do with this problem. Anyone can help me?

--
You received this message because you are subscribed to the Google Groups "golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Andrey mirtchovski at Apr 7, 2014 at 1:36 am
    you have a typo here: "GO_THIRD_PARTIY_PKG_PATH"
    On Sun, Apr 6, 2014 at 7:26 PM, axe wrote:
    Hi nuts,
    I want to write golang code in emacs. And I set up the golang for emacs as
    below:
    1. install auto-complete for emacs.
    2. install gocode.
    3. write dot emacs
    (require 'auto-complete)
    (require 'go-mode-load)
    (require 'go-mode)
    require 'go-autocomplete)
    (require 'auto-complete-config)
    (ac-config-default)
    4. gocode set lib-path "$GO_NATIVE_PKG_PATH:$GO_THIRD_PARTIY_PKG_PATH"
    Now it can do autocompletion when I import the native golang package, but if
    I import third party pkg, the autocompletion hungs and just prompts a
    "PANIC" every time for every package. However, I tried sublime to wirte
    golang with same gocode setting, its prompts works well for both native and
    third party pkgs.

    I don't know what I should do with this problem. Anyone can help me?

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Axe at Apr 7, 2014 at 1:45 am
    = =!. yap. Thx!
    it should be GO_THIRD_PARTY_PKG_PATH
    I used to place the 3rd party packages in a separated directory from go
    native.


    在 2014年4月7日星期一UTC+8上午9时36分25秒,andrey mirtchovski写道:
    you have a typo here: "GO_THIRD_PARTIY_PKG_PATH"

    On Sun, Apr 6, 2014 at 7:26 PM, axe <awu...@gmail.com <javascript:>>
    wrote:
    Hi nuts,
    I want to write golang code in emacs. And I set up the golang for emacs as
    below:
    1. install auto-complete for emacs.
    2. install gocode.
    3. write dot emacs
    (require 'auto-complete)
    (require 'go-mode-load)
    (require 'go-mode)
    require 'go-autocomplete)
    (require 'auto-complete-config)
    (ac-config-default)
    4. gocode set lib-path "$GO_NATIVE_PKG_PATH:$GO_THIRD_PARTIY_PKG_PATH"
    Now it can do autocompletion when I import the native golang package, but if
    I import third party pkg, the autocompletion hungs and just prompts a
    "PANIC" every time for every package. However, I tried sublime to wirte
    golang with same gocode setting, its prompts works well for both native and
    third party pkgs.

    I don't know what I should do with this problem. Anyone can help me?

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgolang-nuts @
categoriesgo
postedApr 7, '14 at 1:26a
activeApr 7, '14 at 1:45a
posts3
users2
websitegolang.org

2 users in discussion

Axe: 2 posts Andrey mirtchovski: 1 post

People

Translate

site design / logo © 2022 Grokbase