FAQ
Hello,

I'm having some trouble to import a package though I added a valid import
path. I can make it works by using a alias but when I try a recompile, it
fails again and complains again.

It first complains about an unused package and then about a undefined
symbol. Here is the Travis-CI build :
https://travis-ci.org/Blackrush/gofus/builds/12145834 the same is happening
on my computer using go1.1.2 linux/amd64.

Why does it fail to compile and how can I fix this issue ?

--
You received this message because you are subscribed to the Google Groups "golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Edmccard at Oct 4, 2013 at 7:42 pm
    The files (client.go, handler.go, network.go) in
    Blackrush/gofus/realm/network/frontend all start with "package network"; I
    think it should work if you change them to "package frontend"
    On Friday, October 4, 2013 3:05:22 PM UTC-4, Blackrush wrote:

    Hello,

    I'm having some trouble to import a package though I added a valid import
    path. I can make it works by using a alias but when I try a recompile, it
    fails again and complains again.

    It first complains about an unused package and then about a undefined
    symbol. Here is the Travis-CI build :
    https://travis-ci.org/Blackrush/gofus/builds/12145834 the same is
    happening on my computer using go1.1.2 linux/amd64.

    Why does it fail to compile and how can I fix this issue ?
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Blackrush at Oct 5, 2013 at 8:45 am
    Thanks, I will have to review a bit more by code the next time ...

    Le vendredi 4 octobre 2013 21:05:22 UTC+2, Blackrush a écrit :
    Hello,

    I'm having some trouble to import a package though I added a valid import
    path. I can make it works by using a alias but when I try a recompile, it
    fails again and complains again.

    It first complains about an unused package and then about a undefined
    symbol. Here is the Travis-CI build :
    https://travis-ci.org/Blackrush/gofus/builds/12145834 the same is
    happening on my computer using go1.1.2 linux/amd64.

    Why does it fail to compile and how can I fix this issue ?
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgolang-nuts @
categoriesgo
postedOct 4, '13 at 7:05p
activeOct 5, '13 at 8:45a
posts3
users2
websitegolang.org

2 users in discussion

Blackrush: 2 posts Edmccard: 1 post

People

Translate

site design / logo © 2022 Grokbase