FAQ
I' trying to debug a test file using gdb, but it reports an error.
My actual working directory is:~/go/src/github.com/kless/shutil/shconf

     go test -c -gcflags "-N -l"
     LANG=C gdb shconf.test

It shows the next warning:

warning: File "/usr/local/go/src/pkg/runtime/runtime-gdb.py" auto-loading
has been declined by your `auto-load safe-path' set to
"$debugdir:$datadir/auto-load".
To enable execution of this file add
     add-auto-load-safe-path /usr/local/go/src/pkg/runtime/runtime-gdb.py
line to your configuration file "/home/neo/.gdbinit".
To completely disable this security protection add
     set auto-load safe-path /
line to your configuration file "/home/neo/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual. E.g., run from the
shell:
     info "(gdb)Auto-loading safe path"

Although I can continue with it.

     (gdb) source /usr/local/go/src/pkg/runtime/runtime-gdb.py
     Loading Go Runtime support.

     (gdb) list
     github.com/kless/shutil/shconf/_test/_testmain.go: No such file or
directory.

How to fix it?

--
You received this message because you are subscribed to the Google Groups "golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Alexander Sychev at Jul 15, 2013 at 9:35 am
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed after a
    producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set auto-load
    safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
       santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an error.
    My actual working directory is:~/go/src/github.com/kless/shutil/shconf

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/runtime/runtime-gdb.py" auto-loading
    has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load".
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run from the
    shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/shconf/_test/_testmain.go: No such file or
    directory.

    How to fix it?

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
       santucco

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Archos at Jul 15, 2013 at 9:47 am
    I had to remove '-gcflags "-N -l"' because I could not set a breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program:
    /home/neo/go/src/github.com/kless/shutil/shconf/shconf.test
    * * *
    At this point, I had to interrupt it, since I follow having the same issue
    that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void, ns=void)
         at /usr/local/go/src/pkg/runtime/os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
         at /usr/local/go/src/pkg/runtime/lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at
    /usr/local/go/src/pkg/runtime/proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
         at /usr/local/go/src/pkg/runtime/proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
         at /usr/local/go/src/pkg/runtime/asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
         at /usr/local/go/src/pkg/runtime/asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed after a
    producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set auto-load
    safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco


    On Mon, Jul 15, 2013 at 12:43 PM, Archos <raul...@sent.com <javascript:>>wrote:
    I' trying to debug a test file using gdb, but it reports an error.
    My actual working directory is:~/go/src/github.com/kless/shutil/shconf

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/runtime/runtime-gdb.py" auto-loading
    has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load".
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run from the
    shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/shconf/_test/_testmain.go: No such file or
    directory.

    How to fix it?

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Alexander Sychev at Jul 15, 2013 at 10:25 am
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions matching
    the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/
    github.com/kless/shutil/shconf/shconf.test
    * * *
    At this point, I had to interrupt it, since I follow having the same issue
    that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void, ns=void)
    at /usr/local/go/src/pkg/runtime/os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at
    /usr/local/go/src/pkg/runtime/proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed after a
    producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set auto-load
    safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an error.
    My actual working directory is:~/go/src/github.com/kless/**shutil/shconf<http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"**.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/**
    runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run from the
    shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/**runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.com.

    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
       santucco

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Archos at Jul 15, 2013 at 10:49 am
    Thanks Alexander, I think that I found the issue, if the python exception
    showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file
    /home/neo/go/src/github.com/kless/shutil/shconf/scan_test.go, line 35.
    void github.com/kless/shutil/shconf.TestScanKeys(struct testing.T *);
    (gdb) run
    Starting program:
    /home/neo/go/src/github.com/kless/shutil/shconf/shconf.test
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/shconf.TestScanKeys (t=0xc20007c000)
         at /home/neo/go/src/github.com/kless/shutil/shconf/scan_test.go:35
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.UnicodeEncodeError'> 'ascii' codec can't
    encode character u'\u01c0' in position 34: ordinal not in range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'




    On Mon, Jul 15, 2013 at 1:47 PM, Archos <raul...@sent.com <javascript:>>wrote:
    I had to remove '-gcflags "-N -l"' because I could not set a breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/
    github.com/kless/shutil/shconf/shconf.test
    * * *
    At this point, I had to interrupt it, since I follow having the same
    issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of "bt":

    (gdb) bt
    #0 runtime.futex () at
    /usr/local/go/src/pkg/runtime/sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void,
    ns=void)
    at /usr/local/go/src/pkg/runtime/os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at
    /usr/local/go/src/pkg/runtime/proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed after
    a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set auto-load
    safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an error.
    My actual working directory is:~/go/src/github.com/kless/**
    shutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"**.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/**
    runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run from the
    shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/**runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.com.

    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Alexander Sychev at Jul 15, 2013 at 11:00 am
    I think the problem is when you start gdb with 'LANG=C'. I guess Python use
    standard runtime of libc to work with locales. You should try to leave
    your current locale instead of using 'C' - locale. I hope your current
    locale is UTF-8 :-)
    Anyway you can try to inspect variables directly without Python's
    extentions.

    On Mon, Jul 15, 2013 at 2:49 PM, Archos wrote:

    Thanks Alexander, I think that I found the issue, if the python exception
    showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file /home/neo/go/src/
    github.com/kless/shutil/shconf/scan_test.go, line 35.
    void github.com/kless/shutil/shconf.TestScanKeys(struct testing.T *);

    (gdb) run
    Starting program: /home/neo/go/src/
    github.com/kless/shutil/shconf/shconf.test
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/shconf.TestScanKeys (t=0xc20007c000)
    at /home/neo/go/src/github.com/kless/shutil/shconf/scan_test.go:35
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.UnicodeEncodeError'> 'ascii' codec
    can't encode character u'\u01c0' in position 34: ordinal not in range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/github.com/**
    kless/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    * * *
    At this point, I had to interrupt it, since I follow having the same
    issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/**
    sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/**
    sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void,
    ns=void)
    at /usr/local/go/src/pkg/runtime/**os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/**lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at /usr/local/go/src/pkg/runtime/**
    proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/**proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/**asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/**asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed after
    a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set auto-load
    safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an error.
    My actual working directory is:~/go/src/github.com/kless/**s**
    hutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime**/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"****.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/****
    runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run from
    the shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/****runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf**/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.**com.

    For more options, visit https://groups.google.com/**grou**ps/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.com.
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
       santucco

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Archos at Jul 15, 2013 at 11:06 am
    You are right, the issue was due to use 'LANG=C'

    El lunes, 15 de julio de 2013 12:00:52 UTC+1, Alexander Sychev escribió:
    I think the problem is when you start gdb with 'LANG=C'. I guess Python
    use standard runtime of libc to work with locales. You should try to leave
    your current locale instead of using 'C' - locale. I hope your current
    locale is UTF-8 :-)
    Anyway you can try to inspect variables directly without Python's
    extentions.


    On Mon, Jul 15, 2013 at 2:49 PM, Archos <raul...@sent.com <javascript:>>wrote:
    Thanks Alexander, I think that I found the issue, if the python exception
    showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file /home/neo/go/src/
    github.com/kless/shutil/shconf/scan_test.go, line 35.
    void github.com/kless/shutil/shconf.TestScanKeys(struct testing.T *);

    (gdb) run
    Starting program: /home/neo/go/src/
    github.com/kless/shutil/shconf/shconf.test
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/shconf.TestScanKeys(t=0xc20007c000)
    at /home/neo/go/src/github.com/kless/shutil/shconf/scan_test.go:35
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.UnicodeEncodeError'> 'ascii' codec
    can't encode character u'\u01c0' in position 34: ordinal not in range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/github.com/**
    kless/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    * * *
    At this point, I had to interrupt it, since I follow having the same
    issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/**
    sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/**
    sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void,
    ns=void)
    at /usr/local/go/src/pkg/runtime/**os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/**lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at /usr/local/go/src/pkg/runtime/**
    proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/**proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/**asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/**asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed
    after a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set auto-load
    safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an error.
    My actual working directory is:~/go/src/github.com/kless/**s**
    hutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime**/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"****.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/****
    runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run from
    the shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/****runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf**/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**com.

    For more options, visit https://groups.google.com/**grou**ps/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.com.
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Archos at Jul 15, 2013 at 11:33 am
    I've tried but I could not debug it. This is my GDB session:

    $ gdb shconf.test

    (gdb) rb TestScanKeys
    (gdb) run

    and start to run every line:

    (gdb) n
    (gdb) [Return]*

    Until that it remains halted; I have to press ^C.
    But now, I have not information from code being run:

    (gdb) info locals
    No locales.

    Any help?

    El lunes, 15 de julio de 2013 12:06:41 UTC+1, Archos escribió:
    You are right, the issue was due to use 'LANG=C'

    El lunes, 15 de julio de 2013 12:00:52 UTC+1, Alexander Sychev escribió:
    I think the problem is when you start gdb with 'LANG=C'. I guess Python
    use standard runtime of libc to work with locales. You should try to leave
    your current locale instead of using 'C' - locale. I hope your current
    locale is UTF-8 :-)
    Anyway you can try to inspect variables directly without Python's
    extentions.

    On Mon, Jul 15, 2013 at 2:49 PM, Archos wrote:

    Thanks Alexander, I think that I found the issue, if the python
    exception showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file /home/neo/go/src/
    github.com/kless/shutil/shconf/scan_test.go, line 35.
    void github.com/kless/shutil/shconf.TestScanKeys(struct testing.T *);

    (gdb) run
    Starting program: /home/neo/go/src/
    github.com/kless/shutil/shconf/shconf.test
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/shconf.TestScanKeys(t=0xc20007c000)
    at /home/neo/go/src/github.com/kless/shutil/shconf/scan_test.go:35
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.UnicodeEncodeError'> 'ascii' codec
    can't encode character u'\u01c0' in position 34: ordinal not in range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a
    breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/github.com/**
    kless/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    * * *
    At this point, I had to interrupt it, since I follow having the same
    issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/**
    sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/**
    sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void,
    ns=void)
    at /usr/local/go/src/pkg/runtime/**os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/**lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at /usr/local/go/src/pkg/runtime/**
    proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/**proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/**asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/**asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev
    escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed
    after a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set auto-load
    safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an error.
    My actual working directory is:~/go/src/github.com/kless/**s**
    hutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime**/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"****.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/****
    runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run from
    the shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/****runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf**/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**com.

    For more options, visit https://groups.google.com/**grou**ps/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.com.
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Alexander Sychev at Jul 15, 2013 at 11:58 am
    Try to compile with " -gcflags '-N -l' " the entire project. I used to
    compile my project " go build -gcflags '-N -l' " and then " go test -c "
    for debug purposes and it works fine.

    On Mon, Jul 15, 2013 at 3:33 PM, Archos wrote:

    I've tried but I could not debug it. This is my GDB session:

    $ gdb shconf.test

    (gdb) rb TestScanKeys
    (gdb) run

    and start to run every line:

    (gdb) n
    (gdb) [Return]*

    Until that it remains halted; I have to press ^C.
    But now, I have not information from code being run:

    (gdb) info locals
    No locales.

    Any help?

    El lunes, 15 de julio de 2013 12:06:41 UTC+1, Archos escribió:
    You are right, the issue was due to use 'LANG=C'

    El lunes, 15 de julio de 2013 12:00:52 UTC+1, Alexander Sychev escribió:
    I think the problem is when you start gdb with 'LANG=C'. I guess Python
    use standard runtime of libc to work with locales. You should try to leave
    your current locale instead of using 'C' - locale. I hope your current
    locale is UTF-8 :-)
    Anyway you can try to inspect variables directly without Python's
    extentions.

    On Mon, Jul 15, 2013 at 2:49 PM, Archos wrote:

    Thanks Alexander, I think that I found the issue, if the python
    exception showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file /home/neo/go/src/github.com/**
    kless/shutil/shconf/scan_test.**go<http://github.com/kless/shutil/shconf/scan_test.go>,
    line 35.
    void github.com/kless/shutil/**shconf.TestScanKeys(struct<http://github.com/kless/shutil/shconf.TestScanKeys(struct>testing.T *);

    (gdb) run
    Starting program: /home/neo/go/src/github.com/**
    kless/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/**shconf.TestScanKeys<http://github.com/kless/shutil/shconf.TestScanKeys>(t=0xc20007c000)
    at /home/neo/go/src/github.com/**kless/shutil/shconf/scan_test.**
    go:35 <http://github.com/kless/shutil/shconf/scan_test.go:35>
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.**UnicodeEncodeError'> 'ascii'
    codec can't encode character u'\u01c0' in position 34: ordinal not in
    range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a
    breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    * * *
    At this point, I had to interrupt it, since I follow having the same
    issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/****
    sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of
    "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/****
    sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void,
    ns=void)
    at /usr/local/go/src/pkg/runtime/****os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/****lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at /usr/local/go/src/pkg/runtime/*
    ***proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/****proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/****asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/****asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev
    escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed
    after a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set
    auto-load safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an error.
    My actual working directory is:~/go/src/github.com/kless/**s****
    hutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime****/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"******.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/******
    runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run from
    the shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/******runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf****/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**co**m.

    For more options, visit https://groups.google.com/**grou****
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**com.
    For more options, visit https://groups.google.com/**grou**ps/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@googlegroups.**com.
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
       santucco

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Archos at Jul 15, 2013 at 12:10 pm
    Thanks Alexander but I follow getting the same result.

    Does anybody could install this program to try to debug it?

    go get github.com/kless/shutil/shconf
    cd github.com/kless/shutil/shconf

    El lunes, 15 de julio de 2013 12:58:18 UTC+1, Alexander Sychev escribió:
    Try to compile with " -gcflags '-N -l' " the entire project. I used to
    compile my project " go build -gcflags '-N -l' " and then " go test -c "
    for debug purposes and it works fine.


    On Mon, Jul 15, 2013 at 3:33 PM, Archos <raul...@sent.com <javascript:>>wrote:
    I've tried but I could not debug it. This is my GDB session:

    $ gdb shconf.test

    (gdb) rb TestScanKeys
    (gdb) run

    and start to run every line:

    (gdb) n
    (gdb) [Return]*

    Until that it remains halted; I have to press ^C.
    But now, I have not information from code being run:

    (gdb) info locals
    No locales.

    Any help?

    El lunes, 15 de julio de 2013 12:06:41 UTC+1, Archos escribió:
    You are right, the issue was due to use 'LANG=C'

    El lunes, 15 de julio de 2013 12:00:52 UTC+1, Alexander Sychev escribió:
    I think the problem is when you start gdb with 'LANG=C'. I guess Python
    use standard runtime of libc to work with locales. You should try to leave
    your current locale instead of using 'C' - locale. I hope your current
    locale is UTF-8 :-)
    Anyway you can try to inspect variables directly without Python's
    extentions.

    On Mon, Jul 15, 2013 at 2:49 PM, Archos wrote:

    Thanks Alexander, I think that I found the issue, if the python
    exception showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file /home/neo/go/src/github.com/**
    kless/shutil/shconf/scan_test.**go<http://github.com/kless/shutil/shconf/scan_test.go>,
    line 35.
    void github.com/kless/shutil/**shconf.TestScanKeys(struct<http://github.com/kless/shutil/shconf.TestScanKeys(struct>testing.T *);

    (gdb) run
    Starting program: /home/neo/go/src/github.com/**
    kless/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/**shconf.TestScanKeys<http://github.com/kless/shutil/shconf.TestScanKeys>(t=0xc20007c000)
    at /home/neo/go/src/github.com/**kless/shutil/shconf/scan_test.**
    go:35 <http://github.com/kless/shutil/shconf/scan_test.go:35>
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.**UnicodeEncodeError'> 'ascii'
    codec can't encode character u'\u01c0' in position 34: ordinal not in
    range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev
    escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a
    breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    * * *
    At this point, I had to interrupt it, since I follow having the same
    issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/****
    sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of
    "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/****
    sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void,
    ns=void)
    at /usr/local/go/src/pkg/runtime/****os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/****lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at /usr/local/go/src/pkg/runtime/
    ****proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/****proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/****asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/****asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev
    escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed
    after a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set
    auto-load safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an error.
    My actual working directory is:~/go/src/github.com/kless/**s****
    hutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime****/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"******.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/******
    runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run
    from the shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/******
    runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf****/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**co**m.

    For more options, visit https://groups.google.com/**grou****
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**com.
    For more options, visit https://groups.google.com/**grou**ps/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@googlegroups.**com.
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Alexander Sychev at Jul 15, 2013 at 1:08 pm
    You have a bug in scan.go:40
    for thisRune, _, err = s.buf.ReadRune();; unicode.IsSpace(thisRune) {

    You set initial value of thisRune, but you won't read a next rune from
    s.buf.
    For the second test the first value of thisRune is a space and the cycle is
    never finished.

    Maybe it should be:

    for thisRune, _, err = s.buf.ReadRune(); unicode.IsSpace(thisRune);
    thisRune, _, err = s.buf.ReadRune() {

    ?


    On Mon, Jul 15, 2013 at 4:10 PM, Archos wrote:

    Thanks Alexander but I follow getting the same result.

    Does anybody could install this program to try to debug it?

    go get github.com/kless/shutil/shconf
    cd github.com/kless/shutil/shconf

    El lunes, 15 de julio de 2013 12:58:18 UTC+1, Alexander Sychev escribió:
    Try to compile with " -gcflags '-N -l' " the entire project. I used to
    compile my project " go build -gcflags '-N -l' " and then " go test -c "
    for debug purposes and it works fine.

    On Mon, Jul 15, 2013 at 3:33 PM, Archos wrote:

    I've tried but I could not debug it. This is my GDB session:

    $ gdb shconf.test

    (gdb) rb TestScanKeys
    (gdb) run

    and start to run every line:

    (gdb) n
    (gdb) [Return]*

    Until that it remains halted; I have to press ^C.
    But now, I have not information from code being run:

    (gdb) info locals
    No locales.

    Any help?

    El lunes, 15 de julio de 2013 12:06:41 UTC+1, Archos escribió:
    You are right, the issue was due to use 'LANG=C'

    El lunes, 15 de julio de 2013 12:00:52 UTC+1, Alexander Sychev escribió:
    I think the problem is when you start gdb with 'LANG=C'. I guess
    Python use standard runtime of libc to work with locales. You should try
    to leave your current locale instead of using 'C' - locale. I hope your
    current locale is UTF-8 :-)
    Anyway you can try to inspect variables directly without Python's
    extentions.

    On Mon, Jul 15, 2013 at 2:49 PM, Archos wrote:

    Thanks Alexander, I think that I found the issue, if the python
    exception showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/scan_test.**go<http://github.com/kless/shutil/shconf/scan_test.go>
    **, line 35.
    void github.com/kless/shutil/**shconf**.TestScanKeys(struct<http://github.com/kless/shutil/shconf.TestScanKeys(struct>testing.T *);

    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/**shconf**.TestScanKeys<http://github.com/kless/shutil/shconf.TestScanKeys>(t=0xc20007c000)
    at /home/neo/go/src/github.com/**kl**ess/shutil/shconf/scan_test.
    **go**:35 <http://github.com/kless/shutil/shconf/scan_test.go:35>
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.**UnicodeEncodeError**'> 'ascii'
    codec can't encode character u'\u01c0' in position 34: ordinal not in
    range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev
    escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a
    breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl****
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    * * *
    At this point, I had to interrupt it, since I follow having the
    same issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/******
    sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of
    "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/******
    sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void,
    ns=void)
    at /usr/local/go/src/pkg/runtime/******os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/******lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at /usr/local/go/src/pkg/runtime/
    ******proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/******proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/******asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/******asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev
    escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed
    after a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set
    auto-load safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an
    error.
    My actual working directory is:~/go/src/github.com/kless/**s*****
    *hutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime******/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"********.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/*******
    *runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run
    from the shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/********
    runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf******/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the
    Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**co****m.

    For more options, visit https://groups.google.com/**grou******
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**co**m.
    For more options, visit https://groups.google.com/**grou****
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@googlegroups.**co**m.
    For more options, visit https://groups.google.com/**grou**ps/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.com.
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
       santucco

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Alexander Sychev at Jul 15, 2013 at 1:16 pm
    BTW, I have run commands this way, and I could debug quite well:
    santucco@santucco ~ $ go get github.com/kless/shutil/shconf
    santucco@santucco ~ $ cd $GOPATH/github.com/kless/shutil/shconf
    santucco@santucco ~/work/go/src/github.com/kless/shutil/shconf $ go build
    -gcflags '-N -l'
    santucco@santucco ~/work/go/src/github.com/kless/shutil/shconf $ go test -c
    santucco@santucco ~/work/go/src/github.com/kless/shutil/shconf $ ls
    scan.go scan_test.go shconf.go shconf.test shconf_test.go
    santucco@santucco ~/work/go/src/github.com/kless/shutil/shconf $ gdb
    ./shconf.test

    On Mon, Jul 15, 2013 at 5:08 PM, Alexander Sychev wrote:

    You have a bug in scan.go:40
    for thisRune, _, err = s.buf.ReadRune();; unicode.IsSpace(thisRune) {

    You set initial value of thisRune, but you won't read a next rune from
    s.buf.
    For the second test the first value of thisRune is a space and the cycle
    is never finished.

    Maybe it should be:

    for thisRune, _, err = s.buf.ReadRune(); unicode.IsSpace(thisRune);
    thisRune, _, err = s.buf.ReadRune() {

    ?


    On Mon, Jul 15, 2013 at 4:10 PM, Archos wrote:

    Thanks Alexander but I follow getting the same result.

    Does anybody could install this program to try to debug it?

    go get github.com/kless/shutil/shconf
    cd github.com/kless/shutil/shconf

    El lunes, 15 de julio de 2013 12:58:18 UTC+1, Alexander Sychev escribió:
    Try to compile with " -gcflags '-N -l' " the entire project. I used to
    compile my project " go build -gcflags '-N -l' " and then " go test -c "
    for debug purposes and it works fine.

    On Mon, Jul 15, 2013 at 3:33 PM, Archos wrote:

    I've tried but I could not debug it. This is my GDB session:

    $ gdb shconf.test

    (gdb) rb TestScanKeys
    (gdb) run

    and start to run every line:

    (gdb) n
    (gdb) [Return]*

    Until that it remains halted; I have to press ^C.
    But now, I have not information from code being run:

    (gdb) info locals
    No locales.

    Any help?

    El lunes, 15 de julio de 2013 12:06:41 UTC+1, Archos escribió:
    You are right, the issue was due to use 'LANG=C'

    El lunes, 15 de julio de 2013 12:00:52 UTC+1, Alexander Sychev
    escribió:
    I think the problem is when you start gdb with 'LANG=C'. I guess
    Python use standard runtime of libc to work with locales. You should try
    to leave your current locale instead of using 'C' - locale. I hope your
    current locale is UTF-8 :-)
    Anyway you can try to inspect variables directly without Python's
    extentions.

    On Mon, Jul 15, 2013 at 2:49 PM, Archos wrote:

    Thanks Alexander, I think that I found the issue, if the python
    exception showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/scan_test.**go<http://github.com/kless/shutil/shconf/scan_test.go>
    **, line 35.
    void github.com/kless/shutil/**shconf**.TestScanKeys(struct<http://github.com/kless/shutil/shconf.TestScanKeys(struct>testing.T *);

    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/**shconf**.TestScanKeys<http://github.com/kless/shutil/shconf.TestScanKeys>(t=0xc20007c000)
    at /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/scan_test.**go**:35<http://github.com/kless/shutil/shconf/scan_test.go:35>
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.**UnicodeEncodeError**'> 'ascii'
    codec can't encode character u'\u01c0' in position 34: ordinal not in
    range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev
    escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a
    breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl****
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    * * *
    At this point, I had to interrupt it, since I follow having the
    same issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/******
    sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of
    "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/******
    sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void,
    ns=void)
    at /usr/local/go/src/pkg/runtime/******os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/******lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at
    /usr/local/go/src/pkg/runtime/******proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/******proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/******asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/******asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev
    escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed
    after a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set
    auto-load safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an
    error.
    My actual working directory is:~/go/src/github.com/kless/**s****
    **hutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime******/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"********.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/******
    **runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run
    from the shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/********
    runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf******/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the
    Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from
    it, send an email to golang-nuts...@**googlegroups.**co****m.

    For more options, visit https://groups.google.com/**grou******
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**co**m.
    For more options, visit https://groups.google.com/**grou****
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@googlegroups.**co**m.
    For more options, visit https://groups.google.com/**grou**ps/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.com.
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
    santucco


    --
    Best regards,
       santucco

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Archos at Jul 15, 2013 at 1:17 pm
    Thanks again!
    Could you write the GDB session (commands used) to trace until the issue?
    (if you used gdb)

    El lunes, 15 de julio de 2013 14:08:23 UTC+1, Alexander Sychev escribió:
    You have a bug in scan.go:40
    for thisRune, _, err = s.buf.ReadRune();; unicode.IsSpace(thisRune) {

    You set initial value of thisRune, but you won't read a next rune from
    s.buf.
    For the second test the first value of thisRune is a space and the cycle
    is never finished.

    Maybe it should be:

    for thisRune, _, err = s.buf.ReadRune(); unicode.IsSpace(thisRune);
    thisRune, _, err = s.buf.ReadRune() {

    ?



    On Mon, Jul 15, 2013 at 4:10 PM, Archos <raul...@sent.com <javascript:>>wrote:
    Thanks Alexander but I follow getting the same result.

    Does anybody could install this program to try to debug it?

    go get github.com/kless/shutil/shconf
    cd github.com/kless/shutil/shconf

    El lunes, 15 de julio de 2013 12:58:18 UTC+1, Alexander Sychev escribió:
    Try to compile with " -gcflags '-N -l' " the entire project. I used to
    compile my project " go build -gcflags '-N -l' " and then " go test -c "
    for debug purposes and it works fine.

    On Mon, Jul 15, 2013 at 3:33 PM, Archos wrote:

    I've tried but I could not debug it. This is my GDB session:

    $ gdb shconf.test

    (gdb) rb TestScanKeys
    (gdb) run

    and start to run every line:

    (gdb) n
    (gdb) [Return]*

    Until that it remains halted; I have to press ^C.
    But now, I have not information from code being run:

    (gdb) info locals
    No locales.

    Any help?

    El lunes, 15 de julio de 2013 12:06:41 UTC+1, Archos escribió:
    You are right, the issue was due to use 'LANG=C'

    El lunes, 15 de julio de 2013 12:00:52 UTC+1, Alexander Sychev
    escribió:
    I think the problem is when you start gdb with 'LANG=C'. I guess
    Python use standard runtime of libc to work with locales. You should try
    to leave your current locale instead of using 'C' - locale. I hope your
    current locale is UTF-8 :-)
    Anyway you can try to inspect variables directly without Python's
    extentions.

    On Mon, Jul 15, 2013 at 2:49 PM, Archos wrote:

    Thanks Alexander, I think that I found the issue, if the python
    exception showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/scan_test.**go<http://github.com/kless/shutil/shconf/scan_test.go>
    **, line 35.
    void github.com/kless/shutil/**shconf**.TestScanKeys(struct<http://github.com/kless/shutil/shconf.TestScanKeys(struct>testing.T *);

    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/**shconf**.TestScanKeys<http://github.com/kless/shutil/shconf.TestScanKeys>(t=0xc20007c000)
    at /home/neo/go/src/github.com/**kl**
    ess/shutil/shconf/scan_test.**go**:35<http://github.com/kless/shutil/shconf/scan_test.go:35>
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.**UnicodeEncodeError**'> 'ascii'
    codec can't encode character u'\u01c0' in position 34: ordinal not in
    range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev
    escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a
    breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n]) y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl****
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    * * *
    At this point, I had to interrupt it, since I follow having the
    same issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/******
    sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of
    "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/******
    sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void, val=void,
    ns=void)
    at /usr/local/go/src/pkg/runtime/******os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/******lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at
    /usr/local/go/src/pkg/runtime/******proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/******proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/******asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/******asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev
    escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is removed
    after a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set
    auto-load safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an
    error.
    My actual working directory is:~/go/src/github.com/kless/**s****
    **hutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime******/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"********.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/******
    **runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run
    from the shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/********
    runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf******/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the
    Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from
    it, send an email to golang-nuts...@**googlegroups.**co****m.

    For more options, visit https://groups.google.com/**grou******
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**co**m.
    For more options, visit https://groups.google.com/**grou****
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@googlegroups.**co**m.
    For more options, visit https://groups.google.com/**grou**ps/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.com.
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Alexander Sychev at Jul 15, 2013 at 2:55 pm
    Done. The trace is in an attached file
    I have build test with " -gcflags '-N -l' " too.


    On Mon, Jul 15, 2013 at 5:17 PM, Archos wrote:

    Thanks again!
    Could you write the GDB session (commands used) to trace until the issue?
    (if you used gdb)

    El lunes, 15 de julio de 2013 14:08:23 UTC+1, Alexander Sychev escribió:
    You have a bug in scan.go:40
    for thisRune, _, err = s.buf.ReadRune();; unicode.IsSpace(thisRune) {

    You set initial value of thisRune, but you won't read a next rune from
    s.buf.
    For the second test the first value of thisRune is a space and the cycle
    is never finished.

    Maybe it should be:

    for thisRune, _, err = s.buf.ReadRune(); unicode.IsSpace(thisRune);
    thisRune, _, err = s.buf.ReadRune() {

    ?


    On Mon, Jul 15, 2013 at 4:10 PM, Archos wrote:

    Thanks Alexander but I follow getting the same result.

    Does anybody could install this program to try to debug it?

    go get github.com/kless/shutil/shconf
    cd github.com/kless/shutil/shconf

    El lunes, 15 de julio de 2013 12:58:18 UTC+1, Alexander Sychev escribió:
    Try to compile with " -gcflags '-N -l' " the entire project. I used to
    compile my project " go build -gcflags '-N -l' " and then " go test -c "
    for debug purposes and it works fine.

    On Mon, Jul 15, 2013 at 3:33 PM, Archos wrote:

    I've tried but I could not debug it. This is my GDB session:

    $ gdb shconf.test

    (gdb) rb TestScanKeys
    (gdb) run

    and start to run every line:

    (gdb) n
    (gdb) [Return]*

    Until that it remains halted; I have to press ^C.
    But now, I have not information from code being run:

    (gdb) info locals
    No locales.

    Any help?

    El lunes, 15 de julio de 2013 12:06:41 UTC+1, Archos escribió:
    You are right, the issue was due to use 'LANG=C'

    El lunes, 15 de julio de 2013 12:00:52 UTC+1, Alexander Sychev
    escribió:
    I think the problem is when you start gdb with 'LANG=C'. I guess
    Python use standard runtime of libc to work with locales. You should try
    to leave your current locale instead of using 'C' - locale. I hope your
    current locale is UTF-8 :-)
    Anyway you can try to inspect variables directly without Python's
    extentions.

    On Mon, Jul 15, 2013 at 2:49 PM, Archos wrote:

    Thanks Alexander, I think that I found the issue, if the python
    exception showed at the end comes from
    the Go code.

    (gdb) rb TestScanKeys
    Breakpoint 1 at 0x430b00: file /home/neo/go/src/github.com/**kl****
    ess/shutil/shconf/scan_test.**go<http://github.com/kless/shutil/shconf/scan_test.go>
    ****, line 35.
    void github.com/kless/shutil/**shconf****.TestScanKeys(struct<http://github.com/kless/shutil/shconf.TestScanKeys(struct>testing.T *);

    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl****
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    [New LWP 7737]
    [Switching to LWP 7737]

    Breakpoint 1, github.com/kless/shutil/**shconf****.TestScanKeys<http://github.com/kless/shutil/shconf.TestScanKeys>(t=0xc20007c000)
    at /home/neo/go/src/github.com/**kl****
    ess/shutil/shconf/scan_test.**go****:35<http://github.com/kless/shutil/shconf/scan_test.go:35>
    35 func TestScanKeys(t *testing.T) {
    (gdb) info locals
    found = false
    atEOF = false
    n = 0
    v = ""
    test = {in = "", key = "", value = ""}
    ~r0 = 0x0
    k = ""
    s = 0x2300000000
    Python Exception <type 'exceptions.**UnicodeEncodeError****'>
    'ascii' codec can't encode character u'\u01c0' in position 34: ordinal not
    in range(128):
    s·2 =


    El lunes, 15 de julio de 2013 11:24:57 UTC+1, Alexander Sychev
    escribió:
    Try to use 'rb TestScanKeys', it sets breakpoints on all functions
    matching the regular expression 'TestScanKeys'



    On Mon, Jul 15, 2013 at 1:47 PM, Archos wrote:

    I had to remove '-gcflags "-N -l"' because I could not set a
    breakpoint.

    * * *
    (gdb) b 'shconf.TestScanKeys'
    Function "shconf.TestScanKeys" not defined.
    Make breakpoint pending on future shared library load? (y or [n])
    y

    Breakpoint 1 ('shconf.TestScanKeys') pending.
    (gdb) run
    Starting program: /home/neo/go/src/github.com/**kl******
    ess/shutil/shconf/shconf.**test<http://github.com/kless/shutil/shconf/shconf.test>
    * * *
    At this point, I had to interrupt it, since I follow having the
    same issue that using "go test" directly.
    The program does not exit, it remains halted.

    * * *
    ^C
    Program received signal SIGINT, Interrupt.
    runtime.futex () at /usr/local/go/src/pkg/runtime/********
    sys_linux_amd64.s:267
    267 RET
    * * *

    But I want to know where it is halted. This is the information of
    "bt":

    (gdb) bt
    #0 runtime.futex () at /usr/local/go/src/pkg/runtime/********
    sys_linux_amd64.s:267
    #1 0x00000000004111f9 in runtime.futexsleep (addr=void,
    val=void, ns=void)
    at /usr/local/go/src/pkg/runtime/********os_linux.c:58
    #2 0x0000000000409b49 in runtime.notesleep (n=void)
    at /usr/local/go/src/pkg/runtime/********lock_futex.c:125
    #3 0x0000000000414b5f in stopm () at
    /usr/local/go/src/pkg/runtime/********proc.c:795
    #4 0x00000000004163f8 in exitsyscall0 (gp=void)
    at /usr/local/go/src/pkg/runtime/********proc.c:1417
    #5 0x0000000000420ed9 in runtime.mcall (fn=void)
    at /usr/local/go/src/pkg/runtime/********asm_amd64.s:195
    #6 0x00000000005c1280 in runtime.g0 ()
    #7 0x0000000000420da6 in _rt0_amd64 ()
    at /usr/local/go/src/pkg/runtime/********asm_amd64.s:86
    #8 0x0000000000000001 in ?? ()
    #9 0x00007fffffffe118 in ?? ()
    #10 0x0000000000000001 in ?? ()
    #11 0x00007fffffffe118 in ?? ()
    #12 0x0000000000000000 in ?? ()


    El lunes, 15 de julio de 2013 10:35:39 UTC+1, Alexander Sychev
    escribió:
    Hi,

    xxxx/_test/_testmain.go is a temporary source file, it is
    removed after a producing of the test.
    I don't think you need to read it.
    Just set breakpoints in your test functions and that is it.

    To avoid the warning at startup of gdb, you should add "set
    auto-load safe-path <your $GOROOT>/src/pkg/runtime/" in $HOME/.gdbinit

    Best regards,
    santucco

    On Mon, Jul 15, 2013 at 12:43 PM, Archos wrote:

    I' trying to debug a test file using gdb, but it reports an
    error.
    My actual working directory is:~/go/src/github.com/kless/**s***
    *****hutil/shconf <http://github.com/kless/shutil/shconf>

    go test -c -gcflags "-N -l"
    LANG=C gdb shconf.test

    It shows the next warning:

    warning: File "/usr/local/go/src/pkg/**runtime********/runtime-gdb.py"
    auto-loading has been declined by your `auto-load safe-path' set to
    "$debugdir:$datadir/auto-load"**********.
    To enable execution of this file add
    add-auto-load-safe-path /usr/local/go/src/pkg/runtime/*****
    *****runtime-gdb.py
    line to your configuration file "/home/neo/.gdbinit".
    To completely disable this security protection add
    set auto-load safe-path /
    line to your configuration file "/home/neo/.gdbinit".
    For more information about this security protection see the
    "Auto-loading safe path" section in the GDB manual. E.g., run
    from the shell:
    info "(gdb)Auto-loading safe path"

    Although I can continue with it.

    (gdb) source /usr/local/go/src/pkg/runtime/**********
    runtime-gdb.py
    Loading Go Runtime support.

    (gdb) list
    github.com/kless/shutil/**shconf********/_test/_testmain.go<http://github.com/kless/shutil/shconf/_test/_testmain.go>:
    No such file or directory.

    How to fix it?

    --
    You received this message because you are subscribed to the
    Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from
    it, send an email to golang-nuts...@**googlegroups.**co******m.

    For more options, visit https://groups.google.com/**grou*******
    *ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the
    Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@**googlegroups.**co****m.
    For more options, visit https://groups.google.com/**grou******
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to golang-nuts...@googlegroups.**co****m.
    For more options, visit https://groups.google.com/**grou****
    ps/opt_out <https://groups.google.com/groups/opt_out>.



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.**com.
    For more options, visit https://groups.google.com/**grou**ps/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google
    Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to golang-nuts...@**googlegroups.com.
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    Best regards,
    santucco
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    Best regards,
       santucco

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgolang-nuts @
categoriesgo
postedJul 15, '13 at 8:44a
activeJul 15, '13 at 2:55p
posts14
users2
websitegolang.org

2 users in discussion

Archos: 7 posts Alexander Sychev: 7 posts

People

Translate

site design / logo © 2022 Grokbase