FAQ
I've just installed Go 1.1 from source on Ubuntu 12.10, most things seem to
work fine but doing so has broken GoSublime's autocompletion features for
the standard libraries. Packages I've downloaded still autocomplete.

Is there a command to autogenerate documentation files that I need to run?
I've searched but to no avail. Would appreciate any pointers.

Cheers!

--
You received this message because you are subscribed to the Google Groups "golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Dave Cheney at May 14, 2013 at 8:14 pm
    Tripple check that you have unset $GOROOT. You don't need it set, really.
    On Wed, May 15, 2013 at 5:59 AM, Richard Thanki wrote:
    I've just installed Go 1.1 from source on Ubuntu 12.10, most things seem to
    work fine but doing so has broken GoSublime's autocompletion features for
    the standard libraries. Packages I've downloaded still autocomplete.

    Is there a command to autogenerate documentation files that I need to run?
    I've searched but to no avail. Would appreciate any pointers.

    Cheers!

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Richard Thanki at May 14, 2013 at 9:27 pm
    Thanks Dave but an echo $GOROOT command reveals that nothing is set as
    GOROOT, performing 'go env' shows that GOROOT="/usr/local/go" - which is
    normal isn't it? Or do I have to unset this as well? If so I'm not sure how
    to do that...

    In any case my full go env is:
    GOARCH="amd64"
    GOBIN=""
    GOCHAR="6"
    GOEXE=""
    GOHOSTARCH="amd64"
    GOHOSTOS="linux"
    GOOS="linux"
    GOPATH="/home/user/go"
    GORACE=""
    GOROOT="/usr/local/go"
    GOTOOLDIR="/usr/local/go/pkg/tool/linux_amd64"
    CC="gcc"
    GOGCCFLAGS="-g -O2 -fPIC -m64 -pthread"
    CGO_ENABLED="1"

    My relevant environment variables are:
    TERM=xterm
    SHELL=/bin/bash
    PATH=/home/user/.cabal/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/local/go/bin:/home/user/go/bin:/home/user/go/bin:/usr/lib/jvm/java-7-oracle/bin:/usr/lib/jvm/java-7-oracle/db/bin:/usr/lib/jvm/java-7-oracle/jre/bin
    PWD=/usr/local/go/pkg
    HOME=/home/user
    GOPATH=/home/user/go


    On 14 May 2013 22:14, Dave Cheney wrote:

    Tripple check that you have unset $GOROOT. You don't need it set, really.
    On Wed, May 15, 2013 at 5:59 AM, Richard Thanki wrote:
    I've just installed Go 1.1 from source on Ubuntu 12.10, most things seem to
    work fine but doing so has broken GoSublime's autocompletion features for
    the standard libraries. Packages I've downloaded still autocomplete.

    Is there a command to autogenerate documentation files that I need to run?
    I've searched but to no avail. Would appreciate any pointers.

    Cheers!

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Dave Cheney at May 14, 2013 at 10:58 pm
    That suggests to me that you also have another version of go installed, usually (although you have gone to some lengths to be different) only the binary versions from the download section of the website default to /usr/local/go.

    Cheers

    Dave


    On 14/05/2013, at 14:27, Richard Thanki wrote:

    Thanks Dave but an echo $GOROOT command reveals that nothing is set as GOROOT, performing 'go env' shows that GOROOT="/usr/local/go" - which is normal isn't it? Or do I have to unset this as well? If so I'm not sure how to do that...

    In any case my full go env is:
    GOARCH="amd64"
    GOBIN=""
    GOCHAR="6"
    GOEXE=""
    GOHOSTARCH="amd64"
    GOHOSTOS="linux"
    GOOS="linux"
    GOPATH="/home/user/go"
    GORACE=""
    GOROOT="/usr/local/go"
    GOTOOLDIR="/usr/local/go/pkg/tool/linux_amd64"
    CC="gcc"
    GOGCCFLAGS="-g -O2 -fPIC -m64 -pthread"
    CGO_ENABLED="1"

    My relevant environment variables are:
    TERM=xterm
    SHELL=/bin/bash
    PATH=/home/user/.cabal/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/local/go/bin:/home/user/go/bin:/home/user/go/bin:/usr/lib/jvm/java-7-oracle/bin:/usr/lib/jvm/java-7-oracle/db/bin:/usr/lib/jvm/java-7-oracle/jre/bin
    PWD=/usr/local/go/pkg
    HOME=/home/user
    GOPATH=/home/user/go


    On 14 May 2013 22:14, Dave Cheney wrote:
    Tripple check that you have unset $GOROOT. You don't need it set, really.
    On Wed, May 15, 2013 at 5:59 AM, Richard Thanki wrote:
    I've just installed Go 1.1 from source on Ubuntu 12.10, most things seem to
    work fine but doing so has broken GoSublime's autocompletion features for
    the standard libraries. Packages I've downloaded still autocomplete.

    Is there a command to autogenerate documentation files that I need to run?
    I've searched but to no avail. Would appreciate any pointers.

    Cheers!

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Richard Thanki at May 14, 2013 at 11:05 pm
    Actually not the case: this is my first time installing from source and so
    I sudo'd into that directory, thinking that was standard practice

    Actually a reinstall of Sublime Text (deleting the previous settings in
    .config) did the trick marvellously - sorry that my first question on this
    board turned out to be a dud!

    Loving the terse wonder of the language though :-) cheers Dave!
    On May 14, 2013 11:58 PM, "Dave Cheney" wrote:

    That suggests to me that you also have another version of go installed,
    usually (although you have gone to some lengths to be different) only the
    binary versions from the download section of the website default to
    /usr/local/go.

    Cheers

    Dave



    On 14/05/2013, at 14:27, Richard Thanki wrote:

    Thanks Dave but an echo $GOROOT command reveals that nothing is set as
    GOROOT, performing 'go env' shows that GOROOT="/usr/local/go" - which is
    normal isn't it? Or do I have to unset this as well? If so I'm not sure how
    to do that...

    In any case my full go env is:
    GOARCH="amd64"
    GOBIN=""
    GOCHAR="6"
    GOEXE=""
    GOHOSTARCH="amd64"
    GOHOSTOS="linux"
    GOOS="linux"
    GOPATH="/home/user/go"
    GORACE=""
    GOROOT="/usr/local/go"
    GOTOOLDIR="/usr/local/go/pkg/tool/linux_amd64"
    CC="gcc"
    GOGCCFLAGS="-g -O2 -fPIC -m64 -pthread"
    CGO_ENABLED="1"

    My relevant environment variables are:
    TERM=xterm
    SHELL=/bin/bash

    PATH=/home/user/.cabal/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/local/go/bin:/home/user/go/bin:/home/user/go/bin:/usr/lib/jvm/java-7-oracle/bin:/usr/lib/jvm/java-7-oracle/db/bin:/usr/lib/jvm/java-7-oracle/jre/bin
    PWD=/usr/local/go/pkg
    HOME=/home/user
    GOPATH=/home/user/go


    On 14 May 2013 22:14, Dave Cheney wrote:

    Tripple check that you have unset $GOROOT. You don't need it set, really.

    On Wed, May 15, 2013 at 5:59 AM, Richard Thanki <richardthanki@gmail.com>
    wrote:
    I've just installed Go 1.1 from source on Ubuntu 12.10, most things seem to
    work fine but doing so has broken GoSublime's autocompletion features for
    the standard libraries. Packages I've downloaded still autocomplete.

    Is there a command to autogenerate documentation files that I need to run?
    I've searched but to no avail. Would appreciate any pointers.

    Cheers!

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Dave Cheney at May 14, 2013 at 11:07 pm
    Please ignore my comment about unconventional go installation, I was confused with another issue I am working on.


    On 14/05/2013, at 16:05, Richard Thanki wrote:

    Actually not the case: this is my first time installing from source and so I sudo'd into that directory, thinking that was standard practice

    Actually a reinstall of Sublime Text (deleting the previous settings in .config) did the trick marvellously - sorry that my first question on this board turned out to be a dud!

    Loving the terse wonder of the language though :-) cheers Dave!
    On May 14, 2013 11:58 PM, "Dave Cheney" wrote:
    That suggests to me that you also have another version of go installed, usually (although you have gone to some lengths to be different) only the binary versions from the download section of the website default to /usr/local/go.

    Cheers

    Dave


    On 14/05/2013, at 14:27, Richard Thanki wrote:

    Thanks Dave but an echo $GOROOT command reveals that nothing is set as GOROOT, performing 'go env' shows that GOROOT="/usr/local/go" - which is normal isn't it? Or do I have to unset this as well? If so I'm not sure how to do that...

    In any case my full go env is:
    GOARCH="amd64"
    GOBIN=""
    GOCHAR="6"
    GOEXE=""
    GOHOSTARCH="amd64"
    GOHOSTOS="linux"
    GOOS="linux"
    GOPATH="/home/user/go"
    GORACE=""
    GOROOT="/usr/local/go"
    GOTOOLDIR="/usr/local/go/pkg/tool/linux_amd64"
    CC="gcc"
    GOGCCFLAGS="-g -O2 -fPIC -m64 -pthread"
    CGO_ENABLED="1"

    My relevant environment variables are:
    TERM=xterm
    SHELL=/bin/bash
    PATH=/home/user/.cabal/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/local/go/bin:/home/user/go/bin:/home/user/go/bin:/usr/lib/jvm/java-7-oracle/bin:/usr/lib/jvm/java-7-oracle/db/bin:/usr/lib/jvm/java-7-oracle/jre/bin
    PWD=/usr/local/go/pkg
    HOME=/home/user
    GOPATH=/home/user/go


    On 14 May 2013 22:14, Dave Cheney wrote:
    Tripple check that you have unset $GOROOT. You don't need it set, really.
    On Wed, May 15, 2013 at 5:59 AM, Richard Thanki wrote:
    I've just installed Go 1.1 from source on Ubuntu 12.10, most things seem to
    work fine but doing so has broken GoSublime's autocompletion features for
    the standard libraries. Packages I've downloaded still autocomplete.

    Is there a command to autogenerate documentation files that I need to run?
    I've searched but to no avail. Would appreciate any pointers.

    Cheers!

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • DisposaBoy at May 15, 2013 at 7:04 am
    Next time, please file a bug report on https://github.com/DisposaBoy/GoSublime . That way actual bugs can be fixed. In this case it sounds like a configuration issue . E.g. you might've set GOROOT in the settings file or some other setting like PATH that caused another go binary to be found . Also note that Sublime Text very likely cannot see the env vars you see on your terminal so checking the vars there is very misleading. Anyway, re-installing Sublime Text or GoSublime is almost always the wrong way to fix an issue

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgolang-nuts @
categoriesgo
postedMay 14, '13 at 8:13p
activeMay 15, '13 at 7:04a
posts7
users3
websitegolang.org

People

Translate

site design / logo © 2022 Grokbase