FAQ
I installed 1.1 on a ThinkPad T23 running VectorLinux 7. Previously, I was
using 1.03 with no problem. Now, all go commands fail with:

SIGILL: illegal instruction
PC=0x81832bd

math.init·1()
     /usr/local/go/src/pkg/math/pow10.go:34 +0x1d
math.init()
     /usr/local/go/src/pkg/math/unsafe.go:21 +0x3c
strconv.init()
     /usr/local/go/src/pkg/strconv/quote.go:442 +0x42
go/parser.init()
     /usr/local/go/src/pkg/go/parser/parser.go:2437 +0x4c
main.init()
     /usr/local/go/src/cmd/go/vet.go:37 +0x4c

goroutine 2 [syscall]:

goroutine 3 [runnable]:
eax 0x0
ebx 0x84a2960
ecx 0x1855e090
edx 0x55
edi 0xb7323000
esi 0x84a1424
ebp 0x1d
esp 0xb72e3ee8
eip 0x81832bd
eflags 0x210206
cs 0x73
fs 0x0
gs 0x33

--
You received this message because you are subscribed to the Google Groups "golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Andrew Gerrand at May 14, 2013 at 4:30 pm
    What kernel is VectorLinux 7 running?

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Rob Pike at May 14, 2013 at 4:30 pm
    You'll need to build from source using the GO386=387 setting. Your
    machine is too old for the SSE instructions that are part of the
    standard 386 build packages.

    -rob

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Goprogrammer at May 14, 2013 at 11:29 pm
    The GO386 setting fixed the problem. Thanks!

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgolang-nuts @
categoriesgo
postedMay 14, '13 at 4:25p
activeMay 14, '13 at 11:29p
posts4
users3
websitegolang.org

People

Translate

site design / logo © 2021 Grokbase