FAQ
I'm trying to get the google drive package for go, but using the below
always throws the error. Should I be installing it manually?


./go get code.google.com/p/google-api-go-client/drive/v2

load cmd/cgo: package cmd/cgo: no Go source files in .../google_appengine/
goroot/src/cmd/cgo


I also posted this on
stackoverflow: http://stackoverflow.com/questions/16511747/go-install-drive-v2-package-cmd-cgo-error/16511916?noredirect=1#16511916


Thanks

--
You received this message because you are subscribed to the Google Groups "golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • David Symonds at May 13, 2013 at 12:39 am
    If you're fetching it for use with App Engine, you won't be able to
    use packages depending on cgo (such as net). Most likely you just need
    to fetch it without building (which you would have done as part of
    that "go get" command); have you tried importing that package in your
    app yet?

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Brad Fitzpatrick at May 13, 2013 at 3:59 am
    Wow. That's not obvious.



    On Sun, May 12, 2013 at 5:38 PM, David Symonds wrote:

    If you're fetching it for use with App Engine, you won't be able to
    use packages depending on cgo (such as net). Most likely you just need
    to fetch it without building (which you would have done as part of
    that "go get" command); have you tried importing that package in your
    app yet?

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Adw999 at May 13, 2013 at 12:41 pm
    If I use

    import (
         "fmt"
         "net/http"

         drive "code.google.com/p/google-api-go-client/drive/v2"
    )

    I receive the error: can't find import:
    "code.google.com/p/google-api-go-client/drive/v2". If I use the standard go
    installer it works fine, it's just the appengine sdk that fails.

    You say I can't use the net package, but the examples use it, for example
    https://github.com/GoogleCloudPlatform/appengine-plus-go/blob/master/gopher.go.

    I have downloaded the packages manually and it is working, but I'd rather
    use the automatic method.
    On Monday, 13 May 2013 02:38:59 UTC+2, David Symonds wrote:

    If you're fetching it for use with App Engine, you won't be able to
    use packages depending on cgo (such as net). Most likely you just need
    to fetch it without building (which you would have done as part of
    that "go get" command); have you tried importing that package in your
    app yet?
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgolang-nuts @
categoriesgo
postedMay 13, '13 at 12:35a
activeMay 13, '13 at 12:41p
posts4
users3
websitegolang.org

People

Translate

site design / logo © 2022 Grokbase