FAQ
The error message is like this:

$ gzip -d go1.0.3.linux-386.tar.gz
gzip: go1.0.3.linux-386.tar.gz: invalid compressed data--crc error


And my gzip version:

gzip 1.3.12


SHA1 checksum is correct.

Anyone tried install go under ubuntu?

Thanks!
David

--
You received this message because you are subscribed to the Google Groups "golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Dave Cheney at Feb 7, 2013 at 3:46 am
    Amazingly this is a bug in the zip command on Ubuntu. I believe there is a bug (closed) about this on the go issue tracker.
    On 07/02/2013, at 14:42, David DENG wrote:

    The error message is like this:

    $ gzip -d go1.0.3.linux-386.tar.gz
    gzip: go1.0.3.linux-386.tar.gz: invalid compressed data--crc error

    And my gzip version:
    gzip 1.3.12

    SHA1 checksum is correct.

    Anyone tried install go under ubuntu?

    Thanks!
    David
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • David DENG at Feb 7, 2013 at 4:27 am
    Great helps! But I'm not that lucky.

    After I upgrading the libraries as in the issue: sudo apt-get upgrade

    The problem remains.

    David
    On Thursday, February 7, 2013 11:45:39 AM UTC+8, Dave Cheney wrote:

    Amazingly this is a bug in the zip command on Ubuntu. I believe there is a
    bug (closed) about this on the go issue tracker.

    On 07/02/2013, at 14:42, David DENG <david...@gmail.com <javascript:>>
    wrote:

    The error message is like this:

    $ gzip -d go1.0.3.linux-386.tar.gz
    gzip: go1.0.3.linux-386.tar.gz: invalid compressed data--crc error


    And my gzip version:

    gzip 1.3.12


    SHA1 checksum is correct.

    Anyone tried install go under ubuntu?

    Thanks!
    David

    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Minux at Feb 7, 2013 at 9:57 am

    On Thursday, February 7, 2013, Dave Cheney wrote:

    Amazingly this is a bug in the zip command on Ubuntu. I believe there is a
    bug (closed) about this on the go issue tracker.
    http://code.google.com/p/go/issues/detail?id=3443

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • David DENG at Feb 7, 2013 at 4:28 am
    I finally install by compiling the source. Anyway.

    David
    On Thursday, February 7, 2013 11:42:56 AM UTC+8, David DENG wrote:

    The error message is like this:

    $ gzip -d go1.0.3.linux-386.tar.gz
    gzip: go1.0.3.linux-386.tar.gz: invalid compressed data--crc error


    And my gzip version:

    gzip 1.3.12


    SHA1 checksum is correct.

    Anyone tried install go under ubuntu?

    Thanks!
    David
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Dave Cheney at Feb 7, 2013 at 4:33 am
    Which distribution are you using ? Ubuntu 10.04 LTS ?
    On Thu, Feb 7, 2013 at 3:28 PM, David DENG wrote:
    I finally install by compiling the source. Anyway.

    David

    On Thursday, February 7, 2013 11:42:56 AM UTC+8, David DENG wrote:

    The error message is like this:

    $ gzip -d go1.0.3.linux-386.tar.gz
    gzip: go1.0.3.linux-386.tar.gz: invalid compressed data--crc error


    And my gzip version:

    gzip 1.3.12


    SHA1 checksum is correct.

    Anyone tried install go under ubuntu?

    Thanks!
    David
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • David DENG at Feb 7, 2013 at 4:37 am
    Yeah:

    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=10.04
    DISTRIB_CODENAME=lucid
    DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS"


    I'm also working on Linode as the one submitting the issue.
    David
    On Thursday, February 7, 2013 12:33:31 PM UTC+8, Dave Cheney wrote:

    Which distribution are you using ? Ubuntu 10.04 LTS ?
    On Thu, Feb 7, 2013 at 3:28 PM, David DENG wrote:
    I finally install by compiling the source. Anyway.

    David

    On Thursday, February 7, 2013 11:42:56 AM UTC+8, David DENG wrote:

    The error message is like this:

    $ gzip -d go1.0.3.linux-386.tar.gz
    gzip: go1.0.3.linux-386.tar.gz: invalid compressed data--crc error


    And my gzip version:

    gzip 1.3.12


    SHA1 checksum is correct.

    Anyone tried install go under ubuntu?

    Thanks!
    David
    --
    You received this message because you are subscribed to the Google Groups
    "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to golang-nuts...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Steve wang at Feb 7, 2013 at 4:38 am
    The command "tar xzvf go1.0.3.linux-386.tar.gz" works well on my
    ubuntu12.04 box.
    On Thursday, February 7, 2013 12:28:21 PM UTC+8, David DENG wrote:

    I finally install by compiling the source. Anyway.

    David
    On Thursday, February 7, 2013 11:42:56 AM UTC+8, David DENG wrote:

    The error message is like this:

    $ gzip -d go1.0.3.linux-386.tar.gz
    gzip: go1.0.3.linux-386.tar.gz: invalid compressed data--crc error


    And my gzip version:

    gzip 1.3.12


    SHA1 checksum is correct.

    Anyone tried install go under ubuntu?

    Thanks!
    David
    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nvcnvn at Feb 7, 2013 at 5:18 am
    Yes, use Steve Wang command.
    I'm using Ubuntu 12.10 Desktop version, you can simple right-click and
    extract the file.

    --
    You received this message because you are subscribed to the Google Groups "golang-nuts" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupgolang-nuts @
categoriesgo
postedFeb 7, '13 at 3:43a
activeFeb 7, '13 at 9:57a
posts9
users5
websitegolang.org

People

Translate

site design / logo © 2022 Grokbase