FAQ
Hello

I'm trying to install cakephp

In httpdf.conf
I must use an alias this is mandatory for my project
Alias /toto "c:/wamp/www/f/app/webroot"
<Directory "c:/wamp/www/f/app/webroot">
Options FollowSymLinks
AllowOverride All
Order deny,allow
Allow from All
</Directory>


But when i go tho the application

I've got the folloing message

<?php
class TotoController extends AppController {

}

Toto is the applicationName not the controller

I really do not i=undesrtant what's going on

Any ideas ?

Thanks


--
Like Us on FaceBook https://www.facebook.com/CakePHP
Find us on Twitter http://twitter.com/CakePHP

---
You received this message because you are subscribed to the Google Groups "CakePHP" group.
To post to this group, send email to cake-php@googlegroups.com.
To unsubscribe from this group, send email to cake-php+unsubscribe@googlegroups.com.
Visit this group at http://groups.google.com/group/cake-php?hl=en.

Search Discussions

  • Jonathan Sundquist at Oct 18, 2012 at 10:22 am
    You needs to tell the application what your base url is within the config
    file so that it knows how to handle the routing correctly.

    - "The cold winds are rising"
    On Oct 18, 2012 2:50 AM, "cosinusweb" wrote:

    Hello

    I'm trying to install cakephp

    In httpdf.conf
    I must use an alias this is mandatory for my project
    Alias /toto "c:/wamp/www/f/app/webroot"
    <Directory "c:/wamp/www/f/app/webroot">
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Allow from All
    </Directory>


    But when i go tho the application

    I've got the folloing message

    <?php
    class TotoController extends AppController {

    }

    Toto is the applicationName not the controller

    I really do not i=undesrtant what's going on

    Any ideas ?

    Thanks


    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups
    "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.

    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.
  • Webmaster Cosinus at Oct 18, 2012 at 10:35 am
    it doesn't chnage anything

    On Thu, Oct 18, 2012 at 12:22 PM, Jonathan Sundquist
    wrote:
    You needs to tell the application what your base url is within the config
    file so that it knows how to handle the routing correctly.

    - "The cold winds are rising"
    On Oct 18, 2012 2:50 AM, "cosinusweb" wrote:

    Hello

    I'm trying to install cakephp

    In httpdf.conf
    I must use an alias this is mandatory for my project
    Alias /toto "c:/wamp/www/f/app/webroot"
    <Directory "c:/wamp/www/f/app/webroot">
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Allow from All
    </Directory>


    But when i go tho the application

    I've got the folloing message

    <?php
    class TotoController extends AppController {

    }

    Toto is the applicationName not the controller

    I really do not i=undesrtant what's going on

    Any ideas ?

    Thanks


    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups
    "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.

    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups
    "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.

    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.
  • Jonathan Sundquist at Oct 18, 2012 at 3:29 pm
    Assuming you are using CakePHP 2.x you could create a basic route as such:

    Router::connect('/todo/:controller/:action/:id');

    Put that within your routes.php config file.
    On Thu, Oct 18, 2012 at 5:35 AM, Webmaster Cosinus wrote:

    it doesn't chnage anything


    On Thu, Oct 18, 2012 at 12:22 PM, Jonathan Sundquist <jsundquist@gmail.com
    wrote:
    You needs to tell the application what your base url is within the config
    file so that it knows how to handle the routing correctly.

    - "The cold winds are rising"
    On Oct 18, 2012 2:50 AM, "cosinusweb" wrote:

    Hello

    I'm trying to install cakephp

    In httpdf.conf
    I must use an alias this is mandatory for my project
    Alias /toto "c:/wamp/www/f/app/webroot"
    <Directory "c:/wamp/www/f/app/webroot">
    Options FollowSymLinks
    AllowOverride All
    Order deny,allow
    Allow from All
    </Directory>


    But when i go tho the application

    I've got the folloing message

    <?php
    class TotoController extends AppController {

    }

    Toto is the applicationName not the controller

    I really do not i=undesrtant what's going on

    Any ideas ?

    Thanks


    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google
    Groups "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.

    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups
    "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.

    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups
    "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.

    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.
  • Vanja Dizdarević at Oct 22, 2012 at 5:54 am
    Try putting *Configure::write('App.base', '/toto'); * inside your *
    bootstrap.php* file.

    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.
  • Vanja Dizdarević at Oct 22, 2012 at 5:56 am
    Oh, sorry, I just saw you already tried that. Could you please do a
    var_dump($_SERVER) inside your bootstrap.php file and post it back to us?

    --
    Like Us on FaceBook https://www.facebook.com/CakePHP
    Find us on Twitter http://twitter.com/CakePHP

    ---
    You received this message because you are subscribed to the Google Groups "CakePHP" group.
    To post to this group, send email to cake-php@googlegroups.com.
    To unsubscribe from this group, send email to cake-php+unsubscribe@googlegroups.com.
    Visit this group at http://groups.google.com/group/cake-php?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcake-php @
categoriesphp
postedOct 18, '12 at 8:21a
activeOct 22, '12 at 5:56a
posts6
users3
websitecakephp.org
irc#cakephp

People

Translate

site design / logo © 2022 Grokbase