FAQ
So, I am getting this strange error. My links have the site name
listed twice in the url.

http://www.mysite.com/mysite.com/users/view/9


Now, http://www.mysite.com brings up my home page as expected, but all
the links on the site have the additional layer in the name for some
reason. I am running on a Virtual Host which has a sub directory of
/mysite.com which holds my cake site and is where my domain name is
pointed. Is there something I need to enable to get my base path to
display right in my links? Thanks

--
Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.


To unsubscribe from this group, send email to
cake-php+unsubscribe@googlegroups.com For more options, visit this group at http://groups.google.com/group/cake-php

Search Discussions

  • Michael Gaiser at Apr 22, 2012 at 10:07 pm
    No one has run into this? It seems that the links are pointing to my
    root directory instead of the directory that has been designated as
    the virtual domain. I'm not really good with .htaccess files so the
    problem might be in there although I am using the default and they do
    seem to work on my localhost. Any help would be greatly appreciated.
    Thanks.


    On Sun, Apr 22, 2012 at 2:05 AM, Michael Gaiser wrote:
    So, I am getting this strange error. My links have the site name
    listed twice in the url.

    http://www.mysite.com/mysite.com/users/view/9


    Now, http://www.mysite.com brings up my home page as expected, but all
    the links on the site have the additional layer in the name for some
    reason. I am running on a Virtual Host which has a sub directory of
    /mysite.com which holds my cake site and is where my domain name is
    pointed. Is there something I need to enable to get my base path to
    display right in my links? Thanks
    --
    Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
    Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.


    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com For more options, visit this group at http://groups.google.com/group/cake-php
  • Thiago Belem at Apr 22, 2012 at 10:21 pm
    How you're creating the links?

    Show us some code.

    --
    ***Thiago Belem*
    Desenvolvedor
    Rio de Janeiro - RJ - Brasil

    *Assando Sites* - Curso online de *CakePHP*
    assando-sites.com.br <http://goo.gl/b1EEd>

    thiagobelem.net
    contato@thiagobelem.net

    *Skype / gTalk **»* thiago.belem.web
    *LinkedIn* *»* br.linkedin.com/in/thiagobelem/pt


    On Sun, Apr 22, 2012 at 19:07, Michael Gaiser wrote:

    No one has run into this? It seems that the links are pointing to my
    root directory instead of the directory that has been designated as
    the virtual domain. I'm not really good with .htaccess files so the
    problem might be in there although I am using the default and they do
    seem to work on my localhost. Any help would be greatly appreciated.
    Thanks.


    On Sun, Apr 22, 2012 at 2:05 AM, Michael Gaiser wrote:
    So, I am getting this strange error. My links have the site name
    listed twice in the url.

    http://www.mysite.com/mysite.com/users/view/9


    Now, http://www.mysite.com brings up my home page as expected, but all
    the links on the site have the additional layer in the name for some
    reason. I am running on a Virtual Host which has a sub directory of
    /mysite.com which holds my cake site and is where my domain name is
    pointed. Is there something I need to enable to get my base path to
    display right in my links? Thanks
    --
    Our newest site for the community: CakePHP Video Tutorials
    http://tv.cakephp.org
    Check out the new CakePHP Questions site http://ask.cakephp.org and help
    others with their CakePHP related questions.


    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com For more options, visit this group
    at http://groups.google.com/group/cake-php
    --
    Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
    Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.


    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com For more options, visit this group at http://groups.google.com/group/cake-php
  • Michael Gaiser at Apr 23, 2012 at 1:08 pm
    I was able to fix the issue by adding this to my core.php file.

    Configure::write('App.baseUrl', "/");

    :)

    --
    Our newest site for the community: CakePHP Video Tutorials http://tv.cakephp.org
    Check out the new CakePHP Questions site http://ask.cakephp.org and help others with their CakePHP related questions.


    To unsubscribe from this group, send email to
    cake-php+unsubscribe@googlegroups.com For more options, visit this group at http://groups.google.com/group/cake-php

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcake-php @
categoriesphp
postedApr 22, '12 at 9:05a
activeApr 23, '12 at 1:08p
posts4
users2
websitecakephp.org
irc#cakephp

2 users in discussion

Michael Gaiser: 3 posts Thiago Belem: 1 post

People

Translate

site design / logo © 2022 Grokbase