Hi all,

for weeks we´ve been successfully using Ansible 1.6.6 - now we got an
update due to our current setup based just on "yum install ansible", so we
have version 1.7-1.el6.

After this update I ran into some problems, Ansible hangs when invoking an
"install.sh" in our playbook - without any further details.
Switching back to 1.6.6 solved the problem.

How can I install 1.6.6 ? At
http://docs.ansible.com/intro_installation.html there are several ways to
install the latest release - but no way to install a tagged release.
Only downloading and unpacking the *.tar.gz isnt enough.

cd /tmp
wget http://releases.ansible.com/ansible/ansible-1.6.6.tar.gz
tar -xvf ansible-1.6.6.tar.gz
cd ansible-1.6.6
python setup.py install

Could someone provide the instructions to a "tagged release installation"
please?

Thanx, Torsten


--
You received this message because you are subscribed to the Google Groups "Ansible Project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ansible-project+unsubscribe@googlegroups.com.
To post to this group, send email to ansible-project@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ansible-project/1b6b9f92-9349-4bc5-8bb9-257c1e9db5b9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Igor Homyakov at Oct 7, 2014 at 3:50 pm
    Hi,

    with `pip` you can install any version of python package you want

    in you case it will be

         pip install ansible=='1.6.6'

    I would recommend you to use requirements.txt to pin certain version
    of python packages
    https://pip.readthedocs.org/en/1.1/requirements.html

    -- Best, Igor

    On Tue, Oct 7, 2014 at 5:37 PM, Torsten Reinhard
    wrote:
    Hi all,

    for weeks we´ve been successfully using Ansible 1.6.6 - now we got an update
    due to our current setup based just on "yum install ansible", so we have
    version 1.7-1.el6.

    After this update I ran into some problems, Ansible hangs when invoking an
    "install.sh" in our playbook - without any further details.
    Switching back to 1.6.6 solved the problem.

    How can I install 1.6.6 ? At http://docs.ansible.com/intro_installation.html
    there are several ways to install the latest release - but no way to install
    a tagged release.
    Only downloading and unpacking the *.tar.gz isnt enough.

    cd /tmp
    wget http://releases.ansible.com/ansible/ansible-1.6.6.tar.gz
    tar -xvf ansible-1.6.6.tar.gz
    cd ansible-1.6.6
    python setup.py install

    Could someone provide the instructions to a "tagged release installation"
    please?

    Thanx, Torsten


    --
    You received this message because you are subscribed to the Google Groups
    "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to ansible-project+unsubscribe@googlegroups.com.
    To post to this group, send email to ansible-project@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/ansible-project/1b6b9f92-9349-4bc5-8bb9-257c1e9db5b9%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to ansible-project+unsubscribe@googlegroups.com.
    To post to this group, send email to ansible-project@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ansible-project/CAGuansodrnss7yU5ahbipT%3D85nZm%2B1_KAJMy3RB%3Dcg_LptBsBA%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupansible-project @
postedOct 7, '14 at 2:31p
activeOct 7, '14 at 3:50p
posts2
users2

2 users in discussion

Igor Homyakov: 1 post Torsten Reinhard: 1 post

People

Translate

site design / logo © 2022 Grokbase