Hello,
Last week we updated one of our servers from unbent 12.0+ to 14.0+ it
deployed with out issue, after the weekend deployment to one of servers is
no longer possible :-(

Here is the command that is failing:

- name: Update the apt cache if older than 2 hrs
   apt: update_cache=yes cache_valid_time=7200
   tags:
     - security-apt

On just one of our servers prd1


TASK: [common | Update the apt cache if older than 2 hrs]
*********************
<prd3> ESTABLISH CONNECTION FOR USER: ubuntu
<prd1> ESTABLISH CONNECTION FOR USER: ubuntu
<prd3> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
<prd1> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
<prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
'ControlPersist=60s', '-o',
'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
'KbdInteractiveAuthentication=no', '-o',
'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
'-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
'ConnectTimeout=10', 'prd1', "/bin/sh -c 'mkdir -p
$HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && chmod a+rx
$HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && echo
$HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142'"]
<prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
'ControlPersist=60s', '-o',
'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
'KbdInteractiveAuthentication=no', '-o',
'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
'-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
'ConnectTimeout=10', 'prd3', "/bin/sh -c 'mkdir -p
$HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && chmod a+rx
$HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && echo
$HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276'"]
<prd3> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmpnz2A7A TO
/home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt
<prd1> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmp0xdCki TO
/home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt
<prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
'ControlPersist=60s', '-o',
'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
'KbdInteractiveAuthentication=no', '-o',
'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
'-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
'ConnectTimeout=10', 'prd1', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
/home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt; rm
-rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/
/dev/null 2>&1\'"\'"\'\'']
<prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
'ControlPersist=60s', '-o',
'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
'KbdInteractiveAuthentication=no', '-o',
'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
'-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
'ConnectTimeout=10', 'prd3', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
/home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt; rm
-rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/
/dev/null 2>&1\'"\'"\'\'']
ok: [prd3 => {"changed": false}
failed: [prd1] => {"failed": true}

I have replaced the keys with XXX

--
You received this message because you are subscribed to the Google Groups "Ansible Project" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ansible-project+unsubscribe@googlegroups.com.
To post to this group, send email to ansible-project@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/ansible-project/134ba4f5-f94e-410f-a2ed-df0f2e65a1d1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Michael DeHaan at Sep 30, 2014 at 7:23 pm
    Anything relevant in the logs?


    On Mon, Sep 29, 2014 at 3:08 PM, Eric Brooke wrote:

    Hello,
    Last week we updated one of our servers from unbent 12.0+ to 14.0+ it
    deployed with out issue, after the weekend deployment to one of servers is
    no longer possible :-(

    Here is the command that is failing:

    - name: Update the apt cache if older than 2 hrs
    apt: update_cache=yes cache_valid_time=7200
    tags:
    - security-apt

    On just one of our servers prd1


    TASK: [common | Update the apt cache if older than 2 hrs]
    *********************
    <prd3> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd1> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd3> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && chmod a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142'"]
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && chmod a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276'"]
    <prd3> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmpnz2A7A TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt
    <prd1> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmp0xdCki TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt; rm
    -rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/
    /dev/null 2>&1\'"\'"\'\'']
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt; rm
    -rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/
    /dev/null 2>&1\'"\'"\'\'']
    ok: [prd3 => {"changed": false}
    failed: [prd1] => {"failed": true}

    I have replaced the keys with XXX

    --
    You received this message because you are subscribed to the Google Groups
    "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to ansible-project+unsubscribe@googlegroups.com.
    To post to this group, send email to ansible-project@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/ansible-project/134ba4f5-f94e-410f-a2ed-df0f2e65a1d1%40googlegroups.com
    <https://groups.google.com/d/msgid/ansible-project/134ba4f5-f94e-410f-a2ed-df0f2e65a1d1%40googlegroups.com?utm_medium=email&utm_source=footer>
    .
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to ansible-project+unsubscribe@googlegroups.com.
    To post to this group, send email to ansible-project@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ansible-project/CA%2BnsWgynA%2BQehA5g3S-hQYNVpaKmoXAUgxsWky--D%3DwM5HaJZw%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Eric Brooke at Sep 30, 2014 at 8:02 pm
    Which logs would you like to see?
    On Tuesday, September 30, 2014 12:23:07 PM UTC-7, Michael DeHaan wrote:

    Anything relevant in the logs?



    On Mon, Sep 29, 2014 at 3:08 PM, Eric Brooke <eric....@mybesthelper.com
    <javascript:>> wrote:
    Hello,
    Last week we updated one of our servers from unbent 12.0+ to 14.0+ it
    deployed with out issue, after the weekend deployment to one of servers is
    no longer possible :-(

    Here is the command that is failing:

    - name: Update the apt cache if older than 2 hrs
    apt: update_cache=yes cache_valid_time=7200
    tags:
    - security-apt

    On just one of our servers prd1


    TASK: [common | Update the apt cache if older than 2 hrs]
    *********************
    <prd3> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd1> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd3> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && chmod a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142'"]
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && chmod a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276'"]
    <prd3> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmpnz2A7A TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt
    <prd1> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmp0xdCki TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt; rm
    -rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/
    /dev/null 2>&1\'"\'"\'\'']
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt; rm
    -rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/
    /dev/null 2>&1\'"\'"\'\'']
    ok: [prd3 => {"changed": false}
    failed: [prd1] => {"failed": true}

    I have replaced the keys with XXX

    --
    You received this message because you are subscribed to the Google Groups
    "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to ansible-proje...@googlegroups.com <javascript:>.
    To post to this group, send email to ansible...@googlegroups.com
    <javascript:>.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/ansible-project/134ba4f5-f94e-410f-a2ed-df0f2e65a1d1%40googlegroups.com
    <https://groups.google.com/d/msgid/ansible-project/134ba4f5-f94e-410f-a2ed-df0f2e65a1d1%40googlegroups.com?utm_medium=email&utm_source=footer>
    .
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to ansible-project+unsubscribe@googlegroups.com.
    To post to this group, send email to ansible-project@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ansible-project/db41b5c7-2276-42e2-8150-8d59f335bbaa%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Eric Brooke at Sep 30, 2014 at 8:37 pm
    I fixed it with a server reboot. Is there a place to restart this service
    rather then the whole server. Any advice appreciated. Thanks in advance
    On Tuesday, 30 September 2014 13:02:38 UTC-7, Eric Brooke wrote:

    Which logs would you like to see?
    On Tuesday, September 30, 2014 12:23:07 PM UTC-7, Michael DeHaan wrote:

    Anything relevant in the logs?



    On Mon, Sep 29, 2014 at 3:08 PM, Eric Brooke <eric....@mybesthelper.com>
    wrote:
    Hello,
    Last week we updated one of our servers from unbent 12.0+ to 14.0+ it
    deployed with out issue, after the weekend deployment to one of servers is
    no longer possible :-(

    Here is the command that is failing:

    - name: Update the apt cache if older than 2 hrs
    apt: update_cache=yes cache_valid_time=7200
    tags:
    - security-apt

    On just one of our servers prd1


    TASK: [common | Update the apt cache if older than 2 hrs]
    *********************
    <prd3> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd1> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd3> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && chmod a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142'"]
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && chmod a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276'"]
    <prd3> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmpnz2A7A TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt
    <prd1> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmp0xdCki TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt; rm
    -rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/
    /dev/null 2>&1\'"\'"\'\'']
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt; rm
    -rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/
    /dev/null 2>&1\'"\'"\'\'']
    ok: [prd3 => {"changed": false}
    failed: [prd1] => {"failed": true}

    I have replaced the keys with XXX

    --
    You received this message because you are subscribed to the Google
    Groups "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to ansible-proje...@googlegroups.com.
    To post to this group, send email to ansible...@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/ansible-project/134ba4f5-f94e-410f-a2ed-df0f2e65a1d1%40googlegroups.com
    <https://groups.google.com/d/msgid/ansible-project/134ba4f5-f94e-410f-a2ed-df0f2e65a1d1%40googlegroups.com?utm_medium=email&utm_source=footer>
    .
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to ansible-project+unsubscribe@googlegroups.com.
    To post to this group, send email to ansible-project@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ansible-project/f3ca6b7d-50bf-47d5-9f21-266a2105473b%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Brian Coca at Sep 30, 2014 at 9:04 pm
    not a service, locks on the apt DB are done to avoid inconsistencies,
    either someone else was running an update or a lock got leftover
    (probably with a hung/interrupted process).

    you can normally use lsof to find out what the offending process is
    and kill it, restart fixed it by killing ALL processes.

    On Tue, Sep 30, 2014 at 4:37 PM, Eric Brooke
    wrote:
    I fixed it with a server reboot. Is there a place to restart this service
    rather then the whole server. Any advice appreciated. Thanks in advance

    On Tuesday, 30 September 2014 13:02:38 UTC-7, Eric Brooke wrote:

    Which logs would you like to see?
    On Tuesday, September 30, 2014 12:23:07 PM UTC-7, Michael DeHaan wrote:

    Anything relevant in the logs?



    On Mon, Sep 29, 2014 at 3:08 PM, Eric Brooke <eric....@mybesthelper.com>
    wrote:
    Hello,
    Last week we updated one of our servers from unbent 12.0+ to 14.0+ it
    deployed with out issue, after the weekend deployment to one of servers is
    no longer possible :-(

    Here is the command that is failing:

    - name: Update the apt cache if older than 2 hrs
    apt: update_cache=yes cache_valid_time=7200
    tags:
    - security-apt

    On just one of our servers prd1


    TASK: [common | Update the apt cache if older than 2 hrs]
    *********************
    <prd3> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd1> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd3> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && chmod a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142'"]
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && chmod a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276'"]
    <prd3> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmpnz2A7A TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt
    <prd1> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmp0xdCki TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt; rm
    -rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/
    /dev/null 2>&1\'"\'"\'\'']
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto', '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r', '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', u'/bin/sh -c \'sudo -k && sudo -H -S -p "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8 /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt; rm
    -rf /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/
    /dev/null 2>&1\'"\'"\'\'']
    ok: [prd3 => {"changed": false}
    failed: [prd1] => {"failed": true}

    I have replaced the keys with XXX

    --
    You received this message because you are subscribed to the Google
    Groups "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to ansible-proje...@googlegroups.com.
    To post to this group, send email to ansible...@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/ansible-project/134ba4f5-f94e-410f-a2ed-df0f2e65a1d1%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups
    "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to ansible-project+unsubscribe@googlegroups.com.
    To post to this group, send email to ansible-project@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/ansible-project/f3ca6b7d-50bf-47d5-9f21-266a2105473b%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.


    --
    Brian Coca
    Stultorum infinitus est numerus
    0110000101110010011001010110111000100111011101000010000001111001011011110111010100100000011100110110110101100001011100100111010000100001
    Pedo mellon a minno

    --
    You received this message because you are subscribed to the Google Groups "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to ansible-project+unsubscribe@googlegroups.com.
    To post to this group, send email to ansible-project@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ansible-project/CADn%2BHsyaUxWckKcFFgrU0hDNU%3De%2BTQ2W_Kix18G8LMG5w6dEaA%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Eric Brooke at Sep 30, 2014 at 10:33 pm
    Thank you Brian
    On Tuesday, 30 September 2014 14:04:45 UTC-7, Brian Coca wrote:

    not a service, locks on the apt DB are done to avoid inconsistencies,
    either someone else was running an update or a lock got leftover
    (probably with a hung/interrupted process).

    you can normally use lsof to find out what the offending process is
    and kill it, restart fixed it by killing ALL processes.

    On Tue, Sep 30, 2014 at 4:37 PM, Eric Brooke
    <eric....@mybesthelper.com <javascript:>> wrote:
    I fixed it with a server reboot. Is there a place to restart this service
    rather then the whole server. Any advice appreciated. Thanks in advance

    On Tuesday, 30 September 2014 13:02:38 UTC-7, Eric Brooke wrote:

    Which logs would you like to see?
    On Tuesday, September 30, 2014 12:23:07 PM UTC-7, Michael DeHaan wrote:

    Anything relevant in the logs?



    On Mon, Sep 29, 2014 at 3:08 PM, Eric Brooke <
    eric....@mybesthelper.com>
    wrote:
    Hello,
    Last week we updated one of our servers from unbent 12.0+ to 14.0+ it
    deployed with out issue, after the weekend deployment to one of
    servers is
    no longer possible :-(

    Here is the command that is failing:

    - name: Update the apt cache if older than 2 hrs
    apt: update_cache=yes cache_valid_time=7200
    tags:
    - security-apt

    On just one of our servers prd1


    TASK: [common | Update the apt cache if older than 2 hrs]
    *********************
    <prd3> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd1> ESTABLISH CONNECTION FOR USER: ubuntu
    <prd3> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> REMOTE_MODULE apt update_cache=yes cache_valid_time=7200
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto',
    '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r',
    '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && chmod
    a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142'"]
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto',
    '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r',
    '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', "/bin/sh -c 'mkdir -p
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && chmod
    a+rx
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276 && echo
    $HOME/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276'"]
    <prd3> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmpnz2A7A
    TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt
    <prd1> PUT /var/folders/dz/_g3k142j3vz652trrswwwxf80000gq/T/tmp0xdCki
    TO
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt
    <prd1> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto',
    '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r',
    '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd1', u'/bin/sh -c \'sudo -k && sudo -H -S -p
    "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8
    /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/apt; rm
    -rf
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-35664788881142/
    /dev/null 2>&1\'"\'"\'\'']
    <prd3> EXEC ['ssh', '-C', '-tt', '-q', '-o', 'ControlMaster=auto',
    '-o',
    'ControlPersist=60s', '-o',
    'ControlPath=/Users/ericbrooke/.ansible/cp/ansible-ssh-%h-%p-%r',
    '-o',
    'KbdInteractiveAuthentication=no', '-o',
    'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey',
    '-o', 'PasswordAuthentication=no', '-o', 'User=ubuntu', '-o',
    'ConnectTimeout=10', 'prd3', u'/bin/sh -c \'sudo -k && sudo -H -S -p
    "[sudo
    via ansible, key=XXX] password: " -u root /bin/sh -c \'"\'"\'echo
    SUDO-SUCCESS-XXX; LANG=en_US.UTF-8 LC_CTYPE=en_US.UTF-8
    /usr/bin/python
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/apt; rm
    -rf
    /home/ubuntu/.ansible/tmp/ansible-tmp-1412016466.77-191935961010276/
    /dev/null 2>&1\'"\'"\'\'']
    ok: [prd3 => {"changed": false}
    failed: [prd1] => {"failed": true}

    I have replaced the keys with XXX

    --
    You received this message because you are subscribed to the Google
    Groups "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it,
    send
    an email to ansible-proje...@googlegroups.com.
    To post to this group, send email to ansible...@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/ansible-project/134ba4f5-f94e-410f-a2ed-df0f2e65a1d1%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups
    "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to ansible-proje...@googlegroups.com <javascript:>.
    To post to this group, send email to ansible...@googlegroups.com
    <javascript:>.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/ansible-project/f3ca6b7d-50bf-47d5-9f21-266a2105473b%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.


    --
    Brian Coca
    Stultorum infinitus est numerus
    0110000101110010011001010110111000100111011101000010000001111001011011110111010100100000011100110110110101100001011100100111010000100001

    Pedo mellon a minno
    --
    You received this message because you are subscribed to the Google Groups "Ansible Project" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to ansible-project+unsubscribe@googlegroups.com.
    To post to this group, send email to ansible-project@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/ansible-project/377c0588-dd76-4c4a-b935-9f6d614d5727%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupansible-project @
postedSep 29, '14 at 9:20p
activeSep 30, '14 at 10:33p
posts6
users3

People

Translate

site design / logo © 2022 Grokbase