FAQ
I found something interesting that I don't understand.
I am working out of a Test database (clone from production onto another server) that has encrypted data but the wallet is not open (and actually not even there) and I am only dealing with non encrypted data. When I run the flashback queries below I get inconsistent results. For one of the queries I would get a wallet is not open error then for a different day it would work fine, but for any day with the versions query I would get a wallet not open error.
Can anybody explain this to me? Also I found that scheduled jobs do not run when the wallet is not open. Any idea on this too?

-- wallet error
select t.*, t.rowid from pos_user.TECH_PARTS AS OF TIMESTAMP TO_TIMESTAMP('11/11/2011 08:00:00','MM/DD/YYYY HH24:MI:SS') t
WHERE t.dbtrucknum = '01321' AND t.dbpartnum = 70355;
-- works fine
select t.*, t.rowid from pos_user.TECH_PARTS AS OF TIMESTAMP TO_TIMESTAMP('11/12/2011 08:00:00','MM/DD/YYYY HH24:MI:SS') t
WHERE t.dbtrucknum = '01321' AND t.dbpartnum = 70355 AND t.dbstart > '09/01/2011';
-- wallet error
SELECT t.*,versions_starttime,versions_startscn,versions_endtime,versions_endscn,versions_xid,versions_operation FROM pos_user.TECH_PARTS
VERSIONS BETWEEN TIMESTAMP TO_TIMESTAMP('11/14/2011 08:00:00','MM/DD/YYYY HH24:MI:SS') AND SYSDATE t WHERE t.dbtrucknum = '01321' AND t.dbpartnum = 70355 AND t.dbstart > '09/01/2011';
-- works fine
select t.*, t.rowid from pos_user.TECH_PARTS AS OF TIMESTAMP TO_TIMESTAMP('11/14/2011 08:00:00','MM/DD/YYYY HH24:MI:SS') t
WHERE t.dbtrucknum = '01321' AND t.dbpartnum = 70355;

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedDec 7, '11 at 10:34p
activeDec 7, '11 at 10:34p
posts1
users1
websiteoracle.com

1 user in discussion

Jeff Chirco: 1 post

People

Translate

site design / logo © 2022 Grokbase