FAQ
A caveat; all of my practical knowledge of TSM/TDPO dates from 10 years ago
and is unlikely to be accurate with regards the latest versions.

First question: What version of TDPO are you using? (I was working with TDPO
2.1)

Keeping that in mind, the first configuration issues I would check would be
the password file.

The password file was of the format: TDPO.

Check to see if the password file on the live server was modified when the
configuration of the live server was changed.

If it was you may need to regenerate it on the QA server.

The password file needs to be owned by the appropriate oracle user and
group.

Obviously there is the possibility that the file is corrupt!

Dave

On Wed, Aug 18, 2010 at 2:42 PM, Amit Verma (IT - Otterbase) <
averma_at_bordersgroupinc.com> wrote:
A little history, we used to have an automated script that refreshed QA
database from production using rman duplicate. They (UNIX guys) moved the
TSM server and modified the configuration files on production to make the
backups go to the new server. Nobody modified the settings or setup new
settings on the new server for the QA machine to be able to read backups
done by prod. Now when I updated my dsm.sys file to point to the new server,
I get the following while running an rman duplicate.



RMAN-03002: failure of Duplicate Db command at 08/17/2010 14:26:06

RMAN-03015: error occurred in stored script Memory Script

ORA-19501: read error on file "oqllff55_1_1", blockno 1 (blocksize=512)

ORA-27190: skgfrd: sbtread2 returned error

ORA-19511: Error received from media manager layer, error text:

ANS1314E (RC14) File data currently unavailable on server



Am I missing something at the TSM server layer, like permissions, creation
of new nodes etc?



Any help would be much appreciated.



Thanks.

-Amit.

--
http://www.freelists.org/webpage/oracle-l

Search Discussions

  • David Barbour at Aug 19, 2010 at 1:01 pm
    Try running 'tdpoconf showenvironment' from the client. This will tell you
    if you can see the library manager, if the password file is valid and
    generally the health of your connection. Might find the problem this way.
    Are you using LAN-Free (direct connect to backup media from the client)
    rather than standard over-the-wire backups through the library manager?



    From: oracle-l-bounce_at_freelists.org
    On Behalf Of David Roberts
    Sent: Thursday, August 19, 2010 2:54 AM
    To: averma_at_bordersgroupinc.com
    Cc: oracle-l
    Subject: Re: TSM RMAN Config question



    A caveat; all of my practical knowledge of TSM/TDPO dates from 10 years ago
    and is unlikely to be accurate with regards the latest versions.



    First question: What version of TDPO are you using? (I was working with TDPO
    2.1)





    Keeping that in mind, the first configuration issues I would check would be
    the password file.



    The password file was of the format: TDPO.



    Check to see if the password file on the live server was modified when the
    configuration of the live server was changed.



    If it was you may need to regenerate it on the QA server.



    The password file needs to be owned by the appropriate oracle user and
    group.





    Obviously there is the possibility that the file is corrupt!



    Dave

    On Wed, Aug 18, 2010 at 2:42 PM, Amit Verma (IT - Otterbase)
    wrote:

    A little history, we used to have an automated script that refreshed QA
    database from production using rman duplicate. They (UNIX guys) moved the
    TSM server and modified the configuration files on production to make the
    backups go to the new server. Nobody modified the settings or setup new
    settings on the new server for the QA machine to be able to read backups
    done by prod. Now when I updated my dsm.sys file to point to the new server,
    I get the following while running an rman duplicate.



    RMAN-03002: failure of Duplicate Db command at 08/17/2010 14:26:06

    RMAN-03015: error occurred in stored script Memory Script

    ORA-19501: read error on file "oqllff55_1_1", blockno 1 (blocksize=512)

    ORA-27190: skgfrd: sbtread2 returned error

    ORA-19511: Error received from media manager layer, error text:

    ANS1314E (RC14) File data currently unavailable on server



    Am I missing something at the TSM server layer, like permissions, creation
    of new nodes etc?



    Any help would be much appreciated.



    Thanks.

    -Amit.
  • MacGregor, Ian A. at Aug 19, 2010 at 1:05 pm
    Have you checked your tape drives and the path to them? I've seen the error when the drives are unavailable or the path to them is misconfigured.

    Ian MacGregor
    ç ANS1314E (RC14) File data currently unavailable on server

    Am I missing something at the TSM server layer, like permissions, creation of new nodes etc?

    Any help would be much appreciated.

    Thanks.
    -Amit.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedAug 19, '10 at 7:53a
activeAug 19, '10 at 1:05p
posts3
users3
websiteoracle.com

People

Translate

site design / logo © 2022 Grokbase