FAQ
Dropping and recreating the oid ldap entry seems to have made the problem go
away. This is both good and bad; good because we do not get the error with
our standard setup, but bad because we have no idea why we were getting
errors in the first place.

Very strange. Thanks to everyone who pitched ideas.

Still have not heard a peep out of Oracle Support.
On Mon, Sep 8, 2008 at 3:39 PM, Charles Schultz wrote:

*David* - Since you are the 2nd person to ask, I'll respond to the list:
Works: 'SERVICE="MSGSTND", LGWR ASYNC NOAFFIRM delay=0 max_failure=0
OPTIONAL REOPEN=60 register'
Does not work: 'SERVICE="MSGSTBY", LGWR ASYNC NOAFFIRM delay=0
max_failure=0 OPTIONAL REOPEN=60 register'


*Romas* - I am working on your idea. Are you suggesting that I use
pfiles/lsof on LGWR?


*Finn* - my apologies about not providing enough information; I never know
how much is too much, especially since the audience in this case is quite
large. Here are my tns resolutions:
/u01/app/oracle: *tnsping msgstnd*

TNS Ping Utility for Solaris: Version 10.2.0.2.0 - Production on
08-SEP-2008 15:33:30
Copyright (c) 1997, 2005, Oracle. All rights reserved.

Used parameter files:
/u01/app/oracle/product/10.2.0.2.home2/network/admin/sqlnet.ora

Used LDAP adapter to resolve the alias
Attempting to contact
(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=standbyhost)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=MSGPROD2)(SERVER=DEDICATED)))
OK (10 msec)
/u01/app/oracle: *tnsping msgstby*

TNS Ping Utility for Solaris: Version 10.2.0.2.0 - Production on
08-SEP-2008 15:33:36
Copyright (c) 1997, 2005, Oracle. All rights reserved.

Used parameter files:
/u01/app/oracle/product/10.2.0.2.home2/network/admin/sqlnet.ora

Used LDAP adapter to resolve the alias
Attempting to contact
(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(HOST=standbyhost.my.com
)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=MSGPROD2)(SERVER=DEDICATED)))
OK (10 msec)

The SERVICE I have listed in the dest parameter exactly matches the entry
in oid ldap. However, taking your thought one step further, perhaps there is
an issue because one tns name has the full host, whereas the other does not.
I will experiment with that to see if that makes a difference or not.


*DBA Dave* wrote:
"So, I got the same message last week (Oracle 10.2.0.3, AIX 5.3)
After trying different options I ended up setting up the db_unique_name in
both instances and that made the trick."

Thanks, did you set the db_unique_name the same or different? Ours is left
default and matches, but I'll think about that.
--
Charles Schultz

--
http://www.freelists.org/webpage/oracle-l

Search Discussions

  • Finn Jorgensen at Sep 9, 2008 at 1:22 am
    Does the new OID entry have the full hostname or still only the hostname
    with no domain?

    I've seen DNS not being able to resolve just hostname, but resolve domained
    hostname just fine. Or vice versa.

    Finn
    On Mon, Sep 8, 2008 at 3:56 PM, Charles Schultz wrote:

    Dropping and recreating the oid ldap entry seems to have made the problem
    go away. This is both good and bad; good because we do not get the error
    with our standard setup, but bad because we have no idea why we were getting
    errors in the first place.

    Very strange. Thanks to everyone who pitched ideas.

    Still have not heard a peep out of Oracle Support.
    --
    http://www.freelists.org/webpage/oracle-l
  • David Ballester at Sep 9, 2008 at 8:43 am
    2008/9/9 Finn Jorgensen
    Does the new OID entry have the full hostname or still only the hostname
    with no domain?

    I've seen DNS not being able to resolve just hostname, but resolve domained
    hostname just fine. Or vice versa.

    Finn
    I totally agree with Finn, Michael, from the primary host try

    nslookup standbyhost.my.com

    and

    nslookup standbyhost

    if the first one is well resolved and the second one not, take a look at the
    /etc/resolve.conf file for the line informing about the "search" values.
    Seems that your machine is not able to resolve hostnames without FQDN or is
    adding another default domain to resolve only hostnames. May be some change
    ( maybe two weeks after the switchback? ) in the resolv.conf ( how you
    obtain your network config for this machine? dhcp, manually... ) as changed
    the value for the serach entry ( seems that the original value was my.com )

    Regards

    D.

    <http://my.com/>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedSep 8, '08 at 8:56p
activeSep 9, '08 at 8:43a
posts3
users3
websiteoracle.com

People

Translate

site design / logo © 2022 Grokbase