FAQ
FYI, I figured it out (no thanks to Oracle support). It was a combination
of two things:



The NLS_LANG variable wasn't set
The location of ORA_NLS10 changed between versions

And just for the record, once those were fixed I could upgrade with
sga_target set with no problems at all...







Thanks,

Jay Miller

Sr. Oracle DBA

x68355



-----Original Message-----
From: Miller, Jay
Sent: Tuesday, September 13, 2005 11:46 AM
To: fuadar_at_yahoo.com; oracle-l_at_freelists.org
Subject: RE: Does sga_target not work for 10.2 upgrade or is Oracle Suppor t
cl ueless?



Thanks, but it's set to WE8ISO8859P1.









Thanks,

Jay Miller

Sr. Oracle DBA

x68355



-----Original Message-----
From: Fuad Arshad
Sent: Monday, September 12, 2005 8:56 PM
To: oracle-l_at_freelists.org
Subject: RE: Does sga_target not work for 10.2 upgrade or is Oracle Suppor t
cl ueless?



what was the characterset of your 1.1 database. i know one of our dba's
complained ofit not able to upgrade for us7ascii characterset.

JayMiller_at_TDWaterhouse.com wrote:

Hi Paul,





The error I got was when issuing the startup upgrade command (Step 29):



SQL> startup upgrade pfile=/oracle/mds/admin/pfile/initmdsdb.ora
ORACLE instance started.
Total System Global Area 1258291200 bytes
Fixed Size 1978336 bytes
Variable Size 369102880 bytes
Database Buffers 872415232 bytes
Redo Buffers 14794752 bytes
ORA-12709: error while loading create database character set





I don't know how this has anything to do with the sga but I've gotten enough
oracle error messages that didn't have anything to do with the actual error
that I'm willing to consider it as a possibility.











Thanks,

Jay Miller

Sr. Oracle DBA

x68355



-----Original Message-----
From: Paul Drake
Sent: Monday, September 12, 2005 6:24 PM
To: Miller, Jay
Cc: oracle-l_at_freelists.org
Subject: Re: Does sga_target not work for 10.2 upgrade or is Oracle Support
cl ueless?



On 9/12/05, JayMiller_at_tdwaterhouse.com
wrote:
I'm having problems upgrading a dev database from 10.1 to 10.2 (the first
time I've tried this). After opening a Tar the support tech said I
obviously didn't follow directions since I didn't set SHARED_POOL_SIZE,
LARGE_POOL_SIZE, or JAVA_POOL_SIZE as it said in the documentation. I had
purposely not set them as I had created this database using sga_target
instead.

So do I actually need to go back to the old parameters to do the upgrade and
then go back to sga_target after completing it? Has anyone upgraded 10.1 to
10.2 using sga_target?

This is 64-bit Solaris, Oracle 10.1.0.4 <http://10.1.0.4/> to 10.2.0.1
<http://10.2.0.1/> .

Thanks,
Jay Miller
Sr. Oracle DBA
x68355

This message is confidential and sent by TD Waterhouse solely for use
by the intended recipient. If you are not the intended recipient, you
are hereby notified that any use, distribution or copying of this
communication is strictly prohibited. This should not be deemed as an
offer or solicitation, to buy or sell any product. Any 3rd party
information contained herein was prepared by sources deemed reliable,
but is not guaranteed. TD Waterhouse does not accept electronic
instructions that would require an original signature. Information
received by or sent from TD Waterhouse is stored, subject to review,
and may be produced to regulatory authorities or others with a legal
right to such.

http://download-east.oracle.com/docs/cd/B19306_01/server.102/b14238.pdf
<http://download-east.oracle.com/docs/cd/B19306_01/server.102/b14238.pdf>

Jay,

Where are you receiving the error - in executing the pre-upgrade script
"utlu102i.sql" ?
(page 3-4 of b14238.pdf - Oracle(r) Database Upgrade Guide 10g Release 2
(10.2) B14238-01)

Using dbma?
I have used sga_target during application of the 10.1.0.4 <http://10.1.0.4/>
patchset on win32 without error.
I have not yet upgraded any databases from 10.1.0.x to 10.2.0.1
<http://10.2.0.1/> .

Paul

Update Parameters: [Update Oracle Database 10.2 init.ora or spfile]

WARNING: --> "shared_pool_size" needs to be increased to at least 178499994
WARNING: --> "java_pool_size" needs to be increased to at least 67108864
WARNING: --> "streams_pool_size" is not currently defined and needs a value

of at
least 50331648
WARNING: --> "session_max_open_files" needs to be increased to at least 20

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedSep 19, '05 at 7:48p
activeSep 19, '05 at 7:48p
posts1
users1
websiteoracle.com

1 user in discussion

JayMiller_at_TDWaterhouse.com: 1 post

People

Translate

site design / logo © 2022 Grokbase