FAQ
I am trying to set up an OPS$ account on Oracle NT so I can run sqlplus,
exp, etc... Without supplying a password. This is not problem on
Unix/Sun/Linux but I can't get it to work on NT/2000. (Oracle 8.1.7)

What am I missing?

Thanks!
Ron

Please see the official ORACLE-L FAQ: http://www.orafaq.com

To unsubscribe send email to: oracle-l-request_at_freelists.org
put 'unsubscribe' in the subject line.

Search Discussions

  • Steve Jelfs at Jul 27, 2004 at 2:22 pm

    Smith, Ron L. wrote:
    I am trying to set up an OPS$ account on Oracle NT so I can run sqlplus,
    exp, etc... Without supplying a password. This is not problem on
    Unix/Sun/Linux but I can't get it to work on NT/2000. (Oracle 8.1.7)

    What am I missing?
    Dunno - what have you done so far?

    Steve

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Solomon, Saul M. at Jul 27, 2004 at 2:31 pm
    Make sure the ID you want to use is in the ORA_DBA group on the windows =
    box.
    If it's a domain account rather than local, go into the registry =
    HKLM/Software/Oracle/HomeX and add the string value =
    OSAUTH_PREFIX_DOMAIN=3DFALSE. This will stop the domain name part of the =
    account being passed to Oracle. Then add the account with the ops$ =
    prefix as normal.

    -----Original Message-----
    From: Steve Jelfs
    Sent: Tuesday, July 27, 2004 3:26 PM
    To: oracle-l_at_freelists.org
    Subject: Re: OPS$ on NT/2000

    Smith, Ron L. wrote:
    I am trying to set up an OPS$ account on Oracle NT so I can run = sqlplus,
    exp, etc... Without supplying a password. This is not problem on
    Unix/Sun/Linux but I can't get it to work on NT/2000. (Oracle 8.1.7)

    What am I missing?
    =20
    Dunno - what have you done so far?

    Steve

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
    ----------------------------------------------------------------
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    ----------------------------------------------------------------
    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Tanel Põder at Jul 27, 2004 at 3:57 pm

    Make sure the ID you want to use is in the ORA_DBA group on the windows =
    box.
    You don't have to be in ORA_DBA group to have OS authentication, but you do
    have to set SQLNET.AUTHENTICATION_SERVICES to include NTS (and set the
    already mentioned registry parameter to false if not using usernames with
    domain names).

    Tanel.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Pete Finnigan at Jul 29, 2004 at 6:10 am
    In article >, Solomon, Saul M. writes
    Make sure the ID you want to use is in the ORA_DBA group on the windows =
    box.
    If it's a domain account rather than local, go into the registry =
    HKLM/Software/Oracle/HomeX and add the string value =
    OSAUTH_PREFIX_DOMAIN=3DFALSE. This will stop the domain name part of the =
    account being passed to Oracle. Then add the account with the ops$ =
    prefix as normal.
    Hi,

    Don't make the user a member of ORA_DBA as it will then be able to
    inherit OSDBA privileges by connecting "as sysdba" which you probably
    don't intend and also if you are using a domain account set the registry
    entry to TRUE so that spoofing the account is harder to do.

    Take a look at the two checklists on Oracle security on my site
    http://www.petefinnigan.com/orasec.htm which mention some security
    checks and recommendations where external accounts are used.

    Kind regards

    Pete

    --
    Pete Finnigan
    email:pete_at_petefinnigan.com
    Web site: http://www.petefinnigan.com - Oracle security audit specialists
    Book:Oracle security step-by-step Guide - see http://store.sans.org for details.

    ----------------------------------------------------------------
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    ----------------------------------------------------------------
    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Jared.Still_at_radisys.com at Jul 27, 2004 at 6:28 pm

    I am trying to set up an OPS$ account on Oracle NT so I can run sqlplus,
    exp, etc... Without supplying a password. This is not problem on
    Unix/Sun/Linux but I can't get it to work on NT/2000. (Oracle 8.1.7)

    What am I missing?
    This may help:

    http://www.cybcon.com/~jkstill/Connect_Internal_Gymnastics_8i_public.doc

    Jared

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedJul 27, '04 at 2:16p
activeJul 29, '04 at 6:10a
posts6
users6
websiteoracle.com

People

Translate

site design / logo © 2022 Grokbase