FAQ
Odd question time:
RTFM'd until we're blue, but we can't get the listener services to register
when specified in the init.ora vs a listener.ora file. HR Apps 11.5.7 on
Oracle 9.2.0.5, HPUX 11.11.

We're trying to set the listener in the init.ora/spfile using the
parameters:
LOCAL_LISTENER=db1
SERVICE_NAMES=db1.us.acme.com
INSTANCE_NAME=db1

tnsnames.ora entry looks like:
db1= (DESCRIPTION= (ADDRESS=(PROTOCOL=tcp)(HOST=dbserver)(PORT=1421)))

As SYSDBA we've done the:
ALTER SYSTEM SET LOCAL_LISTENER='db1'

When we check the listener via lsnrctl we can not detect the services.
$TNS_ADMIN is set correctly.

LSNRCTL> set current_listener db1
LSNRCTL> services
Connecting to (ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx.xxx)(PORT=1421))
TNS-12541: TNS:no listener
TNS-12560: TNS:protocol adapter error
TNS-00511: No listener
HPUX Error: 239: Connection refused

Anyone out there gone through this exercise successfully?

Thanks,

Scott

Please see the official ORACLE-L FAQ: http://www.orafaq.com

To unsubscribe send email to: oracle-l-request_at_freelists.org
put 'unsubscribe' in the subject line.

Search Discussions

  • David Sharples at Jun 28, 2004 at 12:33 pm
    Alter system register; should get it to see it, but doesn't explain why
    you cant get it normally on startup

    -----Original Message-----
    From: oracle-l-bounce_at_freelists.org
    On Behalf Of
    Scott.Shafer_at_dcpds.cpms.osd.mil
    Sent: 28 June 2004 18:31
    To: oracle-l_at_freelists.org
    Subject: spfile/listener question

    Odd question time:
    RTFM'd until we're blue, but we can't get the listener services to
    register
    when specified in the init.ora vs a listener.ora file. HR Apps 11.5.7 on
    Oracle 9.2.0.5, HPUX 11.11.

    We're trying to set the listener in the init.ora/spfile using the
    parameters:
    LOCAL_LISTENER=3Ddb1
    SERVICE_NAMES=3Ddb1.us.acme.com
    INSTANCE_NAME=3Ddb1

    tnsnames.ora entry looks like:
    db1=3D (DESCRIPTION=3D =
    (ADDRESS=3D(PROTOCOL=3Dtcp)(HOST=3Ddbserver)(PORT=3D1421)))

    As SYSDBA we've done the:
    ALTER SYSTEM SET LOCAL_LISTENER=3D'db1'=20

    When we check the listener via lsnrctl we can not detect the services.
    $TNS_ADMIN is set correctly.

    LSNRCTL> set current_listener db1
    LSNRCTL> services
    Connecting to =
    (ADDRESS=3D(PROTOCOL=3DTCP)(HOST=3Dxxx.xxx.xxx.xxx)(PORT=3D1421))
    TNS-12541: TNS:no listener
    TNS-12560: TNS:protocol adapter error
    TNS-00511: No listener
    HPUX Error: 239: Connection refused

    Anyone out there gone through this exercise successfully?

    Thanks,

    Scott

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/

    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
    ----------------------------------------------------------------
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    ----------------------------------------------------------------
    To unsubscribe send email to: oracle-l-request_at_freelists.org

    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
  • Scott.Shafer_at_dcpds.cpms.osd.mil at Jun 28, 2004 at 12:41 pm
    Thanks, but that didn't change anything. We have to be missing something -
    most likely simple - but danged if 4 pairs of eyes can see it...
    --Scott

    -----Original Message-----
    From: David Sharples

    Alter system register; should get it to see it, but doesn't explain why
    you cant get it normally on startup

    -----Original Message-----
    From: oracle-l-bounce_at_freelists.org
    On Behalf Of

    Odd question time:
    RTFM'd until we're blue, but we can't get the listener services to
    register
    when specified in the init.ora vs a listener.ora file. HR Apps 11.5.7 on
    Oracle 9.2.0.5, HPUX 11.11.

    We're trying to set the listener in the init.ora/spfile using the
    parameters:
    LOCAL_LISTENER=3Ddb1
    SERVICE_NAMES=3Ddb1.us.acme.com
    INSTANCE_NAME=3Ddb1

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
  • Tanel Põder at Jun 28, 2004 at 12:41 pm
    Try to set the LOCAL_LISTENER to "DESCRIPTION=
    (ADDRESS=(PROTOCOL=tcp)(HOST=dbserver)(PORT=1421))" instead of tns alias.

    Tanel.

    Original Message -----
    From:
    To:
    Sent: Monday, June 28, 2004 8:30 PM
    Subject: spfile/listener question
    Odd question time:
    RTFM'd until we're blue, but we can't get the listener services to register
    when specified in the init.ora vs a listener.ora file. HR Apps 11.5.7 on
    Oracle 9.2.0.5, HPUX 11.11.

    We're trying to set the listener in the init.ora/spfile using the
    parameters:
    LOCAL_LISTENER=db1
    SERVICE_NAMES=db1.us.acme.com
    INSTANCE_NAME=db1

    tnsnames.ora entry looks like:
    db1= (DESCRIPTION= (ADDRESS=(PROTOCOL=tcp)(HOST=dbserver)(PORT=1421)))

    As SYSDBA we've done the:
    ALTER SYSTEM SET LOCAL_LISTENER='db1'
    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Tanel Põder at Jun 28, 2004 at 12:49 pm
    Sorry, remove the DESCRIPTION part. The correct syntax should be:

    alter system set
    local_listener="(ADDRESS=(PROTOCOL=tcp)(HOST=localhost)(PORT=1521))";

    Tanel.

    Original Message -----
    From: "Tanel Põder"
    To:
    Sent: Monday, June 28, 2004 8:44 PM
    Subject: Re: spfile/listener question
    Try to set the LOCAL_LISTENER to "DESCRIPTION=
    (ADDRESS=(PROTOCOL=tcp)(HOST=dbserver)(PORT=1421))" instead of tns alias.

    Tanel.

    ----- Original Message -----
    From:
    To:
    Sent: Monday, June 28, 2004 8:30 PM
    Subject: spfile/listener question

    Odd question time:
    RTFM'd until we're blue, but we can't get the listener services to register
    when specified in the init.ora vs a listener.ora file. HR Apps 11.5.7 on
    Oracle 9.2.0.5, HPUX 11.11.

    We're trying to set the listener in the init.ora/spfile using the
    parameters:
    LOCAL_LISTENER=db1
    SERVICE_NAMES=db1.us.acme.com
    INSTANCE_NAME=db1

    tnsnames.ora entry looks like:
    db1= (DESCRIPTION= (ADDRESS=(PROTOCOL=tcp)(HOST=dbserver)(PORT=1421)))

    As SYSDBA we've done the:
    ALTER SYSTEM SET LOCAL_LISTENER='db1'

    ----------------------------------------------------------------
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    ----------------------------------------------------------------
    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Scott.Shafer_at_dcpds.cpms.osd.mil at Jun 28, 2004 at 12:50 pm
    Already tried it both ways, with the same result. Metalink is no help so
    far. I appreciate the responses - keep 'em coming.
    Scott Shafer

    -----Original Message-----
    From: Tanel Põder

    Try to set the LOCAL_LISTENER to "DESCRIPTION=
    (ADDRESS=(PROTOCOL=tcp)(HOST=dbserver)(PORT=1421))" instead of tns alias.

    Tanel.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Peter Barnett at Jun 28, 2004 at 2:07 pm
    If you specify the database in a listener.ora file the
    status becomes UNKNOWN when you stat the listener. If
    you let discovery takes its course the status becomes
    OK. This is documented on MetaLink. But, there is no
    explanation as to why this is true. Just gotta trust
    the 'Oracle Gods'.

    Scott.Shafer_at_dcpds.cpms.osd.mil wrote:
    Already tried it both ways, with the same result.
    Metalink is no help so
    far. I appreciate the responses - keep 'em coming.
    Scott Shafer


    -----Original Message-----
    From: Tanel Põder

    Try to set the LOCAL_LISTENER to "DESCRIPTION=
    (ADDRESS=(PROTOCOL=tcp)(HOST=dbserver)(PORT=1421))"
    instead of tns alias.

    Tanel.

    Please see the official ORACLE-L FAQ:
    http://www.orafaq.com
    To unsubscribe send email to:
    oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at
    http://www.freelists.org/archives/oracle-l/
    FAQ is at
    http://www.freelists.org/help/fom-serve/cache/1.html
    >

    Pete Barnett
    Lead Database Administrator
    The Regence Group
    pnbarne_at_regence.com



    Do you Yahoo!?
    Yahoo! Mail - Helps protect you from nasty viruses.
    http://promotions.yahoo.com/new_mail

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Tanel Põder at Jun 28, 2004 at 1:19 pm

    LSNRCTL> set current_listener db1
    LSNRCTL> services
    Connecting to (ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx.xxx)(PORT=1421))
    TNS-12541: TNS:no listener
    TNS-12560: TNS:protocol adapter error
    TNS-00511: No listener
    HPUX Error: 239: Connection refused
    Sorry again, I didn't read your post thoroughly enough, but this error
    message shows that your listener isn't running at all!

    Tanel.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Scott.Shafer_at_dcpds.cpms.osd.mil at Jun 28, 2004 at 1:26 pm
    And that is what is puzzling us... The goal is to get rid of the
    listener.ora file, and use the spfile only. The way the docs read, the
    listener should be started at instance startup via the LOCAL_LISTENER
    init.ora param.

    Scott Shafer

    -----Original Message-----
    From: Tanel Põder
    LSNRCTL> set current_listener db1
    LSNRCTL> services
    Connecting to (ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx.xxx)(PORT=1421))
    TNS-12541: TNS:no listener
    TNS-12560: TNS:protocol adapter error
    TNS-00511: No listener
    HPUX Error: 239: Connection refused
    Sorry again, I didn't read your post thoroughly enough, but this error
    message shows that your listener isn't running at all!

    Tanel.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Mercadante, Thomas F at Jun 28, 2004 at 1:31 pm
    Scott,

    I don't think the intent of the spfile was to do away with the =
    listener.ora
    file.

    Stange thing the init.ora. You can put the listener entry into the =
    int.ora
    to have the database "self-register" with the listener. In this way, =
    you do
    not need an entry in the listener.ora file for each database.

    But if you are using the intelligent agent for use with Orcle OEM, you =
    need
    the databases listed in the listener.ora file for the agent to find the
    databases. A silly contradiction that someone at Oracle missed.

    Tom Mercadante
    Oracle Certified Professional

    -----Original Message-----
    From: Scott.Shafer_at_dcpds.cpms.osd.mil
    =20
    Sent: Monday, June 28, 2004 2:33 PM
    To: oracle-l_at_freelists.org
    Subject: RE: spfile/listener question

    And that is what is puzzling us... The goal is to get rid of the
    listener.ora file, and use the spfile only. The way the docs read, the
    listener should be started at instance startup via the LOCAL_LISTENER
    init.ora param.

    Scott Shafer

    -----Original Message-----
    From: Tanel P=F5der
    LSNRCTL> set current_listener db1
    LSNRCTL> services
    Connecting to=20
    (ADDRESS=3D(PROTOCOL=3DTCP)(HOST=3Dxxx.xxx.xxx.xxx)(PORT=3D1421))
    TNS-12541: TNS:no listener
    TNS-12560: TNS:protocol adapter error
    TNS-00511: No listener
    HPUX Error: 239: Connection refused
    Sorry again, I didn't read your post thoroughly enough, but this error
    message shows that your listener isn't running at all!

    Tanel.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org put
    'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
    ----------------------------------------------------------------
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    ----------------------------------------------------------------
    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Scott.Shafer_at_dcpds.cpms.osd.mil at Jun 28, 2004 at 1:39 pm
    Thanks, Tom. I'll pass it on.
    Scott Shafer

    -----Original Message-----
    From: Mercadante, Thomas F
    Sent: Monday, June 28, 2004 1:35 PM

    I don't think the intent of the spfile was to do away with the =
    listener.ora
    file.

    Stange thing the init.ora. You can put the listener entry into the =
    int.ora
    to have the database "self-register" with the listener. In this way, =
    you do
    not need an entry in the listener.ora file for each database.

    But if you are using the intelligent agent for use with Orcle OEM, you =
    need
    the databases listed in the listener.ora file for the agent to find the
    databases. A silly contradiction that someone at Oracle missed.

    Tom Mercadante
    Oracle Certified Professional

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Mercadante, Thomas F at Jun 28, 2004 at 2:11 pm
    Scott,

    Are you saying that with the entry below in the init.ora file, you =
    database
    did not register with the listener after a db bounce? Did the spfile =
    still
    exists after th4e db bounce? If it did, then the init.ora changes were
    skipped - the db started using the spfile.

    Try adding the entry to the init.ora file. =20
    Shut down the db. =20
    Rename, delete or recreate the spfile.
    Start the db.

    Check the listener again (lsnrctl services).

    Tom Mercadante
    Oracle Certified Professional

    -----Original Message-----
    From: Scott.Shafer_at_dcpds.cpms.osd.mil
    =20
    Sent: Monday, June 28, 2004 1:57 PM
    To: oracle-l_at_freelists.org
    Subject: RE: spfile/listener question

    Already tried it both ways, with the same result. Metalink is no help =
    so
    far. I appreciate the responses - keep 'em coming. Scott Shafer

    -----Original Message-----
    From: Tanel P=F5der

    Try to set the LOCAL_LISTENER to "DESCRIPTION=3D
    (ADDRESS=3D(PROTOCOL=3Dtcp)(HOST=3Ddbserver)(PORT=3D1421))" instead of =
    tns alias.

    Tanel.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org put
    'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/

    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
    ----------------------------------------------------------------
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    ----------------------------------------------------------------
    To unsubscribe send email to: oracle-l-request_at_freelists.org

    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
  • Scott.Shafer_at_dcpds.cpms.osd.mil at Jun 28, 2004 at 2:25 pm
    No, we haven't converted to spfile yet. Just using init.ora for testing.
    Thanks all for the replies. I think it was our misreading of the docs,
    thinking it allowed us to get rid of the listener.ora when that isn't the
    case (too bad).
    Oh well, back to the regularly scheduled PC/non-PC rants...

    Scott Shafer

    -----Original Message-----
    From: Mercadante, Thomas F

    Are you saying that with the entry below in the init.ora file, you =
    database
    did not register with the listener after a db bounce? Did the spfile =
    still
    exists after th4e db bounce? If it did, then the init.ora changes were
    skipped - the db started using the spfile.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Tanel Põder at Jun 28, 2004 at 2:47 pm
    The use of local listener self-registration is that whenever you add or
    remove a new instance or service name to your server, you don't have to
    manually modify listener.ora file.

    Tanel.
    ----- Original Message -----
    From:
    To:
    Sent: Monday, June 28, 2004 10:31 PM
    Subject: RE: spfile/listener question
    No, we haven't converted to spfile yet. Just using init.ora for testing.
    Thanks all for the replies. I think it was our misreading of the docs,
    thinking it allowed us to get rid of the listener.ora when that isn't the
    case (too bad).
    Oh well, back to the regularly scheduled PC/non-PC rants...


    Scott Shafer


    -----Original Message-----
    From: Mercadante, Thomas F

    Are you saying that with the entry below in the init.ora file, you =
    database
    did not register with the listener after a db bounce? Did the spfile =
    still
    exists after th4e db bounce? If it did, then the init.ora changes were
    skipped - the db started using the spfile.


    ----------------------------------------------------------------
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    ----------------------------------------------------------------
    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.

    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
    -----------------------------------------------------------------
  • Feighery Raymond at Jun 29, 2004 at 3:10 am
    You haven't started the listener.
    Dynamic registration via the init.ora file means you don't have to modify
    the listener.ora for each new database entry (e.g. you don't have to add an
    extra SID_LIST entry). However, you still have to define the LISTENER in the
    listener.ora for the listener itself and start it.

    Ray

    -----Original Message-----
    From: Scott.Shafer_at_dcpds.cpms.osd.mil

    Sent: Monday, June 28, 2004 6:31 PM
    To: oracle-l_at_freelists.org
    Subject: spfile/listener question

    Odd question time:
    RTFM'd until we're blue, but we can't get the listener services to register
    when specified in the init.ora vs a listener.ora file. HR Apps 11.5.7 on
    Oracle 9.2.0.5, HPUX 11.11.

    We're trying to set the listener in the init.ora/spfile using the
    parameters:
    LOCAL_LISTENER=db1
    SERVICE_NAMES=db1.us.acme.com
    INSTANCE_NAME=db1

    tnsnames.ora entry looks like:
    db1= (DESCRIPTION= (ADDRESS=(PROTOCOL=tcp)(HOST=dbserver)(PORT=1421)))

    As SYSDBA we've done the:
    ALTER SYSTEM SET LOCAL_LISTENER='db1'

    When we check the listener via lsnrctl we can not detect the services.
    $TNS_ADMIN is set correctly.

    LSNRCTL> set current_listener db1
    LSNRCTL> services
    Connecting to (ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx.xxx)(PORT=1421))
    TNS-12541: TNS:no listener
    TNS-12560: TNS:protocol adapter error
    TNS-00511: No listener
    HPUX Error: 239: Connection refused

    Anyone out there gone through this exercise successfully?

    Thanks,

    Scott

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org put
    'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html

    This email and any attached to it are confidential and intended only for the
    individual or entity to which it is addressed. If you are not the intended
    recipient, please let us know by telephoning or emailing the sender. You
    should also delete the email and any attachment from your systems and should
    not copy the email or any attachment or disclose their content to any other
    person or entity. The views expressed here are not necessarily those of
    Churchill Insurance Group plc or its affiliates or subsidiaries. Thank you.

    Churchill Insurance Group plc. Company Registration Number - 2280426.
    England.

    Registered Office: Churchill Court, Westmoreland Road, Bromley, Kent BR1
    1DP.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
  • Graeme Farmer at Jun 29, 2004 at 5:37 am
    It is not essential to have a listener.ora, provided you want to have the
    listener run on the default port (1521) it will start up without a config
    file.

    HOWEVER, that would NOT be a good idea as changing from the default port is
    mandatory from a security perspective, as is setting a password, admin
    restrictions, etc, etc...

    When using a non-default port, then automatic listener registration is only
    possible via the LOCAL_LISTENER parameter in (s)pfile. This can be set to a
    TNS alias that resolves to the correct host/port combination or you can
    enter a connect descriptor; and, as Ray pointed out, the listener needs to
    be started prior to any registration or indeed listening taking place!

    Cheers,
    gf

    -----Original Message-----
    From: Feighery Raymond
    Sent: Tuesday, 29 June 2004 6:14 PM
    To: 'oracle-l_at_freelists.org'
    Subject: RE: spfile/listener question

    You haven't started the listener.
    Dynamic registration via the init.ora file means you don't have to modify
    the listener.ora for each new database entry (e.g. you don't have to add an
    extra SID_LIST entry). However, you still have to define the LISTENER in the
    listener.ora for the listener itself and start it.

    Ray

    -----Original Message-----
    From: Scott.Shafer_at_dcpds.cpms.osd.mil

    Sent: Monday, June 28, 2004 6:31 PM
    To: oracle-l_at_freelists.org
    Subject: spfile/listener question

    Odd question time:
    RTFM'd until we're blue, but we can't get the listener services to register
    when specified in the init.ora vs a listener.ora file. HR Apps 11.5.7 on
    Oracle 9.2.0.5, HPUX 11.11.

    We're trying to set the listener in the init.ora/spfile using the
    parameters:
    LOCAL_LISTENER=db1
    SERVICE_NAMES=db1.us.acme.com
    INSTANCE_NAME=db1

    tnsnames.ora entry looks like:
    db1= (DESCRIPTION= (ADDRESS=(PROTOCOL=tcp)(HOST=dbserver)(PORT=1421)))

    As SYSDBA we've done the:
    ALTER SYSTEM SET LOCAL_LISTENER='db1'

    When we check the listener via lsnrctl we can not detect the services.
    $TNS_ADMIN is set correctly.

    LSNRCTL> set current_listener db1
    LSNRCTL> services
    Connecting to (ADDRESS=(PROTOCOL=TCP)(HOST=xxx.xxx.xxx.xxx)(PORT=1421))
    TNS-12541: TNS:no listener
    TNS-12560: TNS:protocol adapter error
    TNS-00511: No listener
    HPUX Error: 239: Connection refused

    Anyone out there gone through this exercise successfully?

    Thanks,

    Scott

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org put
    'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html

    This email and any attached to it are confidential and intended only for the
    individual or entity to which it is addressed. If you are not the intended
    recipient, please let us know by telephoning or emailing the sender. You
    should also delete the email and any attachment from your systems and should
    not copy the email or any attachment or disclose their content to any other
    person or entity. The views expressed here are not necessarily those of
    Churchill Insurance Group plc or its affiliates or subsidiaries. Thank you.

    Churchill Insurance Group plc. Company Registration Number - 2280426.
    England.

    Registered Office: Churchill Court, Westmoreland Road, Bromley, Kent BR1
    1DP.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html

    --
    This transmission is for the intended addressee only and is confidential information. If you have received this transmission in error, please notify the sender and delete the transmission. The contents of this e-mail are the opinion of the writer only and are not endorsed by the Mincom Group of companies unless expressly stated otherwise.

    Please see the official ORACLE-L FAQ: http://www.orafaq.com

    To unsubscribe send email to: oracle-l-request_at_freelists.org
    put 'unsubscribe' in the subject line.
    --
    Archives are at http://www.freelists.org/archives/oracle-l/
    FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedJun 28, '04 at 12:24p
activeJun 29, '04 at 5:37a
posts16
users7
websiteoracle.com

People

Translate

site design / logo © 2022 Grokbase