FAQ
When the French characters are loaded properly, are you setting NLS_LANG to
FRANCE_FRENCH.UTF8, or are you using a different character set?

Justin Cave
At 01:39 PM 1/2/2004, jaysingh1_at_optonline.net wrote:
Dear All,

Happy New Year!

I have to load both French and Japanese characters from the same datafile
into tables using SQL*loader.

DB character set is UTF8 (version 8.1.7.3)
Client : Unix (Sun Solaris)

If I set NLS_LANG=AMERICAN_AMERICA.UTF8 then French characters are NOT
getting
loaded properly(garbled-> non-readable format) but Japanese characters are
getting loaded without any problem.

If I set NLS_LANG=French then French characters are getting loaded
properly( no
garbled issue) but Japanese characters are NOT getting loaded(garbled).

French Data
===========
Laforêt
François
modèle
démineur

Japanase Data
===============
絞り込�履歴
絞り込��設定

I copied sample FRENCH & JAPANESE characters above.
Even here in BROWSER,
(A)if the BROWSER Encoding (please select View->Encoding) is set to
Unicode(UTF-8)then Japanese Data (characters) are in READABLE format.

(B)if the BROWSER Encoding (please select View->Encoding) is set to Wester
European(ISO),then French Data (characters) are in READABLE format.

Questions:
==========
1)Why french characters are not getting loaded properly when I set
NLS_LANG=AMERICAN_AMEICA.UTF8
2)How do I load mutiple langauges content from the same datafile into db
table.

Kindly through some light on this?

Thanks for your time.
Jay

--
Please see the official ORACLE-L FAQ: http://www.orafaq.net
--
Author:
INET: jaysingh1_at_optonline.net

Fat City Network Services -- 858-538-5051 http://www.fatcity.com
San Diego, California -- Mailing list and web hosting services
---------------------------------------------------------------------
To REMOVE yourself from this mailing list, send an E-Mail message
to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
the message BODY, include a line containing: UNSUB ORACLE-L
(or the name of mailing list you want to be removed from). You may
also send the HELP command for other information (like subscribing).
--
Please see the official ORACLE-L FAQ: http://www.orafaq.net
--
Author: Justin Cave
INET: jcave_at_cableone.net

Fat City Network Services -- 858-538-5051 http://www.fatcity.com
San Diego, California -- Mailing list and web hosting services
---------------------------------------------------------------------
To REMOVE yourself from this mailing list, send an E-Mail message
to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
the message BODY, include a line containing: UNSUB ORACLE-L
(or the name of mailing list you want to be removed from). You may
also send the HELP command for other information (like subscribing).

Search Discussions

  • Sami at Jan 3, 2004 at 3:09 am
    Justin,Thanks for your reply.
    When the French characters are loaded properl I did set NLS_LANG=French

    -----Original Message-----
    Justin Cave
    Sent: Friday, January 02, 2004 7:14 PM
    To: Multiple recipients of list ORACLE-L

    When the French characters are loaded properly, are you setting NLS_LANG to
    FRANCE_FRENCH.UTF8, or are you using a different character set?

    Justin Cave
    At 01:39 PM 1/2/2004, jaysingh1_at_optonline.net wrote:
    Dear All,

    Happy New Year!

    I have to load both French and Japanese characters from the same datafile
    into tables using SQL*loader.

    DB character set is UTF8 (version 8.1.7.3)
    Client : Unix (Sun Solaris)

    If I set NLS_LANG=AMERICAN_AMERICA.UTF8 then French characters are NOT
    getting
    loaded properly(garbled-> non-readable format) but Japanese characters are
    getting loaded without any problem.

    If I set NLS_LANG=French then French characters are getting loaded
    properly( no
    garbled issue) but Japanese characters are NOT getting loaded(garbled).

    French Data
    ===========
    Laforêt
    François
    modèle
    démineur

    Japanase Data
    ===============
    絞り込�履歴
    絞り込��設定

    I copied sample FRENCH & JAPANESE characters above.
    Even here in BROWSER,
    (A)if the BROWSER Encoding (please select View->Encoding) is set to
    Unicode(UTF-8)then Japanese Data (characters) are in READABLE format.

    (B)if the BROWSER Encoding (please select View->Encoding) is set to Wester
    European(ISO),then French Data (characters) are in READABLE format.

    Questions:
    ==========
    1)Why french characters are not getting loaded properly when I set
    NLS_LANG=AMERICAN_AMEICA.UTF8
    2)How do I load mutiple langauges content from the same datafile into db
    table.

    Kindly through some light on this?

    Thanks for your time.
    Jay

    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author:
    INET: jaysingh1_at_optonline.net

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).
    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author: Justin Cave
    INET: jcave_at_cableone.net

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).

    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author: Sami
    INET: jaysingh1_at_optonline.net

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).
  • Justin Cave at Jan 3, 2004 at 4:04 am
    Did you set it just to French, or did you specify a particular character set?

     From the symptoms you're describing, it sounds like your data file has
    problems. The French characters may be encoded using a different character
    set than the Japanese characters. If you want to load the file, you'll
    have to ensure that everything is encoded with the same character set.

    Justin Cave
    At 08:09 PM 1/2/2004, Sami wrote:
    Justin,Thanks for your reply.
    When the French characters are loaded properl I did set NLS_LANG=French

    -----Original Message-----
    Justin Cave
    Sent: Friday, January 02, 2004 7:14 PM
    To: Multiple recipients of list ORACLE-L


    When the French characters are loaded properly, are you setting NLS_LANG to
    FRANCE_FRENCH.UTF8, or are you using a different character set?

    Justin Cave
    At 01:39 PM 1/2/2004, jaysingh1_at_optonline.net wrote:
    Dear All,

    Happy New Year!

    I have to load both French and Japanese characters from the same datafile
    into tables using SQL*loader.

    DB character set is UTF8 (version 8.1.7.3)
    Client : Unix (Sun Solaris)

    If I set NLS_LANG=AMERICAN_AMERICA.UTF8 then French characters are NOT
    getting
    loaded properly(garbled-> non-readable format) but Japanese characters are
    getting loaded without any problem.

    If I set NLS_LANG=French then French characters are getting loaded
    properly( no
    garbled issue) but Japanese characters are NOT getting loaded(garbled).

    French Data
    ===========
    Laforêt
    François
    modèle
    démineur

    Japanase Data
    ===============
    絞り込�履歴
    絞り込��設定

    I copied sample FRENCH & JAPANESE characters above.
    Even here in BROWSER,
    (A)if the BROWSER Encoding (please select View->Encoding) is set to
    Unicode(UTF-8)then Japanese Data (characters) are in READABLE format.

    (B)if the BROWSER Encoding (please select View->Encoding) is set to Wester
    European(ISO),then French Data (characters) are in READABLE format.

    Questions:
    ==========
    1)Why french characters are not getting loaded properly when I set
    NLS_LANG=AMERICAN_AMEICA.UTF8
    2)How do I load mutiple langauges content from the same datafile into db
    table.

    Kindly through some light on this?

    Thanks for your time.
    Jay

    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author:
    INET: jaysingh1_at_optonline.net

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).
    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author: Justin Cave
    INET: jcave_at_cableone.net

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).

    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author: Sami
    INET: jaysingh1_at_optonline.net

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).
    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author: Justin Cave
    INET: jcave_at_cableone.net

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedJan 3, '04 at 12:14a
activeJan 3, '04 at 4:04a
posts3
users2
websiteoracle.com

2 users in discussion

Justin Cave: 2 posts Sami: 1 post

People

Translate

site design / logo © 2022 Grokbase