FAQ
I'm hoping for expert assistance. I'm using SQL*Loader to load some
2200+ records (comma delimited) into a table and running into this
problem for the modcnt field:

The control file reads:

modcnt DECIMAL EXTERNAL <-- I'm sure this is where my problem is. I have
tried almost every datatype that the control file will accept - some
bleed into the next column which is a date field, messing up that
column, etc with ORA-01841 (full) year must be between -4713 and +9999,
and not be 0.

The datatype in the table is:

MODCNT NUMBER <-- no precision defined

The value in the file for this field is always 0. And when I start to
load the file, I receive this error (I'm testing with a few random
records from the 2200+ and each have the same error):

Record 1: Rejected - Error on table LC_F, column MODCNT.
ORA-01722: invalid number

Any help is greatly appreciated. Thanks,
Saira

--
Please see the official ORACLE-L FAQ: http://www.orafaq.net
--
Author: Saira Somani-Mendelin
INET: [EMAIL PROTECTED]

Fat City Network Services -- 858-538-5051 http://www.fatcity.com
San Diego, California -- Mailing list and web hosting services
---------------------------------------------------------------------

To REMOVE yourself from this mailing list, send an E-Mail message
to: [EMAIL PROTECTED] (note EXACT spelling of 'ListGuru') and in
the message BODY, include a line containing: UNSUB ORACLE-L
(or the name of mailing list you want to be removed from). You may
also send the HELP command for other information (like subscribing).

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedJul 10, '03 at 5:41p
activeJul 10, '03 at 5:41p
posts1
users1
websiteoracle.com

1 user in discussion

Saira Somani-Mendelin: 1 post

People

Translate

site design / logo © 2022 Grokbase