FAQ
My scenario

Fresh install of w2k server, sp 3 high end machine, twin 2G processers
4G ram ...
Installed Oracle 8.17 release 3, Install went perfectly smooth
built 9 databases connected and imported all data I could connect at
will ... All was well

The problem:
when the machine reboots, the service and database does not start
automatically.If I try to
sqlplus user/pass_at_instance
I get the
"Oracle not available", "shared realm does not exist" (in other words
the dbs did not start)

I can start manually using
startdb.bat
svrmgrl.exe command='@C:\db_startup\initdb8i.sql'

initdb8i.sql
connect internal/pass_at_db8i
startup pfile=R:\OR_8I\ADMIN\DB8I\pfile\init.ora
exit

The instance starts and all is well

####################################################

Ive deleted all the services using Oradim and rebooted, then recreated
using

rem D:\install\setODIM.bat
set db=someinstance
sleep 1
ORADIM -DELETE -SID %db%
sleep 2
ORADIM -NEW -SID %db% -INTPWD passwd -STARTMODE auto -PFILE
D:\OraHome1\admin\%db%\PFILE\init%db%.ora -TIMEOUT 90
sleep 2
ORADIM -SHUTDOWN -SID %db% -USRPWD passwd -SHUTTYPE srvc,inst -SHUTMODE
i
sleep 2
ORADIM -STARTUP -SID %db% -USRPWD passwd -STARTTYPE srvc,inst -PFILE
D:\OraHome1\admin\%db%\PFILE\init%db%.ora
echo off
echo.
echo Done creating oradim entries for %db% !

If I create one service, using the above batch file I can connect to
the database,
eg ORADIM -STARTUP -SID %db% -USRPWD passwd -STARTTYPE srvc,inst -PFILE
D:\OraHome1\admin\%db%\PFILE\init%db%.ora
but when the machine reboots and I try to connect I get the oracle not
available

here are my registry settings
http://209.123.6.84/srvreg.jpg

This is very frustrating as I had this problem on a server that had the
OS upgraded and I could never get the autostart working correctly
This is a new machine and I can reboot at will or make any changes (no
one is using this server yet) so I really need to get this working.

I am at a loss... any suggestions would be appreciated

thanks
bob
--
Please see the official ORACLE-L FAQ: http://www.orafaq.net
--
Author: Bob Metelsky
INET: bmetelsky_at_cps92.com

Fat City Network Services -- 858-538-5051 http://www.fatcity.com
San Diego, California -- Mailing list and web hosting services
---------------------------------------------------------------------

To REMOVE yourself from this mailing list, send an E-Mail message
to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
the message BODY, include a line containing: UNSUB ORACLE-L
(or the name of mailing list you want to be removed from). You may
also send the HELP command for other information (like subscribing).

Search Discussions

  • Jared Still at Jan 21, 2003 at 2:49 am
    Have you checked the event logs?

    Also take a look at Doc # 136214.1 on MetaLink.

    Jared
    On Monday 20 January 2003 13:46, Bob Metelsky wrote:
    My scenario

    Fresh install of w2k server, sp 3 high end machine, twin 2G processers
    4G ram ...
    Installed Oracle 8.17 release 3, Install went perfectly smooth
    built 9 databases connected and imported all data I could connect at
    will ... All was well

    The problem:
    when the machine reboots, the service and database does not start
    automatically.If I try to
    sqlplus user/pass_at_instance
    I get the
    "Oracle not available", "shared realm does not exist" (in other words
    the dbs did not start)

    I can start manually using
    startdb.bat
    svrmgrl.exe command='@C:\db_startup\initdb8i.sql'

    initdb8i.sql
    connect internal/pass_at_db8i
    startup pfile=R:\OR_8I\ADMIN\DB8I\pfile\init.ora
    exit

    The instance starts and all is well
    ####################################################

    Ive deleted all the services using Oradim and rebooted, then recreated
    using

    rem D:\install\setODIM.bat
    set db=someinstance
    sleep 1
    ORADIM -DELETE -SID %db%
    sleep 2
    ORADIM -NEW -SID %db% -INTPWD passwd -STARTMODE auto -PFILE
    D:\OraHome1\admin\%db%\PFILE\init%db%.ora -TIMEOUT 90
    sleep 2
    ORADIM -SHUTDOWN -SID %db% -USRPWD passwd -SHUTTYPE srvc,inst -SHUTMODE
    i
    sleep 2
    ORADIM -STARTUP -SID %db% -USRPWD passwd -STARTTYPE srvc,inst -PFILE
    D:\OraHome1\admin\%db%\PFILE\init%db%.ora
    echo off
    echo.
    echo Done creating oradim entries for %db% !

    If I create one service, using the above batch file I can connect to
    the database,
    eg ORADIM -STARTUP -SID %db% -USRPWD passwd -STARTTYPE srvc,inst -PFILE
    D:\OraHome1\admin\%db%\PFILE\init%db%.ora
    but when the machine reboots and I try to connect I get the oracle not
    available

    here are my registry settings
    http://209.123.6.84/srvreg.jpg

    This is very frustrating as I had this problem on a server that had the
    OS upgraded and I could never get the autostart working correctly
    This is a new machine and I can reboot at will or make any changes (no
    one is using this server yet) so I really need to get this working.

    I am at a loss... any suggestions would be appreciated

    thanks
    bob
    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author: Jared Still
    INET: jkstill_at_cybcon.com

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).
  • Bob Metelsky at Jan 21, 2003 at 3:34 pm
    You're the man Jared....!

    The doc you referred me to 136214.1, referered to a patch 1522966 which
    basically has you
    Stop all services/instances
    Rename %Oracle_Home%\bin\orannts8.dll to orannts8.dll.bad
    Then copy over the new orannts8.dll that's provided in the patch
    Reboot

    All my instances are auto starting!

    Many thanks

    bob
    Also take a look at Doc # 136214.1 on MetaLink.

    Jared
    On Monday 20 January 2003 13:46, Bob Metelsky wrote:
    My scenario

    Fresh install of w2k server, sp 3 high end machine, twin 2G
    processers
    4G ram ... Installed Oracle 8.17 release 3, Install went perfectly
    smooth built 9 databases connected and imported all data I could
    connect at will ... All was well

    The problem:
    when the machine reboots, the service and database does not start
    automatically.If I try to sqlplus user/pass_at_instance
    I get the
    "Oracle not available", "shared realm does not exist" (in
    other words
    the dbs did not start)

    I can start manually using
    startdb.bat
    svrmgrl.exe command='@C:\db_startup\initdb8i.sql'

    initdb8i.sql
    connect internal/pass_at_db8i
    startup pfile=R:\OR_8I\ADMIN\DB8I\pfile\init.ora
    exit

    The instance starts and all is well
    ####################################################

    Ive deleted all the services using Oradim and rebooted,
    then recreated
    using

    rem D:\install\setODIM.bat
    set db=someinstance
    sleep 1
    ORADIM -DELETE -SID %db%
    sleep 2
    ORADIM -NEW -SID %db% -INTPWD passwd -STARTMODE auto -PFILE
    D:\OraHome1\admin\%db%\PFILE\init%db%.ora -TIMEOUT 90 sleep 2
    ORADIM -SHUTDOWN -SID %db% -USRPWD passwd -SHUTTYPE
    srvc,inst -SHUTMODE
    i
    sleep 2
    ORADIM -STARTUP -SID %db% -USRPWD passwd -STARTTYPE srvc,inst -PFILE
    D:\OraHome1\admin\%db%\PFILE\init%db%.ora
    echo off
    echo.
    echo Done creating oradim entries for %db% !

    If I create one service, using the above batch file I can
    connect to
    the database, eg ORADIM -STARTUP -SID %db% -USRPWD passwd
    -STARTTYPE
    srvc,inst -PFILE D:\OraHome1\admin\%db%\PFILE\init%db%.ora
    but when the machine reboots and I try to connect I get the
    oracle not
    available

    here are my registry settings
    http://209.123.6.84/srvreg.jpg

    This is very frustrating as I had this problem on a server that had
    the OS upgraded and I could never get the autostart working correctly
    This is a new machine and I can reboot at will or make any
    changes (no
    one is using this server yet) so I really need to get this working.

    I am at a loss... any suggestions would be appreciated

    thanks
    bob
    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author: Jared Still
    INET: jkstill_at_cybcon.com

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru')
    and in the message BODY, include a line containing: UNSUB
    ORACLE-L (or the name of mailing list you want to be removed
    from). You may also send the HELP command for other
    information (like subscribing).
    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.net
    --
    Author: Bob Metelsky
    INET: bmetelsky_at_cps92.com

    Fat City Network Services -- 858-538-5051 http://www.fatcity.com
    San Diego, California -- Mailing list and web hosting services
    ---------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedJan 20, '03 at 9:46p
activeJan 21, '03 at 3:34p
posts3
users2
websiteoracle.com

2 users in discussion

Bob Metelsky: 2 posts Jared Still: 1 post

People

Translate

site design / logo © 2022 Grokbase