FAQ
I am trying to alternate host to a point in time of 01-01-2002.
I restore current controlfile then run
run {
set until time "to_date('01-JAN-2002 03:00:01','DD-MON-YYYY HH24:MI:SS')";
allocate channel ch1 type 'sbt_tape';restore database;
recover database;
}

The netbackup log asks for a cold backup tape from 29-dec-01, restores that
data (if i resetlogs its is fine), then proceeds to ask for a group of
archivelogs and fails with failed to retrieve handle "al_6548_1_450965598'
Backup file not found.
When I look in the logs it is not asking for a tape like it did with the
first part(cold backup) and when i look at rc_backup_piece this handle is
pointing to a media that has been reused.
But we did a 2 weekly redo log backup on the 12-jab-02 and clear which went
to another tape that is still available. When i crosscheck
rc_backup_redolog I see that there are various tapes for that
sequence#(which i presume is the log file number), but how do we get rman
to look at the other tape ?
and why does it not ask for any tape in the logs when it wants the
archivelogs ? This whole process is very confusing and piss*** me off no
end. There's a pint for anyome who can help me here.
I'd be interested to know also how internally rman manages which tapes to
use for restore. In theory the same arcgive logs are on many different
tapes, so how does it decide which one to use ?
Im RTFM'ing as well
thanks

Sam

--
Please see the official ORACLE-L FAQ: http://www.orafaq.com
--
Author:
INET: rabbit_at_emirates.net.ae

Fat City Network Services -- (858) 538-5051 FAX: (858) 538-5051
San Diego, California -- Public Internet access / Mailing Lists
--------------------------------------------------------------------

To REMOVE yourself from this mailing list, send an E-Mail message
to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
the message BODY, include a line containing: UNSUB ORACLE-L
(or the name of mailing list you want to be removed from). You may
also send the HELP command for other information (like subscribing).

Search Discussions

  • Yechiel Adar at Jun 24, 2002 at 2:48 pm
    Hello Sam

    Why do not restore the archive logs manually?
    Ask RMAN to restore the database and then issue
    the recover until yourself.
    Then you have time to explore RMAN behavior.

    BTW - did you backup the 2 weekly archive logs with RMAN
    or was it a separate netbackup file backup?

    Yechiel Adar
    Mehish
    ----- Original Message -----
    To: Multiple recipients of list ORACLE-L
    Sent: Monday, June 24, 2002 1:38 PM
    I am trying to alternate host to a point in time of 01-01-2002.
    I restore current controlfile then run
    run {
    set until time "to_date('01-JAN-2002 03:00:01','DD-MON-YYYY
    HH24:MI:SS')";
    allocate channel ch1 type 'sbt_tape';restore database;
    recover database;
    }

    The netbackup log asks for a cold backup tape from 29-dec-01, restores that
    data (if i resetlogs its is fine), then proceeds to ask for a group of
    archivelogs and fails with failed to retrieve handle "al_6548_1_450965598'
    Backup file not found.
    When I look in the logs it is not asking for a tape like it did with the
    first part(cold backup) and when i look at rc_backup_piece this handle is
    pointing to a media that has been reused.
    But we did a 2 weekly redo log backup on the 12-jab-02 and clear which went
    to another tape that is still available. When i crosscheck
    rc_backup_redolog I see that there are various tapes for that
    sequence#(which i presume is the log file number), but how do we get rman
    to look at the other tape ?
    and why does it not ask for any tape in the logs when it wants the
    archivelogs ? This whole process is very confusing and piss*** me off no
    end. There's a pint for anyome who can help me here.
    I'd be interested to know also how internally rman manages which tapes to
    use for restore. In theory the same arcgive logs are on many different
    tapes, so how does it decide which one to use ?
    Im RTFM'ing as well
    thanks

    Sam



    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    --
    Author:
    INET: rabbit_at_emirates.net.ae

    Fat City Network Services -- (858) 538-5051 FAX: (858) 538-5051
    San Diego, California -- Public Internet access / Mailing Lists
    --------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).
    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    --
    Author: Yechiel Adar
    INET: adar76_at_inter.net.il

    Fat City Network Services -- (858) 538-5051 FAX: (858) 538-5051
    San Diego, California -- Public Internet access / Mailing Lists
    --------------------------------------------------------------------
    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).
  • Rabbit_at_emirates.net.ae at Jun 25, 2002 at 8:13 am
    Thanks for reply:
    I tried to restore the archivelogs on their own and it still asks for a
    backup piece thats on a tape that has been scratched.
    I looked at rc_backup_redolog and see lots of entries for the particular
    archive log.The last entry (in date order) points to a backup_set that is
    on the scratched tape. The second last entry points to a backup set that is
    on the tape that we have in the library. Im guessing that RMAN looks at the
    last entry and figures that this job backed it up and deleted it and
    therefore it is this tape. What I want to know is how I can get the
    archivelogs to be restored from the previous tape. Im probably going to
    raise a tar now.
    I can see in the logs that our bi weekly backup and delete all archivelogs
    ran on the 11/jan/2001 - yet these particular archive logs were backed up
    again the day after. Very strange behaviour yet could explain why RMAN is
    pointing to wrong tape.
    I always suspected RMAN was to easy to not be problematic
    Sam

    --
    Please see the official ORACLE-L FAQ: http://www.orafaq.com
    --
    Author:
    INET: rabbit_at_emirates.net.ae

    Fat City Network Services -- (858) 538-5051 FAX: (858) 538-5051
    San Diego, California -- Public Internet access / Mailing Lists
    --------------------------------------------------------------------

    To REMOVE yourself from this mailing list, send an E-Mail message
    to: ListGuru_at_fatcity.com (note EXACT spelling of 'ListGuru') and in
    the message BODY, include a line containing: UNSUB ORACLE-L
    (or the name of mailing list you want to be removed from). You may
    also send the HELP command for other information (like subscribing).

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedJun 24, '02 at 11:38a
activeJun 25, '02 at 8:13a
posts3
users2
websiteoracle.com

People

Translate

site design / logo © 2022 Grokbase