FAQ
I'm troubleshooting a discrepancy between v$session_wait and Precise/SQL 3.1.  Oracle reports that sessions waiting on "SQL*Net message from client" but the tool shows some of them in MTS wait.  Since Precise/SQL parses the SGA for its data I'm looking into a systemstate dump.  The only link I have found is that the circuit session object have "flag = (10100)" and "flag = (10130)".  The circuits with 10130 are tied to the sessions that are misreported by the tool.  While I'm waiting for tech. support to respond any nuggets you can provide will be greatly appreciated.

Thanks.

Tony Aponte

Environment:

Sun Solaris 8

Oracle 8.1.7.2

5/50 MTS dispatchers/servers

Partial system state dump:

PROCESS 62:

----------------------------------------

SO: ceaef290, type: 1, owner: 0, pt: 0, flag: INIT/-/-/0x00

(process) Oracle pid=62, calls cur/top: 0/d0aab070, flag: (40) DISPATCHER

int error: 0, call error: 0, sess error: 0, txn error 0

(post info) last post received: 0 0 118

last post received-location: kmcpdp

last process to post me: ceae53fc 1 32

last post sent: 2147544044 0 111

last post sent-location: kmcmbf: not KMCVCFTOS

last process posted by me: ceae53fc 1 32

(latch info) wait_event=0 bits=0

Process Group: DEFAULT, pseudo proc: ceba58e4

O/S info: user: oracle, term: UNKNOWN, ospid: 6500

OSD pid info: 6500

----------------------------------------

SO: d08991f4, type: 41, owner: ceaef290, pt: 0, flag: INIT/-/-/0x00

(circuit) dispatcher process id = (ceaef290, 1)

parent process id = (62, 1)

user session id = (152, 28431)

connection context = 1a3c454

user session = (cebf98fc), flag = (10100), queue = (8)   <===== The flag is on this line.

current buffer = (1), status = (0, 0)

----------------------------------------

SO: cebf98fc, type: 3, owner: d08991f4, pt: 0, flag: INIT/-/-/0x00

(session) trans: 0, creator: d08991f4, flag: (80000e1) USR/- -/-/-/-/-/-

DID: 0001-000B-00000A09, short-term DID: 0000-0000-00000000

txn branch: 0

oct: 0, prv: 0, user: 17178/CRUZDO

O/S info: user: CRUZD, term: OMSCTX10, ospid: 4040:3800, machine: STPETE\OMSCTX10

program: siebel.exe

waiting for 'SQL*Net message from client' blocking sess=0x0 seq=1017 wait_time=0

driver id=4d545300, #bytes=1, =0

----------------------------------------

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouporacle-l @
categoriesoracle
postedDec 10, '01 at 10:32p
activeDec 10, '01 at 10:32p
posts1
users1
websiteoracle.com

1 user in discussion

Aponte, Tony: 1 post

People

Translate

site design / logo © 2022 Grokbase