FAQ
I was trying to get the wordpress sample running on AWS following
deploying-sample-release.md<https://github.com/drnic/bosh-getting-started/blob/master/deploying-sample-release.md>,
and ran into networking problems between nginx and wordpress/apache. I
fixed it by indicating the elastic IP public DNS name in the jobs
properties instead of the straight ip addresses. More details below if this
can be useful to others. Anyone managed to workaround this problem
differently to get the wordpress sample serving webpages on AWS ?


Given that the VMs are all created before starting applying the
configuration to them, it would be great to be able to avoid need for
elastic IPs and rather use private DNS entries: is there properties or
variables that could be used in the nginx configuration templates to lookup
the private IP DNS allocated to other jobs? Is the PowerDNS mentionned by
nic
<https://groups.google.com/a/cloudfoundry.org/forum/?fromgroups#%21search/powerdns/bosh-dev/jgk0gsXVFjY/KXA7mAquP6kJ>ready
and could be used instead to define private DNS entries for the network
wiring among the jobs ?

I guess that when provisioning the wordpress sample<https://github.com/cloudfoundry/oss-docs/blob/master/bosh/samples/wordpress.yml>in vSphere there is no such need because the private IP can be statically
be assigned to instances and be specified within the deployment manifest.
Moreover, in CF, there is little such hardcoded wiring as most declare into
nats.

Guillaume.

----


With the configuration suggested in deploying-sample-release.md<https://github.com/drnic/bosh-getting-started/blob/master/deploying-sample-release.md>,
the nginx configuration uses the elastic ip public address (e.g.
176.34.183.210) instead of the elastic IP public DNS entry
(ec2-176-34-183-210.eu-west-1.compute.amazonaws.com) which resolves within
AWS to the private IP (see details<http://docs.amazonwebservices.com/AWSEC2/latest/UserGuide/using-instance-addressing.html>
)

<% properties.wordpress.servers.each do |server| %>

server <%= server %>:<%= properties.wordpress.port %>;

<% end %>

It did not not work as my nginx instance couldn’t ping the wordpress
instance public elastic ip (whereas it properly pings elastic IP public
DNS).

Search Discussions

  • Shane Witbeck at Nov 8, 2012 at 1:37 am
    +1. I'm trying to run the wordpress sample and running into the max of 5
    elastic ip threshold.

    What's the latest on this?
    On Thursday, July 26, 2012 8:11:37 PM UTC-4, Guillaume Berche wrote:

    I was trying to get the wordpress sample running on AWS following
    deploying-sample-release.md<https://github.com/drnic/bosh-getting-started/blob/master/deploying-sample-release.md>,
    and ran into networking problems between nginx and wordpress/apache. I
    fixed it by indicating the elastic IP public DNS name in the jobs
    properties instead of the straight ip addresses. More details below if this
    can be useful to others. Anyone managed to workaround this problem
    differently to get the wordpress sample serving webpages on AWS ?


    Given that the VMs are all created before starting applying the
    configuration to them, it would be great to be able to avoid need for
    elastic IPs and rather use private DNS entries: is there properties or
    variables that could be used in the nginx configuration templates to lookup
    the private IP DNS allocated to other jobs? Is the PowerDNS mentionned by
    nic
    <https://groups.google.com/a/cloudfoundry.org/forum/?fromgroups#%21search/powerdns/bosh-dev/jgk0gsXVFjY/KXA7mAquP6kJ>ready
    and could be used instead to define private DNS entries for the network
    wiring among the jobs ?

    I guess that when provisioning the wordpress sample<https://github.com/cloudfoundry/oss-docs/blob/master/bosh/samples/wordpress.yml>in vSphere there is no such need because the private IP can be statically
    be assigned to instances and be specified within the deployment manifest.
    Moreover, in CF, there is little such hardcoded wiring as most declare into
    nats.

    Guillaume.

    ----


    With the configuration suggested in deploying-sample-release.md<https://github.com/drnic/bosh-getting-started/blob/master/deploying-sample-release.md>,
    the nginx configuration uses the elastic ip public address (e.g.
    176.34.183.210) instead of the elastic IP public DNS entry (
    ec2-176-34-183-210.eu-west-1.compute.amazonaws.com) which resolves within
    AWS to the private IP (see details<http://docs.amazonwebservices.com/AWSEC2/latest/UserGuide/using-instance-addressing.html>
    )

    <% properties.wordpress.servers.each do |server| %>

    server <%= server %>:<%= properties.wordpress.port %>;

    <% end %>

    It did not not work as my nginx instance couldn’t ping the wordpress
    instance public elastic ip (whereas it properly pings elastic IP public
    DNS).

  • Dr Nic Williams at Nov 8, 2012 at 5:17 pm
    There is a new microbosh and stemcell that will support an internal DNS. Martin is working on it. From his description it will be awesome.

    Every job/VM will automatically have a DNS registry that you can use within your properties/job templates, instead of static IPs. So you'll only need a static IP for inbound external networking.

    Off the top of my head, the job DNS will look something like:

    wordpress.2.default.mywordpressblog.bosh

    That is, jobname.index.networkname.deploymentname.bosh

    Cheers
    Nic


    Dr Nic Williams - VP Developer Evangelism
    Engine Yard
    The Leading Platform as a Service
    Mobile: +1 415 860 2185
    Skype: nicwilliams
    Twitter: @drnic

    On Wednesday, November 7, 2012 at 5:37 PM, Shane Witbeck wrote:

    +1. I'm trying to run the wordpress sample and running into the max of 5 elastic ip threshold.

    What's the latest on this?
    On Thursday, July 26, 2012 8:11:37 PM UTC-4, Guillaume Berche wrote:
    I was trying to get the wordpress sample running on AWS following deploying-sample-release.md (https://github.com/drnic/bosh-getting-started/blob/master/deploying-sample-release.md), and ran into networking problems between nginx and wordpress/apache. I fixed it by indicating the elastic IP public DNS name in the jobs properties instead of the straight ip addresses. More details below if this can be useful to others. Anyone managed to workaround this problem differently to get the wordpress sample serving webpages on AWS ?

    Given that the VMs are all created before starting applying the configuration to them, it would be great to be able to avoid need for elastic IPs and rather use private DNS entries: is there properties or variables that could be used in the nginx configuration templates to lookup the private IP DNS allocated to other jobs? Is the PowerDNS mentionned by nic (https://groups.google.com/a/cloudfoundry.org/forum/?fromgroups#%21search/powerdns/bosh-dev/jgk0gsXVFjY/KXA7mAquP6kJ)ready and could be used instead to define private DNS entries for the network wiring among the jobs ?
    I guess that when provisioning the wordpress sample (https://github.com/cloudfoundry/oss-docs/blob/master/bosh/samples/wordpress.yml) in vSphere there is no such need because the private IP can be statically be assigned to instances and be specified within the deployment manifest. Moreover, in CF, there is little such hardcoded wiring as most declare into nats.

    Guillaume.
    ----

    With the configuration suggested in deploying-sample-release.md (https://github.com/drnic/bosh-getting-started/blob/master/deploying-sample-release.md), the nginx configuration uses the elastic ip public address (e.g. 176.34.183.210) instead of the elastic IP public DNS entry (ec2-176-34-183-210.eu-west-1.compute.amazonaws.com (http://ec2-176-34-183-210.eu-west-1.compute.amazonaws.com)) which resolves within AWS to the private IP (see details (http://docs.amazonwebservices.com/AWSEC2/latest/UserGuide/using-instance-addressing.html))

    <% properties.wordpress.servers.each do |server| %>
    server <%= server %>:<%= properties.wordpress.port %>;
    <% end %>

    It did not not work as my nginx instance couldn’t ping the wordpress instance public elastic ip (whereas it properly pings elastic IP public DNS).

  • Martin Englund at Nov 8, 2012 at 7:20 pm
    I've published micro-bosh-stemcell-*-0.7.0.tgz (use "bosh public
    stemcells --tags all" to list them) and am testing it at the moment.
    What is missing is the stemcell you should be deploying your apps on -
    the latest doesn't have the wiring to setup dns:
    https://github.com/cloudfoundry/bosh/commit/b9d80dc

    You almost got the naming correct:
    index.jobname.networkname.deploymentname.bosh

    I'll post an update as soon as I have one :)

    Cheers,
    /Martin
    On Thu, Nov 8, 2012 at 9:16 AM, Dr Nic Williams wrote:
    There is a new microbosh and stemcell that will support an internal DNS.
    Martin is working on it. From his description it will be awesome.

    Every job/VM will automatically have a DNS registry that you can use within
    your properties/job templates, instead of static IPs. So you'll only need a
    static IP for inbound external networking.

    Off the top of my head, the job DNS will look something like:

    wordpress.2.default.mywordpressblog.bosh

    That is, jobname.index.networkname.deploymentname.bosh

    Cheers
    Nic


    Dr Nic Williams - VP Developer Evangelism
    Engine Yard
    The Leading Platform as a Service
    Mobile: +1 415 860 2185
    Skype: nicwilliams
    Twitter: @drnic

    On Wednesday, November 7, 2012 at 5:37 PM, Shane Witbeck wrote:

    +1. I'm trying to run the wordpress sample and running into the max of 5
    elastic ip threshold.

    What's the latest on this?

    On Thursday, July 26, 2012 8:11:37 PM UTC-4, Guillaume Berche wrote:

    I was trying to get the wordpress sample running on AWS following
    deploying-sample-release.md, and ran into networking problems between nginx
    and wordpress/apache. I fixed it by indicating the elastic IP public DNS
    name in the jobs properties instead of the straight ip addresses. More
    details below if this can be useful to others. Anyone managed to workaround
    this problem differently to get the wordpress sample serving webpages on AWS
    ?


    Given that the VMs are all created before starting applying the
    configuration to them, it would be great to be able to avoid need for
    elastic IPs and rather use private DNS entries: is there properties or
    variables that could be used in the nginx configuration templates to lookup
    the private IP DNS allocated to other jobs? Is the PowerDNS mentionned by
    nic ready and could be used instead to define private DNS entries for the
    network wiring among the jobs ?

    I guess that when provisioning the wordpress sample in vSphere there is no
    such need because the private IP can be statically be assigned to instances
    and be specified within the deployment manifest. Moreover, in CF, there is
    little such hardcoded wiring as most declare into nats.

    Guillaume.

    ----


    With the configuration suggested in deploying-sample-release.md, the nginx
    configuration uses the elastic ip public address (e.g. 176.34.183.210)
    instead of the elastic IP public DNS entry
    (ec2-176-34-183-210.eu-west-1.compute.amazonaws.com) which resolves within
    AWS to the private IP (see details)

    <% properties.wordpress.servers.each do |server| %>

    server <%= server %>:<%= properties.wordpress.port %>;

    <% end %>

    It did not not work as my nginx instance couldn’t ping the wordpress
    instance public elastic ip (whereas it properly pings elastic IP public
    DNS).




    --
    cheers,
    /Martin
    --
    Martin Englund, Staff Engineer, Cloud Foundry, VMware Inc.
    "The question is not if you are paranoid, it is if you are paranoid enough."
  • Shane Witbeck at Nov 8, 2012 at 8:50 pm
    Nic/Martin,

    Great. Thanks for the replies. I'll check out 0.7.0

    Shane
    On Thursday, November 8, 2012 2:20:53 PM UTC-5, Martin Englund wrote:

    I've published micro-bosh-stemcell-*-0.7.0.tgz (use "bosh public
    stemcells --tags all" to list them) and am testing it at the moment.
    What is missing is the stemcell you should be deploying your apps on -
    the latest doesn't have the wiring to setup dns:
    https://github.com/cloudfoundry/bosh/commit/b9d80dc

    You almost got the naming correct:
    index.jobname.networkname.deploymentname.bosh

    I'll post an update as soon as I have one :)

    Cheers,
    /Martin
    On Thu, Nov 8, 2012 at 9:16 AM, Dr Nic Williams wrote:
    There is a new microbosh and stemcell that will support an internal DNS.
    Martin is working on it. From his description it will be awesome.

    Every job/VM will automatically have a DNS registry that you can use within
    your properties/job templates, instead of static IPs. So you'll only need a
    static IP for inbound external networking.

    Off the top of my head, the job DNS will look something like:

    wordpress.2.default.mywordpressblog.bosh

    That is, jobname.index.networkname.deploymentname.bosh

    Cheers
    Nic


    Dr Nic Williams - VP Developer Evangelism
    Engine Yard
    The Leading Platform as a Service
    Mobile: +1 415 860 2185
    Skype: nicwilliams
    Twitter: @drnic

    On Wednesday, November 7, 2012 at 5:37 PM, Shane Witbeck wrote:

    +1. I'm trying to run the wordpress sample and running into the max of 5
    elastic ip threshold.

    What's the latest on this?

    On Thursday, July 26, 2012 8:11:37 PM UTC-4, Guillaume Berche wrote:

    I was trying to get the wordpress sample running on AWS following
    deploying-sample-release.md, and ran into networking problems between nginx
    and wordpress/apache. I fixed it by indicating the elastic IP public DNS
    name in the jobs properties instead of the straight ip addresses. More
    details below if this can be useful to others. Anyone managed to
    workaround
    this problem differently to get the wordpress sample serving webpages on AWS
    ?


    Given that the VMs are all created before starting applying the
    configuration to them, it would be great to be able to avoid need for
    elastic IPs and rather use private DNS entries: is there properties or
    variables that could be used in the nginx configuration templates to lookup
    the private IP DNS allocated to other jobs? Is the PowerDNS mentionned by
    nic ready and could be used instead to define private DNS entries for the
    network wiring among the jobs ?

    I guess that when provisioning the wordpress sample in vSphere there is no
    such need because the private IP can be statically be assigned to instances
    and be specified within the deployment manifest. Moreover, in CF, there is
    little such hardcoded wiring as most declare into nats.

    Guillaume.

    ----


    With the configuration suggested in deploying-sample-release.md, the nginx
    configuration uses the elastic ip public address (e.g. 176.34.183.210)
    instead of the elastic IP public DNS entry
    (ec2-176-34-183-210.eu-west-1.compute.amazonaws.com) which resolves within
    AWS to the private IP (see details)

    <% properties.wordpress.servers.each do |server| %>

    server <%= server %>:<%= properties.wordpress.port %>;

    <% end %>

    It did not not work as my nginx instance couldn’t ping the wordpress
    instance public elastic ip (whereas it properly pings elastic IP public
    DNS).




    --
    cheers,
    /Martin
    --
    Martin Englund, Staff Engineer, Cloud Foundry, VMware Inc.
    "The question is not if you are paranoid, it is if you are paranoid
    enough."

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupbosh-users @
postedJul 27, '12 at 12:11a
activeNov 8, '12 at 8:50p
posts5
users4

People

Translate

site design / logo © 2022 Grokbase