Show the output for

1. gem list
2. bosh help micro

- Pradeep
On Wednesday, January 30, 2013 3:54:29 AM UTC+5:30, Dhruv Kapil wrote:

Hi All,

I tried to install the micro bosh deployer by following the steps at the
below link. but i am getting the below errors when trying to run any micro
command, but other commands are working fine. In some commands, it is
asking me to set the Director target. Please see below.

I also tried to run "gem update --system" as well, but it says "Latest
version currently installed. Aborting."


ubuntu@ip-10-29-204-150:~/deployments$ bosh micro deployment aws
Cannot load plugins, please run `gem update --system' to update your
RubyGems
Unknown command: micro deployment aws

--------------------------------------------------------------------------------------------------------------------------------
ubuntu@ip-10-29-204-150:~/deployments$ gem update --system
Latest version currently installed. Aborting.

--------------------------------------------------------------------------------------------------------------------------------
ubuntu@ip-10-29-204-150:~/deployments$ bosh status
Cannot load plugins, please run `gem update --system' to update your
RubyGems
Director
not set

Deployment
not set

--------------------------------------------------------------------------------------------------------------------------------
ubuntu@ip-10-29-204-150:~/deployments$ bosh public stemcells
Cannot load plugins, please run `gem update --system' to update your
RubyGems
+---------------------------------------+------------------------+
Name | Tags |
+---------------------------------------+------------------------+
bosh-stemcell-aws-0.6.4.tgz | aws, stable |
bosh-stemcell-vsphere-0.6.4.tgz | vsphere, stable |
bosh-stemcell-vsphere-0.6.7.tgz | vsphere, stable |
micro-bosh-stemcell-aws-0.6.4.tgz | aws, micro, stable |
micro-bosh-stemcell-vsphere-0.6.4.tgz | vsphere, micro, stable |
+---------------------------------------+------------------------+
To download use `bosh download public stemcell <stemcell_name>'. For full
url use --full.


--------------------------------------------------------------------------------------------------------------------------------


Please let me know what could be the problem.

Search Discussions

  • Dhruv Kapil at Feb 28, 2013 at 5:56 am
    Hi Gary,

    Yes, We are able to deploy bosh & cf using bosh-bootstrap &
    bosh-cloudfoundry provided by Dr. Nic.
    Really appreciate your concern. Will get back to you in case of any issue.

    On 28 February 2013 02:25, ggross@rbcon.com wrote:

    Hi Dhruv, I believe you're beyond this point now, but if you need any
    additional information on this subject, please let me know and I will
    follow it up. Gary


    On Thursday, February 14, 2013 9:54:20 PM UTC-8, prince.p...@gmail.comwrote:
    Show the output for

    1. gem list
    2. bosh help micro

    - Pradeep
    On Wednesday, January 30, 2013 3:54:29 AM UTC+5:30, Dhruv Kapil wrote:

    Hi All,

    I tried to install the micro bosh deployer by following the steps at the
    below link. but i am getting the below errors when trying to run any micro
    command, but other commands are working fine. In some commands, it is
    asking me to set the Director target. Please see below.

    I also tried to run "gem update --system" as well, but it says "Latest
    version currently installed. Aborting."


    ubuntu@ip-10-29-204-150:~/**deployments$ bosh micro deployment aws
    Cannot load plugins, please run `gem update --system' to update your
    RubyGems
    Unknown command: micro deployment aws
    ------------------------------**------------------------------**
    ------------------------------**------------------------------**--------
    ubuntu@ip-10-29-204-150:~/**deployments$ gem update --system
    Latest version currently installed. Aborting.
    ------------------------------**------------------------------**
    ------------------------------**------------------------------**--------
    ubuntu@ip-10-29-204-150:~/**deployments$ bosh status
    Cannot load plugins, please run `gem update --system' to update your
    RubyGems
    Director
    not set

    Deployment
    not set
    ------------------------------**------------------------------**
    ------------------------------**------------------------------**--------
    ubuntu@ip-10-29-204-150:~/**deployments$ bosh public stemcells
    Cannot load plugins, please run `gem update --system' to update your
    RubyGems
    +-----------------------------**----------+-------------------**-----+
    Name | Tags |
    +-----------------------------**----------+-------------------**-----+
    bosh-stemcell-aws-0.6.4.tgz | aws, stable |
    bosh-stemcell-vsphere-0.6.4.**tgz | vsphere, stable |
    bosh-stemcell-vsphere-0.6.7.**tgz | vsphere, stable |
    micro-bosh-stemcell-aws-0.6.4.**tgz | aws, micro, stable |
    micro-bosh-stemcell-vsphere-0.**6.4.tgz | vsphere, micro, stable |
    +-----------------------------**----------+-------------------**-----+
    To download use `bosh download public stemcell <stemcell_name>'. For
    full url use --full.

    ------------------------------**------------------------------**
    ------------------------------**------------------------------**--------


    Please let me know what could be the problem.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupbosh-dev @
postedFeb 15, '13 at 5:54a
activeFeb 28, '13 at 5:56a
posts2
users2

2 users in discussion

Prince Pradeep 1: 1 post Dhruv Kapil: 1 post

People

Translate

site design / logo © 2021 Grokbase