FAQ
I am adding nodes with Cloudera Enterprise Trial 4.8.2 (#101 built by
jenkins on 20140226-1855 git: 8609801079d228f2440a493a3880ab68cad0524b) to
a single node cluster. Adding localhost to the cluster causes this error:

Installation failed. Failed to receive heartbeat from agent.

     Ensure that the host's hostname is configured properly.
     Ensure that port 7182 is accessible on the Cloudera Manager server
(check firewall rules).
     Ensure that ports 9000 and 9001 are free on the host being added.
     Check agent logs in /var/log/cloudera-scm-agent/ on the host being
added (some of the logs can be found in the installation details).

Im not sure how to fix this, but I have done so far:

Disabled all IP Tables rules:

chkconfig iptables --list
iptables 0:off 1:off 2:off 3:off 4:off 5:off 6:off

To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.

Search Discussions

  • Todd Grayson at Apr 3, 2014 at 9:16 pm
    asoto

    CM/CDH configuration mandates that we properly configure host FQDN and
    reverse lookup is working.

    run the following on your nodes both forward and reverse lookup should work

    python -c "import socket; print socket.getfqdn(); print
    socket.gethostbyname(socket.getfqdn())"

    also please verify your hosts file conforms to the discussion here:

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4_3_3_unique_1

    Also note with the parcels issue (and our discussion up to this point)

    With all the install/config/parcel issues you ran into for C5... were
    you installing new on fresh OS, or are you upgrading an older CM install?

    It should NOT be necessary for you to manually manipulate things in the
    parcels directory (you can delete them from the parcels UI).

    Thanks
    Todd
    On 4/3/14 2:05 PM, asoto wrote:
    I am adding nodes with Cloudera Enterprise Trial 4.8.2 (#101 built by
    jenkins on 20140226-1855 git:
    8609801079d228f2440a493a3880ab68cad0524b) to a single node cluster.
    Adding localhost to the cluster causes this error:

    Installation failed. Failed to receive heartbeat from agent.

    Ensure that the host's hostname is configured properly.
    Ensure that port 7182 is accessible on the Cloudera Manager server
    (check firewall rules).
    Ensure that ports 9000 and 9001 are free on the host being added.
    Check agent logs in /var/log/cloudera-scm-agent/ on the host being
    added (some of the logs can be found in the installation details).

    Im not sure how to fix this, but I have done so far:

    Disabled all IP Tables rules:

    chkconfig iptables --list
    iptables 0:off1:off2:off3:off4:off5:off6:off
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+unsubscribe@cloudera.org
    .

    --
    Todd Grayson
    Cloudera Support
    Customer Operations Engineering
    tgrayson@cloudera.com

    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Asoto at Apr 3, 2014 at 9:26 pm
    Todd,

    Thanks for the help so far.

    I have fixed this issue by manually editing the /etc/hosts file. The
    default file from a freshly installed CentOS does not work.

    Since you indicated that 6.5 was not supported, I started a new VM with
    CentOS 6.4 and still got into the whole parcel mess. How is it possible
    that I am getting CDH 4, in a brand new VM? Is it possible that the
    installer I downloaded from
    here http://www.cloudera.com/content/support/en/downloads.html is an old
    version?



    On Thursday, April 3, 2014 5:16:37 PM UTC-4, Todd Grayson wrote:

    asoto

    CM/CDH configuration mandates that we properly configure host FQDN and
    reverse lookup is working.

    run the following on your nodes both forward and reverse lookup should work

    python -c "import socket; print socket.getfqdn(); print
    socket.gethostbyname(socket.getfqdn())"

    also please verify your hosts file conforms to the discussion here:


    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4_3_3_unique_1

    Also note with the parcels issue (and our discussion up to this point)

    With all the install/config/parcel issues you ran into for C5... were you
    installing new on fresh OS, or are you upgrading an older CM install?

    It should NOT be necessary for you to manually manipulate things in the
    parcels directory (you can delete them from the parcels UI).

    Thanks
    Todd

    On 4/3/14 2:05 PM, asoto wrote:

    I am adding nodes with Cloudera Enterprise Trial 4.8.2 (#101 built by
    jenkins on 20140226-1855 git: 8609801079d228f2440a493a3880ab68cad0524b) to
    a single node cluster. Adding localhost to the cluster causes this error:

    Installation failed. Failed to receive heartbeat from agent.

    Ensure that the host's hostname is configured properly.
    Ensure that port 7182 is accessible on the Cloudera Manager server
    (check firewall rules).
    Ensure that ports 9000 and 9001 are free on the host being added.
    Check agent logs in /var/log/cloudera-scm-agent/ on the host being
    added (some of the logs can be found in the installation details).

    Im not sure how to fix this, but I have done so far:

    Disabled all IP Tables rules:

    chkconfig iptables --list
    iptables 0:off 1:off 2:off 3:off 4:off 5:off 6:off
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org <javascript:>.



    --
    Todd Grayson
    Cloudera Support
    Customer Operations Engineeringtgra...@cloudera.com <javascript:>
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Darren Lo at Apr 3, 2014 at 9:27 pm
    Hi Asoto,

    There seems to be a problem with that URL (we're currently fixing it), so
    please use this URL to get the correct cloudera manager installer:
    http://archive.cloudera.com/cm5/installer/latest/cloudera-manager-installer.bin

    Thanks,
    Darren

    On Thu, Apr 3, 2014 at 2:26 PM, asoto wrote:

    Todd,

    Thanks for the help so far.

    I have fixed this issue by manually editing the /etc/hosts file. The
    default file from a freshly installed CentOS does not work.

    Since you indicated that 6.5 was not supported, I started a new VM with
    CentOS 6.4 and still got into the whole parcel mess. How is it possible
    that I am getting CDH 4, in a brand new VM? Is it possible that the
    installer I downloaded from here
    http://www.cloudera.com/content/support/en/downloads.html is an old
    version?



    On Thursday, April 3, 2014 5:16:37 PM UTC-4, Todd Grayson wrote:

    asoto

    CM/CDH configuration mandates that we properly configure host FQDN and
    reverse lookup is working.

    run the following on your nodes both forward and reverse lookup should
    work

    python -c "import socket; print socket.getfqdn(); print
    socket.gethostbyname(socket.getfqdn())"

    also please verify your hosts file conforms to the discussion here:

    http://www.cloudera.com/content/cloudera-content/
    cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-
    Guide/cmig_cm_requirements.html?scroll=cmig_topic_4_3_3_unique_1

    Also note with the parcels issue (and our discussion up to this point)

    With all the install/config/parcel issues you ran into for C5... were you
    installing new on fresh OS, or are you upgrading an older CM install?

    It should NOT be necessary for you to manually manipulate things in the
    parcels directory (you can delete them from the parcels UI).

    Thanks
    Todd

    On 4/3/14 2:05 PM, asoto wrote:

    I am adding nodes with Cloudera Enterprise Trial 4.8.2 (#101 built by
    jenkins on 20140226-1855 git: 8609801079d228f2440a493a3880ab68cad0524b)
    to a single node cluster. Adding localhost to the cluster causes this
    error:

    Installation failed. Failed to receive heartbeat from agent.

    Ensure that the host's hostname is configured properly.
    Ensure that port 7182 is accessible on the Cloudera Manager server
    (check firewall rules).
    Ensure that ports 9000 and 9001 are free on the host being added.
    Check agent logs in /var/log/cloudera-scm-agent/ on the host being
    added (some of the logs can be found in the installation details).

    Im not sure how to fix this, but I have done so far:

    Disabled all IP Tables rules:

    chkconfig iptables --list
    iptables 0:off 1:off 2:off 3:off 4:off 5:off 6:off
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.



    --
    Todd Grayson
    Cloudera Support
    Customer Operations Engineering
    tgra...@cloudera.com

    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Asoto at Apr 4, 2014 at 3:42 pm
    Got it. Thanks!
    On Thursday, April 3, 2014 5:27:07 PM UTC-4, Darren Lo wrote:

    Hi Asoto,

    There seems to be a problem with that URL (we're currently fixing it), so
    please use this URL to get the correct cloudera manager installer:

    http://archive.cloudera.com/cm5/installer/latest/cloudera-manager-installer.bin

    Thanks,
    Darren


    On Thu, Apr 3, 2014 at 2:26 PM, asoto <lex...@gmail.com <javascript:>>wrote:
    Todd,

    Thanks for the help so far.

    I have fixed this issue by manually editing the /etc/hosts file. The
    default file from a freshly installed CentOS does not work.

    Since you indicated that 6.5 was not supported, I started a new VM with
    CentOS 6.4 and still got into the whole parcel mess. How is it possible
    that I am getting CDH 4, in a brand new VM? Is it possible that the
    installer I downloaded from here
    http://www.cloudera.com/content/support/en/downloads.html is an old
    version?



    On Thursday, April 3, 2014 5:16:37 PM UTC-4, Todd Grayson wrote:

    asoto

    CM/CDH configuration mandates that we properly configure host FQDN and
    reverse lookup is working.

    run the following on your nodes both forward and reverse lookup should
    work

    python -c "import socket; print socket.getfqdn(); print
    socket.gethostbyname(socket.getfqdn())"

    also please verify your hosts file conforms to the discussion here:

    http://www.cloudera.com/content/cloudera-content/
    cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-
    Guide/cmig_cm_requirements.html?scroll=cmig_topic_4_3_3_unique_1

    Also note with the parcels issue (and our discussion up to this point)

    With all the install/config/parcel issues you ran into for C5... were
    you installing new on fresh OS, or are you upgrading an older CM install?

    It should NOT be necessary for you to manually manipulate things in the
    parcels directory (you can delete them from the parcels UI).

    Thanks
    Todd

    On 4/3/14 2:05 PM, asoto wrote:

    I am adding nodes with Cloudera Enterprise Trial 4.8.2 (#101 built by
    jenkins on 20140226-1855 git: 8609801079d228f2440a493a3880ab68cad0524b)
    to a single node cluster. Adding localhost to the cluster causes this
    error:

    Installation failed. Failed to receive heartbeat from agent.

    Ensure that the host's hostname is configured properly.
    Ensure that port 7182 is accessible on the Cloudera Manager server
    (check firewall rules).
    Ensure that ports 9000 and 9001 are free on the host being added.
    Check agent logs in /var/log/cloudera-scm-agent/ on the host being
    added (some of the logs can be found in the installation details).

    Im not sure how to fix this, but I have done so far:

    Disabled all IP Tables rules:

    chkconfig iptables --list
    iptables 0:off 1:off 2:off 3:off 4:off 5:off 6:off
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.



    --
    Todd Grayson
    Cloudera Support
    Customer Operations Engineering
    tgra...@cloudera.com

    To unsubscribe from this group and stop receiving emails from it,
    send an email to scm-users+...@cloudera.org <javascript:>.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedApr 3, '14 at 8:05p
activeApr 4, '14 at 3:42p
posts5
users3
websitecloudera.com
irc#hadoop

3 users in discussion

Asoto: 3 posts Todd Grayson: 1 post Darren Lo: 1 post

People

Translate

site design / logo © 2022 Grokbase