FAQ
Cluster installation - The inspector failed to run on all hosts.
Options<http://community.cloudera.com/t5/Cloudera-Manager-Installation/Cluster-installation-The-inspector-failed-to-run-on-all-hosts/m-p/2923#>

11-06-2013 07:09 AM

Hello,



I'm doing a basic cluster installation using Cloudera Standard 4 on CentOS
6.3 64 and it does not work... Here is what I'm doing:



1. I run ./cloudera-manager-installer.bin and go to
http://132.207.67.11:7180/ to continue the installation.

2. Then I follow the wizard and add the host 132.207.67.11 to the cluster
installation.

3. The cluster installation on this host is successful but I find it
strange that the IP is changed to 127.0.0.1.

4. But anyway, I continue and install the parcels.

5. And then at the hosts inspection I get this:



Cluster Installation
Inspect hosts for correctness Run Again
Validations
  Inspector failed on the following hosts... <http://132.207.67.11:7180/cmf/express-wizard/resume>

    - homer.larim.polymtl.ca: IOException thrown while collecting data from
    host: Connection refused

Inspector ran on 0 hosts.
  The inspector failed to run on all hosts. 0 hosts are running CDH3 and 1
hosts are running CDH4. All checked hosts are running the same version of
components. All managed hosts have consistent versions of Java. All checked
Cloudera Management Daemons versions are consistent with the server. All
checked Cloudera Management Agents versions are consistent with the server.



And from the log file cloudera-scm-agent.out

:



[06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO SCM
Agent Version: 4.7.3

[06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO Using
directory: /var/run/cloudera-scm-agent

[06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO Using
supervisor binary path:
/usr/lib64/cmf/agent/src/cmf/../../build/env/bin/supervisord

[06/Nov/2013 09:45:45 +0000] 21416 MainThread agent WARNING Agent
is running on 127.0.0.1 (localhost). This is a misconfiguration for
multi-machine clusters. Check your hostname settings.

[06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO Adding
env vars that start with CMF_AGENT_

[06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO Logging
to /var/log/cloudera-scm-agent/cloudera-scm-agent.log



Why is it using 127.0.0.1. I'm always using FQDN name and the name
resolution is made by DNS. Just the be sure, here is the content of my
hosts file:



127.0.0.1 localhost.localdomain localhost

::1 homer.larim.polymtl.ca homer localhost6.localdomain6 localhost6

132.207.67.11 homer.larim.polymtl.ca homer



Anyway, I'm a bit baffled by the problem since I'm doing a vanilla
installation with all the default value. Can anybody help me?



Thanks a lot...



To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.

Search Discussions

  • Foxz88 at Nov 6, 2013 at 4:15 pm
    Ok I found the solution. I modified the hosts file for the following (
    remove the FQDN for localhost ):

    127.0.0.1 localhost

    ::1 localhost6

    132.207.67.11 homer.larim.polymtl.ca homer

    132.207.67.12 marge.larim.polymtl.ca marge




    On Wednesday, November 6, 2013 10:25:20 AM UTC-5, fox...@gmail.com wrote:

    Cluster installation - The inspector failed to run on all hosts.
    Options<http://community.cloudera.com/t5/Cloudera-Manager-Installation/Cluster-installation-The-inspector-failed-to-run-on-all-hosts/m-p/2923#>

    11-06-2013 07:09 AM

    Hello,



    I'm doing a basic cluster installation using Cloudera Standard 4 on CentOS
    6.3 64 and it does not work... Here is what I'm doing:



    1. I run ./cloudera-manager-installer.bin and go to
    http://132.207.67.11:7180/ to continue the installation.

    2. Then I follow the wizard and add the host 132.207.67.11 to the cluster
    installation.

    3. The cluster installation on this host is successful but I find it
    strange that the IP is changed to 127.0.0.1.

    4. But anyway, I continue and install the parcels.

    5. And then at the hosts inspection I get this:



    Cluster Installation
    Inspect hosts for correctness Run Again
    Validations
    Inspector failed on the following hosts... <http://132.207.67.11:7180/cmf/express-wizard/resume>

    - homer.larim.polymtl.ca: IOException thrown while collecting data
    from host: Connection refused

    Inspector ran on 0 hosts.
    The inspector failed to run on all hosts. 0 hosts are running CDH3 and 1
    hosts are running CDH4. All checked hosts are running the same version of
    components. All managed hosts have consistent versions of Java. All
    checked Cloudera Management Daemons versions are consistent with the server.
    All checked Cloudera Management Agents versions are consistent with the
    server.



    And from the log file cloudera-scm-agent.out

    :



    [06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO SCM
    Agent Version: 4.7.3

    [06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO Using
    directory: /var/run/cloudera-scm-agent

    [06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO Using
    supervisor binary path:
    /usr/lib64/cmf/agent/src/cmf/../../build/env/bin/supervisord

    [06/Nov/2013 09:45:45 +0000] 21416 MainThread agent WARNING Agent
    is running on 127.0.0.1 (localhost). This is a misconfiguration for
    multi-machine clusters. Check your hostname settings.

    [06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO Adding
    env vars that start with CMF_AGENT_

    [06/Nov/2013 09:45:45 +0000] 21416 MainThread agent INFO
    Logging to /var/log/cloudera-scm-agent/cloudera-scm-agent.log



    Why is it using 127.0.0.1. I'm always using FQDN name and the name
    resolution is made by DNS. Just the be sure, here is the content of my
    hosts file:



    127.0.0.1 localhost.localdomain localhost

    ::1 homer.larim.polymtl.ca homer localhost6.localdomain6 localhost6

    132.207.67.11 homer.larim.polymtl.ca homer



    Anyway, I'm a bit baffled by the problem since I'm doing a vanilla
    installation with all the default value. Can anybody help me?



    Thanks a lot...

    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedNov 6, '13 at 3:25p
activeNov 6, '13 at 4:15p
posts2
users1
websitecloudera.com
irc#hadoop

1 user in discussion

Foxz88: 2 posts

People

Translate

site design / logo © 2022 Grokbase