FAQ
Hello,

I am trying to make a cluster with 5 nodes using cloudera manager. I
selected a non root user on SSH credentials page. I also selected 'use
private key' option. I am getting an error 'Installation failed. Failed to
detect root privileges' for one of the nodes; and 'Installation failed.
Failed to authenticate.' for the other nodes.

I realize its mainly because access to these nodes are password protected.
So I created private and public keys. The public keys I copied on all the
nodes in the folder authorized_keys. Still its not working.
Did I miss anything?

Does anyone has a suggestion to fix this issue?

Thanks,
Ashwin

To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.

Search Discussions

  • Todd Grayson at Sep 18, 2013 at 4:39 am
    Please review the note here under the section "networking and security"

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Ashwin Bhattathiripad at Sep 18, 2013 at 5:46 am
    Hello Todd,

    I read the note in that section. I have done exactly that is mentioned in
    that article.
    I am not understanding why i am not getting passwordless access to all the
    nodes. I am getting passwordless access only to one node. Also, when I
    tried creating a single node cluster using that particular node, I am
    getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.

    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here under the section "networking and security"


    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org <javascript:>.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Ashwin Bhattathiripad at Sep 18, 2013 at 6:51 am
    Oh I figured the problem there. I have to make my username passwordless
    sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to do
    passwordless ssh to all the nodes. I did the same things with all 5 of them
    but I am able to login passwordless only to one of them.

    Thanks.

    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin Bhattathiripad
    wrote:
    Hello Todd,

    I read the note in that section. I have done exactly that is mentioned in
    that article.
    I am not understanding why i am not getting passwordless access to all the
    nodes. I am getting passwordless access only to one node. Also, when I
    tried creating a single node cluster using that particular node, I am
    getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.

    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here under the section "networking and security"


    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Tony Li Xu at Sep 18, 2013 at 3:36 pm
    Hi Ashwin:

    Did you use "ssh-copy-id" command to install your public key in a remote
    machine’s authorized_keys? Also, what does "ssh -v username@remote" tell
    you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin Bhattathiripad
    wrote:
    Oh I figured the problem there. I have to make my username passwordless
    sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to do
    passwordless ssh to all the nodes. I did the same things with all 5 of them
    but I am able to login passwordless only to one of them.

    Thanks.


    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin Bhattathiripad
    wrote:
    Hello Todd,

    I read the note in that section. I have done exactly that is mentioned in
    that article.
    I am not understanding why i am not getting passwordless access to all
    the nodes. I am getting passwordless access only to one node. Also, when I
    tried creating a single node cluster using that particular node, I am
    getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.

    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here under the section "networking and security"

    http://www.cloudera.com/**content/cloudera-content/**
    cloudera-docs/CM4Ent/latest/**Cloudera-Manager-Installation-**
    Guide/cmig_cm_requirements.**html?scroll=cmig_topic_4<http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4>

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Ashwin Bhattathiripad at Sep 18, 2013 at 11:51 pm
    I did ssh -v username@remote on all the nodes. This is the node where I can
    do passwordless ssh.

    ssh -v ashwin@10.100.104.18
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.18 [10.100.104.18] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.18' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:6
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information


    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-sessions@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Wed Sep 18 16:34:11 2013 from qfab-spade.imb.uq.edu.au
    [ashwin@cloudera3 ~]$

    This one works fine. Now the node which I dont have passwordless access.

    ssh -v ashwin@10.100.104.19
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.19 [10.100.104.19] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.19' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information


    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Trying private key: /home/ashwin/.ssh/identity
    debug1: Trying private key: /home/ashwin/.ssh/id_dsa
    debug1: Next authentication method: password
    ashwin@10.100.104.19's password:

    On Thursday, September 19, 2013 1:36:20 AM UTC+10, Tony wrote:

    Hi Ashwin:

    Did you use "ssh-copy-id" command to install your public key in a remote
    machine’s authorized_keys? Also, what does "ssh -v username@remote" tell
    you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin Bhattathiripad <bash...@gmail.com<javascript:>
    wrote:
    Oh I figured the problem there. I have to make my username passwordless
    sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to do
    passwordless ssh to all the nodes. I did the same things with all 5 of them
    but I am able to login passwordless only to one of them.

    Thanks.


    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin Bhattathiripad
    wrote:
    Hello Todd,

    I read the note in that section. I have done exactly that is mentioned
    in that article.
    I am not understanding why i am not getting passwordless access to all
    the nodes. I am getting passwordless access only to one node. Also, when I
    tried creating a single node cluster using that particular node, I am
    getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.

    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here under the section "networking and security"

    http://www.cloudera.com/**content/cloudera-content/**
    cloudera-docs/CM4Ent/latest/**Cloudera-Manager-Installation-**
    Guide/cmig_cm_requirements.**html?scroll=cmig_topic_4<http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4>

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org <javascript:>.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Ashwin Bhattathiripad at Sep 19, 2013 at 12:09 am
    Never mind I managed to ssh into all the nodes. I changed the permissions
    of public key on all nodes to 600 and it worked!!! Just gave it a try :D

    Now that problem still exists. not able to connect to scm-server. Any idea
    what may be the reason. I saw many such posts on google groups but I am not
    getting the right answer.

    Thanks a lot Todd and Tony for the help. Really appreciate it :)

    On Thursday, September 19, 2013 9:50:59 AM UTC+10, Ashwin Bhattathiripad
    wrote:
    I did ssh -v username@remote on all the nodes. This is the node where I
    can do passwordless ssh.

    ssh -v ashwin@10.100.104.18
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.18 [10.100.104.18] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.18' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:6
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information


    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-sessions@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Wed Sep 18 16:34:11 2013 from qfab-spade.imb.uq.edu.au
    [ashwin@cloudera3 ~]$

    This one works fine. Now the node which I dont have passwordless access.

    ssh -v ashwin@10.100.104.19
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.19 [10.100.104.19] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.19' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information


    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Trying private key: /home/ashwin/.ssh/identity
    debug1: Trying private key: /home/ashwin/.ssh/id_dsa
    debug1: Next authentication method: password
    ashwin@10.100.104.19's password:

    On Thursday, September 19, 2013 1:36:20 AM UTC+10, Tony wrote:

    Hi Ashwin:

    Did you use "ssh-copy-id" command to install your public key in a remote
    machine’s authorized_keys? Also, what does "ssh -v username@remote" tell
    you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin Bhattathiripad <bash...@gmail.com
    wrote:
    Oh I figured the problem there. I have to make my username passwordless
    sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to do
    passwordless ssh to all the nodes. I did the same things with all 5 of them
    but I am able to login passwordless only to one of them.

    Thanks.


    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin
    Bhattathiripad wrote:
    Hello Todd,

    I read the note in that section. I have done exactly that is mentioned
    in that article.
    I am not understanding why i am not getting passwordless access to all
    the nodes. I am getting passwordless access only to one node. Also, when I
    tried creating a single node cluster using that particular node, I am
    getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.

    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here under the section "networking and
    security"

    http://www.cloudera.com/**content/cloudera-content/**
    cloudera-docs/CM4Ent/latest/**Cloudera-Manager-Installation-**
    Guide/cmig_cm_requirements.**html?scroll=cmig_topic_4<http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4>

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Todd Grayson at Sep 19, 2013 at 12:17 am
    Make sure that the firewall and selinux are disabled...

    On 9/18/13 6:09 PM, Ashwin Bhattathiripad wrote:
    Never mind I managed to ssh into all the nodes. I changed the
    permissions of public key on all nodes to 600 and it worked!!! Just
    gave it a try :D

    Now that problem still exists. not able to connect to scm-server. Any
    idea what may be the reason. I saw many such posts on google groups
    but I am not getting the right answer.

    Thanks a lot Todd and Tony for the help. Really appreciate it :)

    On Thursday, September 19, 2013 9:50:59 AM UTC+10, Ashwin
    Bhattathiripad wrote:

    I did ssh -v username@remote on all the nodes. This is the node
    where I can do passwordless ssh.

    ssh -v ashwin@10.100.104.18 OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.18 [10.100.104.18] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version
    OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.18' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:6
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more
    information


    debug1: Unspecified GSS failure. Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-sessions@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Wed Sep 18 16:34:11 2013 from qfab-spade.imb.uq.edu.au
    <http://qfab-spade.imb.uq.edu.au>
    [ashwin@cloudera3 ~]$

    This one works fine. Now the node which I dont have passwordless
    access.

    ssh -v ashwin@10.100.104.19 OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.19 [10.100.104.19] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version
    OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.19' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more
    information


    debug1: Unspecified GSS failure. Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Trying private key: /home/ashwin/.ssh/identity
    debug1: Trying private key: /home/ashwin/.ssh/id_dsa
    debug1: Next authentication method: password
    ashwin@10.100.104.19 's password:


    On Thursday, September 19, 2013 1:36:20 AM UTC+10, Tony wrote:

    Hi Ashwin:

    Did you use "ssh-copy-id" command to install your public key
    in a remote machine’s authorized_keys? Also, what does "ssh -v
    username@remote" tell you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin Bhattathiripad
    wrote:

    Oh I figured the problem there. I have to make my username
    passwordless sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am
    not able to do passwordless ssh to all the nodes. I did
    the same things with all 5 of them but I am able to login
    passwordless only to one of them.

    Thanks.


    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin
    Bhattathiripad wrote:

    Hello Todd,

    I read the note in that section. I have done exactly
    that is mentioned in that article.
    I am not understanding why i am not getting
    passwordless access to all the nodes. I am getting
    passwordless access only to one node. Also, when I
    tried creating a single node cluster using that
    particular node, I am getting 'failed to detect root
    privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.


    On Wednesday, September 18, 2013 2:39:20 PM UTC+10,
    Todd Grayson wrote:

    Please review the note here under the section
    "networking and security"

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4
    <http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4>


    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes
    using cloudera manager. I
    selected a non root user on SSH credentials
    page. I also selected 'use
    private key' option. I am getting an error
    'Installation failed.
    Failed to detect root privileges' for one of the
    nodes; and
    'Installation failed. Failed to authenticate.'
    for the other nodes.
    I realize its mainly because access to these
    nodes are password
    protected. So I created private and public keys.
    The public keys I
    copied on all the nodes in the folder
    authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop
    receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails
    from it, send an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Ashwin Bhattathiripad at Sep 19, 2013 at 12:29 am
    firewall is not working and selinux is already disabled. One of the posts
    mentioned lack of perl might be the problem. I even have perl installed on
    all the nodes.
    On Thursday, September 19, 2013 10:17:31 AM UTC+10, Todd Grayson wrote:

    Make sure that the firewall and selinux are disabled...


    On 9/18/13 6:09 PM, Ashwin Bhattathiripad wrote:

    Never mind I managed to ssh into all the nodes. I changed the permissions
    of public key on all nodes to 600 and it worked!!! Just gave it a try :D

    Now that problem still exists. not able to connect to scm-server. Any idea
    what may be the reason. I saw many such posts on google groups but I am not
    getting the right answer.

    Thanks a lot Todd and Tony for the help. Really appreciate it :)

    On Thursday, September 19, 2013 9:50:59 AM UTC+10, Ashwin Bhattathiripad
    wrote:
    I did ssh -v username@remote on all the nodes. This is the node where I
    can do passwordless ssh.

    ssh -v ash...@10.100.104.18 <javascript:>
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.18 [10.100.104.18] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.18' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:6
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information


    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-...@openssh.com <javascript:>
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Wed Sep 18 16:34:11 2013 from qfab-spade.imb.uq.edu.au
    [ashwin@cloudera3 ~]$

    This one works fine. Now the node which I dont have passwordless access.

    ssh -v ash...@10.100.104.19 <javascript:>
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.19 [10.100.104.19] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.19' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may provide more information


    debug1: Unspecified GSS failure. Minor code may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Trying private key: /home/ashwin/.ssh/identity
    debug1: Trying private key: /home/ashwin/.ssh/id_dsa
    debug1: Next authentication method: password
    ash...@10.100.104.19 <javascript:>'s password:

    On Thursday, September 19, 2013 1:36:20 AM UTC+10, Tony wrote:

    Hi Ashwin:

    Did you use "ssh-copy-id" command to install your public key in a
    remote machine’s authorized_keys? Also, what does "ssh -v username@remote"
    tell you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin Bhattathiripad <
    bash...@gmail.com> wrote:
    Oh I figured the problem there. I have to make my username passwordless
    sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to do
    passwordless ssh to all the nodes. I did the same things with all 5 of them
    but I am able to login passwordless only to one of them.

    Thanks.


    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin
    Bhattathiripad wrote:
    Hello Todd,

    I read the note in that section. I have done exactly that is mentioned
    in that article.
    I am not understanding why i am not getting passwordless access to all
    the nodes. I am getting passwordless access only to one node. Also, when I
    tried creating a single node cluster using that particular node, I am
    getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.


    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson
    wrote:
    Please review the note here under the section "networking and
    security"


    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from
    it, send an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Todd Grayson at Sep 19, 2013 at 1:59 am
    Please keep the thread going with the scm-users mail list, we do not
    provide private 1 on 1 support through this mail list, the discussion is
    for the benefit of the community.

    DNS/Hostname resolution MUST be working (both forward and reverse) for
    hadoop/cloudera to work.

    If you have not configured your virtual cluster environment within DNS,
    then make sure nsswitch.conf is indicating files before dns for hosts
    resolution.

    In your hosts file make sure you have

    IP address FQDN of host Host name
    (for example as in my lab environment)
    10.100.101.10 cm471.test.lab cm471

    Todd

    On 9/18/13 7:38 PM, Ashwin Bhattathiripad wrote:
    This is the error I am getting.


    Detecting Cloudera Manager Server...

    CentOS release 6.2 (Final)
    *BEGIN host -t PTR 10.30.97.235 *
    235.97.30.10.in-addr.arpa domain name pointer qfab-spade.imb.uq.edu.au
    <http://qfab-spade.imb.uq.edu.au>.
    *END (0) *
    using qfab-spade.imb.uq.edu.au <http://qfab-spade.imb.uq.edu.au> as
    scm server hostname
    *BEGIN which python *
    *END (0) *
    *BEGIN python -c 'import socket; import sys; s =
    socket.socket(socket.AF_INET); s.settimeout(5.0);
    s.connect((sys.argv[1], int(sys.argv[2]))); s.close();'
    qfab-spade.imb.uq.edu.au <http://qfab-spade.imb.uq.edu.au> 7182 *
    /usr/bin/python
    Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "<string>", line 1, in connect
    socket.timeout: timed out
    *END (1) *
    could not contact scm server at qfab-spade.imb.uq.edu.au:7182
    <http://qfab-spade.imb.uq.edu.au:7182>, giving up
    waiting for rollback request



    On Thu, Sep 19, 2013 at 11:36 AM, Ashwin Bhattathiripad
    wrote:

    I am using virtualbox. You mean connecting from my windows machine
    to VM linux host
    via putty? That doesn't work. Is that supposed to work?



    On Thu, Sep 19, 2013 at 11:27 AM, Todd Grayson
    wrote:

    Which VM host software are you using VMWare or virtualBox. I
    assume you can connect fine with SSH to this VM?

    On 9/18/13 6:49 PM, Ashwin Bhattathiripad wrote:
    Red Hat (64-bit). I am using the cloudera quickstart VM which
    is available on the website. I have upgraded the manager to 4.7.1


    On Thu, Sep 19, 2013 at 10:39 AM, Todd Grayson
    wrote:

    What linux distribution are you using?

    On 9/18/13 6:29 PM, Ashwin Bhattathiripad wrote:
    firewall is not working and selinux is already disabled.
    One of the posts mentioned lack of perl might be the
    problem. I even have perl installed on all the nodes.

    On Thursday, September 19, 2013 10:17:31 AM UTC+10, Todd
    Grayson wrote:

    Make sure that the firewall and selinux are disabled...

    On 9/18/13 6:09 PM, Ashwin Bhattathiripad wrote:
    Never mind I managed to ssh into all the nodes. I
    changed the permissions of public key on all nodes
    to 600 and it worked!!! Just gave it a try :D

    Now that problem still exists. not able to connect
    to scm-server. Any idea what may be the reason. I
    saw many such posts on google groups but I am not
    getting the right answer.

    Thanks a lot Todd and Tony for the help. Really
    appreciate it :)

    On Thursday, September 19, 2013 9:50:59 AM UTC+10,
    Ashwin Bhattathiripad wrote:

    I did ssh -v username@remote on all the nodes.
    This is the node where I can do passwordless ssh.

    ssh -v ash...@10.100.104.18
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data
    /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.18
    [10.100.104.18] port 22.
    debug1: Connection established.
    debug1: identity file
    /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa
    type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa
    type -1
    debug1: Remote protocol version 2.0, remote
    software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for
    protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5
    none
    debug1: kex: client->server aes128-ctr hmac-md5
    none
    debug1:
    SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.18' is known and
    matches the RSA host key.
    debug1: Found key in
    /home/ashwin/.ssh/known_hosts:6
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may
    provide more information


    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key:
    /home/ashwin/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-...@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Wed Sep 18 16:34:11 2013 from
    qfab-spade.imb.uq.edu.au
    <http://qfab-spade.imb.uq.edu.au>
    [ashwin@cloudera3 ~]$

    This one works fine. Now the node which I dont
    have passwordless access.

    ssh -v ash...@10.100.104.19
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data
    /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.19
    [10.100.104.19] port 22.
    debug1: Connection established.
    debug1: identity file
    /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa
    type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa
    type -1
    debug1: Remote protocol version 2.0, remote
    software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for
    protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5
    none
    debug1: kex: client->server aes128-ctr hmac-md5
    none
    debug1:
    SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.19' is known and
    matches the RSA host key.
    debug1: Found key in
    /home/ashwin/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may
    provide more information


    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key:
    /home/ashwin/.ssh/id_rsa
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Trying private key:
    /home/ashwin/.ssh/identity
    debug1: Trying private key:
    /home/ashwin/.ssh/id_dsa
    debug1: Next authentication method: password
    ash...@10.100.104.19's password:


    On Thursday, September 19, 2013 1:36:20 AM
    UTC+10, Tony wrote:

    Hi Ashwin:

    Did you use "ssh-copy-id" command to
    install your public key in a remote
    machine’s authorized_keys? Also, what does
    "ssh -v username@remote" tell you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin
    Bhattathiripad wrote:

    Oh I figured the problem there. I have
    to make my username passwordless sudo
    in all the nodes.

    I have got one more doubt. Do you have
    any idea why I am not able to do
    passwordless ssh to all the nodes. I
    did the same things with all 5 of them
    but I am able to login passwordless
    only to one of them.

    Thanks.


    On Wednesday, September 18, 2013
    3:46:34 PM UTC+10, Ashwin
    Bhattathiripad wrote:

    Hello Todd,

    I read the note in that section. I
    have done exactly that is mentioned
    in that article.
    I am not understanding why i am not
    getting passwordless access to all
    the nodes. I am getting
    passwordless access only to one
    node. Also, when I tried creating a
    single node cluster using that
    particular node, I am getting
    'failed to detect root privileges'.

    PS: The user I am using has
    passwordless sudo permissions.

    Thanks.


    On Wednesday, September 18, 2013
    2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here
    under the section "networking
    and security"

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4


    Todd




    On 9/17/13 9:57 PM, Ashwin
    Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster
    with 5 nodes using cloudera
    manager. I
    selected a non root user on
    SSH credentials page. I also
    selected 'use
    private key' option. I am
    getting an error 'Installation
    failed.
    Failed to detect root
    privileges' for one of the
    nodes; and
    'Installation failed. Failed
    to authenticate.' for the other
    nodes.
    I realize its mainly because
    access to these nodes are password
    protected. So I created
    private and public keys. The
    public keys I
    copied on all the nodes in
    the folder authorized_keys.
    Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion
    to fix this issue?
    Thanks,
    Ashwin
    To unsubscribe from this
    group and stop receiving emails
    from it, send
    an email to
    scm-users+...@cloudera.org.

    To unsubscribe from this group and stop
    receiving emails from it, send an email
    to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails
    from it, send an email to
    scm-users+unsubscribe@cloudera.org
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Todd Grayson at Sep 19, 2013 at 2:00 am
    Well, you should have everything you need in that VM already, it should
    not be necessary to add additional packages to get things started.

    Generally when I set up a VM on virtualbox for the "network" settings I
    use "bridged" and within the linux OS I assign an IP address that is in
    the same subnet as the IP address of the host I'm running the VM on.
    NAT will work too, but there is a address translation taking place in
    that case.

    Have you edited /etc/sysconfig/network-scripts/ifcfg-eth0 on the VM to
    match the network you want to be using?

    What is happening when you attempt to start the cloudera manager server
    from the command line on the vm (service cloudera-scm-server start).
    Is there anything indicating errors in the /var/log/cloudera-scm-server
    logging at the time you are starting the process up?

    The URL to connect would be http://your-host-ip:7180

    Does the connection attempt from the browser time out, or load a page
    that has errors?

    (I've seen your error reply already, sending this for the discussion)

    Todd


    On 9/18/13 7:36 PM, Ashwin Bhattathiripad wrote:
    I am using virtualbox. You mean connecting from my windows machine to
    VM linux host
    via putty? That doesn't work. Is that supposed to work?



    On Thu, Sep 19, 2013 at 11:27 AM, Todd Grayson wrote:

    Which VM host software are you using VMWare or virtualBox. I
    assume you can connect fine with SSH to this VM?

    On 9/18/13 6:49 PM, Ashwin Bhattathiripad wrote:
    Red Hat (64-bit). I am using the cloudera quickstart VM which is
    available on the website. I have upgraded the manager to 4.7.1


    On Thu, Sep 19, 2013 at 10:39 AM, Todd Grayson
    wrote:

    What linux distribution are you using?

    On 9/18/13 6:29 PM, Ashwin Bhattathiripad wrote:
    firewall is not working and selinux is already disabled. One
    of the posts mentioned lack of perl might be the problem. I
    even have perl installed on all the nodes.

    On Thursday, September 19, 2013 10:17:31 AM UTC+10, Todd
    Grayson wrote:

    Make sure that the firewall and selinux are disabled...

    On 9/18/13 6:09 PM, Ashwin Bhattathiripad wrote:
    Never mind I managed to ssh into all the nodes. I
    changed the permissions of public key on all nodes to
    600 and it worked!!! Just gave it a try :D

    Now that problem still exists. not able to connect to
    scm-server. Any idea what may be the reason. I saw many
    such posts on google groups but I am not getting the
    right answer.

    Thanks a lot Todd and Tony for the help. Really
    appreciate it :)

    On Thursday, September 19, 2013 9:50:59 AM UTC+10,
    Ashwin Bhattathiripad wrote:

    I did ssh -v username@remote on all the nodes. This
    is the node where I can do passwordless ssh.

    ssh -v ash...@10.100.104.18
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.18 [10.100.104.18]
    port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity
    type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote
    software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192)
    sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.18' is known and matches
    the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:6
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may
    provide more information


    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-...@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Wed Sep 18 16:34:11 2013 from
    qfab-spade.imb.uq.edu.au
    <http://qfab-spade.imb.uq.edu.au>
    [ashwin@cloudera3 ~]$

    This one works fine. Now the node which I dont have
    passwordless access.

    ssh -v ash...@10.100.104.19
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.19 [10.100.104.19]
    port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity
    type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote
    software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192)
    sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.19' is known and matches
    the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure. Minor code may
    provide more information


    debug1: Unspecified GSS failure. Minor code may
    provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Trying private key: /home/ashwin/.ssh/identity
    debug1: Trying private key: /home/ashwin/.ssh/id_dsa
    debug1: Next authentication method: password
    ash...@10.100.104.19's password:


    On Thursday, September 19, 2013 1:36:20 AM UTC+10,
    Tony wrote:

    Hi Ashwin:

    Did you use "ssh-copy-id" command to install
    your public key in a remote machine’s
    authorized_keys? Also, what does "ssh -v
    username@remote" tell you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin
    Bhattathiripad wrote:

    Oh I figured the problem there. I have to
    make my username passwordless sudo in all
    the nodes.

    I have got one more doubt. Do you have any
    idea why I am not able to do passwordless
    ssh to all the nodes. I did the same things
    with all 5 of them but I am able to login
    passwordless only to one of them.

    Thanks.


    On Wednesday, September 18, 2013 3:46:34 PM
    UTC+10, Ashwin Bhattathiripad wrote:

    Hello Todd,

    I read the note in that section. I have
    done exactly that is mentioned in that
    article.
    I am not understanding why i am not
    getting passwordless access to all the
    nodes. I am getting passwordless access
    only to one node. Also, when I tried
    creating a single node cluster using
    that particular node, I am getting
    'failed to detect root privileges'.

    PS: The user I am using has
    passwordless sudo permissions.

    Thanks.


    On Wednesday, September 18, 2013
    2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here under
    the section "networking and security"

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4


    Todd




    On 9/17/13 9:57 PM, Ashwin
    Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster
    with 5 nodes using cloudera
    manager. I
    selected a non root user on SSH
    credentials page. I also selected 'use
    private key' option. I am getting
    an error 'Installation failed.
    Failed to detect root privileges'
    for one of the nodes; and
    'Installation failed. Failed to
    authenticate.' for the other nodes.
    I realize its mainly because
    access to these nodes are password
    protected. So I created private
    and public keys. The public keys I
    copied on all the nodes in the
    folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to
    fix this issue?
    Thanks,
    Ashwin
    To unsubscribe from this group
    and stop receiving emails from it,
    send
    an email to
    scm-users+...@cloudera.org.

    To unsubscribe from this group and stop
    receiving emails from it, send an email to
    scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails
    from it, send an email to scm-users+unsubscribe@cloudera.org
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Ashwin Bhattathiripad at Sep 19, 2013 at 3:39 am
    I checked my nsswitch.conf file. it has hosts: files dns.
    My hosts file has 127.0.0.1 localhost.localdomain localhost
    I have used NAT when booting up the vm. What do I need to do with that?
    When I run service cloudera-scm-server, I get its already running.
    I am able to connect localhost:7180

    When I run sudo cat /etc/sysconfig/network-scripts/ifcfg-eth0 I get this

    DEVICE="eth0"
    BOOTPROTO="dhcp"
    HWADDR="08:00:27:1E:BF:40"
    NM_CONTROLLED="yes"
    ONBOOT="yes"
    TYPE="Ethernet"



    On Thursday, September 19, 2013 12:00:13 PM UTC+10, Todd Grayson wrote:

    Well, you should have everything you need in that VM already, it should
    not be necessary to add additional packages to get things started.

    Generally when I set up a VM on virtualbox for the "network" settings I
    use "bridged" and within the linux OS I assign an IP address that is in the
    same subnet as the IP address of the host I'm running the VM on.� NAT
    will work too, but there is a address translation taking place in that case.

    Have you edited /etc/sysconfig/network-scripts/ifcfg-eth0 on the VM to
    match the network you want to be using?�

    What is happening when you attempt to start the cloudera manager server
    from the command line on the vm� (service cloudera-scm-server start).�
    Is there anything indicating errors in the /var/log/cloudera-scm-server
    logging at the time you are starting the process up?

    The URL to connect would be http://your-host-ip:7180

    Does the connection attempt from the browser time out, or load a page that
    has errors?

    (I've seen your error reply already, sending this for the discussion)

    Todd



    On 9/18/13 7:36 PM, Ashwin Bhattathiripad wrote:

    I am using virtualbox. You mean connecting from my windows machine to VM
    linux host
    �via putty? That doesn't work. Is that supposed to work?



    On Thu, Sep 19, 2013 at 11:27 AM, Todd Grayson <tgra...@cloudera.com<javascript:>
    wrote:
    Which VM host software are you using VMWare or virtualBox.� I assume
    you can connect fine with SSH to this VM?


    On 9/18/13 6:49 PM, Ashwin Bhattathiripad wrote:

    Red Hat (64-bit). I am using the cloudera quickstart VM which is
    available on the website. I have upgraded the manager to 4.7.1


    On Thu, Sep 19, 2013 at 10:39 AM, Todd Grayson <tgra...@cloudera.com<javascript:>
    wrote:
    What linux distribution are you using?


    On 9/18/13 6:29 PM, Ashwin Bhattathiripad wrote:

    firewall is not working and selinux is already disabled. One of the
    posts mentioned lack of perl might be the problem. I even have perl
    installed on all the nodes.
    On Thursday, September 19, 2013 10:17:31 AM UTC+10, Todd Grayson wrote:

    Make sure that the firewall and selinux are disabled...


    On 9/18/13 6:09 PM, Ashwin Bhattathiripad wrote:

    Never mind I managed to ssh into all the nodes. I changed the
    permissions of public key on all nodes to 600 and it worked!!! Just gave it
    a try :D

    Now that problem still exists. not able to connect to scm-server. Any
    idea what may be the reason. I saw many such posts on google groups but I
    am not getting the right answer.

    Thanks a lot Todd and Tony for the help. Really appreciate it :)

    On Thursday, September 19, 2013 9:50:59 AM UTC+10, Ashwin
    Bhattathiripad wrote:
    I did ssh -v username@remote on all the nodes. This is the node where
    I can do passwordless ssh.

    ssh -v ash...@10.100.104.18
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.18 [10.100.104.18] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version
    OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.18' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:6
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure.� Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code may provide more
    information


    debug1: Unspecified GSS failure.� Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-...@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Wed Sep 18 16:34:11 2013 from qfab-spade.imb.uq.edu.au
    [ashwin@cloudera3 ~]$

    This one works fine. Now the node which I dont have passwordless
    access.

    ssh -v ash...@10.100.104.19
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.19 [10.100.104.19] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version
    OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.19' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure.� Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code may provide more
    information


    debug1: Unspecified GSS failure.� Minor code may provide more
    information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Trying private key: /home/ashwin/.ssh/identity
    debug1: Trying private key: /home/ashwin/.ssh/id_dsa
    debug1: Next authentication method: password
    ash...@10.100.104.19's password:

    On Thursday, September 19, 2013 1:36:20 AM UTC+10, Tony wrote:

    Hi Ashwin:

    Did you use "ssh-copy-id" command to install your public key in a
    remote machine�s authorized_keys? Also, what does "ssh -v
    username@remote" tell you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin Bhattathiripad <
    bash...@gmail.com> wrote:
    Oh I figured the problem there. I have to make my username
    passwordless sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to
    do passwordless ssh to all the nodes. I did the same things with all 5 of
    them but I am able to login passwordless only to one of them.

    Thanks.


    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin
    Bhattathiripad wrote:
    Hello Todd,

    I read the note in that section. I have done exactly that is
    mentioned in that article.
    I am not understanding why i am not getting passwordless access to
    all the nodes. I am getting passwordless access only to one node. Also,
    when I tried creating a single node cluster using that particular node, I
    am getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.


    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson
    wrote:
    Please review the note here under the section "networking and
    security"


    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster �with 5 nodes using cloudera
    manager. I
    selected a non root user on SSH credentials page. I also
    selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.
    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from
    it, send an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to scm-users+...@cloudera.org <javascript:>.

    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Tony Li Xu at Sep 19, 2013 at 2:26 pm
    Hi Ashwin:

    Can you ping all the scm-agent nodes from scm-server node? Also, if you are
    using /etc/hosts file for hostname resolution, make sure /etc/hosts file is
    consistent across all nodes.

    Can you at least "telnet" to scm-server port 7180 from agent nodes?

    --
    Tony

    On Wed, Sep 18, 2013 at 11:39 PM, Ashwin Bhattathiripad wrote:

    I checked my nsswitch.conf file. it has hosts: files dns.
    My hosts file has 127.0.0.1 localhost.localdomain localhost
    I have used NAT when booting up the vm. What do I need to do with that?
    When I run service cloudera-scm-server, I get its already running.
    I am able to connect localhost:7180

    When I run sudo cat /etc/sysconfig/network-scripts/ifcfg-eth0 I get this

    DEVICE="eth0"
    BOOTPROTO="dhcp"
    HWADDR="08:00:27:1E:BF:40"
    NM_CONTROLLED="yes"
    ONBOOT="yes"
    TYPE="Ethernet"




    On Thursday, September 19, 2013 12:00:13 PM UTC+10, Todd Grayson wrote:

    Well, you should have everything you need in that VM already, it should
    not be necessary to add additional packages to get things started.

    Generally when I set up a VM on virtualbox for the "network" settings I
    use "bridged" and within the linux OS I assign an IP address that is in the
    same subnet as the IP address of the host I'm running the VM on.� NAT
    will work too, but there is a address translation taking place in that case.

    Have you edited /etc/sysconfig/network-**scripts/ifcfg-eth0 on the VM to
    match the network you want to be using?�

    What is happening when you attempt to start the cloudera manager server
    from the command line on the vm� (service cloudera-scm-server start).�
    Is there anything indicating errors in the /var/log/cloudera-scm-server
    logging at the time you are starting the process up?


    The URL to connect would be http://your-host-ip:7180

    Does the connection attempt from the browser time out, or load a page
    that has errors?

    (I've seen your error reply already, sending this for the discussion)

    Todd



    On 9/18/13 7:36 PM, Ashwin Bhattathiripad wrote:

    I am using virtualbox. You mean connecting from my windows machine to
    VM linux host
    �via putty? That doesn't work. Is that supposed to work?


    On Thu, Sep 19, 2013 at 11:27 AM, Todd Grayson wrote:

    Which VM host software are you using VMWare or virtualBox.� I assume
    you can connect fine with SSH to this VM?


    On 9/18/13 6:49 PM, Ashwin Bhattathiripad wrote:

    Red Hat (64-bit). I am using the cloudera quickstart VM which is
    available on the website. I have upgraded the manager to 4.7.1

    On Thu, Sep 19, 2013 at 10:39 AM, Todd Grayson wrote:

    What linux distribution are you using?


    On 9/18/13 6:29 PM, Ashwin Bhattathiripad wrote:

    firewall is not working and selinux is already disabled. One of the
    posts mentioned lack of perl might be the problem. I even have perl
    installed on all the nodes.
    On Thursday, September 19, 2013 10:17:31 AM UTC+10, Todd Grayson wrote:

    Make sure that the firewall and selinux are disabled...


    On 9/18/13 6:09 PM, Ashwin Bhattathiripad wrote:

    Never mind I managed to ssh into all the nodes. I changed the
    permissions of public key on all nodes to 600 and it worked!!! Just gave it
    a try :D

    Now that problem still exists. not able to connect to scm-server. Any
    idea what may be the reason. I saw many such posts on google groups but I
    am not getting the right answer.

    Thanks a lot Todd and Tony for the help. Really appreciate it :)

    On Thursday, September 19, 2013 9:50:59 AM UTC+10, Ashwin
    Bhattathiripad wrote:
    I did ssh -v username@remote on all the nodes. This is the node
    where I can do passwordless ssh.

    ssh -v ash...@10.100.104.18
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.18 [10.100.104.18] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version
    OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(**1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.18' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:**6
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-**with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure.� Minor code may provide more
    information

    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code may provide more
    information

    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code may provide more
    information


    debug1: Unspecified GSS failure.� Minor code may provide more
    information

    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-...@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Wed Sep 18 16:34:11 2013 from qfab-spade.imb.uq.edu.au
    [ashwin@cloudera3 ~]$

    This one works fine. Now the node which I dont have passwordless
    access.

    ssh -v ash...@10.100.104.19
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.19 [10.100.104.19] port 22.
    debug1: Connection established.
    debug1: identity file /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version
    OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-md5 none
    debug1: kex: client->server aes128-ctr hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(**1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.19' is known and matches the RSA host key.
    debug1: Found key in /home/ashwin/.ssh/known_hosts:**4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-**with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method: gssapi-with-mic
    debug1: Unspecified GSS failure.� Minor code may provide more
    information

    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code may provide more
    information

    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code may provide more
    information


    debug1: Unspecified GSS failure.� Minor code may provide more
    information

    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key: /home/ashwin/.ssh/id_rsa
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-**with-mic,password
    debug1: Trying private key: /home/ashwin/.ssh/identity
    debug1: Trying private key: /home/ashwin/.ssh/id_dsa
    debug1: Next authentication method: password
    ash...@10.100.104.19's password:

    On Thursday, September 19, 2013 1:36:20 AM UTC+10, Tony wrote:

    Hi Ashwin:

    Did you use "ssh-copy-id" command to install your public key in a
    remote machine�s authorized_keys? Also, what does "ssh -v username@remote"
    tell you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin Bhattathiripad <
    bash...@gmail.com> wrote:
    Oh I figured the problem there. I have to make my username
    passwordless sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able
    to do passwordless ssh to all the nodes. I did the same things with all 5
    of them but I am able to login passwordless only to one of them.

    Thanks.


    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin
    Bhattathiripad wrote:
    Hello Todd,

    I read the note in that section. I have done exactly that is
    mentioned in that article.
    I am not understanding why i am not getting passwordless access to
    all the nodes. I am getting passwordless access only to one node. Also,
    when I tried creating a single node cluster using that particular node, I
    am getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.


    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson
    wrote:
    Please review the note here under the section "networking and
    security"

    http://www.cloudera.com/**content/cloudera-content/**
    cloudera-docs/CM4Ent/latest/**Cloudera-Manager-Installation-**
    Guide/cmig_cm_requirements.**html?scroll=cmig_topic_4<http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4>

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster �with 5 nodes using cloudera
    manager. I
    selected a non root user on SSH credentials page. I also
    selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.
    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails
    from it, send an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to scm-users+...@**cloudera.org.

    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Todd Grayson at Sep 19, 2013 at 5:23 pm
    How many VM's are you setting up, just the 1 cloudera demo VM? Or are
    you setting up a couple of other VM's as well to be cluster nodes?

    How much memory do you have in the physical host system you are setting
    the VM's up on?

    Ashwin,

    I'm not sure why these issues are coming up with regard to using this
    VM, I apologize as I'm speaking from a general CM & CDH cluster setup
    with what I've been advising. I'm downloading the Demo VM now and will
    load it up and see what is happening (and if all these changes we are
    talking about are really needed to be able to use it).

    I'll update the thread as I get that done (will probably be tonight).

    Generally speaking when I build this out I just use the CM installer
    over VM's I've built from the RH OS ISO (I use the "basic server" option
    when installing RH).

    Todd
    On 9/18/13 9:39 PM, Ashwin Bhattathiripad wrote:
    I checked my nsswitch.conf file. it has hosts: files dns.
    My hosts file has 127.0.0.1 localhost.localdomain localhost
    I have used NAT when booting up the vm. What do I need to do with that?
    When I run service cloudera-scm-server, I get its already running.
    I am able to connect localhost:7180

    When I run sudo cat /etc/sysconfig/network-scripts/ifcfg-eth0 I get this

    DEVICE="eth0"
    BOOTPROTO="dhcp"
    HWADDR="08:00:27:1E:BF:40"
    NM_CONTROLLED="yes"
    ONBOOT="yes"
    TYPE="Ethernet"




    On Thursday, September 19, 2013 12:00:13 PM UTC+10, Todd Grayson wrote:

    Well, you should have everything you need in that VM already, it
    should not be necessary to add additional packages to get things
    started.

    Generally when I set up a VM on virtualbox for the "network"
    settings I use "bridged" and within the linux OS I assign an IP
    address that is in the same subnet as the IP address of the host
    I'm running the VM on.� NAT will work too, but there is a
    address translation taking place in that case.

    Have you edited /etc/sysconfig/network-scripts/ifcfg-eth0 on the
    VM to match the network you want to be using?�

    What is happening when you attempt to start the cloudera manager
    server from the command line on the vm� (service
    cloudera-scm-server start).� Is there anything indicating errors
    in the /var/log/cloudera-scm-server logging at the time you are
    starting the process up?

    The URL to connect would be http://your-host-ip:7180

    Does the connection attempt from the browser time out, or load a
    page that has errors?

    (I've seen your error reply already, sending this for the discussion)

    Todd


    On 9/18/13 7:36 PM, Ashwin Bhattathiripad wrote:
    I am using virtualbox. You mean connecting from my windows
    machine to VM linux host
    �via putty? That doesn't work. Is that supposed to work?



    On Thu, Sep 19, 2013 at 11:27 AM, Todd Grayson
    <tgra...@cloudera.com <javascript:>> wrote:

    Which VM host software are you using VMWare or virtualBox.�
    I assume you can connect fine with SSH to this VM?

    On 9/18/13 6:49 PM, Ashwin Bhattathiripad wrote:
    Red Hat (64-bit). I am using the cloudera quickstart VM
    which is available on the website. I have upgraded the
    manager to 4.7.1


    On Thu, Sep 19, 2013 at 10:39 AM, Todd Grayson
    <tgra...@cloudera.com <javascript:>> wrote:

    What linux distribution are you using?

    On 9/18/13 6:29 PM, Ashwin Bhattathiripad wrote:
    firewall is not working and selinux is already
    disabled. One of the posts mentioned lack of perl might
    be the problem. I even have perl installed on all the
    nodes.

    On Thursday, September 19, 2013 10:17:31 AM UTC+10,
    Todd Grayson wrote:

    Make sure that the firewall and selinux are disabled...

    On 9/18/13 6:09 PM, Ashwin Bhattathiripad wrote:
    Never mind I managed to ssh into all the nodes. I
    changed the permissions of public key on all nodes
    to 600 and it worked!!! Just gave it a try :D

    Now that problem still exists. not able to connect
    to scm-server. Any idea what may be the reason. I
    saw many such posts on google groups but I am not
    getting the right answer.

    Thanks a lot Todd and Tony for the help. Really
    appreciate it :)

    On Thursday, September 19, 2013 9:50:59 AM UTC+10,
    Ashwin Bhattathiripad wrote:

    I did ssh -v username@remote on all the nodes.
    This is the node where I can do passwordless ssh.

    ssh -v ash...@10.100.104.18
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data
    /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.18
    [10.100.104.18] port 22.
    debug1: Connection established.
    debug1: identity file
    /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa
    type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa
    type -1
    debug1: Remote protocol version 2.0, remote
    software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for
    protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr
    hmac-md5 none
    debug1: kex: client->server aes128-ctr
    hmac-md5 none
    debug1:
    SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.18' is known and
    matches the RSA host key.
    debug1: Found key in
    /home/ashwin/.ssh/known_hosts:6
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method:
    gssapi-with-mic
    debug1: Unspecified GSS failure.� Minor code
    may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code
    may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code
    may provide more information


    debug1: Unspecified GSS failure.� Minor code
    may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key:
    /home/ashwin/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 277
    debug1: Authentication succeeded (publickey).
    debug1: channel 0: new [client-session]
    debug1: Requesting no-more-...@openssh.com
    debug1: Entering interactive session.
    debug1: Sending environment.
    debug1: Sending env LANG = en_US.UTF-8
    Last login: Wed Sep 18 16:34:11 2013 from
    qfab-spade.imb.uq.edu.au
    <http://qfab-spade.imb.uq.edu.au>
    [ashwin@cloudera3 ~]$

    This one works fine. Now the node which I dont
    have passwordless access.

    ssh -v ash...@10.100.104.19
    OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
    debug1: Reading configuration data
    /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 10.100.104.19
    [10.100.104.19] port 22.
    debug1: Connection established.
    debug1: identity file
    /home/ashwin/.ssh/identity type -1
    debug1: identity file /home/ashwin/.ssh/id_rsa
    type 1
    debug1: identity file /home/ashwin/.ssh/id_dsa
    type -1
    debug1: Remote protocol version 2.0, remote
    software version OpenSSH_5.3
    debug1: match: OpenSSH_5.3 pat OpenSSH*
    debug1: Enabling compatibility mode for
    protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.3
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr
    hmac-md5 none
    debug1: kex: client->server aes128-ctr
    hmac-md5 none
    debug1:
    SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '10.100.104.19' is known and
    matches the RSA host key.
    debug1: Found key in
    /home/ashwin/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Next authentication method: gssapi-keyex
    debug1: No valid Key exchange context
    debug1: Next authentication method:
    gssapi-with-mic
    debug1: Unspecified GSS failure.� Minor code
    may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code
    may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Unspecified GSS failure.� Minor code
    may provide more information


    debug1: Unspecified GSS failure.� Minor code
    may provide more information
    Credentials cache file '/tmp/krb5cc_501' not found

    debug1: Next authentication method: publickey
    debug1: Offering public key:
    /home/ashwin/.ssh/id_rsa
    debug1: Authentications that can continue:
    publickey,gssapi-keyex,gssapi-with-mic,password
    debug1: Trying private key:
    /home/ashwin/.ssh/identity
    debug1: Trying private key:
    /home/ashwin/.ssh/id_dsa
    debug1: Next authentication method: password
    ash...@10.100.104.19's password:


    On Thursday, September 19, 2013 1:36:20 AM
    UTC+10, Tony wrote:

    Hi Ashwin:

    Did you use "ssh-copy-id" command to
    install your public key in a remote
    machine�s authorized_keys? Also, what
    does "ssh -v username@remote" tell you?

    --
    Tony


    On Wed, Sep 18, 2013 at 2:51 AM, Ashwin
    Bhattathiripad wrote:

    Oh I figured the problem there. I have
    to make my username passwordless sudo
    in all the nodes.

    I have got one more doubt. Do you have
    any idea why I am not able to do
    passwordless ssh to all the nodes. I
    did the same things with all 5 of them
    but I am able to login passwordless
    only to one of them.

    Thanks.


    On Wednesday, September 18, 2013
    3:46:34 PM UTC+10, Ashwin
    Bhattathiripad wrote:

    Hello Todd,

    I read the note in that section. I
    have done exactly that is
    mentioned in that article.
    I am not understanding why i am
    not getting passwordless access to
    all the nodes. I am getting
    passwordless access only to one
    node. Also, when I tried creating
    a single node cluster using that
    particular node, I am getting
    'failed to detect root privileges'.

    PS: The user I am using has
    passwordless sudo permissions.

    Thanks.


    On Wednesday, September 18, 2013
    2:39:20 PM UTC+10, Todd Grayson
    wrote:

    Please review the note here
    under the section "networking
    and security"

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4
    <http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4>


    Todd




    On 9/17/13 9:57 PM, Ashwin
    Bhattathiripad wrote:
    Hello,

    I am trying to make a
    cluster �with 5 nodes using
    cloudera manager. I
    selected a non root user on
    SSH credentials page. I also
    selected 'use
    private key' option. I am
    getting an error 'Installation
    failed.
    Failed to detect root
    privileges' for one of the
    nodes; and
    'Installation failed. Failed
    to authenticate.' for the
    other nodes.
    I realize its mainly because
    access to these nodes are
    password
    protected. So I created
    private and public keys. The
    public keys I
    copied on all the nodes in
    the folder authorized_keys.
    Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion
    to fix this issue?
    Thanks,
    Ashwin
    To unsubscribe from this
    group and stop receiving
    emails from it, send
    an email to
    scm-users+...@cloudera.org.

    To unsubscribe from this group and
    stop receiving emails from it, send an
    email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving
    emails from it, send an email to
    scm-users+...@cloudera.org <javascript:>.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Ashwin Bhattathiripad at Sep 19, 2013 at 12:11 am
    Never mind I managed to ssh into all the nodes. I changed the permissions
    of public key on all nodes to 600 and it worked!!! Just gave it a try :D

    Now that problem still exists. not able to connect to scm-server. Any idea
    what may be the reason. I saw many such posts on google groups but I am not
    getting the right answer.

    Thanks a lot Todd and Tony for the help. Really appreciate it :)


    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Todd Grayson at Sep 18, 2013 at 4:21 pm
    Take CM out of the activity completely for now. From a shell,
    demonstrate that you can do passwordless ssh between all of the nodes as
    the user you are planning to use. Once you have that working, then
    re-attempt through CM.

    Todd
    On 9/18/13 12:51 AM, Ashwin Bhattathiripad wrote:
    Oh I figured the problem there. I have to make my username
    passwordless sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to
    do passwordless ssh to all the nodes. I did the same things with all 5
    of them but I am able to login passwordless only to one of them.

    Thanks.

    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin
    Bhattathiripad wrote:

    Hello Todd,

    I read the note in that section. I have done exactly that is
    mentioned in that article.
    I am not understanding why i am not getting passwordless access to
    all the nodes. I am getting passwordless access only to one node.
    Also, when I tried creating a single node cluster using that
    particular node, I am getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.


    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson
    wrote:

    Please review the note here under the section "networking and
    security"

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4
    <http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4>


    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera
    manager. I
    selected a non root user on SSH credentials page. I also
    selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.
    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails
    from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Ashwin Bhattathiripad at Sep 18, 2013 at 11:45 pm
    Yea I realized that. First and foremost all the nodes should have
    passwordless ssh access. So trying on that.
    On Thursday, September 19, 2013 2:21:06 AM UTC+10, Todd Grayson wrote:

    Take CM out of the activity completely for now. From a shell,
    demonstrate that you can do passwordless ssh between all of the nodes as
    the user you are planning to use. Once you have that working, then
    re-attempt through CM.

    Todd

    On 9/18/13 12:51 AM, Ashwin Bhattathiripad wrote:

    Oh I figured the problem there. I have to make my username passwordless
    sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to do
    passwordless ssh to all the nodes. I did the same things with all 5 of them
    but I am able to login passwordless only to one of them.

    Thanks.

    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin Bhattathiripad
    wrote:
    Hello Todd,

    I read the note in that section. I have done exactly that is mentioned in
    that article.
    I am not understanding why i am not getting passwordless access to all
    the nodes. I am getting passwordless access only to one node. Also, when I
    tried creating a single node cluster using that particular node, I am
    getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.

    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here under the section "networking and security"


    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to scm-users+...@cloudera.org <javascript:>.

    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Todd Grayson at Sep 21, 2013 at 9:12 pm
    Ok so I'm trying to understand your configuration approach to your VM's
    at this point.

    NAT is not the networking configuration you want.... its more for
    running a desktop vm that you just need to browse or use for casual
    internet access.

    See https://www.virtualbox.org/manual/ch06.html#networkingmodes

    I would suggest setting the vm's up as "Bridged" so you can network
    between the cluster nodes as well as access the internet without issue.

    Todd
    On 9/18/13 5:45 PM, Ashwin Bhattathiripad wrote:
    Yea I realized that. First and foremost all the nodes should have
    passwordless ssh access. So trying on that.

    On Thursday, September 19, 2013 2:21:06 AM UTC+10, Todd Grayson wrote:

    Take CM out of the activity completely for now. From a shell,
    demonstrate that you can do passwordless ssh between all of the
    nodes as the user you are planning to use. Once you have that
    working, then re-attempt through CM.

    Todd
    On 9/18/13 12:51 AM, Ashwin Bhattathiripad wrote:
    Oh I figured the problem there. I have to make my username
    passwordless sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able
    to do passwordless ssh to all the nodes. I did the same things
    with all 5 of them but I am able to login passwordless only to
    one of them.

    Thanks.

    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin
    Bhattathiripad wrote:

    Hello Todd,

    I read the note in that section. I have done exactly that is
    mentioned in that article.
    I am not understanding why i am not getting passwordless
    access to all the nodes. I am getting passwordless access
    only to one node. Also, when I tried creating a single node
    cluster using that particular node, I am getting 'failed to
    detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.


    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd
    Grayson wrote:

    Please review the note here under the section "networking
    and security"

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4
    <http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4>


    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using
    cloudera manager. I
    selected a non root user on SSH credentials page. I
    also selected 'use
    private key' option. I am getting an error
    'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the
    other nodes.
    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The
    public keys I
    copied on all the nodes in the folder authorized_keys.
    Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving
    emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to scm-users+...@cloudera.org <javascript:>.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Hari Sekhon at Sep 22, 2013 at 10:06 pm
    If you want something a bit more protected and advanced, try eth0 Nat and eth1 hostonly network, run your hadoop cluster on the eth1 network, while eth0 is purely for nodes to access the Internet. I do this all the time.

    Regards,

    Hari Sekhon
    Cloudera
    http://www.linkedin.com/in/harisekhon

    On 21 Sep 2013, at 22:12, Todd Grayson wrote:

    Ok so I'm trying to understand your configuration approach to your VM's at this point.

    NAT is not the networking configuration you want.... its more for running a desktop vm that you just need to browse or use for casual internet access.

    See https://www.virtualbox.org/manual/ch06.html#networkingmodes

    I would suggest setting the vm's up as "Bridged" so you can network between the cluster nodes as well as access the internet without issue.

    Todd
    On 9/18/13 5:45 PM, Ashwin Bhattathiripad wrote:
    Yea I realized that. First and foremost all the nodes should have passwordless ssh access. So trying on that.
    On Thursday, September 19, 2013 2:21:06 AM UTC+10, Todd Grayson wrote:

    Take CM out of the activity completely for now. From a shell, demonstrate that you can do passwordless ssh between all of the nodes as the user you are planning to use. Once you have that working, then re-attempt through CM.

    Todd
    On 9/18/13 12:51 AM, Ashwin Bhattathiripad wrote:
    Oh I figured the problem there. I have to make my username passwordless sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to do passwordless ssh to all the nodes. I did the same things with all 5 of them but I am able to login passwordless only to one of them.

    Thanks.
    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin Bhattathiripad wrote:

    Hello Todd,

    I read the note in that section. I have done exactly that is mentioned in that article.
    I am not understanding why i am not getting passwordless access to all the nodes. I am getting passwordless access only to one node. Also, when I tried creating a single node cluster using that particular node, I am getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.

    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here under the section "networking and security"

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.
  • Ashwin Bhattathiripad at Sep 23, 2013 at 6:05 am
    Ok now I somehow managed to set up one node cluster through Cloudera VM. I
    have submitted a job to it and awaiting results. As of now its working fine
    as it is on the localhost.
    Yes, you suggested me before also regarding the networking configuration of
    switching to 'bridged'. But my vm doesnt seem to have internet access once
    I do that.

    Since i am not able to work around the nodes through cloudera VM, I have
    decided I will directly access the nodes from my windows machine through
    putty instead of using the cloudera VM. I will let you know how it goes.

    Thanks to all for the help. Really appreciate it.

    Regards,
    Ashwin
    On Sunday, September 22, 2013 7:12:18 AM UTC+10, Todd Grayson wrote:

    Ok so I'm trying to understand your configuration approach to your VM's
    at this point.

    NAT is not the networking configuration you want.... its more for running
    a desktop vm that you just need to browse or use for casual internet access.

    See https://www.virtualbox.org/manual/ch06.html#networkingmodes

    I would suggest setting the vm's up as "Bridged" so you can network
    between the cluster nodes as well as access the internet without issue.

    Todd

    On 9/18/13 5:45 PM, Ashwin Bhattathiripad wrote:

    Yea I realized that. First and foremost all the nodes should have
    passwordless ssh access. So trying on that.
    On Thursday, September 19, 2013 2:21:06 AM UTC+10, Todd Grayson wrote:

    Take CM out of the activity completely for now. From a shell,
    demonstrate that you can do passwordless ssh between all of the nodes as
    the user you are planning to use. Once you have that working, then
    re-attempt through CM.

    Todd

    On 9/18/13 12:51 AM, Ashwin Bhattathiripad wrote:

    Oh I figured the problem there. I have to make my username passwordless
    sudo in all the nodes.

    I have got one more doubt. Do you have any idea why I am not able to do
    passwordless ssh to all the nodes. I did the same things with all 5 of them
    but I am able to login passwordless only to one of them.

    Thanks.

    On Wednesday, September 18, 2013 3:46:34 PM UTC+10, Ashwin Bhattathiripad
    wrote:
    Hello Todd,

    I read the note in that section. I have done exactly that is mentioned
    in that article.
    I am not understanding why i am not getting passwordless access to all
    the nodes. I am getting passwordless access only to one node. Also, when I
    tried creating a single node cluster using that particular node, I am
    getting 'failed to detect root privileges'.

    PS: The user I am using has passwordless sudo permissions.

    Thanks.

    On Wednesday, September 18, 2013 2:39:20 PM UTC+10, Todd Grayson wrote:

    Please review the note here under the section "networking and security"


    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_cm_requirements.html?scroll=cmig_topic_4

    Todd



    On 9/17/13 9:57 PM, Ashwin Bhattathiripad wrote:
    Hello,

    I am trying to make a cluster with 5 nodes using cloudera manager. I
    selected a non root user on SSH credentials page. I also selected 'use
    private key' option. I am getting an error 'Installation failed.
    Failed to detect root privileges' for one of the nodes; and
    'Installation failed. Failed to authenticate.' for the other nodes.

    I realize its mainly because access to these nodes are password
    protected. So I created private and public keys. The public keys I
    copied on all the nodes in the folder authorized_keys. Still its not
    working.
    Did I miss anything?

    Does anyone has a suggestion to fix this issue?

    Thanks,
    Ashwin
    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org.
    To unsubscribe from this group and stop receiving emails from it,
    send an email to scm-users+...@cloudera.org.


    To unsubscribe from this group and stop receiving emails from it, send
    an email to scm-users+...@cloudera.org <javascript:>.

    To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedSep 18, '13 at 3:57a
activeSep 23, '13 at 6:05a
posts20
users4
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase