FAQ
Hello All,

While installing CDH4 via cloudera manager , getting python dependency
problem.
SEnding logs.

*Version : 4.6.2 *
*Release : 1.cm462.p0.187 *
*BEGIN sudo yum -y install cloudera-manager-agent *
*Loaded plugins: fastestmirror *
*Loading mirror speeds from cached hostfile *
*Setting up Install Process *
*Parsing package install arguments *
*Resolving Dependencies *
*--> Running transaction check *
*---> Package cloudera-manager-agent.x86_64 0:4.6.2-1.cm462.p0.187 set to
be updated *
*--> Processing Dependency: python >= 2.4.3-43 for package:
cloudera-manager-agent *
*--> Finished Dependency Resolution *
*cloudera-manager-agent-4.6.2-1.cm462.p0.187.x86_64 from cloudera-manager
has depsolving problems *
*--> Missing Dependency: python >= 2.4.3-43 is needed by package
cloudera-manager-agent-4.6.2-1.cm462.p0.187.x86_64 (cloudera-manager) *
*Error: Missing Dependency: python >= 2.4.3-43 is needed by package
cloudera-manager-agent-4.6.2-1.cm462.p0.187.x86_64 (cloudera-manager) *
*END (1) *
*remote package cloudera-manager-agent could not be installed, giving up *
*waiting for rollback request*


But I've put a python upgrade to 2.7.5 and python -V is output 2.7.5
I can not think where the problem!!
Can anybody help me!
--
Thanks & Regards
shadow_zq

Search Discussions

  • Shadow_zq at Aug 9, 2013 at 1:42 am
    Hi Philip,
    OS is centos 5.3
    I am using a local repository, Downloaded from the following

    http://archive.cloudera.com/cm4/repo-as-tarball/4.6.2/cm4.6.2-centos5.tar.gz

    http://archive.cloudera.com/cdh4/repo-as-tarball/4.3.0/cdh4.3.0-centos5.tar.gz

    http://archive.cloudera.com/cm4/installer/4.6.2.1/cloudera-manager-installer.bin

    I downloaded wrong? or the cloudera-manager-installer.bin is wrong


    On Friday, August 9, 2013 4:14:01 AM UTC+8, Philip Zeyliger wrote:

    Hi shadow_zq,

    Given your error message, I'll bet that you're trying to install the RH5
    packages on RH6, and this doesn't work. What is the repo that yum is
    using, and what OS are you on?

    -- Philip


    On Thu, Aug 8, 2013 at 11:22 AM, shadow_zq <zhangqi...@126.com<javascript:>
    wrote:
    Hello All,

    While installing CDH4 via cloudera manager , getting python dependency
    problem.
    SEnding logs.

    *Version : 4.6.2 *
    *Release : 1.cm462.p0.187 *
    *BEGIN sudo yum -y install cloudera-manager-agent *
    *Loaded plugins: fastestmirror *
    *Loading mirror speeds from cached hostfile *
    *Setting up Install Process *
    *Parsing package install arguments *
    *Resolving Dependencies *
    *--> Running transaction check *
    *---> Package cloudera-manager-agent.x86_64 0:4.6.2-1.cm462.p0.187 set
    to be updated *
    *--> Processing Dependency: python >= 2.4.3-43 for package:
    cloudera-manager-agent *
    *--> Finished Dependency Resolution *
    *cloudera-manager-agent-4.6.2-1.cm462.p0.187.x86_64 from
    cloudera-manager has depsolving problems *
    *--> Missing Dependency: python >= 2.4.3-43 is needed by package
    cloudera-manager-agent-4.6.2-1.cm462.p0.187.x86_64 (cloudera-manager) *
    *Error: Missing Dependency: python >= 2.4.3-43 is needed by package
    cloudera-manager-agent-4.6.2-1.cm462.p0.187.x86_64 (cloudera-manager) *
    *END (1) *
    *remote package cloudera-manager-agent could not be installed, giving up
    *
    *waiting for rollback request*


    But I've put a python upgrade to 2.7.5 and python -V is output 2.7.5
    I can not think where the problem!!
    Can anybody help me!
    --
    Thanks & Regards
    shadow_zq
  • Shadow_zq at Aug 12, 2013 at 6:43 am
    Hi Todd :
    you are right,I having a mix of path A, path B and path C. I follow
    "path C" and success
    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_install_path_C.html
    THS
    On Friday, August 9, 2013 11:10:46 AM UTC+8, Todd Grayson wrote:

    Shadow_zq,

    It appears that types of installation are being mixed here. Most likely
    you want to follow "path B".


    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_install_path_B.html

    Also review this content here, as it covers setting up your own repo:


    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CM4Ent/latest/Cloudera-Manager-Installation-Guide/cmig_custom_installation.html

    In what you provided below, it appears that there is a mix of path A and
    Path B type installations, with Path C. This will result in things getting
    confused and a failed installation.

    Please review these documentation links and then let us know if there are
    further questions.

    Todd


    On 8/8/13 7:42 PM, shadow_zq wrote:

    Hi Philip,
    OS is centos 5.3
    I am using a local repository, Downloaded from the following


    http://archive.cloudera.com/cm4/repo-as-tarball/4.6.2/cm4.6.2-centos5.tar.gz


    http://archive.cloudera.com/cdh4/repo-as-tarball/4.3.0/cdh4.3.0-centos5.tar.gz


    http://archive.cloudera.com/cm4/installer/4.6.2.1/cloudera-manager-installer.bin

    I downloaded wrong? or the cloudera-manager-installer.bin is wrong


    On Friday, August 9, 2013 4:14:01 AM UTC+8, Philip Zeyliger wrote:

    Hi shadow_zq,

    Given your error message, I'll bet that you're trying to install the
    RH5 packages on RH6, and this doesn't work. What is the repo that yum is
    using, and what OS are you on?

    -- Philip

    On Thu, Aug 8, 2013 at 11:22 AM, shadow_zq wrote:

    Hello All,

    While installing CDH4 via cloudera manager , getting python dependency
    problem.
    SEnding logs.

    *Version : 4.6.2 *
    *Release : 1.cm462.p0.187 *
    *BEGIN sudo yum -y install cloudera-manager-agent *
    *Loaded plugins: fastestmirror *
    *Loading mirror speeds from cached hostfile *
    *Setting up Install Process *
    *Parsing package install arguments *
    *Resolving Dependencies *
    *--> Running transaction check *
    *---> Package cloudera-manager-agent.x86_64 0:4.6.2-1.cm462.p0.187 set
    to be updated *
    *--> Processing Dependency: python >= 2.4.3-43 for package:
    cloudera-manager-agent *
    *--> Finished Dependency Resolution *
    *cloudera-manager-agent-4.6.2-1.cm462.p0.187.x86_64 from
    cloudera-manager has depsolving problems *
    *--> Missing Dependency: python >= 2.4.3-43 is needed by package
    cloudera-manager-agent-4.6.2-1.cm462.p0.187.x86_64 (cloudera-manager) *
    *Error: Missing Dependency: python >= 2.4.3-43 is needed by package
    cloudera-manager-agent-4.6.2-1.cm462.p0.187.x86_64 (cloudera-manager) *
    *END (1) *
    *remote package cloudera-manager-agent could not be installed, giving
    up *
    *waiting for rollback request*


    But I've put a python upgrade to 2.7.5 and python -V is output 2.7.5
    I can not think where the problem!!
    Can anybody help me!
    --
    Thanks & Regards
    shadow_zq

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedAug 8, '13 at 6:22p
activeAug 12, '13 at 6:43a
posts3
users1
websitecloudera.com
irc#hadoop

1 user in discussion

Shadow_zq: 3 posts

People

Translate

site design / logo © 2022 Grokbase