FAQ
Hi,

I am trying to deploy a gateway on a Centos 6.3 host but fails when it
tries to install the cloudera-manager-agent:
Error: Package: glibc-2.12-1.80.el6.i686 (base)


I tried install glibc-2.12-1.80.el6.i686 directly from the host but I'm
getting this error:

--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.80.el6.i686 (base)
            Requires: glibc-common = 2.12-1.80.el6
            Installed: glibc-common-2.12-1.80.el6_3.6.x86_64
(@oni-updates/$releasever)
                glibc-common = 2.12-1.80.el6_3.6
            Available: glibc-common-2.12-1.80.el6.x86_64 (base)
                glibc-common = 2.12-1.80.el6
            Available: glibc-common-2.12-1.80.el6_3.3.x86_64 (updates)
                glibc-common = 2.12-1.80.el6_3.3
            Available: glibc-common-2.12-1.80.el6_3.4.x86_64 (updates)
                glibc-common = 2.12-1.80.el6_3.4
            Available: glibc-common-2.12-1.80.el6_3.5.x86_64 (updates)
                glibc-common = 2.12-1.80.el6_3.5
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest


Any suggestions?

Search Discussions

  • Wongster80 at Jul 18, 2013 at 5:18 am
    Probably should mention that it's a Centos 6.3 installation on a x86_64
    platform
    On Wednesday, July 17, 2013 10:11:43 PM UTC-7, wongster80 wrote:

    Hi,

    I am trying to deploy a gateway on a Centos 6.3 host but fails when it
    tries to install the cloudera-manager-agent:
    Error: Package: glibc-2.12-1.80.el6.i686 (base)


    I tried install glibc-2.12-1.80.el6.i686 directly from the host but I'm
    getting this error:

    --> Finished Dependency Resolution
    Error: Package: glibc-2.12-1.80.el6.i686 (base)
    Requires: glibc-common = 2.12-1.80.el6
    Installed: glibc-common-2.12-1.80.el6_3.6.x86_64
    (@oni-updates/$releasever)
    glibc-common = 2.12-1.80.el6_3.6
    Available: glibc-common-2.12-1.80.el6.x86_64 (base)
    glibc-common = 2.12-1.80.el6
    Available: glibc-common-2.12-1.80.el6_3.3.x86_64 (updates)
    glibc-common = 2.12-1.80.el6_3.3
    Available: glibc-common-2.12-1.80.el6_3.4.x86_64 (updates)
    glibc-common = 2.12-1.80.el6_3.4
    Available: glibc-common-2.12-1.80.el6_3.5.x86_64 (updates)
    glibc-common = 2.12-1.80.el6_3.5
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest


    Any suggestions?
  • Allan at Jul 18, 2013 at 11:23 am
    try

    yum -v install glibc



    Sent from my iPad
    On Jul 18, 2013, at 1:11 AM, wongster80 wrote:

    Hi,

    I am trying to deploy a gateway on a Centos 6.3 host but fails when it tries to install the cloudera-manager-agent:
    Error: Package: glibc-2.12-1.80.el6.i686 (base)


    I tried install glibc-2.12-1.80.el6.i686 directly from the host but I'm getting this error:

    --> Finished Dependency Resolution
    Error: Package: glibc-2.12-1.80.el6.i686 (base)
    Requires: glibc-common = 2.12-1.80.el6
    Installed: glibc-common-2.12-1.80.el6_3.6.x86_64 (@oni-updates/$releasever)
    glibc-common = 2.12-1.80.el6_3.6
    Available: glibc-common-2.12-1.80.el6.x86_64 (base)
    glibc-common = 2.12-1.80.el6
    Available: glibc-common-2.12-1.80.el6_3.3.x86_64 (updates)
    glibc-common = 2.12-1.80.el6_3.3
    Available: glibc-common-2.12-1.80.el6_3.4.x86_64 (updates)
    glibc-common = 2.12-1.80.el6_3.4
    Available: glibc-common-2.12-1.80.el6_3.5.x86_64 (updates)
    glibc-common = 2.12-1.80.el6_3.5
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest


    Any suggestions?
  • Wongster80 at Jul 19, 2013 at 6:11 pm
    Hi,

    It looks like an issue with Redhat/Centos
    itself https://bugzilla.redhat.com/show_bug.cgi?id=911675
    What I ended up doing is downgrading a bunch of rpms to satisfy 4.6 agent
    installation:
      yum --disablerepo=updates downgrade glibc glibc-common
    yum --disablerepo=updates downgrade cups-libs
    yum --disablerepo=updates install db4
    yum --disablerepo=updates downgrade cyrus-sasl*

    I'm going to try updating my centos63 update repo and try moving to
    centos64


    Thanks
    On Thursday, July 18, 2013 4:23:37 AM UTC-7, Allan Wilson wrote:

    try

    yum -v install glibc



    Sent from my iPad

    On Jul 18, 2013, at 1:11 AM, wongster80 <aidan...@openx.com <javascript:>>
    wrote:

    Hi,

    I am trying to deploy a gateway on a Centos 6.3 host but fails when it
    tries to install the cloudera-manager-agent:
    Error: Package: glibc-2.12-1.80.el6.i686 (base)


    I tried install glibc-2.12-1.80.el6.i686 directly from the host but I'm
    getting this error:

    --> Finished Dependency Resolution
    Error: Package: glibc-2.12-1.80.el6.i686 (base)
    Requires: glibc-common = 2.12-1.80.el6
    Installed: glibc-common-2.12-1.80.el6_3.6.x86_64
    (@oni-updates/$releasever)
    glibc-common = 2.12-1.80.el6_3.6
    Available: glibc-common-2.12-1.80.el6.x86_64 (base)
    glibc-common = 2.12-1.80.el6
    Available: glibc-common-2.12-1.80.el6_3.3.x86_64 (updates)
    glibc-common = 2.12-1.80.el6_3.3
    Available: glibc-common-2.12-1.80.el6_3.4.x86_64 (updates)
    glibc-common = 2.12-1.80.el6_3.4
    Available: glibc-common-2.12-1.80.el6_3.5.x86_64 (updates)
    glibc-common = 2.12-1.80.el6_3.5
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest


    Any suggestions?

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedJul 18, '13 at 5:11a
activeJul 19, '13 at 6:11p
posts4
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Wongster80: 3 posts Allan: 1 post

People

Translate

site design / logo © 2022 Grokbase