FAQ
Hi,

I am trying to disable dfs.permissions in a test env using CM4.5 CDH4.3 via
UI option: Service-Wide/Check HDFS Permissions(dfs.permissions).

It is not taking affect. Is this a known issue in CM / CDH, is there any
work-around for this?

Thanks,
Jee

Search Discussions

  • bc Wong at Jun 28, 2013 at 7:07 pm
    Did you restart HDFS after that?

    If you've already done that, then could you go to: CM -> HDFS -> NN ->
    Processes -> "Show" config/environment for NN, and attach the
    hdfs-site.xml?

    Cheers,
    bc
    On Fri, Jun 28, 2013 at 10:16 AM, jee wrote:
    Hi,

    I am trying to disable dfs.permissions in a test env using CM4.5 CDH4.3 via
    UI option: Service-Wide/Check HDFS Permissions(dfs.permissions).

    It is not taking affect. Is this a known issue in CM / CDH, is there any
    work-around for this?

    Thanks,
    Jee
  • Tony Li Xu at Jun 28, 2013 at 8:19 pm
    Hi Wong:

    Just out of my curiosity, I tried disable HDFS permissions in our testing
    cluster, by set "Service->Service hdfs1->Configuration->Service-Wide->check
    HDFS Permissions" to false. Now in "CM -> HDFS -> NN ->
    Processes -> "Show" config/environment for NN", I can see the snippet:

    <property>
         <name>dfs.permissions</name>
         <value>false</value>
       </property>

    is in the hdfs-site.xml, however in my namenode server,
    /etc/hadoop/conf/hdfs-site.xml, the above snippet is not there. Even I
    did a "Deploy Client Configuration", I do have all my nodes set up as
    Gateway.

    --

    Tony


    On Fri, Jun 28, 2013 at 3:06 PM, bc Wong wrote:

    Did you restart HDFS after that?

    If you've already done that, then could you go to: CM -> HDFS -> NN ->
    Processes -> "Show" config/environment for NN, and attach the
    hdfs-site.xml?

    Cheers,
    bc
    On Fri, Jun 28, 2013 at 10:16 AM, jee wrote:
    Hi,

    I am trying to disable dfs.permissions in a test env using CM4.5 CDH4.3 via
    UI option: Service-Wide/Check HDFS Permissions(dfs.permissions).

    It is not taking affect. Is this a known issue in CM / CDH, is there any
    work-around for this?

    Thanks,
    Jee
  • bc Wong at Jun 28, 2013 at 8:24 pm
    /etc/hadoop/conf/hdfs-site.xml is only used by clients. Under CM
    management, the daemons don't read that. So, dfs.permissions is
    actually off. (You just think that it isn't.)

    Cheers,
    bc
    On Fri, Jun 28, 2013 at 1:19 PM, Tony Li Xu wrote:
    Hi Wong:

    Just out of my curiosity, I tried disable HDFS permissions in our testing
    cluster, by set "Service->Service hdfs1->Configuration->Service-Wide->check
    HDFS Permissions" to false. Now in "CM -> HDFS -> NN ->
    Processes -> "Show" config/environment for NN", I can see the snippet:

    <property>
    <name>dfs.permissions</name>
    <value>false</value>
    </property>

    is in the hdfs-site.xml, however in my namenode server,
    /etc/hadoop/conf/hdfs-site.xml, the above snippet is not there. Even I did a
    "Deploy Client Configuration", I do have all my nodes set up as Gateway.

    --

    Tony


    On Fri, Jun 28, 2013 at 3:06 PM, bc Wong wrote:

    Did you restart HDFS after that?

    If you've already done that, then could you go to: CM -> HDFS -> NN ->
    Processes -> "Show" config/environment for NN, and attach the
    hdfs-site.xml?

    Cheers,
    bc
    On Fri, Jun 28, 2013 at 10:16 AM, jee wrote:
    Hi,

    I am trying to disable dfs.permissions in a test env using CM4.5 CDH4.3
    via
    UI option: Service-Wide/Check HDFS Permissions(dfs.permissions).

    It is not taking affect. Is this a known issue in CM / CDH, is there any
    work-around for this?

    Thanks,
    Jee
  • Tony Li Xu at Jun 28, 2013 at 8:31 pm
    I thought the "Deploy Client Configuration" would update and insert
    "dfs.permissions"
    into /etc/hadoop/conf/hdfs-site.xml file..

    Anyway, good to know this.

    Thanks Wong! :)

    --
    Tony

    On Fri, Jun 28, 2013 at 4:23 PM, bc Wong wrote:

    /etc/hadoop/conf/hdfs-site.xml is only used by clients. Under CM
    management, the daemons don't read that. So, dfs.permissions is
    actually off. (You just think that it isn't.)

    Cheers,
    bc
    On Fri, Jun 28, 2013 at 1:19 PM, Tony Li Xu wrote:
    Hi Wong:

    Just out of my curiosity, I tried disable HDFS permissions in our testing
    cluster, by set "Service->Service
    hdfs1->Configuration->Service-Wide->check
    HDFS Permissions" to false. Now in "CM -> HDFS -> NN ->
    Processes -> "Show" config/environment for NN", I can see the snippet:

    <property>
    <name>dfs.permissions</name>
    <value>false</value>
    </property>

    is in the hdfs-site.xml, however in my namenode server,
    /etc/hadoop/conf/hdfs-site.xml, the above snippet is not there. Even I did a
    "Deploy Client Configuration", I do have all my nodes set up as Gateway.

    --

    Tony


    On Fri, Jun 28, 2013 at 3:06 PM, bc Wong wrote:

    Did you restart HDFS after that?

    If you've already done that, then could you go to: CM -> HDFS -> NN ->
    Processes -> "Show" config/environment for NN, and attach the
    hdfs-site.xml?

    Cheers,
    bc
    On Fri, Jun 28, 2013 at 10:16 AM, jee wrote:
    Hi,

    I am trying to disable dfs.permissions in a test env using CM4.5
    CDH4.3
    via
    UI option: Service-Wide/Check HDFS Permissions(dfs.permissions).

    It is not taking affect. Is this a known issue in CM / CDH, is there
    any
    work-around for this?

    Thanks,
    Jee
  • bc Wong at Jun 28, 2013 at 9:10 pm
    That's because "dfs.permissions" has nothing to do with clients.
    Exposing it to clients would cause more confusion.
    On Fri, Jun 28, 2013 at 1:31 PM, Tony Li Xu wrote:
    I thought the "Deploy Client Configuration" would update and insert
    "dfs.permissions" into /etc/hadoop/conf/hdfs-site.xml file..

    Anyway, good to know this.

    Thanks Wong! :)

    --
    Tony

    On Fri, Jun 28, 2013 at 4:23 PM, bc Wong wrote:

    /etc/hadoop/conf/hdfs-site.xml is only used by clients. Under CM
    management, the daemons don't read that. So, dfs.permissions is
    actually off. (You just think that it isn't.)

    Cheers,
    bc
    On Fri, Jun 28, 2013 at 1:19 PM, Tony Li Xu wrote:
    Hi Wong:

    Just out of my curiosity, I tried disable HDFS permissions in our
    testing
    cluster, by set "Service->Service
    hdfs1->Configuration->Service-Wide->check
    HDFS Permissions" to false. Now in "CM -> HDFS -> NN ->
    Processes -> "Show" config/environment for NN", I can see the snippet:

    <property>
    <name>dfs.permissions</name>
    <value>false</value>
    </property>

    is in the hdfs-site.xml, however in my namenode server,
    /etc/hadoop/conf/hdfs-site.xml, the above snippet is not there. Even I
    did a
    "Deploy Client Configuration", I do have all my nodes set up as Gateway.

    --

    Tony


    On Fri, Jun 28, 2013 at 3:06 PM, bc Wong wrote:

    Did you restart HDFS after that?

    If you've already done that, then could you go to: CM -> HDFS -> NN ->
    Processes -> "Show" config/environment for NN, and attach the
    hdfs-site.xml?

    Cheers,
    bc
    On Fri, Jun 28, 2013 at 10:16 AM, jee wrote:
    Hi,

    I am trying to disable dfs.permissions in a test env using CM4.5
    CDH4.3
    via
    UI option: Service-Wide/Check HDFS Permissions(dfs.permissions).

    It is not taking affect. Is this a known issue in CM / CDH, is there
    any
    work-around for this?

    Thanks,
    Jee

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedJun 28, '13 at 5:16p
activeJun 28, '13 at 9:10p
posts6
users3
websitecloudera.com
irc#hadoop

3 users in discussion

bc Wong: 3 posts Tony Li Xu: 2 posts Jee: 1 post

People

Translate

site design / logo © 2022 Grokbase