FAQ
Hello!

I receive the above mentioned error despite being quite sure my
configuration is ok.

I have a DNS service up and running. Normal resolving and loopback. tested
and ok.
Additionally I have configured /etc/hosts with all IP Adresses
(e.g. 192.168.1.160 romeo0.lan romeo0)

The full error message is:
"The hostname and canonical name for this host are not consistent when
checked from a Java process."



hostname
=> romeo0

hostname -f
=> romeo0.lan

host -v -t A romeo0.lan
=>

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;romeo0.lan. IN A

;; ANSWER SECTION:
romeo0.lan. 3600 IN A 192.168.1.160

;; AUTHORITY SECTION:
lan. 3600 IN NS romeo0.lan.


dig romeo0.lan
>
; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> romeo0.lan
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;romeo0.lan. IN A

;; ANSWER SECTION:
romeo0.lan. 3600 IN A 192.168.1.160

;; AUTHORITY SECTION:
lan. 3600 IN NS romeo0.lan.

;; Query time: 0 msec
;; SERVER: 192.168.1.160#53(192.168.1.160)
>

Search Discussions

  • Brian Burton at Jun 13, 2013 at 1:13 pm
    Stefan,

    You're in luck, I just had this same question and one of our developers
    (A.B.) provided some detailed information on this:

    The DNS resolution check uses the Java InetAddress class (much like what
    Hadoop daemons typically do) to:
    1. get the local address (addr = InetAddress.getLocalHost()) and uses the
    retrieved address to
    2. get the hostname (addr.getHostName()) and the FQDN / canonicalHostName
    (addr.getCanonicalHostName())
    3. Verify that 'hostname' can be used to derive 'canonicalHostName' by
    using the info in /etc/resolv.conf
    -- 3a. If /etc/resolv.conf has an entry of the form "domain isp.domain.name",
    'hostname'.isp.domain.name should be 'canonicalHostName' for the check to
    pass.
    -- 3b. If /etc/resolv.conf has an entry of the form "search domain1.name
    domain2.name .. domainN.name", 'canonicalHostName' should be one of
    'hostname'.domain1.name, 'hostname'.domain2.name .. or
    'hostname'.domainN.name

    Here are a couple of things to check/verify:
    - Check /etc/resolv.conf on the hosts that are not 'healthy'. See what the
    domain and search lines are.romeo0.lan is not part of /etc/resolv.conf on
    those hosts and/or different from what it is on the 'healthy' hosts.
    - Look for an INFO message of the form ""hostname <hostname> differs from
    the canonical name <canonicalname>" in the agent logs
    (/var/log/cloudera-scm-agent/*.log) on the unhealthy hosts. That should
    give you the exact names being used for the check performed in step 3 above.

    Please let us know if this helps to determine the source of the health
    check failure, or if you have any questions or need clarification on
    anything.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 8:10 AM, Stefan wrote:

    Hello!

    I receive the above mentioned error despite being quite sure my
    configuration is ok.

    I have a DNS service up and running. Normal resolving and loopback. tested
    and ok.
    Additionally I have configured /etc/hosts with all IP Adresses
    (e.g. 192.168.1.160 romeo0.lan romeo0)

    The full error message is:
    "The hostname and canonical name for this host are not consistent when
    checked from a Java process."



    hostname
    => romeo0

    hostname -f
    => romeo0.lan

    host -v -t A romeo0.lan
    =>

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.


    dig romeo0.lan

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> romeo0.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.160#53(192.168.1.160)
  • Stefan at Jun 13, 2013 at 2:06 pm
    Brian,
    thanks for your reply. I checked the logs and found that the java process
    reads:
    hostname = romeo
    canonical name = romoe0.lan

    Yes I am aware of this and I believe this is correct. I configured the
    hostname as a non fully qualified name according to instructions here:
    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CDH4/4.2.0/CDH4-Installation-Guide/cdh4ig_topic_11_1.html

    Of course I can rename the hostname to romeo0.lan

    Should I do that? Still a bit confused, maybe I am missing something here.

    btw: I have no search or domain entries in resolve.conf because I assumed
    they are optinal.

    Stefan
    On Thursday, June 13, 2013 3:13:16 PM UTC+2, bdb wrote:

    Stefan,

    You're in luck, I just had this same question and one of our developers
    (A.B.) provided some detailed information on this:

    The DNS resolution check uses the Java InetAddress class (much like what
    Hadoop daemons typically do) to:
    1. get the local address (addr = InetAddress.getLocalHost()) and uses the
    retrieved address to
    2. get the hostname (addr.getHostName()) and the FQDN / canonicalHostName
    (addr.getCanonicalHostName())
    3. Verify that 'hostname' can be used to derive 'canonicalHostName' by
    using the info in /etc/resolv.conf
    -- 3a. If /etc/resolv.conf has an entry of the form "domain
    isp.domain.name", 'hostname'.isp.domain.name should be
    'canonicalHostName' for the check to pass.
    -- 3b. If /etc/resolv.conf has an entry of the form "search domain1.name
    domain2.name .. domainN.name", 'canonicalHostName' should be one of
    'hostname'.domain1.name, 'hostname'.domain2.name .. or
    'hostname'.domainN.name

    Here are a couple of things to check/verify:
    - Check /etc/resolv.conf on the hosts that are not 'healthy'. See what the
    domain and search lines are.romeo0.lan is not part of /etc/resolv.conf on
    those hosts and/or different from what it is on the 'healthy' hosts.
    - Look for an INFO message of the form ""hostname <hostname> differs from
    the canonical name <canonicalname>" in the agent logs
    (/var/log/cloudera-scm-agent/*.log) on the unhealthy hosts. That should
    give you the exact names being used for the check performed in step 3 above.

    Please let us know if this helps to determine the source of the health
    check failure, or if you have any questions or need clarification on
    anything.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>


    On Thu, Jun 13, 2013 at 8:10 AM, Stefan <stefan...@gmail.com <javascript:>
    wrote:
    Hello!

    I receive the above mentioned error despite being quite sure my
    configuration is ok.

    I have a DNS service up and running. Normal resolving and loopback.
    tested and ok.
    Additionally I have configured /etc/hosts with all IP Adresses
    (e.g. 192.168.1.160 romeo0.lan romeo0)

    The full error message is:
    "The hostname and canonical name for this host are not consistent when
    checked from a Java process."



    hostname
    => romeo0

    hostname -f
    => romeo0.lan

    host -v -t A romeo0.lan
    =>

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.


    dig romeo0.lan

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> romeo0.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.160#53(192.168.1.160)
  • Brian Burton at Jun 13, 2013 at 3:34 pm
    Stefan,

    Your setup is correct. I'll check to see what the behavior is with no
    entries in /etc/resolv.conf and get back to you.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 10:06 AM, Stefan wrote:

    Brian,
    thanks for your reply. I checked the logs and found that the java process
    reads:
    hostname = romeo
    canonical name = romoe0.lan

    Yes I am aware of this and I believe this is correct. I configured the
    hostname as a non fully qualified name according to instructions here:

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CDH4/4.2.0/CDH4-Installation-Guide/cdh4ig_topic_11_1.html

    Of course I can rename the hostname to romeo0.lan

    Should I do that? Still a bit confused, maybe I am missing something here.

    btw: I have no search or domain entries in resolve.conf because I assumed
    they are optinal.

    Stefan

    On Thursday, June 13, 2013 3:13:16 PM UTC+2, bdb wrote:

    Stefan,

    You're in luck, I just had this same question and one of our developers
    (A.B.) provided some detailed information on this:

    The DNS resolution check uses the Java InetAddress class (much like what
    Hadoop daemons typically do) to:
    1. get the local address (addr = InetAddress.getLocalHost()) and uses the
    retrieved address to
    2. get the hostname (addr.getHostName()) and the FQDN / canonicalHostName
    (addr.getCanonicalHostName())
    3. Verify that 'hostname' can be used to derive 'canonicalHostName' by
    using the info in /etc/resolv.conf
    -- 3a. If /etc/resolv.conf has an entry of the form "domain
    isp.domain.name", 'hostname'.isp.domain.name **should be
    'canonicalHostName' for the check to pass.
    -- 3b. If /etc/resolv.conf has an entry of the form "search domain1.name
    domain2.**name <http://domain2.name/> .. domainN.name",
    'canonicalHostName' should be one of 'hostname'.domain1.name, 'hostname'.
    domain2.name .. or 'hostname'.domainN.name

    Here are a couple of things to check/verify:
    - Check /etc/resolv.conf on the hosts that are not 'healthy'. See what
    the domain and search lines are.romeo0.lan is not part of /etc/resolv.conf
    on those hosts and/or different from what it is on the 'healthy' hosts.
    - Look for an INFO message of the form ""hostname <hostname> differs from
    the canonical name <canonicalname>" in the agent logs
    (/var/log/cloudera-scm-agent/***.log) on the unhealthy hosts. That
    should give you the exact names being used for the check performed in step
    3 above.

    Please let us know if this helps to determine the source of the health
    check failure, or if you have any questions or need clarification on
    anything.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 8:10 AM, Stefan wrote:

    Hello!

    I receive the above mentioned error despite being quite sure my
    configuration is ok.

    I have a DNS service up and running. Normal resolving and loopback.
    tested and ok.
    Additionally I have configured /etc/hosts with all IP Adresses
    (e.g. 192.168.1.160 romeo0.lan romeo0)

    The full error message is:
    "The hostname and canonical name for this host are not consistent when
    checked from a Java process."



    hostname
    => romeo0

    hostname -f
    => romeo0.lan

    host -v -t A romeo0.lan
    =>

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. ** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.


    dig romeo0.lan

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.**rc1.el6_4.4 <<>> romeo0.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. ** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.160#53(192.168.1.**160)
  • Stefan at Jun 13, 2013 at 4:32 pm
    Hi Brian,

    I changed the hostename in etc/sysconfig/network to the FQDN (romeo0.lan)
    and now it works.

    I dont know, maybe the support page I was referring to can be misunderstood.

    Thanks for helping me with all the infos that allowed me to solve the issue.
    Stefan
    On Thursday, June 13, 2013 5:34:16 PM UTC+2, bdb wrote:

    Stefan,

    Your setup is correct. I'll check to see what the behavior is with no
    entries in /etc/resolv.conf and get back to you.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>


    On Thu, Jun 13, 2013 at 10:06 AM, Stefan <stefan...@gmail.com<javascript:>
    wrote:
    Brian,
    thanks for your reply. I checked the logs and found that the java process
    reads:
    hostname = romeo
    canonical name = romoe0.lan

    Yes I am aware of this and I believe this is correct. I configured the
    hostname as a non fully qualified name according to instructions here:

    http://www.cloudera.com/content/cloudera-content/cloudera-docs/CDH4/4.2.0/CDH4-Installation-Guide/cdh4ig_topic_11_1.html

    Of course I can rename the hostname to romeo0.lan

    Should I do that? Still a bit confused, maybe I am missing something here.

    btw: I have no search or domain entries in resolve.conf because I assumed
    they are optinal.

    Stefan

    On Thursday, June 13, 2013 3:13:16 PM UTC+2, bdb wrote:

    Stefan,

    You're in luck, I just had this same question and one of our developers
    (A.B.) provided some detailed information on this:

    The DNS resolution check uses the Java InetAddress class (much like what
    Hadoop daemons typically do) to:
    1. get the local address (addr = InetAddress.getLocalHost()) and uses
    the retrieved address to
    2. get the hostname (addr.getHostName()) and the FQDN /
    canonicalHostName (addr.getCanonicalHostName())
    3. Verify that 'hostname' can be used to derive 'canonicalHostName' by
    using the info in /etc/resolv.conf
    -- 3a. If /etc/resolv.conf has an entry of the form "domain
    isp.domain.name", 'hostname'.isp.domain.name **should be
    'canonicalHostName' for the check to pass.
    -- 3b. If /etc/resolv.conf has an entry of the form "search domain1.name
    domain2.**name <http://domain2.name/> .. domainN.name",
    'canonicalHostName' should be one of 'hostname'.domain1.name,
    'hostname'.domain2.name .. or 'hostname'.domainN.name

    Here are a couple of things to check/verify:
    - Check /etc/resolv.conf on the hosts that are not 'healthy'. See what
    the domain and search lines are.romeo0.lan is not part of /etc/resolv.conf
    on those hosts and/or different from what it is on the 'healthy' hosts.
    - Look for an INFO message of the form ""hostname <hostname> differs
    from the canonical name <canonicalname>" in the agent logs
    (/var/log/cloudera-scm-agent/***.log) on the unhealthy hosts. That
    should give you the exact names being used for the check performed in step
    3 above.

    Please let us know if this helps to determine the source of the health
    check failure, or if you have any questions or need clarification on
    anything.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 8:10 AM, Stefan wrote:

    Hello!

    I receive the above mentioned error despite being quite sure my
    configuration is ok.

    I have a DNS service up and running. Normal resolving and loopback.
    tested and ok.
    Additionally I have configured /etc/hosts with all IP Adresses
    (e.g. 192.168.1.160 romeo0.lan romeo0)

    The full error message is:
    "The hostname and canonical name for this host are not consistent when
    checked from a Java process."



    hostname
    => romeo0

    hostname -f
    => romeo0.lan

    host -v -t A romeo0.lan
    =>

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. ** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.


    dig romeo0.lan

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.**rc1.el6_4.4 <<>> romeo0.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. ** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.160#53(192.168.1.**160)
  • Brian Burton at Jun 14, 2013 at 2:57 pm
    Stefan,

    Glad you were able to get it working. Thanks for closing the loop and
    letting us know the fix.

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 12:26 PM, Stefan wrote:

    Hi Brian,

    I changed the hostename in etc/sysconfig/network to the FQDN (romeo0.lan)
    and now it works.

    I dont know, maybe the support page I was referring to can be
    misunderstood.

    Thanks for helping me with all the infos that allowed me to solve the
    issue.
    Stefan

    On Thursday, June 13, 2013 5:34:16 PM UTC+2, bdb wrote:

    Stefan,

    Your setup is correct. I'll check to see what the behavior is with no
    entries in /etc/resolv.conf and get back to you.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 10:06 AM, Stefan wrote:

    Brian,
    thanks for your reply. I checked the logs and found that the java
    process reads:
    hostname = romeo
    canonical name = romoe0.lan

    Yes I am aware of this and I believe this is correct. I configured the
    hostname as a non fully qualified name according to instructions here:
    http://www.cloudera.com/**content/cloudera-content/**
    cloudera-docs/CDH4/4.2.0/CDH4-**Installation-Guide/cdh4ig_**
    topic_11_1.html<http://www.cloudera.com/content/cloudera-content/cloudera-docs/CDH4/4.2.0/CDH4-Installation-Guide/cdh4ig_topic_11_1.html>

    Of course I can rename the hostname to romeo0.lan

    Should I do that? Still a bit confused, maybe I am missing something
    here.

    btw: I have no search or domain entries in resolve.conf because I
    assumed they are optinal.

    Stefan

    On Thursday, June 13, 2013 3:13:16 PM UTC+2, bdb wrote:

    Stefan,

    You're in luck, I just had this same question and one of our developers
    (A.B.) provided some detailed information on this:

    The DNS resolution check uses the Java InetAddress class (much like
    what Hadoop daemons typically do) to:
    1. get the local address (addr = InetAddress.getLocalHost()) and uses
    the retrieved address to
    2. get the hostname (addr.getHostName()) and the FQDN /
    canonicalHostName (addr.getCanonicalHostName())
    3. Verify that 'hostname' can be used to derive 'canonicalHostName' by
    using the info in /etc/resolv.conf
    -- 3a. If /etc/resolv.conf has an entry of the form "domain
    isp.domain.name", 'hostname'.isp.domain.name **sho**uld be
    'canonicalHostName' for the check to pass.
    -- 3b. If /etc/resolv.conf has an entry of the form "search
    domain1.name domain2.**n**ame <http://domain2.name/> .. domainN.name",
    'canonicalHostName' should be one of 'hostname'.domain1.name,
    'hostname'.domain2.name .. or 'hostname'.domainN.name

    Here are a couple of things to check/verify:
    - Check /etc/resolv.conf on the hosts that are not 'healthy'. See what
    the domain and search lines are.romeo0.lan is not part of /etc/resolv.conf
    on those hosts and/or different from what it is on the 'healthy' hosts.
    - Look for an INFO message of the form ""hostname <hostname> differs
    from the canonical name <canonicalname>" in the agent logs
    (/var/log/cloudera-scm-agent/*****.log) on the unhealthy hosts. That
    should give you the exact names being used for the check performed in step
    3 above.

    Please let us know if this helps to determine the source of the health
    check failure, or if you have any questions or need clarification on
    anything.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 8:10 AM, Stefan wrote:

    Hello!

    I receive the above mentioned error despite being quite sure my
    configuration is ok.

    I have a DNS service up and running. Normal resolving and loopback.
    tested and ok.
    Additionally I have configured /etc/hosts with all IP Adresses
    (e.g. 192.168.1.160 romeo0.lan romeo0)

    The full error message is:
    "The hostname and canonical name for this host are not consistent when
    checked from a Java process."



    hostname
    => romeo0

    hostname -f
    => romeo0.lan

    host -v -t A romeo0.lan
    =>

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL:


    ;; QUESTION SECTION:
    ;romeo0.lan. **** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.


    dig romeo0.lan

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.**rc1**.el6_4.4 <<>> romeo0.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL:


    ;; QUESTION SECTION:
    ;romeo0.lan. **** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.160#53(192.168.1.**160**)
  • Nicholas Roberts at Jun 15, 2013 at 1:26 am
    this hostname as FQDN issue stumped me on Ubuntu 12 also

    on my previous version of CM I was able to use node1 but on this version of
    CM I needed node1.lan

    also, note, Ubuntu no longer has resolv.conf like it used to
    http://askubuntu.com/questions/130452/how-do-i-add-a-dns-server-via-resolv-conf
    On Friday, June 14, 2013 7:57:55 AM UTC-7, bdb wrote:

    Stefan,

    Glad you were able to get it working. Thanks for closing the loop and
    letting us know the fix.

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>


    On Thu, Jun 13, 2013 at 12:26 PM, Stefan <stefan...@gmail.com<javascript:>
    wrote:
    Hi Brian,

    I changed the hostename in etc/sysconfig/network to the FQDN (romeo0.lan)
    and now it works.

    I dont know, maybe the support page I was referring to can be
    misunderstood.

    Thanks for helping me with all the infos that allowed me to solve the
    issue.
    Stefan

    On Thursday, June 13, 2013 5:34:16 PM UTC+2, bdb wrote:

    Stefan,

    Your setup is correct. I'll check to see what the behavior is with no
    entries in /etc/resolv.conf and get back to you.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 10:06 AM, Stefan wrote:

    Brian,
    thanks for your reply. I checked the logs and found that the java
    process reads:
    hostname = romeo
    canonical name = romoe0.lan

    Yes I am aware of this and I believe this is correct. I configured the
    hostname as a non fully qualified name according to instructions here:
    http://www.cloudera.com/**content/cloudera-content/**
    cloudera-docs/CDH4/4.2.0/CDH4-**Installation-Guide/cdh4ig_**
    topic_11_1.html<http://www.cloudera.com/content/cloudera-content/cloudera-docs/CDH4/4.2.0/CDH4-Installation-Guide/cdh4ig_topic_11_1.html>

    Of course I can rename the hostname to romeo0.lan

    Should I do that? Still a bit confused, maybe I am missing something
    here.

    btw: I have no search or domain entries in resolve.conf because I
    assumed they are optinal.

    Stefan

    On Thursday, June 13, 2013 3:13:16 PM UTC+2, bdb wrote:

    Stefan,

    You're in luck, I just had this same question and one of our
    developers (A.B.) provided some detailed information on this:

    The DNS resolution check uses the Java InetAddress class (much like
    what Hadoop daemons typically do) to:
    1. get the local address (addr = InetAddress.getLocalHost()) and uses
    the retrieved address to
    2. get the hostname (addr.getHostName()) and the FQDN /
    canonicalHostName (addr.getCanonicalHostName())
    3. Verify that 'hostname' can be used to derive 'canonicalHostName' by
    using the info in /etc/resolv.conf
    -- 3a. If /etc/resolv.conf has an entry of the form "domain
    isp.domain.name", 'hostname'.isp.domain.name **sho**uld be
    'canonicalHostName' for the check to pass.
    -- 3b. If /etc/resolv.conf has an entry of the form "search
    domain1.name domain2.**n**ame <http://domain2.name/> ..
    domainN.name", 'canonicalHostName' should be one of 'hostname'.
    domain1.name, 'hostname'.domain2.name .. or 'hostname'.domainN.name

    Here are a couple of things to check/verify:
    - Check /etc/resolv.conf on the hosts that are not 'healthy'. See what
    the domain and search lines are.romeo0.lan is not part of /etc/resolv.conf
    on those hosts and/or different from what it is on the 'healthy' hosts.
    - Look for an INFO message of the form ""hostname <hostname> differs
    from the canonical name <canonicalname>" in the agent logs
    (/var/log/cloudera-scm-agent/*****.log) on the unhealthy hosts. That
    should give you the exact names being used for the check performed in step
    3 above.

    Please let us know if this helps to determine the source of the health
    check failure, or if you have any questions or need clarification on
    anything.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 8:10 AM, Stefan wrote:

    Hello!

    I receive the above mentioned error despite being quite sure my
    configuration is ok.

    I have a DNS service up and running. Normal resolving and loopback.
    tested and ok.
    Additionally I have configured /etc/hosts with all IP Adresses
    (e.g. 192.168.1.160 romeo0.lan romeo0)

    The full error message is:
    "The hostname and canonical name for this host are not consistent
    when checked from a Java process."



    hostname
    => romeo0

    hostname -f
    => romeo0.lan

    host -v -t A romeo0.lan
    =>

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1,
    ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. **** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.


    dig romeo0.lan

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.**rc1**.el6_4.4 <<>> romeo0.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1,
    ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. **** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.160#53(192.168.1.**160**)
  • Manal Helal at Jun 30, 2013 at 7:25 pm
    Hi,

    I am having the same problem in both ubunto and CentOS data nodes, and I
    don't have a "search" line in the /etc/resolv.conf in the problematic
    nodes, so I added it because it is the only different line between the
    healthy and unhealthy nodes.

    # Generated by NetworkManager
    search 8.8.4.4 CentOS
    nameserver 8.8.8.8


    Is there a way to solve it permanently, it comes back, because the file
    keeps getting re-written,


    thank you very much,
    On Friday, 14 June 2013 16:57:55 UTC+2, bdb wrote:

    Stefan,

    Glad you were able to get it working. Thanks for closing the loop and
    letting us know the fix.

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>


    On Thu, Jun 13, 2013 at 12:26 PM, Stefan <stefan...@gmail.com<javascript:>
    wrote:
    Hi Brian,

    I changed the hostename in etc/sysconfig/network to the FQDN (romeo0.lan)
    and now it works.

    I dont know, maybe the support page I was referring to can be
    misunderstood.

    Thanks for helping me with all the infos that allowed me to solve the
    issue.
    Stefan

    On Thursday, June 13, 2013 5:34:16 PM UTC+2, bdb wrote:

    Stefan,

    Your setup is correct. I'll check to see what the behavior is with no
    entries in /etc/resolv.conf and get back to you.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 10:06 AM, Stefan wrote:

    Brian,
    thanks for your reply. I checked the logs and found that the java
    process reads:
    hostname = romeo
    canonical name = romoe0.lan

    Yes I am aware of this and I believe this is correct. I configured the
    hostname as a non fully qualified name according to instructions here:
    http://www.cloudera.com/**content/cloudera-content/**
    cloudera-docs/CDH4/4.2.0/CDH4-**Installation-Guide/cdh4ig_**
    topic_11_1.html<http://www.cloudera.com/content/cloudera-content/cloudera-docs/CDH4/4.2.0/CDH4-Installation-Guide/cdh4ig_topic_11_1.html>

    Of course I can rename the hostname to romeo0.lan

    Should I do that? Still a bit confused, maybe I am missing something
    here.

    btw: I have no search or domain entries in resolve.conf because I
    assumed they are optinal.

    Stefan

    On Thursday, June 13, 2013 3:13:16 PM UTC+2, bdb wrote:

    Stefan,

    You're in luck, I just had this same question and one of our
    developers (A.B.) provided some detailed information on this:

    The DNS resolution check uses the Java InetAddress class (much like
    what Hadoop daemons typically do) to:
    1. get the local address (addr = InetAddress.getLocalHost()) and uses
    the retrieved address to
    2. get the hostname (addr.getHostName()) and the FQDN /
    canonicalHostName (addr.getCanonicalHostName())
    3. Verify that 'hostname' can be used to derive 'canonicalHostName' by
    using the info in /etc/resolv.conf
    -- 3a. If /etc/resolv.conf has an entry of the form "domain
    isp.domain.name", 'hostname'.isp.domain.name **sho**uld be
    'canonicalHostName' for the check to pass.
    -- 3b. If /etc/resolv.conf has an entry of the form "search
    domain1.name domain2.**n**ame <http://domain2.name/> ..
    domainN.name", 'canonicalHostName' should be one of 'hostname'.
    domain1.name, 'hostname'.domain2.name .. or 'hostname'.domainN.name

    Here are a couple of things to check/verify:
    - Check /etc/resolv.conf on the hosts that are not 'healthy'. See what
    the domain and search lines are.romeo0.lan is not part of /etc/resolv.conf
    on those hosts and/or different from what it is on the 'healthy' hosts.
    - Look for an INFO message of the form ""hostname <hostname> differs
    from the canonical name <canonicalname>" in the agent logs
    (/var/log/cloudera-scm-agent/*****.log) on the unhealthy hosts. That
    should give you the exact names being used for the check performed in step
    3 above.

    Please let us know if this helps to determine the source of the health
    check failure, or if you have any questions or need clarification on
    anything.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 8:10 AM, Stefan wrote:

    Hello!

    I receive the above mentioned error despite being quite sure my
    configuration is ok.

    I have a DNS service up and running. Normal resolving and loopback.
    tested and ok.
    Additionally I have configured /etc/hosts with all IP Adresses
    (e.g. 192.168.1.160 romeo0.lan romeo0)

    The full error message is:
    "The hostname and canonical name for this host are not consistent
    when checked from a Java process."



    hostname
    => romeo0

    hostname -f
    => romeo0.lan

    host -v -t A romeo0.lan
    =>

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1,
    ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. **** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.


    dig romeo0.lan

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.**rc1**.el6_4.4 <<>> romeo0.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1,
    ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. **** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.160#53(192.168.1.**160**)
  • Philip Langdale at Jul 1, 2013 at 6:50 pm
    As it says, NetworkManager generates that file. You'd want to configure
    network manager to use a specific server and search domain, etc.

    --phil

    On 30 June 2013 12:25, Manal Helal wrote:

    Hi,

    I am having the same problem in both ubunto and CentOS data nodes, and I
    don't have a "search" line in the /etc/resolv.conf in the problematic
    nodes, so I added it because it is the only different line between the
    healthy and unhealthy nodes.

    # Generated by NetworkManager
    search 8.8.4.4 CentOS
    nameserver 8.8.8.8


    Is there a way to solve it permanently, it comes back, because the file
    keeps getting re-written,


    thank you very much,
    On Friday, 14 June 2013 16:57:55 UTC+2, bdb wrote:

    Stefan,

    Glad you were able to get it working. Thanks for closing the loop and
    letting us know the fix.

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 12:26 PM, Stefan wrote:

    Hi Brian,

    I changed the hostename in etc/sysconfig/network to the FQDN
    (romeo0.lan) and now it works.

    I dont know, maybe the support page I was referring to can be
    misunderstood.

    Thanks for helping me with all the infos that allowed me to solve the
    issue.
    Stefan

    On Thursday, June 13, 2013 5:34:16 PM UTC+2, bdb wrote:

    Stefan,

    Your setup is correct. I'll check to see what the behavior is with no
    entries in /etc/resolv.conf and get back to you.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 10:06 AM, Stefan wrote:

    Brian,
    thanks for your reply. I checked the logs and found that the java
    process reads:
    hostname = romeo
    canonical name = romoe0.lan

    Yes I am aware of this and I believe this is correct. I configured the
    hostname as a non fully qualified name according to instructions here:
    http://www.cloudera.com/**conten**t/cloudera-content/**cloudera-**
    docs/CDH4/4.2.0/CDH4-**Installat**ion-Guide/cdh4ig_**topic_11_1.**html<http://www.cloudera.com/content/cloudera-content/cloudera-docs/CDH4/4.2.0/CDH4-Installation-Guide/cdh4ig_topic_11_1.html>

    Of course I can rename the hostname to romeo0.lan

    Should I do that? Still a bit confused, maybe I am missing something
    here.

    btw: I have no search or domain entries in resolve.conf because I
    assumed they are optinal.

    Stefan

    On Thursday, June 13, 2013 3:13:16 PM UTC+2, bdb wrote:

    Stefan,

    You're in luck, I just had this same question and one of our
    developers (A.B.) provided some detailed information on this:

    The DNS resolution check uses the Java InetAddress class (much like
    what Hadoop daemons typically do) to:
    1. get the local address (addr = InetAddress.getLocalHost()) and uses
    the retrieved address to
    2. get the hostname (addr.getHostName()) and the FQDN /
    canonicalHostName (addr.getCanonicalHostName())
    3. Verify that 'hostname' can be used to derive 'canonicalHostName'
    by using the info in /etc/resolv.conf
    -- 3a. If /etc/resolv.conf has an entry of the form "domain
    isp.domain.name", 'hostname'.isp.domain.name **sho****uld be
    'canonicalHostName' for the check to pass.
    -- 3b. If /etc/resolv.conf has an entry of the form "search
    domain1.name domain2.**n****ame <http://domain2.name/> ..
    domainN.name", 'canonicalHostName' should be one of 'hostname'.
    domain1.name, 'hostname'.domain2.name .. or 'hostname'.domainN.name

    Here are a couple of things to check/verify:
    - Check /etc/resolv.conf on the hosts that are not 'healthy'. See
    what the domain and search lines are.romeo0.lan is not part of
    /etc/resolv.conf on those hosts and/or different from what it is on the
    'healthy' hosts.
    - Look for an INFO message of the form ""hostname <hostname> differs
    from the canonical name <canonicalname>" in the agent logs
    (/var/log/cloudera-scm-agent/*******.log) on the unhealthy hosts.
    That should give you the exact names being used for the check performed in
    step 3 above.

    Please let us know if this helps to determine the source of the
    health check failure, or if you have any questions or need clarification on
    anything.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 8:10 AM, Stefan wrote:

    Hello!

    I receive the above mentioned error despite being quite sure my
    configuration is ok.

    I have a DNS service up and running. Normal resolving and loopback.
    tested and ok.
    Additionally I have configured /etc/hosts with all IP Adresses
    (e.g. 192.168.1.160 romeo0.lan romeo0)

    The full error message is:
    "The hostname and canonical name for this host are not consistent
    when checked from a Java process."



    hostname
    => romeo0

    hostname -f
    => romeo0.lan

    host -v -t A romeo0.lan
    =>

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1,
    ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. ****** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.


    dig romeo0.lan

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.**rc1****.el6_4.4 <<>>
    romeo0.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1,
    ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. ****** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.160#53(192.168.1.**160****)
  • Joe Travaglini at Jul 1, 2013 at 6:54 pm
    NetworkManager is more trouble than it's worth.
    Probably more worthwhile to service NetworkManager stop, chkconfig
    NetworkManager off, service network start, chkconfig network on, and have
    all your sysconfig/network-scripts/ifcfg* have NM_CONTROLLED=no. Will make
    your life easier.

    On Mon, Jul 1, 2013 at 2:50 PM, Philip Langdale wrote:

    As it says, NetworkManager generates that file. You'd want to configure
    network manager to use a specific server and search domain, etc.

    --phil

    On 30 June 2013 12:25, Manal Helal wrote:

    Hi,

    I am having the same problem in both ubunto and CentOS data nodes, and I
    don't have a "search" line in the /etc/resolv.conf in the problematic
    nodes, so I added it because it is the only different line between the
    healthy and unhealthy nodes.

    # Generated by NetworkManager
    search 8.8.4.4 CentOS
    nameserver 8.8.8.8


    Is there a way to solve it permanently, it comes back, because the file
    keeps getting re-written,


    thank you very much,
    On Friday, 14 June 2013 16:57:55 UTC+2, bdb wrote:

    Stefan,

    Glad you were able to get it working. Thanks for closing the loop and
    letting us know the fix.

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 12:26 PM, Stefan wrote:

    Hi Brian,

    I changed the hostename in etc/sysconfig/network to the FQDN
    (romeo0.lan) and now it works.

    I dont know, maybe the support page I was referring to can be
    misunderstood.

    Thanks for helping me with all the infos that allowed me to solve the
    issue.
    Stefan

    On Thursday, June 13, 2013 5:34:16 PM UTC+2, bdb wrote:

    Stefan,

    Your setup is correct. I'll check to see what the behavior is with no
    entries in /etc/resolv.conf and get back to you.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 10:06 AM, Stefan wrote:

    Brian,
    thanks for your reply. I checked the logs and found that the java
    process reads:
    hostname = romeo
    canonical name = romoe0.lan

    Yes I am aware of this and I believe this is correct. I configured
    the hostname as a non fully qualified name according to instructions here:
    http://www.cloudera.com/**conten**t/cloudera-content/**cloudera-**
    docs/CDH4/4.2.0/CDH4-**Installat**ion-Guide/cdh4ig_**topic_11_1.**
    html<http://www.cloudera.com/content/cloudera-content/cloudera-docs/CDH4/4.2.0/CDH4-Installation-Guide/cdh4ig_topic_11_1.html>

    Of course I can rename the hostname to romeo0.lan

    Should I do that? Still a bit confused, maybe I am missing something
    here.

    btw: I have no search or domain entries in resolve.conf because I
    assumed they are optinal.

    Stefan

    On Thursday, June 13, 2013 3:13:16 PM UTC+2, bdb wrote:

    Stefan,

    You're in luck, I just had this same question and one of our
    developers (A.B.) provided some detailed information on this:

    The DNS resolution check uses the Java InetAddress class (much like
    what Hadoop daemons typically do) to:
    1. get the local address (addr = InetAddress.getLocalHost()) and
    uses the retrieved address to
    2. get the hostname (addr.getHostName()) and the FQDN /
    canonicalHostName (addr.getCanonicalHostName())
    3. Verify that 'hostname' can be used to derive 'canonicalHostName'
    by using the info in /etc/resolv.conf
    -- 3a. If /etc/resolv.conf has an entry of the form "domain
    isp.domain.name", 'hostname'.isp.domain.name **sho****uld be
    'canonicalHostName' for the check to pass.
    -- 3b. If /etc/resolv.conf has an entry of the form "search
    domain1.name domain2.**n****ame <http://domain2.name/> ..
    domainN.name", 'canonicalHostName' should be one of 'hostname'.
    domain1.name, 'hostname'.domain2.name .. or 'hostname'.domainN.name

    Here are a couple of things to check/verify:
    - Check /etc/resolv.conf on the hosts that are not 'healthy'. See
    what the domain and search lines are.romeo0.lan is not part of
    /etc/resolv.conf on those hosts and/or different from what it is on the
    'healthy' hosts.
    - Look for an INFO message of the form ""hostname <hostname> differs
    from the canonical name <canonicalname>" in the agent logs
    (/var/log/cloudera-scm-agent/*******.log) on the unhealthy hosts.
    That should give you the exact names being used for the check performed in
    step 3 above.

    Please let us know if this helps to determine the source of the
    health check failure, or if you have any questions or need clarification on
    anything.

    Thanks,

    *Brian Burton*
    *Customer Operations Engineer*
    <http://www.cloudera.com>

    On Thu, Jun 13, 2013 at 8:10 AM, Stefan wrote:

    Hello!

    I receive the above mentioned error despite being quite sure my
    configuration is ok.

    I have a DNS service up and running. Normal resolving and loopback.
    tested and ok.
    Additionally I have configured /etc/hosts with all IP Adresses
    (e.g. 192.168.1.160 romeo0.lan romeo0)

    The full error message is:
    "The hostname and canonical name for this host are not consistent
    when checked from a Java process."



    hostname
    => romeo0

    hostname -f
    => romeo0.lan

    host -v -t A romeo0.lan
    =>

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37626
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1,
    ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. ****** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.


    dig romeo0.lan

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.**rc1****.el6_4.4 <<>>
    romeo0.lan
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61443
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1,
    ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;romeo0.lan. ****** IN A

    ;; ANSWER SECTION:
    romeo0.lan. 3600 IN A 192.168.1.160

    ;; AUTHORITY SECTION:
    lan. 3600 IN NS romeo0.lan.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.160#53(192.168.1.**160****)

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedJun 13, '13 at 12:10p
activeJul 1, '13 at 6:54p
posts10
users6
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase