FAQ
Hi team ,

I am new to Hadoop world. I am trying to set up single node cluster on my
laptop. I have installed 2 VMs on my machine. The first one is hosting the
cloudera manager . I am planning to use this instance to access your
cluster, monitor it, configure it, add some nodes, etc. This will be you
main access to your cluster.

The second VM is your first node. This is where all the hadoop related
applications run.As there is only one node at the beginning, all the
roles/applications are running on this single node.

Here are few steps that I followed -

    1. Import the 2 VMs into VirtualBox and start them
    2. Configure the network


The users on the VMs are root and user.

On the node1 VM, login as root and i used command "ifconfig" to get the IP
address..

First, i removed the hosts file using "rm /etc/hosts". And added the hosts
back to the file using "echo 1XX.XXX.1.1 manager >> /etc/hosts" by
replacing 1XX.XXX.1.1 with my manager IP. I did the same thing for node1. "echo
1XX.XXX.1.2 node1 >> /etc/hosts" by replacing again the IP address with the
node1 IP address. And last add localhost "echo 12X.X.X.1 localhost >>
/etc/hosts".


Then I did from manager console, type "ping -c 1 node1". and it said , 0 %
packet loss. Then same thing from node1 ,I typed "ping -c manager". and it
said 0% packet loss.


After that , I used cat /etc/hosts command on node1 and manager VM , it
shows in total three IP addess as follows

1XX.XXX.1.1 manager

1XX.XXX.1.2 node1

12X.X.X.1 localhost


I also see that I connected to user@node1 and root@manager terminals .


Now when I try to start services from firefox icon on manager VM, system
throws following error - "Command aborted because of exception : Command
timed-out after 150 seconds".


Can someone please help with this issue ? It will be of great help

Thanks
Allan

Search Discussions

  • Tony Li Xu at Jun 4, 2013 at 3:27 pm
    Hi Alan:

    Which service did you try to start? So you can log into CM without any
    problem, right? Can you also check the service's log file see if there any
    specific errors?
    "Services->Instances->Role Instances (Choose a role)-> Role Log Details"

    --
    Tony

    On Tue, Jun 4, 2013 at 12:20 AM, Alan G wrote:

    Hi team ,

    I am new to Hadoop world. I am trying to set up single node cluster on my
    laptop. I have installed 2 VMs on my machine. The first one is hosting the
    cloudera manager . I am planning to use this instance to access your
    cluster, monitor it, configure it, add some nodes, etc. This will be you
    main access to your cluster.

    The second VM is your first node. This is where all the hadoop related
    applications run.As there is only one node at the beginning, all the
    roles/applications are running on this single node.

    Here are few steps that I followed -

    1. Import the 2 VMs into VirtualBox and start them
    2. Configure the network


    The users on the VMs are root and user.

    On the node1 VM, login as root and i used command "ifconfig" to get the IP
    address..

    First, i removed the hosts file using "rm /etc/hosts". And added the
    hosts back to the file using "echo 1XX.XXX.1.1 manager >> /etc/hosts" by
    replacing 1XX.XXX.1.1 with my manager IP. I did the same thing for node1. "echo
    1XX.XXX.1.2 node1 >> /etc/hosts" by replacing again the IP address with
    the node1 IP address. And last add localhost "echo 12X.X.X.1 localhost >>
    /etc/hosts".


    Then I did from manager console, type "ping -c 1 node1". and it said , 0
    % packet loss. Then same thing from node1 ,I typed "ping -c manager".
    and it said 0% packet loss.


    After that , I used cat /etc/hosts command on node1 and manager VM , it
    shows in total three IP addess as follows

    1XX.XXX.1.1 manager

    1XX.XXX.1.2 node1

    12X.X.X.1 localhost


    I also see that I connected to user@node1 and root@manager terminals .


    Now when I try to start services from firefox icon on manager VM, system
    throws following error - "Command aborted because of exception : Command
    timed-out after 150 seconds".


    Can someone please help with this issue ? It will be of great help

    Thanks
    Allan
  • Alan G at Jun 5, 2013 at 1:58 am
    Hi Tony,

    I am sorry I could not locate the log based on navigation path you
    specified below. I opened system validation messages (small icon on right
    corner) , it says no host heartbeat.

    When I pined node1 and manager , it says 0% packet loss.
    Does this info help? please let me know.. if you have a screen shot to find
    log below, then it wil be of great help
    Thanks
    Allan

    On Tuesday, June 4, 2013 8:26:54 AM UTC-7, Tony wrote:

    Hi Alan:

    Which service did you try to start? So you can log into CM without any
    problem, right? Can you also check the service's log file see if there any
    specific errors?
    "Services->Instances->Role Instances (Choose a role)-> Role Log Details"

    --
    Tony


    On Tue, Jun 4, 2013 at 12:20 AM, Alan G <allans...@gmail.com <javascript:>
    wrote:
    Hi team ,

    I am new to Hadoop world. I am trying to set up single node cluster on my
    laptop. I have installed 2 VMs on my machine. The first one is hosting the
    cloudera manager . I am planning to use this instance to access your
    cluster, monitor it, configure it, add some nodes, etc. This will be you
    main access to your cluster.

    The second VM is your first node. This is where all the hadoop related
    applications run.As there is only one node at the beginning, all the
    roles/applications are running on this single node.

    Here are few steps that I followed -

    1. Import the 2 VMs into VirtualBox and start them
    2. Configure the network


    The users on the VMs are root and user.

    On the node1 VM, login as root and i used command "ifconfig" to get the
    IP address..

    First, i removed the hosts file using "rm /etc/hosts". And added the
    hosts back to the file using "echo 1XX.XXX.1.1 manager >> /etc/hosts" by
    replacing 1XX.XXX.1.1 with my manager IP. I did the same thing for node1. "echo
    1XX.XXX.1.2 node1 >> /etc/hosts" by replacing again the IP address with
    the node1 IP address. And last add localhost "echo 12X.X.X.1 localhost
    /etc/hosts".

    Then I did from manager console, type "ping -c 1 node1". and it said , 0
    % packet loss. Then same thing from node1 ,I typed "ping -c manager".
    and it said 0% packet loss.


    After that , I used cat /etc/hosts command on node1 and manager VM , it
    shows in total three IP addess as follows

    1XX.XXX.1.1 manager

    1XX.XXX.1.2 node1

    12X.X.X.1 localhost


    I also see that I connected to user@node1 and root@manager terminals .


    Now when I try to start services from firefox icon on manager VM, system
    throws following error - "Command aborted because of exception : Command
    timed-out after 150 seconds".


    Can someone please help with this issue ? It will be of great help

    Thanks
    Allan
  • Tony Li Xu at Jun 5, 2013 at 6:01 pm
    Hi Alan:

    See my attached picture. For example, if I want to check the namenode role
    log file, I go:
    "Services" -> "Service hdfs1" -> "Instance" tab, then choose "namenode".
    "Role Log Details" is highlighted.

    What service did you try to start? If you can't find the log file in the
    UI, can you just post it here?

    For me, the log file of namenode service is located at:
    /var/log/hadoop-hdfs/hadoop-cmf-hdfs1-NAMENODE-hadoop1.domain.log.out

    Thanks
    --
    Tony

    On Tue, Jun 4, 2013 at 9:58 PM, Alan G wrote:

    Hi Tony,

    I am sorry I could not locate the log based on navigation path you
    specified below. I opened system validation messages (small icon on right
    corner) , it says no host heartbeat.

    When I pined node1 and manager , it says 0% packet loss.
    Does this info help? please let me know.. if you have a screen shot to
    find log below, then it wil be of great help
    Thanks
    Allan

    On Tuesday, June 4, 2013 8:26:54 AM UTC-7, Tony wrote:

    Hi Alan:

    Which service did you try to start? So you can log into CM without any
    problem, right? Can you also check the service's log file see if there any
    specific errors?
    "Services->Instances->Role Instances (Choose a role)-> Role Log Details"

    --
    Tony

    On Tue, Jun 4, 2013 at 12:20 AM, Alan G wrote:

    Hi team ,

    I am new to Hadoop world. I am trying to set up single node cluster on
    my laptop. I have installed 2 VMs on my machine. The first one is hosting
    the cloudera manager . I am planning to use this instance to access
    your cluster, monitor it, configure it, add some nodes, etc. This will be
    you main access to your cluster.

    The second VM is your first node. This is where all the hadoop related
    applications run.As there is only one node at the beginning, all the
    roles/applications are running on this single node.

    Here are few steps that I followed -

    1. Import the 2 VMs into VirtualBox and start them
    2. Configure the network


    The users on the VMs are root and user.

    On the node1 VM, login as root and i used command "ifconfig" to get the
    IP address..

    First, i removed the hosts file using "rm /etc/hosts". And added the
    hosts back to the file using "echo 1XX.XXX.1.1 manager >> /etc/hosts"
    by replacing 1XX.XXX.1.1 with my manager IP. I did the same thing for
    node1. "echo 1XX.XXX.1.2 node1 >> /etc/hosts" by replacing again the IP
    address with the node1 IP address. And last add localhost "echo
    12X.X.X.1 localhost >> /etc/hosts".


    Then I did from manager console, type "ping -c 1 node1". and it said ,
    0 % packet loss. Then same thing from node1 ,I typed "ping -c manager".
    and it said 0% packet loss.


    After that , I used cat /etc/hosts command on node1 and manager VM , it
    shows in total three IP addess as follows

    1XX.XXX.1.1 manager

    1XX.XXX.1.2 node1

    12X.X.X.1 localhost


    I also see that I connected to user@node1 and root@manager terminals .


    Now when I try to start services from firefox icon on manager VM, system
    throws following error - "Command aborted because of exception : Command
    timed-out after 150 seconds".


    Can someone please help with this issue ? It will be of great help

    Thanks
    Allan

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedJun 4, '13 at 4:20a
activeJun 5, '13 at 6:01p
posts4
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Tony Li Xu: 2 posts Alan G: 2 posts

People

Translate

site design / logo © 2022 Grokbase