FAQ
I've been trying to run cloudera-manager (on the web UI they provide). I
have a rack of machined I'm trying to install Impala onto. Since these
machines didn't have access to the internet, I set up a proxy (in
/etc/yum.conf). The issue I am now having is:

Error: Missing Dependency: fuse-libs is needed by package
cloudera-manager-agent-4.5.2-1.cm452.p0.327.x86_64 (cloudera-manager)
Error: Missing Dependency: python >= 2.4.3-43 is needed by package
cloudera-manager-agent-4.5.2-1.cm452.p0.327.x86_64 (cloudera-manager)
Error: Missing Dependency: fuse is needed by package
cloudera-manager-agent-4.5.2-1.cm452.p0.327.x86_64 (cloudera-manager)

I tried deleting unwanted repos and also clearing yum's cache and trying
again (Even tried the hacky: --skip-broken) but nothing seems to work. The
issue seems to be that the machines on my rack can't seem to find the fuse
or fuse-libs packages (I 'yum list fuse*' on a host on the rack and it
didn't return anything).

After having searched this issue up, I can't really find anything that
really applies here (I realize that this is a common issue, but most people
found that clearing the yum cache resolves it, but it didn't for me).


Does anyone have any suggestions on how to resolve this?

Search Discussions

  • Philip Langdale at May 14, 2013 at 7:50 pm
    These dependencies are core system packages, so you need to make sure you
    have repos defined for them - which should be the case by default, but you
    need to check.

    What command line did you run to try and do the install?

    --phil

    On 14 May 2013 11:52, Amlesh Jayakumar wrote:

    I've been trying to run cloudera-manager (on the web UI they provide). I
    have a rack of machined I'm trying to install Impala onto. Since these
    machines didn't have access to the internet, I set up a proxy (in
    /etc/yum.conf). The issue I am now having is:

    Error: Missing Dependency: fuse-libs is needed by package
    cloudera-manager-agent-4.5.2-1.cm452.p0.327.x86_64 (cloudera-manager)
    Error: Missing Dependency: python >= 2.4.3-43 is needed by package
    cloudera-manager-agent-4.5.2-1.cm452.p0.327.x86_64 (cloudera-manager)
    Error: Missing Dependency: fuse is needed by package
    cloudera-manager-agent-4.5.2-1.cm452.p0.327.x86_64 (cloudera-manager)

    I tried deleting unwanted repos and also clearing yum's cache and trying
    again (Even tried the hacky: --skip-broken) but nothing seems to work. The
    issue seems to be that the machines on my rack can't seem to find the fuse
    or fuse-libs packages (I 'yum list fuse*' on a host on the rack and it
    didn't return anything).

    After having searched this issue up, I can't really find anything that
    really applies here (I realize that this is a common issue, but most people
    found that clearing the yum cache resolves it, but it didn't for me).


    Does anyone have any suggestions on how to resolve this?

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedMay 14, '13 at 6:52p
activeMay 14, '13 at 7:50p
posts2
users2
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase