FAQ
Hello,

I had started the express-wizard setup on a local cluster, but the DNS
server information was incorrect (we didn't have reverse DNS lookup). I got
part-way through the installation, and then it got stuck at the "Installing
Selected Parcels" screen.

I was able to click on the Cloudera Manager link at the top, fix the DNS
issues, add all the hosts, and finish the install.

However, now whenever I log in to the Cloudera Manager as admin, the first
screen that comes up is the same "Installing Selected Parcels" screen, with
the url "cmf/express-wizard/resume."
.
How can I cancel the express-wizard installation?

Thanks,
Daniel

Search Discussions

  • Herman Chen at Apr 12, 2013 at 7:18 pm
    Hi Daniel,

    You can manually go to /cmf/express-wizard/welcome to reset the wizard. We
    are aware of this issue and will address it in a future release.

    Herman


    On Fri, Apr 12, 2013 at 12:14 PM, Daniel Sprechman wrote:

    Hello,

    I had started the express-wizard setup on a local cluster, but the DNS
    server information was incorrect (we didn't have reverse DNS lookup). I got
    part-way through the installation, and then it got stuck at the "Installing
    Selected Parcels" screen.

    I was able to click on the Cloudera Manager link at the top, fix the DNS
    issues, add all the hosts, and finish the install.

    However, now whenever I log in to the Cloudera Manager as admin, the first
    screen that comes up is the same "Installing Selected Parcels" screen, with
    the url "cmf/express-wizard/resume."
    .
    How can I cancel the express-wizard installation?

    Thanks,
    Daniel
  • Daniel Sprechman at Apr 12, 2013 at 8:20 pm
    Thanks for the quick response! I just gave that a try, did a complete
    circle, and now i'm stuck with the same problem.

    Here's what I tried:

    I went to /cmf/express-wizard/welcome, and then I tried either logging out
    or closing the browser at different points in the wizard setup. It would
    still come up with the same "Installing Selected Parcels" stuck screen
    whenever I logged in. Then I tried adding a new machine. I got through part
    of the process, but it failed at an authentication step (I had typed some
    wrong info). I closed the browser, opened it back up and logged in, and it
    kept trying to connect to the new machine and failed. I tried clicking the
    back button on the bottom left to type in the correct authentication
    information, and it brought me to the login screen.

    So then the "Installing Selected Parcels" screen was replaced by a
    "Installation failed on all hosts" screen.

    Then I went back to the /welcome screen, followed the same steps, but typed
    in the correct authentication information. It successfully added the
    machine. I clicked continue, and a message came up saying that the maximum
    number of clusters has been reached. I logged out, logged in, and it's back
    to the "Installing Selected Parcels..." screen.

    Not sure how to proceed.

    Thanks,
    Daniel

    On Friday, April 12, 2013 3:17:54 PM UTC-4, Herman Chen wrote:

    Hi Daniel,

    You can manually go to /cmf/express-wizard/welcome to reset the wizard.
    We are aware of this issue and will address it in a future release.

    Herman



    On Fri, Apr 12, 2013 at 12:14 PM, Daniel Sprechman <spr...@gmail.com<javascript:>
    wrote:
    Hello,

    I had started the express-wizard setup on a local cluster, but the DNS
    server information was incorrect (we didn't have reverse DNS lookup). I got
    part-way through the installation, and then it got stuck at the "Installing
    Selected Parcels" screen.

    I was able to click on the Cloudera Manager link at the top, fix the DNS
    issues, add all the hosts, and finish the install.

    However, now whenever I log in to the Cloudera Manager as admin, the
    first screen that comes up is the same "Installing Selected Parcels"
    screen, with the url "cmf/express-wizard/resume."
    .
    How can I cancel the express-wizard installation?

    Thanks,
    Daniel
  • Andrew Yao at Apr 12, 2013 at 9:54 pm
    Hi Daniel,

    Can you try this?

    1.1 Go to /cmf/debug/demos?type=userSettings (This is a backdoor)
    1.2 Press the [ Clear Settings ] button
    1.3 Then log out and log back in.



    On Fri, Apr 12, 2013 at 1:20 PM, Daniel Sprechman wrote:

    Thanks for the quick response! I just gave that a try, did a complete
    circle, and now i'm stuck with the same problem.

    Here's what I tried:

    I went to /cmf/express-wizard/welcome, and then I tried either logging out
    or closing the browser at different points in the wizard setup. It would
    still come up with the same "Installing Selected Parcels" stuck screen
    whenever I logged in. Then I tried adding a new machine. I got through part
    of the process, but it failed at an authentication step (I had typed some
    wrong info). I closed the browser, opened it back up and logged in, and it
    kept trying to connect to the new machine and failed. I tried clicking the
    back button on the bottom left to type in the correct authentication
    information, and it brought me to the login screen.

    So then the "Installing Selected Parcels" screen was replaced by a
    "Installation failed on all hosts" screen.

    Then I went back to the /welcome screen, followed the same steps, but
    typed in the correct authentication information. It successfully added the
    machine. I clicked continue, and a message came up saying that the maximum
    number of clusters has been reached. I logged out, logged in, and it's back
    to the "Installing Selected Parcels..." screen.

    Not sure how to proceed.

    Thanks,
    Daniel

    On Friday, April 12, 2013 3:17:54 PM UTC-4, Herman Chen wrote:

    Hi Daniel,

    You can manually go to /cmf/express-wizard/welcome to reset the wizard.
    We are aware of this issue and will address it in a future release.

    Herman


    On Fri, Apr 12, 2013 at 12:14 PM, Daniel Sprechman wrote:

    Hello,

    I had started the express-wizard setup on a local cluster, but the DNS
    server information was incorrect (we didn't have reverse DNS lookup). I got
    part-way through the installation, and then it got stuck at the "Installing
    Selected Parcels" screen.

    I was able to click on the Cloudera Manager link at the top, fix the DNS
    issues, add all the hosts, and finish the install.

    However, now whenever I log in to the Cloudera Manager as admin, the
    first screen that comes up is the same "Installing Selected Parcels"
    screen, with the url "cmf/express-wizard/resume."
    .
    How can I cancel the express-wizard installation?

    Thanks,
    Daniel

    --
    Andrew Yao

    Software Engineer
    Cloudera
  • Daniel Sprechman at Apr 12, 2013 at 10:06 pm
    That did it! Thank you!!

    My settings were set to:

    com.cloudera.scm.hosts.table {"pageLength":"100","defaultSort":[1,"desc",1]}
    com.cloudera.server.web.cmf.wizard.express.addHosts.state4.5.0
    {"hasNewHosts":true,"installedHosts":true,"createdCluster":true,"parcels":[{"product":"CDH","version":"4.2.0-1.cdh4.2.0.p0.10"}],"cluster":{},"hosts":["myhostname1"],"installMethod":"useParcel","cdhVersion":4}

    Daniel

    On Friday, April 12, 2013 5:54:09 PM UTC-4, Andrew Yao wrote:

    Hi Daniel,

    Can you try this?

    1.1 Go to /cmf/debug/demos?type=userSettings (This is a backdoor)
    1.2 Press the [ Clear Settings ] button
    1.3 Then log out and log back in.




    On Fri, Apr 12, 2013 at 1:20 PM, Daniel Sprechman <spr...@gmail.com<javascript:>
    wrote:
    Thanks for the quick response! I just gave that a try, did a complete
    circle, and now i'm stuck with the same problem.

    Here's what I tried:

    I went to /cmf/express-wizard/welcome, and then I tried either logging
    out or closing the browser at different points in the wizard setup. It
    would still come up with the same "Installing Selected Parcels" stuck
    screen whenever I logged in. Then I tried adding a new machine. I got
    through part of the process, but it failed at an authentication step (I had
    typed some wrong info). I closed the browser, opened it back up and logged
    in, and it kept trying to connect to the new machine and failed. I tried
    clicking the back button on the bottom left to type in the correct
    authentication information, and it brought me to the login screen.

    So then the "Installing Selected Parcels" screen was replaced by a
    "Installation failed on all hosts" screen.

    Then I went back to the /welcome screen, followed the same steps, but
    typed in the correct authentication information. It successfully added the
    machine. I clicked continue, and a message came up saying that the maximum
    number of clusters has been reached. I logged out, logged in, and it's back
    to the "Installing Selected Parcels..." screen.

    Not sure how to proceed.

    Thanks,
    Daniel

    On Friday, April 12, 2013 3:17:54 PM UTC-4, Herman Chen wrote:

    Hi Daniel,

    You can manually go to /cmf/express-wizard/welcome to reset the wizard.
    We are aware of this issue and will address it in a future release.

    Herman


    On Fri, Apr 12, 2013 at 12:14 PM, Daniel Sprechman wrote:

    Hello,

    I had started the express-wizard setup on a local cluster, but the DNS
    server information was incorrect (we didn't have reverse DNS lookup). I got
    part-way through the installation, and then it got stuck at the "Installing
    Selected Parcels" screen.

    I was able to click on the Cloudera Manager link at the top, fix the
    DNS issues, add all the hosts, and finish the install.

    However, now whenever I log in to the Cloudera Manager as admin, the
    first screen that comes up is the same "Installing Selected Parcels"
    screen, with the url "cmf/express-wizard/resume."
    .
    How can I cancel the express-wizard installation?

    Thanks,
    Daniel

    --
    Andrew Yao

    Software Engineer
    Cloudera
  • Darren Culbreath at Apr 13, 2013 at 6:17 pm
    I am having the same issue.

    CentOS 5.8
    Rackspace Image

    I did this:

    1.1 Go to /cmf/debug/demos?type=userSettings (This is a backdoor)
    1.2 Press the [ Clear Settings ] button
    1.3 Then log out and log back in.

    Does it leave a server log I can look at on the Hosts ?

    thx.
    -Darren
    On Friday, April 12, 2013 5:54:09 PM UTC-4, Andrew Yao wrote:

    Hi Daniel,

    Can you try this?

    1.1 Go to /cmf/debug/demos?type=userSettings (This is a backdoor)
    1.2 Press the [ Clear Settings ] button
    1.3 Then log out and log back in.




    On Fri, Apr 12, 2013 at 1:20 PM, Daniel Sprechman <spr...@gmail.com<javascript:>
    wrote:
    Thanks for the quick response! I just gave that a try, did a complete
    circle, and now i'm stuck with the same problem.

    Here's what I tried:

    I went to /cmf/express-wizard/welcome, and then I tried either logging
    out or closing the browser at different points in the wizard setup. It
    would still come up with the same "Installing Selected Parcels" stuck
    screen whenever I logged in. Then I tried adding a new machine. I got
    through part of the process, but it failed at an authentication step (I had
    typed some wrong info). I closed the browser, opened it back up and logged
    in, and it kept trying to connect to the new machine and failed. I tried
    clicking the back button on the bottom left to type in the correct
    authentication information, and it brought me to the login screen.

    So then the "Installing Selected Parcels" screen was replaced by a
    "Installation failed on all hosts" screen.

    Then I went back to the /welcome screen, followed the same steps, but
    typed in the correct authentication information. It successfully added the
    machine. I clicked continue, and a message came up saying that the maximum
    number of clusters has been reached. I logged out, logged in, and it's back
    to the "Installing Selected Parcels..." screen.

    Not sure how to proceed.

    Thanks,
    Daniel

    On Friday, April 12, 2013 3:17:54 PM UTC-4, Herman Chen wrote:

    Hi Daniel,

    You can manually go to /cmf/express-wizard/welcome to reset the wizard.
    We are aware of this issue and will address it in a future release.

    Herman


    On Fri, Apr 12, 2013 at 12:14 PM, Daniel Sprechman wrote:

    Hello,

    I had started the express-wizard setup on a local cluster, but the DNS
    server information was incorrect (we didn't have reverse DNS lookup). I got
    part-way through the installation, and then it got stuck at the "Installing
    Selected Parcels" screen.

    I was able to click on the Cloudera Manager link at the top, fix the
    DNS issues, add all the hosts, and finish the install.

    However, now whenever I log in to the Cloudera Manager as admin, the
    first screen that comes up is the same "Installing Selected Parcels"
    screen, with the url "cmf/express-wizard/resume."
    .
    How can I cancel the express-wizard installation?

    Thanks,
    Daniel

    --
    Andrew Yao

    Software Engineer
    Cloudera

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedApr 12, '13 at 7:14p
activeApr 13, '13 at 6:17p
posts6
users4
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase