FAQ
All,
I have a Cludera Manager(FE) CDH4 installed on a three node cluster. The
Hosts all report as Good in Health. The next step I recon is to Add a
service and Role to the Hosts. When I select a Service to Add , I keep
getting "No Hosts Found". My server Log has the following exception:

2013-04-07 07:00:00,227 INFO
[1963249369@scm-web-6:common.JFrameException@167] Exception report
generated accessing http://chamanti:7180/cmf/parcel/install
org.springframework.web.bind.MissingServletRequestParameterException:
Required Long parameter 'clusterId' is not present
at
org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter$ServletHandlerMethodInvoker.raiseMissingParameterException(AnnotationMethodHandlerAdapter.java:738)
at


I am running CentOS release 6.4

Much appreciate any pointers to resolving this.

Regards,
Murali

Search Discussions

  • Andrew Yao at Apr 8, 2013 at 5:50 am
    Hi Murali,

    This was a known issue in an earlier version of CM 4.5, and it should have
    been fixed in the latest version 4.5.1.
    4.5.1 was released on April 5th. Can you check if you are running 4.5.1 by
    going to the *Help* -> *About*?

    If the "No Hosts Found" problem persists after you upgrade to 4.5.1, then
    it means your hosts are not part of any specific cluster yet.

    1. Run the *Add Hosts Wizard *(from the Hosts tab) again.
    2. Instead of entering the IP Ranges again, you should see a tab that
    says *Currently Managed Hosts. *click that.
    3. Select the hosts and proceed with the wizard.
    4. It should add these hosts to your cluster (if there is only 1 cluster
    managed by CM)

    After that you should be able to add a service to your cluster as expected.

    Please let us know if this fixes the problem.

    thanks,

    --
    Andrew Yao

    Software Engineer
    Cloudera


    On Sun, Apr 7, 2013 at 7:18 AM, Murali Adari wrote:

    All,
    I have a Cludera Manager(FE) CDH4 installed on a three node cluster. The
    Hosts all report as Good in Health. The next step I recon is to Add a
    service and Role to the Hosts. When I select a Service to Add , I keep
    getting "No Hosts Found". My server Log has the following exception:

    2013-04-07 07:00:00,227 INFO [1963249369@scm-web-6
    :common.JFrameException@167] Exception report generated accessing
    http://chamanti:7180/cmf/parcel/install
    org.springframework.web.bind.MissingServletRequestParameterException:
    Required Long parameter 'clusterId' is not present
    at
    org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter$ServletHandlerMethodInvoker.raiseMissingParameterException(AnnotationMethodHandlerAdapter.java:738)
    at


    I am running CentOS release 6.4

    Much appreciate any pointers to resolving this.

    Regards,
    Murali
  • Murali Adari at Apr 9, 2013 at 10:02 am
    Andrew,

    You were SPOT ON! That worked like a charm!
    Thanks a ton. Was going in nuts trying to figure this out.
    My version is 4.5 . after I get this going I will upgrade to 4.5.1.
    Once again thank you for the resolution but more importantly for your time
    and attention,

    Kind Regards,
    Murali
    On Monday, April 8, 2013 1:50:15 AM UTC-4, Andrew Yao wrote:

    Hi Murali,

    This was a known issue in an earlier version of CM 4.5, and it should have
    been fixed in the latest version 4.5.1.
    4.5.1 was released on April 5th. Can you check if you are running 4.5.1 by
    going to the *Help* -> *About*?

    If the "No Hosts Found" problem persists after you upgrade to 4.5.1, then
    it means your hosts are not part of any specific cluster yet.

    1. Run the *Add Hosts Wizard *(from the Hosts tab) again.
    2. Instead of entering the IP Ranges again, you should see a tab that
    says *Currently Managed Hosts. *click that.
    3. Select the hosts and proceed with the wizard.
    4. It should add these hosts to your cluster (if there is only 1
    cluster managed by CM)

    After that you should be able to add a service to your cluster as expected.

    Please let us know if this fixes the problem.

    thanks,

    --
    Andrew Yao

    Software Engineer
    Cloudera



    On Sun, Apr 7, 2013 at 7:18 AM, Murali Adari <murali...@gmail.com<javascript:>
    wrote:
    All,
    I have a Cludera Manager(FE) CDH4 installed on a three node cluster. The
    Hosts all report as Good in Health. The next step I recon is to Add a
    service and Role to the Hosts. When I select a Service to Add , I keep
    getting "No Hosts Found". My server Log has the following exception:

    2013-04-07 07:00:00,227 INFO
    [1963249369@scm-web-6:common.JFrameException@167] Exception report
    generated accessing http://chamanti:7180/cmf/parcel/install
    org.springframework.web.bind.MissingServletRequestParameterException:
    Required Long parameter 'clusterId' is not present
    at
    org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter$ServletHandlerMethodInvoker.raiseMissingParameterException(AnnotationMethodHandlerAdapter.java:738)
    at


    I am running CentOS release 6.4

    Much appreciate any pointers to resolving this.

    Regards,
    Murali

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedApr 7, '13 at 2:18p
activeApr 9, '13 at 10:02a
posts3
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Murali Adari: 2 posts Andrew Yao: 1 post

People

Translate

site design / logo © 2022 Grokbase