FAQ
Hi all,

I'm trying on the CM Free Edition. After I finish the 'Add New Hosts to
Cluster' Tab, the new hosts weren't in my cluster.
Because of that, I can't add instance to service, please help me on the
issue.

Thx.

Search Discussions

  • Herman Chen at Mar 13, 2013 at 3:24 pm
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do, you
    probably did not go through the entire wizard. 'Add New Hosts to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman

    On Tue, Mar 12, 2013 at 9:24 PM, John Yang wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the 'Add New Hosts to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help me on the
    issue.

    Thx.
  • John Yang at Mar 14, 2013 at 2:37 am
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any tab called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I missed?

    John



    Herman Chen於 2013年3月13日星期三UTC+8下午11時24分09秒寫道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do, you
    probably did not go through the entire wizard. 'Add New Hosts to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman


    On Tue, Mar 12, 2013 at 9:24 PM, John Yang <man...@gmail.com <javascript:>>
    wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the 'Add New Hosts to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help me on the
    issue.

    Thx.
  • Herman Chen at Mar 14, 2013 at 5:27 pm
    Hi John

    If you don't see the tab that means the hosts aren't managed yet. Go
    through the 'Add New Hosts to Cluster' wizard again, and make sure you
    'Continue' all the way to the end of the wizard. After wizard
    completes successfully, verify the following for me:
    1. on Hosts page do you see the new hosts?
    2. if you do, what does the 'Cluster' column say?

    Herman
    On Wed, Mar 13, 2013 at 7:37 PM, John Yang wrote:
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any tab called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I missed?

    John



    Herman Chen於 2013年3月13日星期三UTC+8下午11時24分09秒寫道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do, you
    probably did not go through the entire wizard. 'Add New Hosts to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman

    On Tue, Mar 12, 2013 at 9:24 PM, John Yang wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the 'Add New Hosts
    to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help me on the
    issue.

    Thx.
  • John Yang at Mar 15, 2013 at 3:24 am
    Hi Herman,

    Thanks for your help!
    1. Yes, I can see new created host
    2. I think the problem is here, I can't see any column called 'Cluster' :(

    John

    Herman Chen於 2013年3月15日星期五UTC+8上午1時27分09秒寫道:
    Hi John

    If you don't see the tab that means the hosts aren't managed yet. Go
    through the 'Add New Hosts to Cluster' wizard again, and make sure you
    'Continue' all the way to the end of the wizard. After wizard
    completes successfully, verify the following for me:
    1. on Hosts page do you see the new hosts?
    2. if you do, what does the 'Cluster' column say?

    Herman

    On Wed, Mar 13, 2013 at 7:37 PM, John Yang <man...@gmail.com <javascript:>>
    wrote:
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any tab called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I missed?

    John



    Herman Chen於 2013年3月13日星期三UTC+8下午11時24分09秒寫道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do, you
    probably did not go through the entire wizard. 'Add New Hosts to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman

    On Tue, Mar 12, 2013 at 9:24 PM, John Yang wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the 'Add New
    Hosts
    to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help me on
    the
    issue.

    Thx.
  • Herman Chen at Mar 15, 2013 at 1:56 pm
    Hi John

    What version of CM are you running? See Help->About.

    Herman

    On Thu, Mar 14, 2013 at 8:24 PM, John Yang wrote:
    Hi Herman,

    Thanks for your help!
    1. Yes, I can see new created host
    2. I think the problem is here, I can't see any column called 'Cluster' :(

    John

    Herman Chen於 2013年3月15日星期五UTC+8上午1時27分09秒寫道:
    Hi John

    If you don't see the tab that means the hosts aren't managed yet. Go
    through the 'Add New Hosts to Cluster' wizard again, and make sure you
    'Continue' all the way to the end of the wizard. After wizard
    completes successfully, verify the following for me:
    1. on Hosts page do you see the new hosts?
    2. if you do, what does the 'Cluster' column say?

    Herman
    On Wed, Mar 13, 2013 at 7:37 PM, John Yang wrote:
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any tab called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I missed?

    John



    Herman Chen於 2013年3月13日星期三UTC+8下午11時24分09秒寫道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do, you
    probably did not go through the entire wizard. 'Add New Hosts to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman

    On Tue, Mar 12, 2013 at 9:24 PM, John Yang wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the 'Add New
    Hosts
    to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help me on
    the
    issue.

    Thx.
  • John Yang at Mar 18, 2013 at 2:21 am
    Hi Herman,

    *Version*: 4.5.0
    Cloudera Manager Free Edition

    John


    Herman Chen於 2013年3月15日星期五UTC+8下午9時55分39秒寫道:
    Hi John

    What version of CM are you running? See Help->About.

    Herman


    On Thu, Mar 14, 2013 at 8:24 PM, John Yang <man...@gmail.com <javascript:>>
    wrote:
    Hi Herman,

    Thanks for your help!
    1. Yes, I can see new created host
    2. I think the problem is here, I can't see any column called 'Cluster' :(
    John

    Herman Chen於 2013年3月15日星期五UTC+8上午1時27分09秒寫道:
    Hi John

    If you don't see the tab that means the hosts aren't managed yet. Go
    through the 'Add New Hosts to Cluster' wizard again, and make sure you
    'Continue' all the way to the end of the wizard. After wizard
    completes successfully, verify the following for me:
    1. on Hosts page do you see the new hosts?
    2. if you do, what does the 'Cluster' column say?

    Herman
    On Wed, Mar 13, 2013 at 7:37 PM, John Yang wrote:
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any tab
    called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I missed?

    John



    Herman Chen於 2013年3月13日星期三UTC+8下午11時24分09秒寫道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do, you
    probably did not go through the entire wizard. 'Add New Hosts to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman

    On Tue, Mar 12, 2013 at 9:24 PM, John Yang wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the 'Add New
    Hosts
    to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help me
    on
    the
    issue.

    Thx.
  • Herman Chen at Mar 18, 2013 at 9:07 pm
    Hi John

    That is surprising. Could you take a screenshot of the About page? Thanks.

    Herman
    On Sun, Mar 17, 2013 at 7:21 PM, John Yang wrote:
    Hi Herman,

    Version: 4.5.0
    Cloudera Manager Free Edition

    John


    Herman Chen於 2013年3月15日星期五UTC+8下午9時55分39秒寫道:
    Hi John

    What version of CM are you running? See Help->About.

    Herman

    On Thu, Mar 14, 2013 at 8:24 PM, John Yang wrote:
    Hi Herman,

    Thanks for your help!
    1. Yes, I can see new created host
    2. I think the problem is here, I can't see any column called 'Cluster'
    :(

    John

    Herman Chen於 2013年3月15日星期五UTC+8上午1時27分09秒寫道:
    Hi John

    If you don't see the tab that means the hosts aren't managed yet. Go
    through the 'Add New Hosts to Cluster' wizard again, and make sure you
    'Continue' all the way to the end of the wizard. After wizard
    completes successfully, verify the following for me:
    1. on Hosts page do you see the new hosts?
    2. if you do, what does the 'Cluster' column say?

    Herman
    On Wed, Mar 13, 2013 at 7:37 PM, John Yang wrote:
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any tab
    called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I missed?

    John



    Herman Chen於 2013年3月13日星期三UTC+8下午11時24分09秒寫道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do, you
    probably did not go through the entire wizard. 'Add New Hosts to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman

    On Tue, Mar 12, 2013 at 9:24 PM, John Yang wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the 'Add New
    Hosts
    to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help me
    on
    the
    issue.

    Thx.
  • John Yang at Mar 19, 2013 at 2:38 am
    <https://lh5.googleusercontent.com/-kp_ddwkzYWQ/UUfPIHr542I/AAAAAAAACHQ/J7ixHpxO3IY/s1600/Screenshot+cloudera.png>
    Hi Herman,

    Here's the screenshot of the About page.

    John


    Herman Chen於 2013年3月19日星期二UTC+8上午5時00分32秒寫道:
    Hi John

    That is surprising. Could you take a screenshot of the About page? Thanks.

    Herman

    On Sun, Mar 17, 2013 at 7:21 PM, John Yang <man...@gmail.com <javascript:>>
    wrote:
    Hi Herman,

    Version: 4.5.0
    Cloudera Manager Free Edition

    John


    Herman Chen於 2013年3月15日星期五UTC+8下午9時55分39秒寫道:
    Hi John

    What version of CM are you running? See Help->About.

    Herman

    On Thu, Mar 14, 2013 at 8:24 PM, John Yang wrote:
    Hi Herman,

    Thanks for your help!
    1. Yes, I can see new created host
    2. I think the problem is here, I can't see any column called
    'Cluster'
    :(

    John

    Herman Chen於 2013年3月15日星期五UTC+8上午1時27分09秒寫道:
    Hi John

    If you don't see the tab that means the hosts aren't managed yet. Go
    through the 'Add New Hosts to Cluster' wizard again, and make sure
    you
    'Continue' all the way to the end of the wizard. After wizard
    completes successfully, verify the following for me:
    1. on Hosts page do you see the new hosts?
    2. if you do, what does the 'Cluster' column say?

    Herman
    On Wed, Mar 13, 2013 at 7:37 PM, John Yang wrote:
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any tab
    called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I missed?

    John



    Herman Chen於 2013年3月13日星期三UTC+8下午11時24分09秒寫道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do,
    you
    probably did not go through the entire wizard. 'Add New Hosts to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman

    On Tue, Mar 12, 2013 at 9:24 PM, John Yang wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the 'Add
    New
    Hosts
    to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help
    me
    on
    the
    issue.

    Thx.
  • Herman Chen at Mar 19, 2013 at 6:09 pm
    Hi John

    Thanks for the screenshot. The Cluster column is not shown in Free Edition,
    since only one cluster is supported, so this is expected. If you try "Add
    New Hosts to Cluster" wizard again but there is no "Currently Managed
    Hosts" tab, that means all of your hosts should be in your cluster already.
    Can you describe in more detail what happens when you tried to "add
    instance to service"?

    Herman

    On Mon, Mar 18, 2013 at 7:38 PM, John Yang wrote:


    <https://lh5.googleusercontent.com/-kp_ddwkzYWQ/UUfPIHr542I/AAAAAAAACHQ/J7ixHpxO3IY/s1600/Screenshot+cloudera.png>
    Hi Herman,

    Here's the screenshot of the About page.

    John


    Herman Chen於 2013年3月19日星期二UTC+8上午5時00分32秒寫道:
    Hi John

    That is surprising. Could you take a screenshot of the About page?
    Thanks.

    Herman
    On Sun, Mar 17, 2013 at 7:21 PM, John Yang wrote:
    Hi Herman,

    Version: 4.5.0
    Cloudera Manager Free Edition

    John


    Herman Chen於 2013年3月15日星期五UTC+**8下午9時55分39秒寫道:
    Hi John

    What version of CM are you running? See Help->About.

    Herman

    On Thu, Mar 14, 2013 at 8:24 PM, John Yang wrote:
    Hi Herman,

    Thanks for your help!
    1. Yes, I can see new created host
    2. I think the problem is here, I can't see any column called
    'Cluster'
    :(

    John

    Herman Chen於 2013年3月15日星期五UTC+**8上午1時27分09秒寫道:
    Hi John

    If you don't see the tab that means the hosts aren't managed yet.
    Go
    through the 'Add New Hosts to Cluster' wizard again, and make sure
    you
    'Continue' all the way to the end of the wizard. After wizard
    completes successfully, verify the following for me:
    1. on Hosts page do you see the new hosts?
    2. if you do, what does the 'Cluster' column say?

    Herman

    On Wed, Mar 13, 2013 at 7:37 PM, John Yang <man...@gmail.com>
    wrote:
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any tab
    called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I missed?

    John



    Herman Chen於 2013年3月13日星期三UTC+**8下午11時24分09秒寫道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do,
    you
    probably did not go through the entire wizard. 'Add New Hosts to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman


    On Tue, Mar 12, 2013 at 9:24 PM, John Yang <man...@gmail.com>
    wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the 'Add
    New
    Hosts
    to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help
    me
    on
    the
    issue.

    Thx.
  • John Yang at Mar 21, 2013 at 10:56 am
    Hi Herman,

    I figured out a way to add the role to the host.
    First, create a template for the cluster, and choose the roles
    needed.(Hosts>Templates>Create)
    Second, select the newly created host in Hosts tab, then 'Actions for
    Selected' > 'Apply Host Template'
    Finally the newly created host will got the role and in the cluster, too.

    But the newly created hosts are still out of the cluster after the 'Add New
    Hosts to Cluster' wizard finished.

    Thanks for your help :)

    John

    Herman Chen於 2013年3月20日星期三UTC+8上午2時08分50秒寫道:
    Hi John

    Thanks for the screenshot. The Cluster column is not shown in Free
    Edition, since only one cluster is supported, so this is expected. If you
    try "Add New Hosts to Cluster" wizard again but there is no "Currently
    Managed Hosts" tab, that means all of your hosts should be in your cluster
    already. Can you describe in more detail what happens when you tried to "add
    instance to service"?

    Herman


    On Mon, Mar 18, 2013 at 7:38 PM, John Yang <man...@gmail.com <javascript:>
    wrote:
    <https://lh5.googleusercontent.com/-kp_ddwkzYWQ/UUfPIHr542I/AAAAAAAACHQ/J7ixHpxO3IY/s1600/Screenshot+cloudera.png>
    Hi Herman,

    Here's the screenshot of the About page.

    John


    Herman Chen於 2013年3月19日星期二UTC+8上午5時00分32秒寫道:
    Hi John

    That is surprising. Could you take a screenshot of the About page?
    Thanks.

    Herman
    On Sun, Mar 17, 2013 at 7:21 PM, John Yang wrote:
    Hi Herman,

    Version: 4.5.0
    Cloudera Manager Free Edition

    John


    Herman Chen於 2013年3月15日星期五UTC+**8下午9時55分39秒寫道:
    Hi John

    What version of CM are you running? See Help->About.

    Herman

    On Thu, Mar 14, 2013 at 8:24 PM, John Yang wrote:
    Hi Herman,

    Thanks for your help!
    1. Yes, I can see new created host
    2. I think the problem is here, I can't see any column called
    'Cluster'
    :(

    John

    Herman Chen於 2013年3月15日星期五UTC+**8上午1時27分09秒寫道:
    Hi John

    If you don't see the tab that means the hosts aren't managed yet.
    Go
    through the 'Add New Hosts to Cluster' wizard again, and make sure
    you
    'Continue' all the way to the end of the wizard. After wizard
    completes successfully, verify the following for me:
    1. on Hosts page do you see the new hosts?
    2. if you do, what does the 'Cluster' column say?

    Herman

    On Wed, Mar 13, 2013 at 7:37 PM, John Yang <man...@gmail.com>
    wrote:
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any
    tab
    called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I missed?

    John



    Herman Chen於 2013年3月13日星期三UTC+**8下午11時24分09秒寫道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you do,
    you
    probably did not go through the entire wizard. 'Add New Hosts
    to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman


    On Tue, Mar 12, 2013 at 9:24 PM, John Yang <man...@gmail.com>
    wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the
    'Add New
    Hosts
    to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please help
    me
    on
    the
    issue.

    Thx.
  • Herman Chen at Mar 21, 2013 at 6:13 pm
    Hi John

    Thanks for the update, glad to hear you got it to work using Host Template.
    Are you running your cluster on AWS? If so that may be the issue. The Add
    Hosts wizard in AWS environment currently does not associate the new hosts
    with the cluster.

    Herman

    On Thu, Mar 21, 2013 at 3:56 AM, John Yang wrote:

    Hi Herman,

    I figured out a way to add the role to the host.
    First, create a template for the cluster, and choose the roles
    needed.(Hosts>Templates>Create)
    Second, select the newly created host in Hosts tab, then 'Actions for
    Selected' > 'Apply Host Template'
    Finally the newly created host will got the role and in the cluster, too.

    But the newly created hosts are still out of the cluster after the 'Add
    New Hosts to Cluster' wizard finished.

    Thanks for your help :)

    John

    Herman Chen於 2013年3月20日星期三UTC+8上午2時08分50秒寫道:
    Hi John

    Thanks for the screenshot. The Cluster column is not shown in Free
    Edition, since only one cluster is supported, so this is expected. If you
    try "Add New Hosts to Cluster" wizard again but there is no "Currently
    Managed Hosts" tab, that means all of your hosts should be in your cluster
    already. Can you describe in more detail what happens when you tried to "add
    instance to service"?

    Herman

    On Mon, Mar 18, 2013 at 7:38 PM, John Yang wrote:


    <https://lh5.googleusercontent.com/-kp_ddwkzYWQ/UUfPIHr542I/AAAAAAAACHQ/J7ixHpxO3IY/s1600/Screenshot+cloudera.png>
    Hi Herman,

    Here's the screenshot of the About page.

    John


    Herman Chen於 2013年3月19日星期二UTC+**8上午5時00分32秒寫道:
    Hi John

    That is surprising. Could you take a screenshot of the About page?
    Thanks.

    Herman
    On Sun, Mar 17, 2013 at 7:21 PM, John Yang wrote:
    Hi Herman,

    Version: 4.5.0
    Cloudera Manager Free Edition

    John


    Herman Chen於 2013年3月15日星期五UTC+**8下午9時55分39秒寫道**:
    Hi John

    What version of CM are you running? See Help->About.

    Herman


    On Thu, Mar 14, 2013 at 8:24 PM, John Yang <man...@gmail.com>
    wrote:
    Hi Herman,

    Thanks for your help!
    1. Yes, I can see new created host
    2. I think the problem is here, I can't see any column called
    'Cluster'
    :(

    John

    Herman Chen於 2013年3月15日星期五UTC+**8上午1時27分09秒寫道**:
    Hi John

    If you don't see the tab that means the hosts aren't managed yet.
    Go
    through the 'Add New Hosts to Cluster' wizard again, and make
    sure you
    'Continue' all the way to the end of the wizard. After wizard
    completes successfully, verify the following for me:
    1. on Hosts page do you see the new hosts?
    2. if you do, what does the 'Cluster' column say?

    Herman

    On Wed, Mar 13, 2013 at 7:37 PM, John Yang <man...@gmail.com>
    wrote:
    Hi Herman,

    Thanks for your reply.
    I ran 'Add New Hosts to Cluster' again but I couldn't see any
    tab
    called
    'Currently Managed Hosts'.
    Maybe it's the Free Edition or there is something else I
    missed?
    John



    Herman Chen於 2013年3月13日星期三UTC+**8下午11時24分09秒寫**道:
    Hi John

    If you go to the Hosts tab do you see the new hosts? If you
    do, you
    probably did not go through the entire wizard. 'Add New Hosts
    to
    Cluster' again but choose the already managed hosts from the
    "Currently Managed Hosts" tab.

    Herman


    On Tue, Mar 12, 2013 at 9:24 PM, John Yang <man...@gmail.com>
    wrote:
    Hi all,

    I'm trying on the CM Free Edition. After I finish the
    'Add New
    Hosts
    to
    Cluster' Tab, the new hosts weren't in my cluster.
    Because of that, I can't add instance to service, please
    help me
    on
    the
    issue.

    Thx.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedMar 13, '13 at 4:24a
activeMar 21, '13 at 6:13p
posts12
users2
websitecloudera.com
irc#hadoop

2 users in discussion

John Yang: 6 posts Herman Chen: 6 posts

People

Translate

site design / logo © 2022 Grokbase