FAQ
HI,

Please refer to the blog
http://blog.cloudera.com/blog/2009/03/hadoop-metrics/

I have installed CDH using Cloudera Manager. I want to dump the Hadoop
metrics to Jconsole, for which I was referring the above blog. The problem
is that how do I set the configurations using Cloudera Manager?

If I set the hadoop environment properties in HDFS Environment Safety Valve
and MapReduce Environment Safety Valve, it is throwing
error:*UnicodeEncodeError: 'ascii' codec can't encode character
u'\u201d' in
position 193: ordinal not in range(128)*

Is there any blog or tutorial which contains the steps using Cloudera
Manager? Can any one tell me what all I need to do in order to configure
hadoop metrics for JConsole in my case?

THanks,
Gaurav

Search Discussions

  • Gaurav Dasgupta at Mar 6, 2013 at 1:42 pm
    The "UniCode" error resolved. There was some syntax/character error while
    setting the environment properties.

    But now, I am facing a new problem. Which user should own the
    "jmxremote.password" file? While starting the HDFS service, its saying that:

    Error: Password file not readable: /etc/hadoop/conf/jmxremote.password

    Presently, root is owning the file with a permission of 600. I tried
    changing the owner to "cloudera-scm" also, but its same.

    Thanks,
    Gaurav
  • Michalis Kongtongk at Mar 6, 2013 at 2:03 pm
    Hi Gaurav,

    You said you chown the file to 'cloudera-scm', can you check chmod 755 the
    file and see if it starts?

    Michalis

    On Wed, Mar 6, 2013 at 1:42 PM, Gaurav Dasgupta wrote:

    The "UniCode" error resolved. There was some syntax/character error while
    setting the environment properties.

    But now, I am facing a new problem. Which user should own the
    "jmxremote.password" file? While starting the HDFS service, its saying that:

    Error: Password file not readable: /etc/hadoop/conf/jmxremote.password

    Presently, root is owning the file with a permission of 600. I tried
    changing the owner to "cloudera-scm" also, but its same.

    Thanks,
    Gaurav
  • Gaurav Dasgupta at Mar 6, 2013 at 3:14 pm
    Giving extra permissions to all gives error saying: Password file should be
    restricted.
    I gave 666 with chown cloudera-scm:cloudera-scm, and it gave me that error.

    As per procedure, the permission should be 600. Hence I need to know who's
    the exact reader/owner of the file. KNowing that will solve my problem.
  • Harsh J at Mar 6, 2013 at 3:51 pm
    If its the HDFS service you're configuring it for, then 'hdfs' is the reader.
    On Wed, Mar 6, 2013 at 8:44 PM, Gaurav Dasgupta wrote:
    Giving extra permissions to all gives error saying: Password file should be
    restricted.
    I gave 666 with chown cloudera-scm:cloudera-scm, and it gave me that error.

    As per procedure, the permission should be 600. Hence I need to know who's
    the exact reader/owner of the file. KNowing that will solve my problem.


    --
    Harsh J

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedMar 6, '13 at 11:40a
activeMar 6, '13 at 3:51p
posts5
users3
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase