FAQ
Hi,

I'm new to Cloudera Manager. I've installed CM v#4.1.3, CDH4 and I'm having
problems with Beeswax Server first startup.
Hue service is failed to start after installation. On stderr.log for
beeswax_server I encountered the following error among other errors:
"...
+ echo Executing /usr/share/hue/build/env/bin/hue beeswax_server
+ exec /usr/share/hue/build/env/bin/hue beeswax_server
Unknown command: 'beeswax_server'
Type 'hue help' for usage.
..."

[All other installed services (hdfs, mapreduce, oozie and zookeeper) were
started successfully.]

Can someone help me understand what went wrong with my installation?

Thanks,
Jasmin

Search Discussions

  • Jasmin Megidish at Feb 17, 2013 at 10:07 am
    stderr.log is attached.
    בתאריך יום ראשון, 17 בפברואר 2013 12:05:48 UTC+2, מאת Jasmin Megidish:
    Hi,

    I'm new to Cloudera Manager. I've installed CM v#4.1.3, CDH4 and I'm
    having problems with Beeswax Server first startup.
    Hue service is failed to start after installation. On stderr.log for
    beeswax_server I encountered the following error among other errors:
    "...
    + echo Executing /usr/share/hue/build/env/bin/hue beeswax_server
    + exec /usr/share/hue/build/env/bin/hue beeswax_server
    Unknown command: 'beeswax_server'
    Type 'hue help' for usage.
    ..."

    [All other installed services (hdfs, mapreduce, oozie and zookeeper) were
    started successfully.]

    Can someone help me understand what went wrong with my installation?

    Thanks,
    Jasmin
  • Harsh J at Feb 17, 2013 at 1:32 pm
    Hi Jasmin,

    From the error it appears that Hue's somehow unaware of the beeswax application.

    Is the package "hue-beeswax" installed on the machine designated for
    Hue? For example, if you run "sudo rpm -qa | grep beeswax", do you see
    any results? If not, can you try to do "sudo yum install hue-beeswax"
    to install it and then try starting it again?
    On Sun, Feb 17, 2013 at 3:37 PM, Jasmin Megidish wrote:

    stderr.log is attached.
    בתאריך יום ראשון, 17 בפברואר 2013 12:05:48 UTC+2, מאת Jasmin Megidish:
    Hi,

    I'm new to Cloudera Manager. I've installed CM v#4.1.3, CDH4 and I'm
    having problems with Beeswax Server first startup.
    Hue service is failed to start after installation. On stderr.log for
    beeswax_server I encountered the following error among other errors:
    "...
    + echo Executing /usr/share/hue/build/env/bin/hue beeswax_server
    + exec /usr/share/hue/build/env/bin/hue beeswax_server
    Unknown command: 'beeswax_server'
    Type 'hue help' for usage.
    ..."

    [All other installed services (hdfs, mapreduce, oozie and zookeeper) were
    started successfully.]

    Can someone help me understand what went wrong with my installation?

    Thanks,
    Jasmin


    --
    Harsh J
  • Jasmin Megidish at Feb 17, 2013 at 1:56 pm
    Hi Harsh,

    When I run "sudo rpm -qa | grep beeswax" I get results:
    "hue-beeswax-2.1.0+223-1.cdh4.1.3.p0.20.el5"

    Thanks,
    Jasmin

    בתאריך יום ראשון, 17 בפברואר 2013 15:32:33 UTC+2, מאת Harsh J:
    Hi Jasmin,

    From the error it appears that Hue's somehow unaware of the beeswax
    application.

    Is the package "hue-beeswax" installed on the machine designated for
    Hue? For example, if you run "sudo rpm -qa | grep beeswax", do you see
    any results? If not, can you try to do "sudo yum install hue-beeswax"
    to install it and then try starting it again?
    On Sun, Feb 17, 2013 at 3:37 PM, Jasmin Megidish wrote:

    stderr.log is attached.
    בתאריך יום ראשון, 17 בפברואר 2013 12:05:48 UTC+2, מאת Jasmin Megidish:
    Hi,

    I'm new to Cloudera Manager. I've installed CM v#4.1.3, CDH4 and I'm
    having problems with Beeswax Server first startup.
    Hue service is failed to start after installation. On stderr.log for
    beeswax_server I encountered the following error among other errors:
    "...
    + echo Executing /usr/share/hue/build/env/bin/hue beeswax_server
    + exec /usr/share/hue/build/env/bin/hue beeswax_server
    Unknown command: 'beeswax_server'
    Type 'hue help' for usage.
    ..."

    [All other installed services (hdfs, mapreduce, oozie and zookeeper)
    were
    started successfully.]

    Can someone help me understand what went wrong with my installation?

    Thanks,
    Jasmin


    --
    Harsh J
  • Romain Rigaux at Feb 18, 2013 at 6:18 am
    Weird, is Hive installed too (or before Hue)?

    Romain
    On Sun, Feb 17, 2013 at 5:56 AM, Jasmin Megidish wrote:

    Hi Harsh,

    When I run "sudo rpm -qa | grep beeswax" I get results:
    "hue-beeswax-2.1.0+223-1.cdh4.1.3.p0.20.el5"

    Thanks,
    Jasmin

    בתאריך יום ראשון, 17 בפברואר 2013 15:32:33 UTC+2, מאת Harsh J:
    Hi Jasmin,

    From the error it appears that Hue's somehow unaware of the beeswax
    application.

    Is the package "hue-beeswax" installed on the machine designated for
    Hue? For example, if you run "sudo rpm -qa | grep beeswax", do you see
    any results? If not, can you try to do "sudo yum install hue-beeswax"
    to install it and then try starting it again?

    On Sun, Feb 17, 2013 at 3:37 PM, Jasmin Megidish <jasm...@gmail.com>
    wrote:
    stderr.log is attached.
    בתאריך יום ראשון, 17 בפברואר 2013 12:05:48 UTC+2, מאת Jasmin Megidish:
    Hi,

    I'm new to Cloudera Manager. I've installed CM v#4.1.3, CDH4 and I'm
    having problems with Beeswax Server first startup.
    Hue service is failed to start after installation. On stderr.log for
    beeswax_server I encountered the following error among other errors:
    "...
    + echo Executing /usr/share/hue/build/env/bin/**hue beeswax_server
    + exec /usr/share/hue/build/env/bin/**hue beeswax_server
    Unknown command: 'beeswax_server'
    Type 'hue help' for usage.
    ..."

    [All other installed services (hdfs, mapreduce, oozie and zookeeper)
    were
    started successfully.]

    Can someone help me understand what went wrong with my installation?

    Thanks,
    Jasmin


    --
    Harsh J
  • bc Wong at Feb 19, 2013 at 6:33 pm
    From the original error of "unknown command: beeswax_server", we can
    conclude that the "beeswax" application is not registered with Hue. That
    could be due to `hue-beeswax' not installed (ruled out). Or something went
    wrong when trying to app-reg "beeswax".

    Can you try and paste the results:
    $ /usr/share/hue/tools/app_reg/app_reg.py --list

    Cheers,
    bc
    On Sun, Feb 17, 2013 at 10:18 PM, Romain Rigaux wrote:

    Weird, is Hive installed too (or before Hue)?

    Romain

    On Sun, Feb 17, 2013 at 5:56 AM, Jasmin Megidish wrote:

    Hi Harsh,

    When I run "sudo rpm -qa | grep beeswax" I get results:
    "hue-beeswax-2.1.0+223-1.cdh4.1.3.p0.20.el5"

    Thanks,
    Jasmin

    בתאריך יום ראשון, 17 בפברואר 2013 15:32:33 UTC+2, מאת Harsh J:
    Hi Jasmin,

    From the error it appears that Hue's somehow unaware of the beeswax
    application.

    Is the package "hue-beeswax" installed on the machine designated for
    Hue? For example, if you run "sudo rpm -qa | grep beeswax", do you see
    any results? If not, can you try to do "sudo yum install hue-beeswax"
    to install it and then try starting it again?

    On Sun, Feb 17, 2013 at 3:37 PM, Jasmin Megidish <jasm...@gmail.com>
    wrote:
    stderr.log is attached.
    בתאריך יום ראשון, 17 בפברואר 2013 12:05:48 UTC+2, מאת Jasmin Megidish:
    Hi,

    I'm new to Cloudera Manager. I've installed CM v#4.1.3, CDH4 and I'm
    having problems with Beeswax Server first startup.
    Hue service is failed to start after installation. On stderr.log for
    beeswax_server I encountered the following error among other errors:
    "...
    + echo Executing /usr/share/hue/build/env/bin/**hue beeswax_server
    + exec /usr/share/hue/build/env/bin/**hue beeswax_server
    Unknown command: 'beeswax_server'
    Type 'hue help' for usage.
    ..."

    [All other installed services (hdfs, mapreduce, oozie and zookeeper)
    were
    started successfully.]

    Can someone help me understand what went wrong with my installation?

    Thanks,
    Jasmin


    --
    Harsh J
  • Jasmin Megidish at Feb 25, 2013 at 8:58 am
    Hi,

    Something went wrong with Hue packages installation. Attempts to start Hue
    or reconfigure the service failed on missing files. By simply re-installing
    the relevant RPMs ("yum reinstall hue*") the problem was fixed.

    Thank you all for your responses!

    בתאריך יום שלישי, 19 בפברואר 2013 20:33:11 UTC+2, מאת bc Wong:
    From the original error of "unknown command: beeswax_server", we can
    conclude that the "beeswax" application is not registered with Hue. That
    could be due to `hue-beeswax' not installed (ruled out). Or something went
    wrong when trying to app-reg "beeswax".

    Can you try and paste the results:
    $ /usr/share/hue/tools/app_reg/app_reg.py --list

    Cheers,
    bc

    On Sun, Feb 17, 2013 at 10:18 PM, Romain Rigaux <rom...@cloudera.com<javascript:>
    wrote:
    Weird, is Hive installed too (or before Hue)?

    Romain


    On Sun, Feb 17, 2013 at 5:56 AM, Jasmin Megidish <jasm...@gmail.com<javascript:>
    wrote:
    Hi Harsh,

    When I run "sudo rpm -qa | grep beeswax" I get results:
    "hue-beeswax-2.1.0+223-1.cdh4.1.3.p0.20.el5"

    Thanks,
    Jasmin

    בתאריך יום ראשון, 17 בפברואר 2013 15:32:33 UTC+2, מאת Harsh J:
    Hi Jasmin,

    From the error it appears that Hue's somehow unaware of the beeswax
    application.

    Is the package "hue-beeswax" installed on the machine designated for
    Hue? For example, if you run "sudo rpm -qa | grep beeswax", do you see
    any results? If not, can you try to do "sudo yum install hue-beeswax"
    to install it and then try starting it again?

    On Sun, Feb 17, 2013 at 3:37 PM, Jasmin Megidish <jasm...@gmail.com>
    wrote:
    stderr.log is attached.
    בתאריך יום ראשון, 17 בפברואר 2013 12:05:48 UTC+2, מאת Jasmin
    Megidish:
    Hi,

    I'm new to Cloudera Manager. I've installed CM v#4.1.3, CDH4 and I'm
    having problems with Beeswax Server first startup.
    Hue service is failed to start after installation. On stderr.log for
    beeswax_server I encountered the following error among other errors:
    "...
    + echo Executing /usr/share/hue/build/env/bin/**hue beeswax_server
    + exec /usr/share/hue/build/env/bin/**hue beeswax_server
    Unknown command: 'beeswax_server'
    Type 'hue help' for usage.
    ..."

    [All other installed services (hdfs, mapreduce, oozie and zookeeper)
    were
    started successfully.]

    Can someone help me understand what went wrong with my installation?

    Thanks,
    Jasmin


    --
    Harsh J

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupscm-users @
categorieshadoop
postedFeb 17, '13 at 10:05a
activeFeb 25, '13 at 8:58a
posts7
users4
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase